f



[ace-users] ACE SSL build errors on Ubuntu 12.10 with ACE+TAO version 6.1.0

I'm not sure if this is a bug or not, however, the last time it poped up in=
 the email list history was in 2007. I'm getting a bug in compiling ACE wit=
h SSL in my environment. Initially, I installed the ACE libraries and dev e=
nvironment for Ununtu 12.10, along with the OpenSSL libraries. My intent wa=
s to start playing around with an ACE based SSL web client. When the librar=
ies shipped with this version of Ubuntu started wigging out in the HTTPS_Se=
ssion area, I figured that this was just the builders bad form for not runn=
ing the ACE tests. So, off I went to build ACE, with SSL.

Currently, ace without SSL builds fine, but as soon as I add in the ssl=3D1=
 to the make line, I get linker errors. Looking at the source code, this ap=
pears to be some kind of confusion over defines in the ssl.h file belonging=
 to the OpenSSL package. Anyway, here's the PRF:

    ACE VERSION: 6.1.0

    HOST MACHINE and OPERATING SYSTEM:
       Ubuntu 12.10

    TARGET MACHINE and OPERATING SYSTEM, if different from HOST:
        Same
    COMPILER NAME AND VERSION (AND PATCHLEVEL):
        gcc 4.7.2
    THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform-
    specific file, simply state which one]: ace/config-linux.h

    THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you
    use a link to a platform-specific file, simply state which one
    (unless this isn't used in this case, e.g., with Microsoft Visual
    C++)]:include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU

    CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features
    (used by MPC when you generate your own makefiles): N/A

    AREA/CLASS/EXAMPLE AFFECTED:
      SSL build fails

    DOES THE PROBLEM AFFECT:
        COMPILATION? Compilation of the SSL_Context.cpp source file
        This is an ACE library build problem

    SYNOPSIS:
Building the ace library with the command "ssl=3D1 make" from ACE_ROOT fail=
s in the SSL context session. Looks like a problem with the defines in the =
OpenSSL file "ssl.h".


    DESCRIPTION:
Building the ace library with the command "ssl=3D1 make" from ACE_ROOT yiel=
ds the following compilation errors:
g++ -fno-strict-aliasing -fvisibility=3Dhidden -fvisibility-inlines-hidden =
-O3 -ggdb -pthread -Wall -W -Wpointer-arith -pipe -D_GNU_SOURCE   -I/home/e=
carew/Projects/ACE_wrappers -D__ACE_INLINE__ -I../.. -I/usr/kerberos/includ=
e -DACE_SSL_BUILD_DLL  -c -fPIC -o .shobj/SSL_Context.o SSL_Context.cpp
SSL_Context.cpp: In member function =91int ACE_SSL_Context::set_mode(int)=
=92:
SSL_Context.cpp:240:16: error: =91::SSLv2_client_method=92 has not been dec=
lared
SSL_Context.cpp:243:16: error: =91::SSLv2_server_method=92 has not been dec=
lared
SSL_Context.cpp:246:16: error: =91::SSLv2_method=92 has not been declared
make[1]: *** [.shobj/SSL_Context.o] Error 1
make[1]: Leaving directory `/home/ecarew/Projects/ACE_wrappers/ace/SSL'
make: *** [SSL] Error 2
0
Evan
1/31/2013 2:59:27 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
961 Views

Similar Articles

[PageSpeed] 13

Reply:

Similar Artilces:

[ace-users] ACE SSL build errors on Ubuntu 12.10 with ACE+TAO version 6.1.0
--14dae9340cc3f8a4c204d496c32b Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: quoted-printable I'm not sure if this is a bug or not, however, the last time it poped up in the email list history was in 2007. I'm getting a bug in compiling ACE with SSL in my environment. Initially, I installed the ACE libraries and dev environment for Ununtu 12.10, along with the OpenSSL libraries. My intent was to start playing around with an ACE based SSL web client. When the libraries shipped with this version of Ubuntu started wigging out in the HTTPS_Session area, I figured that this was just the builders bad form for not running the ACE tests. So, off I went to build ACE, with SSL. Currently, ace without SSL builds fine, but as soon as I add in the ssl=3D1 to the make line, I get linker errors. Looking at the source code, this appears to be some kind of confusion over defines in the ssl.h file belonging to the OpenSSL package. Anyway, here's the PRF: ACE VERSION: 6.1.0 HOST MACHINE and OPERATING SYSTEM: Ubuntu 12.10 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: Same COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc 4.7.2 THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: ace/config-linux.h THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file...

[ace-users] Ubuntu 12.10 ACE+TAO v6.1.7 Build errors
So to try and get past this error, I ran the realclean make macro, and trie= d to make the source tree a second time. No joy. Since this error is an ACE= app complaining about not being able to link to its own, just created libr= ary binary, I assume this is a build architecture issue. The g++ "-L" optio= n seems to be pointing to the right place, however, the linker isn't recogn= izing it. ACE VERSION: 6.1.7 HOST MACHINE and OPERATING SYSTEM: Ubuntu 12.10 32bit OS on Intel TARGET MACHINE and OPERATING SYSTEM, if different from HOST: Same COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc version 4.7.2 (Ubuntu/L= inaro 4.7.2-2ubuntu1) THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: ace/config-linux.h THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file, simply state which one]: $(ACE_= ROOT)/include/makeinclude/platform_linux.GNU CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features (used by MPC when you generate your own makefiles): N/A AREA/CLASS/EXAMPLE AFFECTED: Looks like the build process broke in gperf, in file test.cpp DOES THE PROBLEM AFFECT: COMPILATION? No LINKING? Yes On Unix systems, did you run make realclean first? Yes EXECUTION? N/A OTHER (please specify)? N/a [Please indicate whether...

[ace-bugs] FW: building ACE 6.2.0/6.2.2 win XL C/C++ v12.1 on AIX7.1 results in compiler error when instantiating ace templates
--_004_80317163A516B94B988E1615F9FAFB1989DFD215otwlxg22opentex_ Content-Type: multipart/alternative; boundary="_000_80317163A516B94B988E1615F9FAFB1989DFD215otwlxg22opentex_" --_000_80317163A516B94B988E1615F9FAFB1989DFD215otwlxg22opentex_ Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable To: ace-bugs@list.isis.vanderbilt.edu<mailto:ace-bugs@list.isis.vanderbilt.= edu> Subject: [area]: [synopsis] ACE VERSION: 6.2.2 HOST MACHINE and OPERATING SYSTEM: AIX 7.1 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: config.h -> config-aix-7.h THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file, simply state which one (unless this isn't used in this case, e.g., with Microsoft Visual C++)]: platform_aix_ibm.GNU CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features (used by MPC when you generate your own makefiles): AREA/CLASS/EXAMPLE AFFECTED: [What example failed? What module failed to compile?] DOES THE PROBLEM AFFECT: COMPILATION On Unix systems, did you run make realclean first? YES Our application fails to build with ACE6.2.0/6.2.2 on AIX 7.1 with AIX XL C= /C...

[tao-users] Use of TAO_OutputCDR and ACE_Message_Block in CORBA::Any from TAO 1.4.1|ACE 5.4.1 to TAO2.2.0|ACE 6.2.0
This is a multipart message in MIME format. ------=_NextPart_000_00BF_01CEA8D4.9E005C80 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable TAO VERSION: 2.2.0 ACE VERSION: 6.2.0 =20 HOST MACHINE and OPERATING SYSTEM: x86_64 and Red Hat - Linux 2.6.18-194.26.1.el5 =20 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: =20 COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc (GCC) 4.8.1 =20 THE $ACE_ROOT/ace/config.h FILE: config-linux.h =20 THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE: platform_linux.GNU =20 CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features (used by MPC when you generate your own makefiles): =20 AREA/CLASS/EXAMPLE AFFECTED: TAO_OutputCDR and ACE_Message_Block. =20 DOES THE PROBLEM AFFECT: EXECUTION. My application is affected. =20 SYNOPSIS: The code that extract data from CORBA::Any using TAO_OutputCDR and ACE_Message_Block for user defined types works properly in the old platform (TAO 1.4.1|ACE 5.4.1), but not in the new one(ACE 6.2.0). =20 DESCRIPTION: The code in the =93REPEAT BY=94 section works fine in the old platform = for user defined types, that is, the TAO_OutputCDR and ACE_Message_Block objects have the same length, but in the new platform th...

RE: [tao-users] Re: [ace-users] Re: Announcing the release of the new beta (ACE-5.4.10, TAO-1.4.10 and CIAO-0.4.10)
Hi, > > >> We encourage you to download the new beta, use it with your > > >> applications, and let us know soon if you encounter any problems > > >> since we plan to cut the x.5 release by February 28th. > > > > As per Wallace's comments, we have an aggressive schedule > for the x.5 > > release to meet the needs of some major sponsors. If > people can give > > x.4.10 a "test drive" in the next couple of days and report problems > > they encounter we'll try to ensure that we fix any >...

[ace-users] ACE 6.0.1 and TAO 2.0.1 RPMs available
Hi all, ACE 6.0.1 and TAO 2.0.1 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE 11.1/11.2/11.3/Factory Regards, Johnny Willemsen Remedy IT Check our scoreboard at http://scoreboard.theaceorb.nl/ ...

[ace-users] Ubuntu 12.10 ACE v6.1.7 undefined reference to `ACE::INet::SSL_Proxy_Connector::SSL_Proxy_Connector()'
ACE VERSION: 6.1.7 HOST MACHINE and OPERATING SYSTEM: Ubuntu 12.10 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: Same COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1) THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: ace/config-linux.h THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file, simply state which one]: $(ACE_ROOT)/include/makeinclude/platform_linux.GNU CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features (used by MPC when you generate your own makefiles): N/A AREA/CLASS/EXAMPLE AFFECTED: ACE::INet::SSL_Proxy_Connector DOES THE PROBLEM AFFECT: COMPILATION? No LINKING? Yes On Unix systems, did you run make realclean first? Yes EXECUTION? N/A OTHER (please specify)? [Please indicate whether ACE, your application, or both are affected.] Just my application was affected. SYNOPSIS: Linking my application failes on lookup of: ACE::INet::SSL_Proxy_Connector::SSL_Proxy_Connector() DESCRIPTION: My application is trying to link to the ACE SSL Libraries and is failing on the undefined reference above. REPEAT BY: g++ -g ssltest.cpp -o ssltest str.o -I. -I/usr/include/libxml2 -lACE -lACE_SSL -lACE_INet -lACE_INet_SSL -lboost_filesystem -lboost_system -D...

[ace-bugs] Re: [ace-users]: Building ACE on Mandrakelinux 10.1
Hi, > ACE VERSION: 5.4.6 Thanks for using the PRF. Are you really using this version. In your compile output we can see that you build Makefile.ace, this makefile is not part of the 5.4.6 release but is in the 5.4/5.4.1 version of ACE. Please download the x.4.6 beta from http://deuce.doc.wustl.edu/Download.html and build that version. The 5.4/5.4.1 versions are not supported with GCC 3.4 and newer. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > HOST MACHINE and OPERATING SY...

[ace-users] Ubuntu 12.10 ACE + TAO v6.1.7 Partial Workaround
Currently, ACE+TAO 6.1.7 won't compile, as the apps directory breaks on gpe= rf. Since TAO has a dependency in gperf, TAO may not work either. Fortunate= ly, if all you need to do is work with ACE's C++ network library, then comp= iling the source package ACE.tar.bz2 (micro-release 6.1.7) will work. Also = note that according to Johnny W., the SSL portion of ACE+TAO that comes pre= packaged from the Ubuntu servers (v6.1.0) is broken for Ubuntu 12.10. Perha= ps installing these new libraries on top of the broken ones, then re-linkin= g would solve the problem. Are you feeling lucky? In my previous post, I reported that Johnny W. didn't believe ACE+TAO from = Ubuntu didn't come with SSL enabled. As it turns out, some good samaritan f= igured this out and turned SSL on for the pre-packaged stuff, however, the = behavior on compilation of your apps, if they happen to rely on HTTPS_Sessi= on is the same, broken linking. Hi, > Currently, ACE+TAO 6.1.7 won't compile, as the apps directory breaks on gperf. Since TAO has a dependency in gperf, TAO may not work either. Fortunately, if all you need to do is work with ACE's C++ network library, then compiling the source package ACE.tar.bz2 (micro-release 6.1.7) will work. Also note that according to Johnny W., the SSL portion of ACE+TAO that comes prepackaged from the Ubuntu servers (v6.1.0) is broken for Ubuntu 12.10. Perhaps installing these new libraries on top of the broken ...

[ace-users] [ace-user] problem on building ACE+TAO+CAIO
Dear, all. I have a problem on buliding ACE+TAO+CAIO. ACE VERSION: 5.5 HOST MACHINE and OPERATING SYSTEM: HOST Machine: Intel Pentium D 3.0 1GB OS: Windows XP Professional SP2 TARGET MACHINE and OPERATING SYSTEM Same with the HOST machine and OS THE $ACE_ROOT/ace/config.h FILE #define ACE_HAS_MFC 1 #define ACE_NO_INLINE #define ACE_HAS_STANDARD_CPP_LIBRARY 1 #include "ace/config-win32.h" DOES THE PROBLEM AFFECT: ACE+TAO+CAIO building SYNOPSIS: occurrance of ...

[ace-users] ACE/TAO 6.1.0 vs. Oracle Solaris Studio 12.3
Has anyone built ACE/TAO 6.1.0 on Solaris with Oracle Solaris Studio = 12.3? I can't even get past the very first file! -- solaris10{cmbld}% which cc /opt/solarisstudio12.3/bin/cc solaris10{cmbld}% which CC /opt/solarisstudio12.3/bin/CC solaris10{cmbld}% which f77 /opt/solarisstudio12.3/bin/f77 solaris10{cmbld}% cat build_ACE_Solaris10_sun-solaris10.log=20 gmake[1]: Entering directory = `/long/path/to/ACE_wrappers/v6.1.0/sun-solaris10.Studio12.3/src/ace' GNUmakefile: = /long/path/to/ACE_wrappers/v6.1.0/sun-solaris10.Studio12.3/src/ace/GNUmake= file.ACE MAKEFLAGS=3Dw CC -mt -xO4 -g -library=3DCstd -DACE_HAS_KSTAT = -DACE_HAS_CUSTOM_EXPORT_MACROS=3D0 -D_POSIX_PTHREAD_SEMANTICS = -I/long/path/to/ACE_wrappers/v6.1.0/sun-solaris10.Studio12.3/src = -DACE_HAS_SCTP -DACE_HAS_LKSCTP -DACE_NO_INLINE -I.. -DACE_BUILD_DLL -c = -KPIC -o .shobj/Local_Name_Space.o Local_Name_Space.cpp = "/long/path/to/ACE_wrappers/v6.1.0/sun-solaris10.Studio12.3/src/ace/Array_= Map.h", line 105: Error: Too few arguments for template = std::reverse_iterator<std::_Iterator, std::_Category, std::_Tt, = std::_Reference, std::_Pointer, std::_Distance>. = "/long/path/to/ACE_wrappers/v6.1.0/sun-solaris10.Studio12.3/src/ace/Servic= e_Repository.h", line 193: Where: While specializing = "ACE_Array_Map<unsigned, const ACE_Service_Type*, = std::equal_to<unsigned>>". = "/long/path/to/ACE_wrappers/v6.1.0/s...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4
Hi Jason, Thanks for using the PRF. >> ACE VERSION: 5.3.1 This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 beta should work "out of the box" for Mac OS X Tiger. If you want a preview, please download the version in our CVS repo at http://cvs.doc.wustl.edu/ take care, Doug >> HOST MACHINE and OPERATING SYSTEM: Mac OS X 10.4.2 >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> powerpc-apple-darwin8-gcc-4.0.1 >> >> CONTENTS OF $ACE_ROOT/ace/config.h: >> >> /* -*- C++ ...

RE: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Doug, > > Thanks for using the PRF. > > >> ACE VERSION: 5.3.1 > > This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 beta should > work "out of the box" for Mac OS X Tiger. If you want a preview, > please download the version in our CVS repo at I know it isn't the most recent version available, but this version is used extensively across the corporation. Changing the version of ACE all these products used will cause the architect's heads to explode ;) Is it your opinion that 5.3.1 is hopeless cause on ...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, >> I know it isn't the most recent version available, but this version >> is used extensively across the corporation. Changing the version of >> ACE all these products used will cause the architect's heads to >> explode ;) >> >> Is it your opinion that 5.3.1 is hopeless cause on Tiger? It'll take some work, but companies like Riverace, Remedy, and OCI can help out with this stuff if staying with 5.3.1 is essential. Please see http://www.cs.wustl.edu/~schmidt/commercial-support.html for help with this stuff. >>...

RE: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, > > >> ACE VERSION: 5.3.1 > > > > This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 > beta should > > work "out of the box" for Mac OS X Tiger. If you want a preview, > > please download the version in our CVS repo at > > I know it isn't the most recent version available, but this > version is used > extensively across the corporation. Changing the version of > ACE all these > products used will cause the architect's heads to explode ;) ;-) Right - this is where the value of commercial support providers comes into play. DOC's research efforts continue to march on as they should, while commercial product efforts are best served by sticking with a version of ACE over time. Companies such as Riverace can make a 5.3-base version work on Mac OS X Tiger, for instance, as well as make sure that when your product is ready for an upgrade, the new version of ACE won't surprise you. I'd be happy to discuss further how we can help you and your architects - we don't want any heads to explode :-) -Steve -- Steve Huston, Riverace Corporation Helping you succeed with ACE See http://www.riverace.com/support.htm ...

[ace-users] ACE+TAO+CIAO
Hi all, We are pleased to announce the latest ACE+TAO+CIAO beta. This beta has been tagged ACE+TAO+CIAO-5_5_6. The main difference between this release and x.5.5 is that the ACE exception macros (except for ACE_THROW_RETURN and ACE_THROW_SPEC) have been removed from all TAO and CIAO code. It is available from the same download location as per the previous release. http://download.dre.vanderbilt.edu/ The doxygen documentation for the beta is also available. Included with this beta, besides the packages combined of sources and generate makefiles, we also provide source only pac...

RE: [ace-users] ACE+TAO+CIAO
Hi, Please use the prf form and which configuration you build. I personally think you have an old version of ACE/TAO on the system that is used. Regards, Johnny > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Domingos Monteiro > Sent: donderdag 9 juni 2005 18:05 > To: Simon McQueen > Cc: ace-users@cs.wustl.edu > Subject: Re: [ace-users] ACE+TAO+CIAO - 5.4.6 + 1.4.6 + 0.4.6 released > > Hi, > > I've just dowloaded this version > I've started to compile...

[ace-users] [ace 6.0.3] Build failures on Mac OS X 10.7.0
Hi, I have build failures on Mac OS X. The linker command is missing a '-' = before the o flag. When I workaround, I'll get a duplicate symbol error = (Obstack_T in Service_Gestalt.o and Parse_Node.o). I didn't find these identifers either in Service_Gestalt.cpp nor in = Parse_Node.cpp. Thanks Lothar PROBLEM-REPORT-FORM: ACE VERSION: 6.0.3 HOST MACHINE and OPERATING SYSTEM: MacBook:ace lothar$ uname -a Darwin MacBook.local 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 = 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386 i386 TARGET ...

[ace-users] ACE 6.2.0/6.2.2 bult with XL C/C++ v 12.1 on AIX71 or XL C/C++ v 9.0 on AIX61
--_000_80317163A516B94B988E1615F9FAFB1989DFE22Cotwlxg22opentex_ Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable To: ace-bugs@list.isis.vanderbilt.edu<mailto:ace-bugs@list.isis.vanderbilt.= edu>; ace-users@list.isis.vanderbilt.edu<mailto:ace-users@list.isis.vanderb= ilt.edu>; Subject: [area]: [synopsis] ACE VERSION: 6.2.2 HOST MACHINE and OPERATING SYSTEM: AIX71 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: config.h -> config-aix-7.h THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file, simply state which one (unless this isn't used in this case, e.g., with Microsoft Visual C++)]: platform_aix_ibm.GNU CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features (used by MPC when you generate your own makefiles): AREA/CLASS/EXAMPLE AFFECTED: DOES THE PROBLEM AFFECT: COMPILATION? NO LINKING? YES/NO On Unix systems, did you run make realclean first? YES EXECUTION? YES OTHER (please specify)? [Please indicate whether ACE, your application, or both are affected.] SYNOPSIS: Numerous symbols searched for by an application are not foun...

[ace-announce] ACE 6.0.1 and TAO 2.0.1 RPMs available
Hi all, ACE 6.0.1 and TAO 2.0.1 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE 11.1/11.2/11.3/Factory Regards, Johnny Willemsen Remedy IT Check our scoreboard at http://scoreboard.theaceorb.nl/ ...

[tao-users] Re: [ace-users] How to use c++ native exception handling instead of ACE's while building ACE+TAO
Hi, >> My only guess is that all of the libs you are linking in your >> builds were not compiled with a consistent set of options. Right, my recommendation would be to completely blow away your existing ACE+TAO x.5 directory, download a fresh version, and start from a clean slate. It sounds like you may have things lying around from previous build attempts. Thanks, Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Institute for Software Integrated Systems...

[ace-bugs] Re: [ace-users] How to use c++ native exception handling instead of ACE's while building ACE+TAO
Hi, To ensure that we have proper version/platform/compiler information, please make sure you fill out the appropriate problem report form (PRF), which is in $ACE_ROOT/PROBLEM-REPORT-FORM $TAO_ROOT/PROBLEM-REPORT-FORM or in $ACE_ROOT/BUG-REPORT-FORM $TAO_ROOT/BUG-REPORT-FORM in older versions of ACE+TAO. Make sure to include this information when asking any questions about ACE+TAO since otherwise we have to "guess" what version/platform/compiler/options you've using, which is error-prone and slows down our responsiveness. > I know we can set except...

[ace-bugs] Re: [ace-users] ACE build problem on 7.1
Hi Duncan, Thanks for using the PRF. >> ACE VERSION: 5.4 >> HOST MACHINE and OPERATING SYSTEM:x86 Win2K >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPILER NAME AND VERSION (AND PATCHLEVEL): MSVC 7.1.3088 >> >> CONTENTS OF $ACE_ROOT/ace/config.h: >> #define ACE_HAS_STANDARD_CPP_LIBRARY 1 >> #define ACE_AS_STATIC_LIBS 1 >> #include "ace/config-win32.h" >> >> AREA/CLASS/EXAMPLE AFFECTED: general build >> DOES THE PROBLEM AFFECT: >> COMPILATION? yes >> LINKING? N/A >> EXECUTION? N/A >> OTHER (please specify)? N/A >> SYNOPSIS: >> We have switched from MSVC 7.0 to 7.1 & I get the following error in release >> mode build only.. >> DESCRIPTION: >> I get the following error *IN RELEASE MODE ONLY*:- >> >> Compiling... >> EOTQuote.cpp >> Y:\EOTExternal\ACE\ACE_wrappers\ace\OS_NS_Thread.inl(4497) : error C2039: >> 'TryEnterCriticalSection' : is not a member of 'operator``global namespace''' >> Y:\EOTExternal\ACE\ACE_wrappers\ace\OS_NS_Thread.inl(4497) : error C3861: >> 'TryEnterCriticalSection': identifier not found, even with argument-dependent >> lookup Please see the discussion of this in the OCI FAQ at http://www.theaceorb.com/faq/faq.html#154 The FAQ entry is entitled "Why do I ge...

[ace-users] ACE VERSION: 5.6.8 HOST MACHINE and OPERATING SYSTEM: Linux Debian on x86 COMPILER NAME AND VERSION (AND PATCHLEVEL): g++-4.1.2 THE $ACE_ROOT/ace/config.h: config-linux.h THE $ACE_ROOT/inc
This is a multipart message in MIME format. --=_alternative 004800E0C1257577_= Content-Type: text/plain; charset="ISO-8859-1" Content-Transfer-Encoding: quoted-printable ACE VERSION: 5.6.8 HOST MACHINE and OPERATING SYSTEM: Linux Debian on x86 COMPILER NAME AND VERSION (AND PATCHLEVEL):=20 g++-4.1.2 THE $ACE=5FROOT/ace/config.h: config-linux.h THE $ACE=5FROOT/include/makeinclude/platform=5Fmacros.GNU FILE: platform=5Flinux.GNU CONTENTS OF $ACE=5FROOT/bin/MakeProjectCreator/config/default.features (unmodified): AREA/CLASS/EXAMPLE AFFECTED: Signal ...

Web resources about - [ace-users] ACE SSL build errors on Ubuntu 12.10 with ACE+TAO version 6.1.0 - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/4/2016 3:02:29 PM