f



[tao-users] ACE/TAO without network adapter and TCP/IP stack on windows 95 execution problem #2

This is a multi-part message in MIME format.

------=_NextPart_000_000D_01C46467.A7DFAF00
Content-Type: text/plain;
	charset="koi8-r"
Content-Transfer-Encoding: quoted-printable

Hi!

It's me again :)

I debug ACE/TAO and found that `SHMIOP` transport protocol based on =
socket API and don't work if socket API failed :(

Inside `TAO_SHMIOP_Connector::open` I can see =
`this->base_connector_.open` call. `base_connector_` is `ACE_SOCK` class =
and this class don't work fine if network not present (configured) on a =
computer (`ACE_OS::socket` call failed).

Does anybody know what I can do to fix my stupid situation and run my =
program on windows 95 without network support.

P.S. If I install `DialUp network` adapter all work fine, but I can't do =
it on the client computers as it demands the Windows 95 distribution =
disk which can not be available.

Thanks a lot and best regards.
---
Russia, Moscow, GARANT-SERVICE Company (www.garant.ru)
Mickael P. Golovin, phone://+7-(095)-930-8908+5018

----- Original Message -----=20
From: Mickael P. Golovin=20
To: tao-users@cs.wustl.edu=20
Sent: Tuesday, July 06, 2004 6:36 PM
Subject: [tao-users] ACE/TAO without network adapter and TCP/IP stack on =
windows 95 execution problem


Hi!

Additional information:
  I compiled ACE/TAO with `#define ACE_HAS_WINNT4 0` and `#define =
ACE_HAS_WINSOCK2 0` defines.
  I read about `shmiop` protocol/transport and run my program with next =
directives inside my `*.conf` file:
    dynamic SHMIOP_Factory Service_Object * =
TAO_Strategies:_make_TAO_SHMIOP_Protocol_Factory () ""
    dynamic Advanced_Resource_Factory Service_Object * =
TAO_Strategies:_make_TAO_Advanced_Resource_Factory () =
"-ORBProtocolFactory SHMIOP_Factory"
  I run my program with next ORB options:
    -ORBSvcConf svc.conf -ORBEndPoint shmiop://
But have the same problem :( I turn on logging and can see message:
  ACE_Select_Reactor_T::open failed inside ACE_Select_Reactor_T::CTOR: =
Network subsystem failed // why?
  ACE_Select_Reactor_T::open failed inside ACE_Select_Reactor_T::CTOR: =
Network subsystem failed
  (-1822809|4293153695) ORB Core unable to initialize reactor: Network =
subsystem failed
Any ideas/comments?
Help!

P.S. `wsock32.dll` exists inside my windows system catalog, but on the =
computer where I'm testing my application I don't have any network =
adapter and TCP/IP stack.

Thanks a lot and best regards.
---
Russia, Moscow, GARANT-SERVICE Company (www.garant.ru)
Mickael P. Golovin, phone://+7-(095)-930-8908+5018

----- Original Message -----=20
From: Mickael P. Golovin=20
To: tao-users@cs.wustl.edu=20
Sent: Friday, July 02, 2004 5:35 PM
Subject: [tao-users] ACE/TAO without windows sockets library question


Hi!

Does anybody know - can I use ACE/TAO without SOCKET API on the Windows =
system that does not have any network?

I have CORBA program client and server in one system process - single =
exe file (special local version of my client-server project). On the =
`Windows 9x/ME` I don't have any TCP IP stack and network adapter and my =
program does not work :(

I turn off Winsock2 using `ACE_HAS_WINSOCK2` define, but I don't =
understand how I can turn off Winsock1 and make program that does not =
require WINSOCK API...

Is it possible make CORBA program, that using collocated model and not =
require any network API/DLL/Adapters?

Thanks a lot and best regards.
---
Russia, Moscow, GARANT-SERVICE Company (www.garant.ru)
Mickael P. Golovin, phone://+7-(095)-930-8908+5018
------=_NextPart_000_000D_01C46467.A7DFAF00
Content-Type: text/html;
	charset="koi8-r"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; charset=3Dkoi8-r">
<META content=3D"MSHTML 6.00.2800.1400" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV>Hi!</DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=3D2>It's me again :)</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>I debug ACE/TAO and found that `SHMIOP` transport =
protocol=20
based on socket API and don't work if socket API failed :(</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Inside `TAO_SHMIOP_Connector::open` I can see=20
`this-&gt;base_connector_.open` call. `base_connector_` is `ACE_SOCK` =
class and=20
this class don't work fine if network not present (configured)&nbsp;on a =

computer (`ACE_OS::socket` call failed).</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Does anybody know what I can do to fix my stupid =
situation and=20
run my program on windows 95 without network support.</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>P.S. If I install `DialUp network` adapter all work =
fine, but=20
I can't do it on the client computers as it demands the Windows 95=20
distribution&nbsp;disk which can not be available.</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV>Thanks a lot and best regards.<BR>---<BR>Russia, Moscow, =
GARANT-SERVICE=20
Company (<A href=3D"http://www.garant.ru">www.garant.ru</A>)<BR>Mickael =
P.=20
Golovin, phone://+7-(095)-930-8908+5018</DIV>
<DIV style=3D"FONT: 10pt arial"><FONT face=3D"Courier =
New"></FONT>&nbsp;</DIV>
<DIV style=3D"FONT: 10pt arial">----- Original Message -----=20
<DIV style=3D"BACKGROUND: #e4e4e4; font-color: black"><B>From:</B> <A=20
title=3Dmigel@garant.ru href=3D"mailto:migel@garant.ru">Mickael P. =
Golovin</A>=20
</DIV>
<DIV><B>To:</B> <A title=3Dtao-users@cs.wustl.edu=20
href=3D"mailto:tao-users@cs.wustl.edu">tao-users@cs.wustl.edu</A> </DIV>
<DIV><B>Sent:</B> Tuesday, July 06, 2004 6:36 PM</DIV>
<DIV><B>Subject:</B> [tao-users] ACE/TAO without network adapter and =
TCP/IP=20
stack on windows 95 execution problem</DIV></DIV>
<DIV><BR></DIV>
<DIV>Hi!</DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Additional information:</FONT></DIV>
<BLOCKQUOTE dir=3Dltr style=3D"MARGIN-RIGHT: 0px">
  <DIV><FONT size=3D2>I compiled ACE/TAO with `#define ACE_HAS_WINNT4 0` =
and=20
  `#define ACE_HAS_WINSOCK2 0` defines.</FONT></DIV>
  <DIV><FONT size=3D2>I read about `shmiop` protocol/transport and run =
my program=20
  with next directives inside my `*.conf` file:</FONT></DIV>
  <BLOCKQUOTE dir=3Dltr style=3D"MARGIN-RIGHT: 0px">
    <DIV><FONT size=3D2>dynamic SHMIOP_Factory Service_Object *=20
    TAO_Strategies:_make_TAO_SHMIOP_Protocol_Factory () ""</FONT></DIV>
    <DIV><FONT size=3D2>dynamic Advanced_Resource_Factory Service_Object =
*=20
    TAO_Strategies:_make_TAO_Advanced_Resource_Factory () =
"-ORBProtocolFactory=20
    SHMIOP_Factory"</FONT></DIV></BLOCKQUOTE>
  <DIV dir=3Dltr><FONT size=3D2>I run my program with next ORB =
options:</FONT></DIV>
  <BLOCKQUOTE dir=3Dltr style=3D"MARGIN-RIGHT: 0px">
    <DIV dir=3Dltr><FONT size=3D2>-ORBSvcConf svc.conf -ORBEndPoint=20
    shmiop://</FONT></DIV></BLOCKQUOTE></BLOCKQUOTE>
<DIV><FONT size=3D2>But have the same problem :( I turn on logging and =
can see=20
message:</FONT></DIV>
<BLOCKQUOTE dir=3Dltr style=3D"MARGIN-RIGHT: 0px">
  <DIV><FONT size=3D2>ACE_Select_Reactor_T::open failed inside=20
  ACE_Select_Reactor_T::CTOR: <FONT color=3D#ff0000>Network subsystem =
failed //=20
  why?</FONT><BR>ACE_Select_Reactor_T::open failed inside=20
  ACE_Select_Reactor_T::CTOR: <FONT color=3D#ff0000>Network subsystem=20
  failed</FONT><BR>(-1822809|4293153695) ORB Core unable to initialize =
reactor:=20
  <FONT color=3D#ff0000>Network subsystem =
failed</FONT></FONT></DIV></BLOCKQUOTE>
<DIV><FONT size=3D2>Any ideas/comments?</FONT></DIV>
<DIV><FONT color=3D#ff0000 size=3D2>Help!</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>P.S. `wsock32.dll` exists inside my windows system =
catalog,=20
but on the computer where I'm testing my application I don't have any =
network=20
adapter and TCP/IP stack.</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV>Thanks a lot and best regards.<BR>---<BR>Russia, Moscow, =
GARANT-SERVICE=20
Company (<A href=3D"http://www.garant.ru">www.garant.ru</A>)<BR>Mickael =
P.=20
Golovin, phone://+7-(095)-930-8908+5018</DIV>
<DIV style=3D"FONT: 10pt arial"><FONT face=3D"Courier =
New"></FONT>&nbsp;</DIV>
<DIV style=3D"FONT: 10pt arial">----- Original Message -----=20
<DIV style=3D"BACKGROUND: #e4e4e4; font-color: black"><B>From:</B> <A=20
title=3Dmigel@garant.ru href=3D"mailto:migel@garant.ru">Mickael P. =
Golovin</A>=20
</DIV>
<DIV><B>To:</B> <A title=3Dtao-users@cs.wustl.edu=20
href=3D"mailto:tao-users@cs.wustl.edu">tao-users@cs.wustl.edu</A> </DIV>
<DIV><B>Sent:</B> Friday, July 02, 2004 5:35 PM</DIV>
<DIV><B>Subject:</B> [tao-users] ACE/TAO without windows sockets library =

question</DIV></DIV>
<DIV><FONT size=3D2></FONT><BR></DIV>
<DIV><FONT size=3D2>Hi!</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Does anybody know - can I use ACE/TAO without SOCKET =
API on=20
the Windows system that does not have any network?</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>I have CORBA program client and server in one system =
process -=20
single exe file&nbsp;(special local version of my client-server =
project). On the=20
`Windows 9x/ME` I don't have any TCP IP stack and network adapter and my =
program=20
does not work :(</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>I turn off Winsock2 using `ACE_HAS_WINSOCK2` define, =
but I=20
don't understand how I can turn off Winsock1 and make program that does =
not=20
require WINSOCK API...</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Is it possible make CORBA program, that using =
collocated model=20
and not require any network API/DLL/Adapters?</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Thanks a lot and best regards.<BR>---<BR>Russia, =
Moscow,=20
GARANT-SERVICE Company (<A=20
href=3D"http://www.garant.ru">www.garant.ru</A>)<BR>Mickael P. Golovin,=20
phone://+7-(095)-930-8908+5018</FONT></DIV></BODY></HTML>

------=_NextPart_000_000D_01C46467.A7DFAF00--

0
Mickael
7/7/2004 5:21:22 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
417 Views

Similar Articles

[PageSpeed] 39

Reply:

Similar Artilces:

[ace-bugs] Re: [tao-users] ACE/TAO without network adapter and TCP/IP stack on windows 95 execution problem
Hi Migel, >> I debug ACE/TAO and found that `SHMIOP` transport protocol based on = >> socket API and don't work if socket API failed :( >> >> Inside `TAO_SHMIOP_Connector::open` I can see = >> `this->base_connector_.open` call. `base_connector_` is `ACE_SOCK` class = >> and this class don't work fine if network not present (configured) on a = >> computer (`ACE_OS::socket` call failed). >> >> Does anybody know what I can do to fix my stupid situation and run my = >> program on windows 95 without network support...

[tao-users] ACE/TAO without network adapter and TCP/IP stack on windows 95 execution problem
This is a multi-part message in MIME format. ------=_NextPart_000_0138_01C46388.2281CAD0 Content-Type: text/plain; charset="koi8-r" Content-Transfer-Encoding: quoted-printable Hi! Additional information: I compiled ACE/TAO with `#define ACE_HAS_WINNT4 0` and `#define = ACE_HAS_WINSOCK2 0` defines. I read about `shmiop` protocol/transport and run my program with next = directives inside my `*.conf` file: dynamic SHMIOP_Factory Service_Object * = TAO_Strategies:_make_TAO_SHMIOP_Protocol_Factory () "" dynamic Advanced_Resource_Factory Service_Ob...

[tao-users] [ace-users] Problem linking ACE/TAO
This message is in MIME format. Since your mail reader does not understand this format, some or all of this message may not be legible. ------=_NextPart_000_0042_01C67435.B64C4BE0 Content-Type: text/plain; charset="windows-1252" Content-Transfer-Encoding: quoted-printable Hello, I have an application using ACE/TAO and I get a linking error trying to = build executable. ACE/TAO VERSION: 5.5 / 1.5 OPERATING SYSTEM: Win 2000 SP 4 COMPILER NAME and VERSION: VC++ 2005 Standard Edition CONTENTS of $ACE_ROOT/ace/config.h: #define ACE_HAS_STANDARD_CP...

[ace-users] [tao-users] Problem linking ACE/TAO
This message is in MIME format. Since your mail reader does not understand this format, some or all of this message may not be legible. ------=_NextPart_000_0042_01C67435.B64C4BE0 Content-Type: text/plain; charset="windows-1252" Content-Transfer-Encoding: quoted-printable Hello, I have an application using ACE/TAO and I get a linking error trying to = build executable. ACE/TAO VERSION: 5.5 / 1.5 OPERATING SYSTEM: Win 2000 SP 4 COMPILER NAME and VERSION: VC++ 2005 Standard Edition CONTENTS of $ACE_ROOT/ace/config.h: #define ACE_HAS_STANDARD_CP...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO #2
Hi, See http://www.remedy.nl/en/borland.html for an overview of the supported Borland products with TAO. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > -----Original Message----- > From: Espen Harlinn [mailto:espen@harlinn.no] > Sent: donderdag 2 februari 2006 18:06 > To: jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO > > Hi, > > I'm curious about the current status of ACE/TAO...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO #2
Hi, The x.4.8 version of ACE/TAO is supported with BCB2006, we have some linker warnings/errors in some configurations, Borland is working on these for Update2, but these are not causing a problem. See ACE_wrappers/ACE-INSTALL.html for info about how to use it. We deliver also commercial support for using BCB2006 with ACE/TAO. See www.theaceorb.nl for our services. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > -----Original Message----- > From: Espen Harlinn [mailto:espen@harlinn...

[tao-users] [ace-users] ACE/TAO/CIAO x.5.2 release announcement
Hi, Thanks to the substantial efforts by many developers, testers, and users, we are pleased to announce the new x.5.2 ACE+TAO+CIAO beta. The latest beta has been tagged ACE-5.5.2, TAO-1.5.2, and CIAO-0.5.2. As usual, it is available at: http://deuce.doc.wustl.edu/Download.html The doxygen documentation for the beta is available. We do have some missing files in that package which we resolve as soon as possible. We encourage you to download the new beta, use it with your applications, and let us know if you encounter any problems. Please use the: $ACE_ROOT/PROBLEM-REPO...

[ace-users] [tao-users] ACE/TAO/CIAO x.5.2 release announcement
Hi, Thanks to the substantial efforts by many developers, testers, and users, we are pleased to announce the new x.5.2 ACE+TAO+CIAO beta. The latest beta has been tagged ACE-5.5.2, TAO-1.5.2, and CIAO-0.5.2. As usual, it is available at: http://deuce.doc.wustl.edu/Download.html The doxygen documentation for the beta is available. We do have some missing files in that package which we resolve as soon as possible. We encourage you to download the new beta, use it with your applications, and let us know if you encounter any problems. Please use the: $ACE_ROOT/PROBLEM-REPO...

[ace-users] [tao-users] ACE+TAO x.5.2 RPM for Fedora Core
Greetings, I've uploaded Fedora Core source and binary RPM for ACE+TAO x.5.2 to: http://dist.bonsai.com/ken/ace_tao_rpm/ NOTE - I've enabled ACE_HAS_IPV6 and ACE_USES_IPV4_IPV6_MIGRATION in these builds; please let me know if this causes problems. Please let me know if there are problems/issues. Ken -- Ken Sedgwick Bonsai Software, Inc. (510) 610-4162 ken+5a4@bonsai.com Public Key: http://www.bonsai.com/ken/ken.asc GPG Fingerprint: 851E 3B07 E586 0843 9434 5CC7 4033 3B9B 3F3F 9640 ...

[tao-users] [ace-users] ACE+TAO x.5.2 RPM for Fedora Core
Greetings, I've uploaded Fedora Core source and binary RPM for ACE+TAO x.5.2 to: http://dist.bonsai.com/ken/ace_tao_rpm/ NOTE - I've enabled ACE_HAS_IPV6 and ACE_USES_IPV4_IPV6_MIGRATION in these builds; please let me know if this causes problems. Please let me know if there are problems/issues. Ken -- Ken Sedgwick Bonsai Software, Inc. (510) 610-4162 ken+5a4@bonsai.com Public Key: http://www.bonsai.com/ken/ken.asc GPG Fingerprint: 851E 3B07 E586 0843 9434 5CC7 4033 3B9B 3F3F 9640 ...

[ace-users] [ace-user] problem on building ACE+TAO+CAIO
Dear, all. I have a problem on buliding ACE+TAO+CAIO. ACE VERSION: 5.5 HOST MACHINE and OPERATING SYSTEM: HOST Machine: Intel Pentium D 3.0 1GB OS: Windows XP Professional SP2 TARGET MACHINE and OPERATING SYSTEM Same with the HOST machine and OS THE $ACE_ROOT/ace/config.h FILE #define ACE_HAS_MFC 1 #define ACE_NO_INLINE #define ACE_HAS_STANDARD_CPP_LIBRARY 1 #include "ace/config-win32.h" DOES THE PROBLEM AFFECT: ACE+TAO+CAIO building SYNOPSIS: occurrance of ...

Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2 #2
Hi, > Did you recommend to use VxWorks 6.4 with ACE+TAO 5.5.1a patch 4? VxWorks 6.4 is more stable then VxWorks 6.2, but still has its known problems. The p4 is so far as I know only a backport of the config-vxworks6.4.h that is part of the doc_group version 1.6.1. We are currently doing some work on VxWorks 6.4 kernel mode for PPC604. As part of this work we have made several improvements to the VxWorks 6.4 support which will be part of the upcoming 1.6.2 version. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceo...

[ace-users] RE: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6 #2
Hi, > -----Original Message----- > From: Douglas C. Schmidt [mailto:schmidt@cse.wustl.edu] > Sent: Monday, March 27, 2006 9:09 AM > To: nealweston@bellsouth.net; ace-users@cs.wustl.edu; > parsons@dre.vanderbilt.edu > Subject: Re: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6 > > Hi Neal, > > >> I am trying to build ACE-5.5 and TAO-1.5 on a SPARC > Solaris 2.8 system > >> using gcc 3.3.6 and GNU make 3.80. > >> > >> The build is failing in > ACE_wrappers/build/TAO/orbsvcs/orbsvcs (output > ...

[tao-users] Use of TAO_OutputCDR and ACE_Message_Block in CORBA::Any from TAO 1.4.1|ACE 5.4.1 to TAO2.2.0|ACE 6.2.0
This is a multipart message in MIME format. ------=_NextPart_000_00BF_01CEA8D4.9E005C80 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable TAO VERSION: 2.2.0 ACE VERSION: 6.2.0 =20 HOST MACHINE and OPERATING SYSTEM: x86_64 and Red Hat - Linux 2.6.18-194.26.1.el5 =20 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: =20 COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc (GCC) 4.8.1 =20 THE $ACE_ROOT/ace/config.h FILE: config-linux.h =20 THE $ACE...

[tao-users] ACE/TAO without windows sockets library question
This is a multi-part message in MIME format. ------=_NextPart_000_0117_01C4605A.F2F34990 Content-Type: text/plain; charset="koi8-r" Content-Transfer-Encoding: quoted-printable Hi! Does anybody know - can I use ACE/TAO without SOCKET API on the Windows = system that does not have any network? I have CORBA program client and server in one system process - single = exe file (special local version of my client-server project). On the = `Windows 9x/ME` I don't have any TCP IP stack and network adapter and my = program does not work :( I turn off Winsock2 using `...

[tao-users] RE: [ace-users] ACE/TAO on Solaris 10
Hi, There have been some replies. People do have things working on Solaris and there have been made fixes in ACE/TAO. Could you wait another week or so and try the x.4.8 or try cvs, see http://cvs.doc.wustl.edu Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > Dear list members, > > (I sent this message couple of days ago and am unsure if it > was distributed, > thus re-sending it again. I apologize if you received it more > than once) > > I would like to give ...

[tao-users] Re: [ace-users] How to use c++ native exception handling instead of ACE's while building ACE+TAO
Hi, >> My only guess is that all of the libs you are linking in your >> builds were not compiled with a consistent set of options. Right, my recommendation would be to completely blow away your existing ACE+TAO x.5 directory, download a fresh version, and start from a clean slate. It sounds like you may have things lying around from previous build attempts. Thanks, Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Institute for Software Integrated Systems...

[tao-users] ACE 6.0.2 and TAO 2.0.2 RPMs available #2
Hi all, ACE 6.0.2 and TAO 2.0.2 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE 11.2/11.3/11.4/Factory/Tumbleweed Regards, Johnny Willemsen Remedy IT http://scoreboard.theaceorb.nl/ http://www.orbzone.org http://www.theaceorb.nl ...

[ace-users] ACE 6.0.2 and TAO 2.0.2 RPMs available #2
Hi all, ACE 6.0.2 and TAO 2.0.2 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE 11.2/11.3/11.4/Factory/Tumbleweed Regards, Johnny Willemsen Remedy IT http://scoreboard.theaceorb.nl/ http://www.orbzone.org http://www.theaceorb.nl ...

Re: [tao-users] Re: ACE/TAO call back problem #2
This is a multipart message in MIME format. --=_alternative 0025F9B5C1256F63_= Content-Type: text/plain; charset="us-ascii" I had a similar problem a long time ago :-). In my case, the IOR passed by the client to the server contained a hostname which was unknown in the server. We did not use a DNS. The server used a hosts file. In our case, using ORBDottedDecimalAddresses 1 was the solution. Best wishes --=_alternative 0025F9B5C1256F63_= Content-Type: text/html; charset="us-ascii" <br><font size=2 face="sans-serif">I had a similar p...

[ace-users] build ACE+TAO+CIAO-6.2.3 problem
ACE VERSION: ACE+TAO+CIAO-6.2.3 HOST MACHINE and OPERATING SYSTEM: windows xp with vs 2010 express Detail: ========== Build: 664 succeeded, 2 failed, 0 up-to-date, 0 skipped ========== 37>------ Build started: Project: DLL_Test_Lib, Configuration: Debug Win32 ------ 32> Creating library ..\..\..\lib\ACE_INetd.lib and object ...\..\..\lib\ACE_INetd.exp 37> DLL_Test_Impl.cpp 37>LINK : fatal error LNK1104: cannot open file 'DLL_Test_Parentd.lib' 32> Creating library ..\..\..\lib\ACE_INetd.lib and object ...\..\..\lib\ACE_INetd.exp 38>------ Bu...

[ace-users] Re: [tao-users] Problem with removing event handler #2 #2
Hi Rob, > I figured that out, and removed ACE_Event_Handler::DONT_CALL from my > remove_handler call this morning. As far as I can tell handle_close is > still not getting called. Perhaps you're not defining handle_close() with the right signature? At any rate, there's no good reason for this not to work, so I recommend you crank up the debugger and figure out what's going on. thanks, doug ...

Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2
Hi, > SYNOPSIS: > What is the differences in linkage between compilation of ACE+TAO with > or without (RTP, PTHREAD), when we allow or disallow both of them > together? We can't allow RTP at our project. If we disallow RTP and > PTHREAD we have a problems with linkage with some TAO libraries. For differences check the VxWorks documentation. There are also runtime differences when you build rtp/pthread mix. We as Remedy IT can assist with this decision and give you information which combinations do behave better then others. Regards, Johnny Willemsen ...

[ace-users] ACE-TAO problems
Hi, My project seems to have some weired behaviour under the following conditio= ns 1. ACE_TAO built in debug mode and Project in 'release mode with debug supp= ort'. All EXEs break execution on memory operations when run in debugger. It is s= howing 'Invalid Address specified to RtlFreeHeap' error in the output windo= w and shows the erroneous line in ACE source. Then we have to keep pressing F5 to continue execution. This behaviour is o= nly when run in debugger. If we attach debugger after running the EXE, or r= un outside the debugger ,then there will not be a...

Web resources about - [tao-users] ACE/TAO without network adapter and TCP/IP stack on windows 95 execution problem #2 - comp.soft-sys.ace

Resources last updated: 2/14/2016 9:28:46 PM