f



RE: [ace-users] ACE-5.4+TAO-1.4 compilation error.

Hi,

>     ACE VERSION: 5.4

Thanks for using the PRF form. This version is old, try the x.4.2 release
you can download from http://deuce.doc.wustl.edu/Download.html. Be ware that
the doc_group doesn't support VxWorks, we as Remedy IT are planning to get
the VxWorks port up to shape, see www.theaceorb.nl/en/vxworks.html for the
plans we have, if you are interested contact us directly.

>      HOST MACHINE and OPERATING SYSTEM:
>          cygwin on w2k

Never, never install Cygwin when using VxWorks, yes, I know the documents
describe it, but it gives more problems than solutions

> 
>      TARGET MACHINE and OPERATING SYSTEM, if different from HOST:
>      COMPILER NAME AND VERSION (AND PATCHLEVEL):
>          VxWork 5.5.1 Tornado 2.2
>      CONTENTS OF $ACE_ROOT/ace/config.h:
>          config-vxworks5.x_g++.h
>      CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU  
> (unless
>      this isn't used in this case, e.g., with Microsoft Visual C++):
>          include  
> $(ACE_ROOT)/include/makeinclude/platform_vxworks5.x_g++.GNU
>      AREA/CLASS/EXAMPLE AFFECTED:
> [What example failed?  What module failed to compile?]
> 
>      DOES THE PROBLEM AFFECT:
>          COMPILATION? X
>          LINKING?
>              On Unix systems, did you run make realclean first?
>          EXECUTION?
>          OTHER (please specify)?
> [Please indicate whether ACE, your application, or both are affected.]
> 	ACE does not compile.
>      SYNOPSIS:
> [Brief description of the problem]
> 
>      In ace/Time_Value.h, it includes Time_Value.inl where timespec_t
>      is typdefed as struct timespec. However, h/times.h where struct
>      timespec is included at ace/post.h after Time_Value.inl. 
> I compiled
>      ace by cd into ace directory and make, then G++ complained about
>      the use of the members of of timespec_t type and error out,
>      compilation stoped.

So far as I know, this problem doesn't exist anymore but x.4.2 but you get
other errors in return, for solutions, contact me directly.

Regards,

Johnny Willemsen
Remedy IT
Leeghwaterstraat 25
2811 DT Reeuwijk
The Netherlands
www.theaceorb.nl / www.remedy.nl 
 












0
Johnny
8/10/2004 6:46:55 AM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
809 Views

Similar Articles

[PageSpeed] 54

Reply:

Similar Artilces:

RE: [tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > > Hi Lothar > > > > > � � ACE VERSION: 5.4.5 > > > > Thanks for using the PRF form. Could you try to find the > problem and send > > us patches to fix this? > > > > Regards, > > > > Johnny Willemsen > > I have no problem committing some time to the problem. I do > however know as > much as nothing about the ACE XML parser and it's recent > changes. It seems to > me that (some) of the recent changes might have caused the > test failures. So > if someone working actively on ACEXML gives me directions I > am willing to > spend my time investigating the problem. I can't remember that work has been done the last months so I am also amazed things broke. Nobody is actively working on it, so I think there are not much directions at this moment. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl On Wednesday 18 May 2005 11:01, Johnny Willemsen wrote: > Hi, > I can't remember that work has been done the last months so I am also > amazed things broke. Nobody is actively working on it, so I think there are > not much directions at this moment. Well, it did definiteley work with 5.4.4. So any changes that broke it must have been made between 5.4.4 and 5.4.5. I also read in the release email of 5.4.5 in the CIAO...

RE: [tao-users] Re: [ace-users] Re: Announcing the release of the new beta (ACE-5.4.10, TAO-1.4.10 and CIAO-0.4.10)
Hi, > > >> We encourage you to download the new beta, use it with your > > >> applications, and let us know soon if you encounter any problems > > >> since we plan to cut the x.5 release by February 28th. > > > > As per Wallace's comments, we have an aggressive schedule > for the x.5 > > release to meet the needs of some major sponsors. If > people can give > > x.4.10 a "test drive" in the next couple of days and report problems > > they encounter we'll try to ensure that we fix any > showstoppers before > > According to bugzilla bug 2323 is not fixed yet. > > http://deuce.doc.wustl.edu/bugzilla/show_bug.cgi?id=2323 > > For us it is a show stopper. We use the OCI version which does not > have problems related to this bug but it would be nice to be able to > use the latest version with more fixes. FYI, the reason that this test now fails is because Ossama added several new test cases which wheren't in the test in the past, this uncovered some bugs which according to our information where already there a long time. Johnny "Johnny Willemsen" <jwillemsen@remedy.nl> writes: > > > >> We encourage you to download the new beta, use it with your > > > >> applications, and let us know soon if you encounter any problems > > > >> sinc...

[tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi Lothar > � � ACE VERSION: 5.4.5 Thanks for using the PRF form. Could you try to find the problem and send us patches to fix this? Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > > � � HOST MACHINE and OPERATING SYSTEM: > uname -a > Linux janus 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC > 2005 x86_64 x86_64 > x86_64 GNU/Linux > > � � TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > � � COMPILER NAME AND VERSION (AND PATCHLEVEL): > gcc-4.0.0 --version > gcc-4.0.0 (GCC) 4.0.0 > > � � CONTENTS OF $ACE_ROOT/ace/config.h [if you use a link to > a platform- > � � specific file, simply state which one]: > cat /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/ace/config.h > #define ACE_HAS_XML_SVC_CONF > #include "ace/config-linux.h" > > � � CONTENTS OF > $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless > � � this isn't used in this case, e.g., with Microsoft Visual C++): > cat > /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/include/makeinclude/ > platform_macros.GNU > > # configure ACE/TAO for our use > > debug=1 > optimize=1 > exceptions=1 > threads=1 > inline=1 > rtti=1 > versioned_so=1 > interface_repo=1 > ssl=1 > > include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU ...

[ace-users] Re: [tao-support] Has ACE 5.4.4/TAO 1.4.4 been built with gcc 4.0.0 yet
Hi Robert, > When building ACE 5.4.4/TAO 1.4.4 using gcc 4.0.0 under fedora core > 4 test 2 on an x86 platform I get a lot of errors mainly to do with > template instantiations. Has anyone successfully build TAO/ACE using > the latest gcc ? We just added GCC 4.0.0 support to ACE+TAO recently. The forthcoming x.4.5 beta should work nicely with GCC 4.0.0. We hope to have this available very shortly (there's just one remaining snag with typecodes that should be fixed in the next day or so). If you'd like to give things a try before we release x.4.5 please download the contents of ACE+TAO from our CVS repo at http://cvs.doc.wustl.edu/ and see if it works for you on your platform. If not, please let us know and we'll try to make sure that it's working before we put out the beta release. Thanks, Doug I've tried the CVS version on macosx 10.4, with gcc4.0 and still got the same intantiation problem. On 5/9/05, Douglas C. Schmidt <schmidt@cs.wustl.edu> wrote: > > Hi Robert, > > > When building ACE 5.4.4/TAO 1.4.4 using gcc 4.0.0 under fedora core > > 4 test 2 on an x86 platform I get a lot of errors mainly to do with > > template instantiations. Has anyone successfully build TAO/ACE using > > the latest gcc ? > > We just added GCC 4.0.0 support to ACE+TAO recently. The forthcoming > x.4.5 beta should work nicely with GCC 4.0.0. We hope to ha...

[ace-bugs] Error during compilation ACE-5.4.4 + TAO-1.4.4
--001485f99caa0c8d8c0475c7d5ee Content-Type: text/plain; charset=UTF-8 Hello,I'm trying to compile ACE-5.4.4+TAO-1.4.4 and I got an error while I trying to compile it: /home/mchacon/nextgen/extra/ACE_wrappers/ace/os_include/os_stropts.h:64:28: error: stropts.h: No such file or directory I use Fedora 11 with gcc 4.4.1 and I was searching in google and I found that there are some is issue about strems buffer in Linux, please take a look these links: http://www.archivum.info/comp.soft-sys.ace/2008-04/00069/Re:_[tao-users]_PRF:_Autobuild_on_Fedora_Rawhide_(GCC_4.3.0)_is_a_no-go https://bugzilla.redhat.com/show_bug.cgi?id=439403 Is there any workaround to fix it? I have the header in Fedora Core 3, but I trying to make it work in Fedora 11, Is it possible? Thanks and Regards! Salu2... masch... --001485f99caa0c8d8c0475c7d5ee Content-Type: text/html; charset=UTF-8 Content-Transfer-Encoding: quoted-printable Hello,<div>I&#39;m trying to compile ACE-5.4.4+TAO-1.4.4 and I got an error= while I trying to compile it:</div><div><br></div><div>/home/mchacon/nextg= en/extra/ACE_wrappers/ace/os_include/os_stropts.h:64:28: error: stropts.h: = No such file or directory</div> <div><br></div><div>I use Fedora 11 with gcc 4.4.1 and=C2=A0I was searching= in google and I found that there are some is issue about strems buffer in = Linux, please take a look these links:</div&g...

[ace-users] ACE-5.4+TAO-1.4 compilation error.
Here is the problem report: ACE VERSION: 5.4 HOST MACHINE and OPERATING SYSTEM: cygwin on w2k TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): VxWork 5.5.1 Tornado 2.2 CONTENTS OF $ACE_ROOT/ace/config.h: config-vxworks5.x_g++.h CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless this isn't used in this case, e.g., with Microsoft Visual C++): include $(ACE_ROOT)/include/makeinclude/platform_vxworks5.x_g++.GNU AREA/CLASS/EXAMPLE AFFECTED: [What example failed? What module failed to compile?] DOES THE PROBLEM AFFECT: COMPILATION? X LINKING? On Unix systems, did you run make realclean first? EXECUTION? OTHER (please specify)? [Please indicate whether ACE, your application, or both are affected.] ACE does not compile. SYNOPSIS: [Brief description of the problem] In ace/Time_Value.h, it includes Time_Value.inl where timespec_t is typdefed as struct timespec. However, h/times.h where struct timespec is included at ace/post.h after Time_Value.inl. I compiled ace by cd into ace directory and make, then G++ complained about the use of the members of of timespec_t type and error out, compilation stoped. here is the make.log c:/Tornado2.2/host/x86-win32/bin/ccppc -mlongcall -Bc:/Tornad...

[ace-users] Re: a little bug of ACE-5.4.1+TAO-1.4.1+CIAO-0.4.1.tar.gz
Hi Adam, Please upgrade to ACE+TAO x.4.8, which you can download from http://deuce.doc.wustl.edu/Download.html under the heading "latest beta kit". The DOC groups at Washington University, UC Irvine, and Vanderbilt University only provide "best effort" support for non-sponsors for the latest beta kit, as described in http://www.cs.wustl.edu/~schmidt/ACE_wrappers/docs/ACE-bug-process.html Thus, if you need more "predictable" help for ACE 5.4.1, I recommend that you check out http://www.cs.wustl.edu/~schmidt/commercial-support.html for a list of companies that will provide you with ACE+TAO commercial support. Thanks, Doug >> When I compile this version, it prompts me the following errors that >> /*------ >> gmake[6]: *** No rule to make target `Client_Request_Interceptor.cpp', >> needed by `.obj/Client_Request_Interceptor.o'. Stop. >> ------*/ >> >> Then I find there is something wrong about the directory: >> /export/home/adam/ace.5.4.1.cc.64/TAO/tests/Portable_Interceptors/Request_Interceptor_Flow >> There are two files whose file names suffix are very strange. >> 1. Client_Request_Interceptor.cp >> 2. Server_Request_Interceptor.cp >> After I rename them from .cp to .cpp >> >> I wonder if this is a bug or some thing I configure wrong? >> >> Regards, >> Adam >> -...

RE: [ace-users] segfault on linux x86-64 with ACE/TAO 5.4.4/1.4.4
Hi Lothar, Thanks for using the PRF form. It looks that one of the pointers to strcmp is zero, maybe that results in the crash. Could you post a small test app that reproduces the problem? Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > ACE VERSION: 5.4.4 > > HOST MACHINE and OPERATING SYSTEM: > uname -a > Linux janus 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC > 2005 x86_64 x86_64 > x86_64 GNU/Linux > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > COMPILER NAME AND VERSION (AND PATCHLEVEL): > gcc-4.0.0 --version > gcc-4.0.0 (GCC) 4.0.0 > > CONTENTS OF $ACE_ROOT/ace/config.h [if you use a link to > a platform- > specific file, simply state which one]: > cat /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/ace/config.h > #define ACE_HAS_XML_SVC_CONF > #include "ace/config-linux.h" > > CONTENTS OF > $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless > this isn't used in this case, e.g., with Microsoft Visual C++): > cat > /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/include/makeinclude/ > platform_macros.GNU > > # configure ACE/TAO for our use > > debug=1 > optimize=1 > exceptions=1 > threads=1 > inline=1 > rtti=1 > versioned_so=1 > interface_repo=1 > ssl=...

RE: [ace-users] segfault on linux x86-64 with ACE/TAO 5.4.4/1.4.4 #2
Hi, > Thanks for the reply. > The reason why I posted the stacktrace is that I have > currently no clue how to > reproduce a small testcase. But I will keep trying. > > I had the hope that someone familiar with ACE_Malloc_T<> > could shed light on > this subject. As I said the curious thing is that it works > with 32bit and > fails with 64bit. The only thing that I can imagine off is that somewhere a 64bit pointer is by accident handled as 32bit. Johnny ...

RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > Well, it did definiteley work with 5.4.4. So any changes that > broke it must > have been made between 5.4.4 and 5.4.5. I also read in the > release email of > 5.4.5 in the CIAO section: > > The Config Handlers have been modified to use XML parsing code > � generated by the XML Schema Compiler (XSC). �Binary releases of XSC > � can currently be found at > (http://www.dre.vanderbilt.edu/~boris/xsc), > � and a recent snapshot of the CVS repository can be found at > � (http://www.dre.vanderbilt.edu/~wotte/xsc.tbz2). �We plan > to integrate > � XSC into the CVS repo and release soon. This is CIAO only, there must be a change in ACEXML or ACE that has done this. The ACEXML library has it own changelog > I don't know if that affects only CIAO or ACE as well, but it > might be > related. > > I would be still glad if someone has any pointers/ideas where > exactely I > should spend my time efficiently in order to investigate the problem. > > P.S. > Aren't there any nightly build configuration(s) that uses XML > rather than the > old service configuration? No, so far as I know there are no builds testing this. Another option you have is pass this on to a commercial support organization and also sponsor then an autobuild with xml service config files. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The ...

[ace-users] Re: Error while ACE 5.3.1 or 5.4.1 compiling and installing by MinGW 3.3.3
Hi Vitaly, Please upgrade to ACE 5.4.4, which you can download from http://deuce.doc.wustl.edu/Download.html since I think that is more likely to work with MinGW 3.3.3. Johnny, can you confirm/deny this please? Thanks, Doug >> Hi, >> I have installed MinGW packages: >> >> binutils-2.13.90-20030111-1.tar.gz >> gcc-core-3.3.3-20040217-1.tar.gz >> gcc-g++-3.3.3-20040217-1.tar.gz >> mingw-runtime-3.3.tar.gz >> w32api-2.5.tar.gz >> >> Also I've configured environment due to ACE-INSTALL.html according >> MinGW compiler. OS: WinXP SP2. >> >> $ACE_ROOT=F:\ACE531 >> >> I get next compiling error: >> F:\ACE531\ace>gmake >> gmake.EXE[1]: Entering directory `F:/ACE531/ace' >> d:\Utils\Unix\diff.EXE: -: Invalid argument >> gmake.EXE[1]: Leaving directory `F:/ACE531/ace' >> gmake.EXE[1]: Entering directory `F:/ACE531/ace' >> d:/Utils/Unix/gmake.EXE -f Makefile.dirs SUBDIR_TARGET=all >> RMCast.subdir >> gmake.EXE[2]: Entering directory `F:/ACE531/ace' >> d:/Utils/Unix/gmake.EXE -f Makefile -C RMCast all >> gmake.EXE[3]: Entering directory `F:/ACE531/ace/RMCast' >> Installing libACE_RMCast.dll -> F:\ACE531/ace >> d:\Utils\Unix\cp.EXE: F:ACE531aceRMCast/libACE_RMCast.dll: No such >> file or directory >> Installing libACE_RMCa...

RE: [ace-users] ACE+TAO+CIAO
Hi, Please use the prf form and which configuration you build. I personally think you have an old version of ACE/TAO on the system that is used. Regards, Johnny > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Domingos Monteiro > Sent: donderdag 9 juni 2005 18:05 > To: Simon McQueen > Cc: ace-users@cs.wustl.edu > Subject: Re: [ace-users] ACE+TAO+CIAO - 5.4.6 + 1.4.6 + 0.4.6 released > > Hi, > > I've just dowloaded this version > I've started to compile ACE with > - MSVC 7.1 > - Win XP > And get the following link errors: > > Message_Block.obj : error LNK2005: "public: virtual void __thiscall > ACE_Deadline_Message_Strategy::convert_priority(class ACE_Time_Value > &,class ACE_Message_Block const &)" > (?convert_priority@ACE_Deadline_Message_Strategy@@UAEXAAVACE_T > ime_Value@@ABVACE_Message_Block@@@Z) > already defined in CDR_Size.obj > Message_Block.obj : error LNK2005: "public: virtual void __thiscall > ACE_Laxity_Message_Strategy::convert_priority(class ACE_Time_Value > &,class ACE_Message_Block const &)" > (?convert_priority@ACE_Laxity_Message_Strategy@@UAEXAAVACE_Tim > e_Value@@ABVACE_Message_Block@@@Z) > already defined in CDR_Size.obj > SString.obj : error LNK2005: "public: __thiscall > ACE_NS_WString::ACE_N...

[ace-bugs] Re: [ace-users] ACE 5.4.1 compilation failure on FreeBSD 5.2
Hi Jarek, >> Has anyone built ACE 5.4.1 with Proactor on FreeBSD 5.2-RELEASE ? I don't think we have access to this platform. If you can send us a patch that fixes the problem that would be great! Thanks, Doug >> ACE VERSION: 5.4.1 >> >> HOST MACHINE and OPERATING SYSTEM: >> >> FreeBSD 5.2-RELEASE >> >> $ uname -a >> FreeBSD skorpion 5.2-RELEASE FreeBSD 5.2-RELEASE #0: Sat Jan 17 20:17:52 CET >> 2004 jarek@skorpion:/usr/src/sys/i386/compile/JAREK_1 i386 >> >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> >> Same >> >> $ g++ -v >> Using built-in specs. >> Configured with: FreeBSD/i386 system compiler >> Thread model: posix >> gcc version 3.3.3 [FreeBSD] 20031106 >> >> CONTENTS OF $ACE_ROOT/ace/config.h [if you use a link to a platform- >> specific file, simply state which one]: >> >> config-freebsd.h >> >> CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless >> this isn't used in this case, e.g., with Microsoft Visual C++): >> >> platform_freebsd.GNU >> >> AREA/CLASS/EXAMPLE AFFECTED: >> >> POSIX_CB_Proactor.cpp >> >> DOES THE PROBLEM AFFECT: ...

[ace-users] segfault on linux x86-64 with ACE/TAO 5.4.4/1.4.4
ACE VERSION: 5.4.4 HOST MACHINE and OPERATING SYSTEM: uname -a Linux janus 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC 2005 x86_64 x86_64 x86_64 GNU/Linux TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc-4.0.0 --version gcc-4.0.0 (GCC) 4.0.0 CONTENTS OF $ACE_ROOT/ace/config.h [if you use a link to a platform- specific file, simply state which one]: cat /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/ace/config.h #define ACE_HAS_XML_SVC_CONF #include "ace/config-linux.h" CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless this isn't used in this case, e.g., with Microsoft Visual C++): cat /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/include/makeinclude/platform_macros.GNU # configure ACE/TAO for our use debug=1 optimize=1 exceptions=1 threads=1 inline=1 rtti=1 versioned_so=1 interface_repo=1 ssl=1 include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU # Disable the RCSID for release/non-debug builds. CPPFLAGS += -DACE_USE_RCSID=0 # enable 64 bit build CPPFLAGS += -m64 # enable 32 bit build #CPPFLAGS += -m32 CC=/opt2/linux/x86_64/bin/gcc-4.0.0 CXX=/opt2/linux/x86_64/bin/g++-4.0.0 TAO_IDL_PREPROCESSOR=${CC} CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features (used by MPC when you generate your own makefiles): AREA/CLASS/EXAMPLE AFFECTED: application / unit tests ...

Re: [ace-users] Errors while compiling c++ 3.4.2
Hi Eyal, I believe we've fixed these problems in the latest version of ACE that's tucked inside our CVS repository. Can you please take a look at this version available in http://deuce.doc.wustl.edu/Download.html and see if things work better. If not, please let us know so we can fix them before we release ACE 5.4.3 in a week or so. Thanks, Doug >> I get the following while compiling: >> >> /usr/bin/c++ -D_POSIX_C_SOURCE=199506L -DNDEBUG -DUSING_GCC >> -D_POSIX_PTHREAD_SEMANTICS -DLINUX -I../inc >> -I../3rd_party/ACE-5.3.0/ACE_wrappers -fPIC -pedantic -fno-for-scope >> -Wno-long-long -Wno-deprecated -o Trace.o.linux -c Trace.cpp >> In file included from >> ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/Unbounded_Set.h:306, >> from ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/Memory_Pool.h:30, >> from ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/Malloc.h:414, >> from ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/String_Base.cpp:3, >> from ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/String_Base.h:423, >> from ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/SString.h:17, >> from >> ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/Configuration.h:34, >> from >> ../3rd_party/ACE-5.3.0/ACE_wrappers/ace/Configuration_Import_Export.h:28, >...

RE: [ace-users] Re: ACE 5.4 compilation error on HP-UX 11.11/GNU g++ 3.4.3
The needed fix is, indeed, in ACE 5.5. If, for some reason, you need to stay on 5.4, the 5.4e Fix Kit from Riverace has this problem fixed as well. The fix is needed for g++ 3.4 on any platform. -Steve -- Steve Huston, Riverace Corporation Helping you succeed with ACE See http://www.riverace.com/support.htm > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Douglas C. Schmidt > Sent: Saturday, March 11, 2006 7:01 PM > To: ecoboja@yahoo.com; ace-users@cs.wustl.edu > Subject: [ace-users] Re: ACE 5.4 compilation error on HP-UX > 11.11/GNU g++ 3.4.3 > > > Hi, > > Thanks for using the PRF. > > >> ACE VERSION: 5.4 > > Please upgrade to ACE 5.5, which you can download from > > http://deuce.doc.wustl.edu/Download.html > > The DOC groups at Washington University, UC Irvine, and Vanderbilt > University only provide "best effort" support for non-sponsors for the > latest release, as described in > > http://www.cs.wustl.edu/~schmidt/ACE_wrappers/docs/ACE-bug-pro > cess.html > > Thus, if you need more "predictable" help for ACE 5.4, I recommend > that you check out > >...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi, >> ACE VERSION: 5.4.3 Thakns for using the PRF! >> HOST MACHINE and OPERATING SYSTEM: >> Solaris10 X86 We (i.e., the DOC groups at UCI/VU/WU) don't have Solaris running on an x86 box (yet). It would therefore be great if you could figure out what patches need to be applied so that ACE compiles properly on this platform. BTW, Kitty/Bala, weren't we planning on running Solaris on an AMD box at some point? Thanks, Doug >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> Compiler: SUN CC 5.6 >> Make: GNU make 3.80 >> >> CONTENTS OF $ACE_ROOT/ace/config.h [if you use a link to a >> platform- >> specific file, simply state which one]: >> #include "ace/config-sunos5.9.h" >> >> CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU >> (unless >> this isn't used in this case, e.g., with Microsoft Visual C++): >> include $(ACE_ROOT)/include/makeinclude/platform_sunos5_sunc++.GNU >> >> >> CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features >> (used by MPC when you generate your own makefiles): >> >> AREA/CLASS/EXAMPLE AFFECTED: >> [What example failed? What module failed to com...

[ace-users] Re: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi Jin, >> The solaris 9/10 for sparc is not the same as solaris 9/10 for >> Intel X86,although it is almost free,and the SunStudio 9 (CC >> 5.6)for sparc is not the same as SunStudio 9(CC 5.6) for Intel X86. This is yet one more reason why you'll need to do the legwork on this. Please let us know what you find out. Thanks, Doug -- Dr. Douglas C. Schmidt, Professor TEL: (615) 343-8197 Electrical Engineering and Computer Science FAX: (615) 343-7440 Vanderbilt University WEB: www.cs.wustl.edu/~schmidt/ Nashville, TN 37203 NET: d.schmidt@vanderbilt.edu ...

RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5
Hi, > ACE VERSION: 5.5 Thanks for using the PRF form. > HOST MACHINE and OPERATING SYSTEM: > > Intel, WindowsXp, Windows 2003 An important bit information is missing, which compiler did you use. > AREA/CLASS/EXAMPLE AFFECTED: > The only problem we encountered was a compilation error > when construction ACE_Time_Value. > > The ACE_Time_Value cannot be constructed anymore from an integer. > > For example: ACE_Time_Value( 5 ) --> Compile error Great to hear things work without problems. This errors sounds strange, we do have test cases like this in tests/Time_Value_Test.cpp. We do have made all constructors of ACE_Time_Value explicit. As a result if you have a method that expects a ACE_Time_Value&, you just can't pass for example 5, you have to pass an ACE_Time_Value(5). Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Steve, > > Is this necessary? I mean make it implicit by default. The > > explicit is > > not even supported, and has no chance to work cleanly. Why > > should we patch > > broken stuff. Just a thought? > > At least for ACE 5.5, Riverace supports the Forte compiler that > requires explicit. After that, we can drop it. Ok. Steve, could you maybe make clear with the build names which builds use explicit templates? Explicit templates in TAO are known to be broken at this moment. Johnny ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
> > Ok, the problem is in platform_sunos5_sunc++.GNU, when a > not known forte > > version is found, it defaults to explicit. I am updating > right now, for 4.2 > > and 5.3 we default to explicit, for all others to implicit This sounds good. > Is this necessary? I mean make it implicit by default. The > explicit is > not even supported, and has no chance to work cleanly. Why > should we patch > broken stuff. Just a thought? At least for ACE 5.5, Riverace supports the Forte compiler that requires explicit. After that, we can drop it. Thanks, -Steve ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
> Ok. Steve, could you maybe make clear with the build names > which builds use explicit templates? I'll try to get this clarified. > Explicit templates in TAO are known to be broken at this > moment. None of the tests at Riverace try to build TAO. -Steve ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > > I don't think the DOC group supports this compiler anymore.. More > > > particularly this compiler is buggy and you may land up with > > > unresolved > > > symbols even if you get past this part. > > > > I missed the compiler version. But, Forte 8 gives output of > SUN C++ 5.5. Ok, the problem is in platform_sunos5_sunc++.GNU, when a not known forte version is found, it defaults to explicit. I am updating right now, for 4.2 and 5.3 we default to explicit, for all others to implicit Qinghuajin and other Forte 9 users, you can work around this by added the following line to your platform_macros.GNU file. templates = implicit Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Johnny- > Ok, the problem is in platform_sunos5_sunc++.GNU, when a not known forte > version is found, it defaults to explicit. I am updating right now, for 4.2 > and 5.3 we default to explicit, for all others to implicit Is this necessary? I mean make it implicit by default. The explicit is not even supported, and has no chance to work cleanly. Why should we patch broken stuff. Just a thought? > Qinghuajin and other Forte 9 users, you can work around this by added the > following line to your platform_macros.GNU file. > templates = implicit This is until we release x.4.4., right? Thanks Bala ...

Web resources about - RE: [ace-users] ACE-5.4+TAO-1.4 compilation error. - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/5/2016 7:22:25 PM