f



RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5

Hi,

> ACE VERSION: 5.5

Thanks for using the PRF form.

> HOST MACHINE and OPERATING SYSTEM:
> 
>    Intel, WindowsXp, Windows 2003

An important bit information is missing, which compiler did you use.

> AREA/CLASS/EXAMPLE AFFECTED:
>    The only problem we encountered was a compilation error 
> when construction ACE_Time_Value.
> 
>    The ACE_Time_Value cannot be constructed anymore from an integer.
> 
>    For example: ACE_Time_Value( 5 ) --> Compile error

Great to hear things work without problems. This errors sounds strange, we
do have test cases like this in tests/Time_Value_Test.cpp. We do have made
all constructors of ACE_Time_Value explicit. As a result if you have a
method that expects a ACE_Time_Value&, you just can't pass for example 5,
you have to pass an ACE_Time_Value(5). 

Regards,

Johnny Willemsen
Remedy IT
Postbus 101
2650 AC  Berkel en Rodenrijs
The Netherlands
www.theaceorb.nl / www.remedy.nl  


0
Johnny
3/7/2006 12:52:52 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
1215 Views

Similar Articles

[PageSpeed] 51

Reply:

Similar Artilces:

Re: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2
Hi Ishay, >> Sorry, we are using DevStudio 7.1 (2003) We use this too. Please see ACE_ROOT/tests/Time_Value_Test.cpp for lots of examples that use ACE_Time_Value with integers. Please see if this works on your OS/compiler platform. Thanks, Doug >> ~ Ishay >> >> Software Architect >> Onigma Ltd. >> Tel: +972-3-6877315 >> Fax: +972-3-6877128 >> Mobile: +972-54-2325090 >> Email: ishay@onigma.com >> >> -----Original Message----- >> From: Johnny Willemsen [mailto:jwillemsen@remedy.nl] >> Sent: Tuesday, March 07, 2006 2:42 PM >> To: 'Ishay Green'; ace-users@cs.wustl.edu >> Subject: RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 >> >> Hi, >> >> > ACE VERSION: 5.5 >> >> Thanks for using the PRF form. >> >> > HOST MACHINE and OPERATING SYSTEM: >> > >> > Intel, WindowsXp, Windows 2003 >> >> An important bit information is missing, which compiler did you use. >> >> > AREA/CLASS/EXAMPLE AFFECTED: >> > The only problem we encountered was a compilation error >> > when construction ACE_Time_Value. >> > >> > The ACE_Time_Value cannot be constructed anymore from an integer. >> > >> > For example: ACE_Time_Value( 5 ) --> Compile error >>...

RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2
Hi, Sorry, we are using DevStudio 7.1 (2003) ~ Ishay Software Architect Onigma Ltd. Tel: +972-3-6877315 Fax: +972-3-6877128 Mobile: +972-54-2325090 Email: ishay@onigma.com -----Original Message----- From: Johnny Willemsen [mailto:jwillemsen@remedy.nl] Sent: Tuesday, March 07, 2006 2:42 PM To: 'Ishay Green'; ace-users@cs.wustl.edu Subject: RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 Hi, > ACE VERSION: 5.5 Thanks for using the PRF form. > HOST MACHINE and OPERATING SYSTEM: > > Intel, WindowsXp, Windows 2003 An important bit information is missing, which compiler did you use. > AREA/CLASS/EXAMPLE AFFECTED: > The only problem we encountered was a compilation error > when construction ACE_Time_Value. > > The ACE_Time_Value cannot be constructed anymore from an integer. > > For example: ACE_Time_Value( 5 ) --> Compile error Great to hear things work without problems. This errors sounds strange, we do have test cases like this in tests/Time_Value_Test.cpp. We do have made all constructors of ACE_Time_Value explicit. As a result if you have a method that expects a ACE_Time_Value&, you just can't pass for example 5, you have to pass an ACE_Time_Value(5). Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

[ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5
This is a multi-part message in MIME format. --Boundary_(ID_ogLNJ2XjtOnI/qoGYuqYNQ) Content-type: text/plain; charset=us-ascii Content-transfer-encoding: 7BIT ACE VERSION: 5.5 HOST MACHINE and OPERATING SYSTEM: Intel, WindowsXp, Windows 2003 AREA/CLASS/EXAMPLE AFFECTED: Our team has upgraded from ACE 5.4.7 to ACE 5.5. I am submitting this email as a service for the ace members that considure upgrading to ACE 5.5 and using the same platform and features we are using from the ACE Frameworks library. After running a regression test the upgrade seemed to work without any problems. The only problem we encountered was a compilation error when construction ACE_Time_Value. The ACE_Time_Value cannot be constructed anymore from an integer. For example: ACE_Time_Value( 5 ) --> Compile error DESCRIPTION: We are using ACE_WIN32_Proactor with sockets, pipes and directory changes. BOTTOM LINE: If you are an ace user who are using the same platform and architecture you could upgrade to the new framework knowing that somewhere in the world (Israel/Onigma) the upgrade worked perfectly and nightly. ~ Ishay Software Architect Onigma Ltd. Tel: +972-3-6877315 Fax: +972-3-6877128 Mobile: +972-54-2325090 Email: ishay@onigma.com --Boundary_(ID_ogLNJ2XjtOnI/qoGYuqYNQ) Content-type: text/html; charset=us-ascii Content-transfer-encoding: 7BI...

[ace-users] Re: Upgrading project from ACE 5.2.8 to ACE 5.4 version
Hi Sekhar, Thanks very much for your email. Please make sure to send all questions related to TAO or ACE to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly since I travel frequently and often don't have ready access to email. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. > I got problems when building my project with latest ACE 5.4 version > but my project has no problems while building with ACE 5.2.8 > version. I need help to upgrade my project to build with ACE 5.4 > version. >...

RE: [tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > > Hi Lothar > > > > > � � ACE VERSION: 5.4.5 > > > > Thanks for using the PRF form. Could you try to find the > problem and send > > us patches to fix this? > > > > Regards, > > > > Johnny Willemsen > > I have no problem committing some time to the problem. I do > however know as > much as nothing about the ACE XML parser and it's recent > changes. It seems to > me that (some) of the recent changes might have caused the > test failures. So > if someone working actively on ACEXML gives me directions I > am willing to > spend my time investigating the problem. I can't remember that work has been done the last months so I am also amazed things broke. Nobody is actively working on it, so I think there are not much directions at this moment. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl On Wednesday 18 May 2005 11:01, Johnny Willemsen wrote: > Hi, > I can't remember that work has been done the last months so I am also > amazed things broke. Nobody is actively working on it, so I think there are > not much directions at this moment. Well, it did definiteley work with 5.4.4. So any changes that broke it must have been made between 5.4.4 and 5.4.5. I also read in the release email of 5.4.5 in the CIAO...

[ace-users] error of ACE-5.5.9.tar.gz or ACE-5.5.9.tar.bz2 file size
--0-461002240-1183106959=:96810 Content-Type: text/plain; charset=gb2312 Content-Transfer-Encoding: 8bit Hi All : I found that ACE-5.5.9.tar.gz file size < ACE-5.5.9.tar.bz2 file size, Is it correctly? ACE-5.5.9.tar.bz2 - > 7.68 MB (8,061,560 bytes) ACE-5.5.9.tar.gz - > 7.31 MB (7,674,934 bytes) Regards --------------------------------- ��ע�Ż��������3.5G������20M������ --0-461002240-1183106959=:96810 Content-Type: text/html; charset=gb2312 Content-Transfer-Encoding: 8bit Hi All :<br><br>I found that ACE-5.5.9.tar.gz file size &lt; ACE-5.5.9.tar.bz2&nbsp; file size, Is it correctly?<br><br>ACE-5.5.9.tar.bz2 - &gt; 7.68 MB (8,061,560 bytes)<br>ACE-5.5.9.tar.gz&nbsp; - &gt;&nbsp; 7.31 MB (7,674,934 bytes)<br><br>Regards<br><br><br><p>&#32; <hr size=1><a href="http://cn.mail.yahoo.com" target=blank>��ע�Ż��������3.5G������20M������</a> --0-461002240-1183106959=:96810-- Hi, >I found that ACE-5.5.9.tar.gz file size < ACE-5.5.9.tar.bz2 file size, Is it correctly? > >ACE-5.5.9.tar.bz2 - > 7.68 MB (8,061,560 bytes) >ACE-5.5.9.tar.gz - > 7.31 MB (7,674,934 bytes) Why does it matter? Are the contents the same? Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Va...

[tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi Lothar > � � ACE VERSION: 5.4.5 Thanks for using the PRF form. Could you try to find the problem and send us patches to fix this? Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > > � � HOST MACHINE and OPERATING SYSTEM: > uname -a > Linux janus 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC > 2005 x86_64 x86_64 > x86_64 GNU/Linux > > � � TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > � � COMPILER NAME AND VERSION (AND PATCHLEVEL): > gcc-4.0.0 --version > gcc-4.0.0 (GCC) 4.0.0 > > � � CONTENTS OF $ACE_ROOT/ace/config.h [if you use a link to > a platform- > � � specific file, simply state which one]: > cat /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/ace/config.h > #define ACE_HAS_XML_SVC_CONF > #include "ace/config-linux.h" > > � � CONTENTS OF > $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless > � � this isn't used in this case, e.g., with Microsoft Visual C++): > cat > /opt2/linux/x86_64/ACE/1.4.4/ACE_wrappers/include/makeinclude/ > platform_macros.GNU > > # configure ACE/TAO for our use > > debug=1 > optimize=1 > exceptions=1 > threads=1 > inline=1 > rtti=1 > versioned_so=1 > interface_repo=1 > ssl=1 > > include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU ...

Re: [ace-users] compile ace-5.5.7 error on redhat enterprise linux 5
Hi, > thanks for your advice, but I'm very sorry to say that it still not > work ,I got the same errors as I described earlier. Have you done a full rebuild of the ACE library? johnny This is a multi-part message in MIME format. --------------030205080602090608010905 Content-Type: text/plain; charset=GB2312 Content-Transfer-Encoding: 8bit Johnny Willemsen �: > Hi, > >> thanks for your advice, but I'm very sorry to say that it still not >> work ,I got the same errors as I described earlier. > > Have you done a full rebuild of the ACE library? > > johnny > Surely I did. Maybe I should try the older release.... --------------030205080602090608010905 Content-Type: text/x-vcard; charset=utf-8; name="xphenix.cn.vcf" Content-Transfer-Encoding: base64 Content-Disposition: attachment; filename="xphenix.cn.vcf" YmVnaW46dmNhcmQNCmZuOkxpbWluZyBaaGFuZw0KbjpaaGFuZztMaW1pbmcNCm9yZzpSYWRp YW5UZWs7UmVzZWFyY2ggQW5kIERldmVsb3BtZW50DQphZHI6OztOYXB0dW5lLCBDaG9uZ3Fp bmcsIENoaW5hO0Nob25ncWluZzs7NDAxMTIxO0NoaW5hDQplbWFpbDtpbnRlcm5ldDp4cGhl bml4LmNuQGdtYWlsLmNvbQ0KdGl0bGU6U29mdHdhcmUgRW5naW5lZXINCm5vdGU6TVNOOiB4 cGhlbml4X2NuQGhvdG1haWwuY29tDQp2ZXJzaW9uOjIuMQ0KZW5kOnZjYXJkDQoNCg== --------------030205080602090608010905-- ...

RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > Well, it did definiteley work with 5.4.4. So any changes that > broke it must > have been made between 5.4.4 and 5.4.5. I also read in the > release email of > 5.4.5 in the CIAO section: > > The Config Handlers have been modified to use XML parsing code > � generated by the XML Schema Compiler (XSC). �Binary releases of XSC > � can currently be found at > (http://www.dre.vanderbilt.edu/~boris/xsc), > � and a recent snapshot of the CVS repository can be found at > � (http://www.dre.vanderbilt.edu/~wotte/xsc.tbz2). �We plan > to integrate > � XSC into the CVS repo and release soon. This is CIAO only, there must be a change in ACEXML or ACE that has done this. The ACEXML library has it own changelog > I don't know if that affects only CIAO or ACE as well, but it > might be > related. > > I would be still glad if someone has any pointers/ideas where > exactely I > should spend my time efficiently in order to investigate the problem. > > P.S. > Aren't there any nightly build configuration(s) that uses XML > rather than the > old service configuration? No, so far as I know there are no builds testing this. Another option you have is pass this on to a commercial support organization and also sponsor then an autobuild with xml service config files. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The ...

Re: [ace-users] C2733 error when using ACE-5.5.8 + TProactor to build realse version app, but 5.5.7 is OK. Maybe a bug
Hi, Please use the original PRF in the future. I think this is solved in the upcoming x.5.9 version Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl *** Integrated compile and test statistics see http://scoreboard.theaceorb.nl *** *** Commercial service and support for ACE/TAO/CIAO *** *** See http://www.theaceorb.nl/en/support.html *** <hongxing777@gmail.com> wrote in message news:<1182424516.315329.272880@z28g2000prd.googlegroups.com>... > Version: 5.5.8 > host: windows xp sp2, suse linux enterprise server 9 sp2 > compiler: vs.net 2003, gcc 3.3.3 > > I integrated TProactor into ACE-5.5.8 and build my app based on it. My > app runs stable in debug version. But when I switched to release > version, the compiler reports the following error: > D:\hongxing\component\ACE_wrappers\ace\os_include\os_intrin.h(48) : > error C2733: second C linkage of overloaded function > "_InterlockedExchange" D:\hongxing\component\ACE_wrappers\ace > \os_include\os_intrin.h(49) : error C2733: second C linkage of > overloaded function "_InterlockedExchangeAdd" > > when I switched back to ACE-5.5.7, everything is ok. > I found in the ACE-5.5.8 $ACE_ROOT\ace\os_include dir, there are two > additional files os_byteswap.h and os_intrin.h (compared to > ACE-5.5.7). And ther...

Re: [ace-users] ACE BUG: C2733 compiler error of version 5.5.8 and 5.5.9.
Hi, Where is the error exact coming from, the Tproactor, or something else Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl *** Integrated compile and test statistics see http://scoreboard.theaceorb.nl *** *** Commercial service and support for ACE/TAO/CIAO *** *** See http://www.theaceorb.nl/en/support.html *** <hongxing777@gmail.com> wrote in message news:<1182916210.107576.239920@i38g2000prf.googlegroups.com>... > Version: 5.5.9 > host: windows xp sp2, suse linux enterprise server 9 sp2 > compiler: vs.net 2003, gcc 3.3.3 > > I integrated TProactor into ACE-5.5.9 and build my app based on it. > My > app runs stable in debug version. But when I switched to release > version, the compiler reports the following error: > D:\ACE_wrappers\ace\os_include\os_intrin.h(48) : error C2733: second C > linkage of overloaded function "_InterlockedExchange" > D:\ACE_wrappers\ace\os_include\os_intrin.h(49) : error C2733: second C > linkage of overloaded function "_InterlockedExchangeAdd" > > when I switched back to ACE-5.5.7, everything is ok. > I found in the ACE-5.5.9 $ACE_ROOT\ace\os_include dir, there are two > additional files os_byteswap.h and os_intrin.h (compared to > ACE-5.5.7). And there is a new additional option > ACE_HAS_INTRINSIC_INTERLOCKED. I...

[ace-bugs] Re: [ace-users] ACE 5.4.1 compilation failure on FreeBSD 5.2
Hi Jarek, >> Has anyone built ACE 5.4.1 with Proactor on FreeBSD 5.2-RELEASE ? I don't think we have access to this platform. If you can send us a patch that fixes the problem that would be great! Thanks, Doug >> ACE VERSION: 5.4.1 >> >> HOST MACHINE and OPERATING SYSTEM: >> >> FreeBSD 5.2-RELEASE >> >> $ uname -a >> FreeBSD skorpion 5.2-RELEASE FreeBSD 5.2-RELEASE #0: Sat Jan 17 20:17:52 CET >> 2004 jarek@skorpion:/usr/src/sys/i386/compile/JAREK_1 i386 >> >> TA...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads.
--0-2130807226-1099048241=:32593 Content-Type: text/plain; charset=us-ascii Hello, One more observation. The problem occurs only when the entry in the services file has 8888 or 6888 or 8887 or 7886. i.e Basically when the entry has two '8' in the second two digits in the port number. This problem was not encountered with ACE 5.1. It is quite a strange occurence. We are using ACE_INET_Addr("ipname","portname") constructor. Please do let us know if there is any workaround for the same. Thanks and Regards, ashish borkar <ashish_ace2003@yahoo.c...

Re: [ace-users] g++ 3.4.3 and ACE 5.5 & TAO 1.5
Hi, Please upgrade to ACE/TAO 1.5.3 which you can obtain from http://download.dre.vanderbilt.edu. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl "M@uro!!" <mauro.gaddo@gmail.com> wrote in message news:<1161692263.239945.111960@m7g2000cwm.googlegroups.com>... > During compiling on HP-UX 11.11 with g++ i have the following error: > > g++ -DHAVE_CONFIG_H -I../.. -I.. -DACE_HAS_ACE_TOKEN > -DACE_HAS_ACE_SVCCONF -DACE_BUILD_DLL -DHPUX_VERS=1111 -w -W -Wall > -Wpointer-arith -g -O2 -pthread -pipe -I. -I.. -MT > libACE_la-OS_NS_stdio.lo -MD -MP -MF .deps/libACE_la-OS_NS_stdio.Tpo -c > ../../ace/OS_NS_stdio.cpp -fPIC -DPIC -o .libs/libACE_la-OS_NS_stdio.o > ../../ace/OS_NS_stdio.cpp: In function `int ACE_OS::fprintf(FILE*, > const wchar_t*, ...)': > ../../ace/OS_NS_stdio.cpp:242: error: `::vfwprintf' has not been > declared > > Can someone helps me? > > Thanks!! > M. > ...

Re: [ace-users] compile ace-5.5.7 error on redhat enterprise linux 5 #2
Hi, I don't think an older release will also not work. This is a new OS with a new compiler, I would expect the define to work, but strangely it doesn't work. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl "Zhang Liming" <xphenix.cn@gmail.com> wrote in message news:<f06r86$e2o$1@news.yaako.com>... > Johnny Willemsen ??: > > Hi, > > > >> thanks for your advice, but I'm very sorry to say that it still not > >> work ,I got the same errors as I described earlier. > > > > Have you done a full rebuild of the ACE library? > > > > johnny > > > Surely I did. Maybe I should try the older release.... > > This is a multi-part message in MIME format. --------------040607020902010404080705 Content-Type: text/plain; charset=GB2312 Content-Transfer-Encoding: 8bit Johnny Willemsen �: > Hi, > > I don't think an older release will also not work. This is a new OS with a > new compiler, I would expect the define to work, but strangely it doesn't > work. > > Regards, > > Johnny Willemsen > Remedy IT > Postbus 101 > 2650 AC Berkel en Rodenrijs > The Netherlands > www.theaceorb.nl / www.remedy.nl > > > "Zhang Liming" <xphenix.cn@gmail.com> wrote in message > n...

[ace-users] ACE 5.5.7
------=_Part_208621_21000434.1174652008180 Content-Type: text/plain; charset=ISO-8859-1; format=flowed Content-Transfer-Encoding: 7bit Content-Disposition: inline Hi everybody, I am traying to install the ACE 5.5.7 but I ------=_Part_208621_21000434.1174652008180 Content-Type: text/html; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline Hi everybody,<br> I am traying to install the ACE 5.5.7 but I <br> ------=_Part_208621_21000434.1174652008180-- ...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads. #2
Hi Ashish, >> Thankyou very much for your reply. >> As per our analysis, in Inet_Addr.cpp file, for some reason port_number variable is set to some negative value because of which, in the set function at line number 396 control is going in the if loop >> if (port_number < 0 ) >> { >> ACE_UNUSED_ARG(inet_address); >> ACE_NOTSUP_RETURN(-1); >> } >> which is returning -1 and that is why we are getting value of port as 0000.0000 in our application. >> This may be because port_number is not in the network byte order. R...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads. #2
Hi Ashish, >> One more observation. The problem occurs only when the entry in the services file has >> 8888 or 6888 or 8887 or 7886. i.e Basically when the entry has two '8' in the second two digits in the port number. This problem was not encountered with ACE 5.1. >> It is quite a strange occurence. >> We are using ACE_INET_Addr("ipname","portname") constructor. >> >> Please do let us know if there is any workaround for the same. This does indeed sound very strange! We (i.e., the members of the DOC group at VU/UCI...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads. #2
--0-1676139888-1099299995=:70132 Content-Type: multipart/alternative; boundary="0-1128690004-1099299995=:70132" --0-1128690004-1099299995=:70132 Content-Type: text/plain; charset=us-ascii Note: forwarded message attached. --------------------------------- Do you Yahoo!? Yahoo! Mail - Helps protect you from nasty viruses. --0-1128690004-1099299995=:70132 Content-Type: text/html; charset=us-ascii <DIV><BR><BR>Note: forwarded message attached.</DIV><p> <hr size=1>Do you Yahoo!?<br> <a href="http://us.rd.yaho...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi, >> ACE VERSION: 5.4.3 Thakns for using the PRF! >> HOST MACHINE and OPERATING SYSTEM: >> Solaris10 X86 We (i.e., the DOC groups at UCI/VU/WU) don't have Solaris running on an x86 box (yet). It would therefore be great if you could figure out what patches need to be applied so that ACE compiles properly on this platform. BTW, Kitty/Bala, weren't we planning on running Solaris on an AMD box at some point? Thanks, Doug >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPIL...

[ace-users] Re: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi Jin, >> The solaris 9/10 for sparc is not the same as solaris 9/10 for >> Intel X86,although it is almost free,and the SunStudio 9 (CC >> 5.6)for sparc is not the same as SunStudio 9(CC 5.6) for Intel X86. This is yet one more reason why you'll need to do the legwork on this. Please let us know what you find out. Thanks, Doug -- Dr. Douglas C. Schmidt, Professor TEL: (615) 343-8197 Electrical Engineering and Computer Science FAX: (615) 343-7440 Vanderbilt University WEB: www.cs.wustl.edu/~schmidt/ Nashvil...

Re: [ace-users] When is planed to release the ACE 5.5 and TAO 1.5 ?
Hi Slava, >> When is planed to release the ACE 5.5 and TAO 1.5? My current estimate is in the early fall of '05. We'd originally planned to do it this summer, but we have a lot of DOC group members going on summer internships at various companies we work closely with at ISIS, so that'll set our schedule back a bit. The main new capabilities that'll be in ACE+TAO+CIAO x.5 is the Real-time CCM stuff we'll be adding to CIAO over the next several months. There will also be a bunch of time/space optimizations, as well. Take care, Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Institute for Software Integrated Systems WEB: www.dre.vanderbilt.edu/~schmidt Vanderbilt University, Nashville TN, 37203 NET: d.schmidt@vanderbilt.edu ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Steve, > > Is this necessary? I mean make it implicit by default. The > > explicit is > > not even supported, and has no chance to work cleanly. Why > > should we patch > > broken stuff. Just a thought? > > At least for ACE 5.5, Riverace supports the Forte compiler that > requires explicit. After that, we can drop it. Ok. Steve, could you maybe make clear with the build names which builds use explicit templates? Explicit templates in TAO are known to be broken at this moment. Johnny ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > Ok, the problem is in platform_sunos5_sunc++.GNU, when a > not known forte > > version is found, it defaults to explicit. I am updating > right now, for 4.2 > > and 5.3 we default to explicit, for all others to implicit > > Is this necessary? I mean make it implicit by default. The > explicit is > not even supported, and has no chance to work cleanly. Why > should we patch > broken stuff. Just a thought? I have thought also about this, but maybe there are users around we don't know if. We can drop all this after x.5 is released, until that time, I just keep it there, just as we have a lot of other stuff that is probably broken. > > Qinghuajin and other Forte 9 users, you can work around > this by added the > > following line to your platform_macros.GNU file. > > templates = implicit > > This is until we release x.4.4., right? Yes, with x.4.4 this will be done correctly. Johnny ...

Web resources about - RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/5/2016 9:12:42 AM