f



RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2

Hi,

Sorry, we are using DevStudio 7.1 (2003)

~ Ishay

Software Architect
Onigma Ltd.
Tel: +972-3-6877315
Fax: +972-3-6877128
Mobile: +972-54-2325090
Email: ishay@onigma.com

-----Original Message-----
From: Johnny Willemsen [mailto:jwillemsen@remedy.nl] 
Sent: Tuesday, March 07, 2006 2:42 PM
To: 'Ishay Green'; ace-users@cs.wustl.edu
Subject: RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5

Hi,

> ACE VERSION: 5.5

Thanks for using the PRF form.

> HOST MACHINE and OPERATING SYSTEM:
> 
>    Intel, WindowsXp, Windows 2003

An important bit information is missing, which compiler did you use.

> AREA/CLASS/EXAMPLE AFFECTED:
>    The only problem we encountered was a compilation error 
> when construction ACE_Time_Value.
> 
>    The ACE_Time_Value cannot be constructed anymore from an integer.
> 
>    For example: ACE_Time_Value( 5 ) --> Compile error

Great to hear things work without problems. This errors sounds strange, we
do have test cases like this in tests/Time_Value_Test.cpp. We do have made
all constructors of ACE_Time_Value explicit. As a result if you have a
method that expects a ACE_Time_Value&, you just can't pass for example 5,
you have to pass an ACE_Time_Value(5). 

Regards,

Johnny Willemsen
Remedy IT
Postbus 101
2650 AC  Berkel en Rodenrijs
The Netherlands
www.theaceorb.nl / www.remedy.nl  


0
Ishay
3/7/2006 1:30:53 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
1045 Views

Similar Articles

[PageSpeed] 13

Reply:

Similar Artilces:

Re: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2
Hi Ishay, >> Sorry, we are using DevStudio 7.1 (2003) We use this too. Please see ACE_ROOT/tests/Time_Value_Test.cpp for lots of examples that use ACE_Time_Value with integers. Please see if this works on your OS/compiler platform. Thanks, Doug >> ~ Ishay >> >> Software Architect >> Onigma Ltd. >> Tel: +972-3-6877315 >> Fax: +972-3-6877128 >> Mobile: +972-54-2325090 >> Email: ishay@onigma.com >> >> -----Original Message----- >> From: Johnny Willemsen [mailto:jwillemsen@remedy.nl] >> Sent: Tuesday, March 07, 2006 2:42 PM >> To: 'Ishay Green'; ace-users@cs.wustl.edu >> Subject: RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 >> >> Hi, >> >> > ACE VERSION: 5.5 >> >> Thanks for using the PRF form. >> >> > HOST MACHINE and OPERATING SYSTEM: >> > >> > Intel, WindowsXp, Windows 2003 >> >> An important bit information is missing, which compiler did you use. >> >> > AREA/CLASS/EXAMPLE AFFECTED: >> > The only problem we encountered was a compilation error >> > when construction ACE_Time_Value. >> > >> > The ACE_Time_Value cannot be constructed anymore from an integer. >> > >> > For example: ACE_Time_Value( 5 ) --> Compile error >>...

RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5
Hi, > ACE VERSION: 5.5 Thanks for using the PRF form. > HOST MACHINE and OPERATING SYSTEM: > > Intel, WindowsXp, Windows 2003 An important bit information is missing, which compiler did you use. > AREA/CLASS/EXAMPLE AFFECTED: > The only problem we encountered was a compilation error > when construction ACE_Time_Value. > > The ACE_Time_Value cannot be constructed anymore from an integer. > > For example: ACE_Time_Value( 5 ) --> Compile error Great to hear things work without problems. This errors sounds strange, we do have test cases like this in tests/Time_Value_Test.cpp. We do have made all constructors of ACE_Time_Value explicit. As a result if you have a method that expects a ACE_Time_Value&, you just can't pass for example 5, you have to pass an ACE_Time_Value(5). Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

[ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5
This is a multi-part message in MIME format. --Boundary_(ID_ogLNJ2XjtOnI/qoGYuqYNQ) Content-type: text/plain; charset=us-ascii Content-transfer-encoding: 7BIT ACE VERSION: 5.5 HOST MACHINE and OPERATING SYSTEM: Intel, WindowsXp, Windows 2003 AREA/CLASS/EXAMPLE AFFECTED: Our team has upgraded from ACE 5.4.7 to ACE 5.5. I am submitting this email as a service for the ace members that considure upgrading to ACE 5.5 and using the same platform and features we are using from the ACE Frameworks library. After running a regression test the upgrade seemed to work without any problems. The only problem we encountered was a compilation error when construction ACE_Time_Value. The ACE_Time_Value cannot be constructed anymore from an integer. For example: ACE_Time_Value( 5 ) --> Compile error DESCRIPTION: We are using ACE_WIN32_Proactor with sockets, pipes and directory changes. BOTTOM LINE: If you are an ace user who are using the same platform and architecture you could upgrade to the new framework knowing that somewhere in the world (Israel/Onigma) the upgrade worked perfectly and nightly. ~ Ishay Software Architect Onigma Ltd. Tel: +972-3-6877315 Fax: +972-3-6877128 Mobile: +972-54-2325090 Email: ishay@onigma.com --Boundary_(ID_ogLNJ2XjtOnI/qoGYuqYNQ) Content-type: text/html; charset=us-ascii Content-transfer-encoding: 7BI...

[ace-users] Re: Upgrading project from ACE 5.2.8 to ACE 5.4 version
Hi Sekhar, Thanks very much for your email. Please make sure to send all questions related to TAO or ACE to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly since I travel frequently and often don't have ready access to email. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. > I got problems when building my project with latest ACE 5.4 version > but my project has no problems while building with ACE 5.2.8 > version. I need help to upgrade my project to build with ACE 5.4 > version. >...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
> Ok. Steve, could you maybe make clear with the build names > which builds use explicit templates? I'll try to get this clarified. > Explicit templates in TAO are known to be broken at this > moment. None of the tests at Riverace try to build TAO. -Steve ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > Ok, the problem is in platform_sunos5_sunc++.GNU, when a > not known forte > > version is found, it defaults to explicit. I am updating > right now, for 4.2 > > and 5.3 we default to explicit, for all others to implicit > > Is this necessary? I mean make it implicit by default. The > explicit is > not even supported, and has no chance to work cleanly. Why > should we patch > broken stuff. Just a thought? I have thought also about this, but maybe there are users around we don't know if. We can drop all this after x.5 is released, until that time, I just keep it there, just as we have a lot of other stuff that is probably broken. > > Qinghuajin and other Forte 9 users, you can work around > this by added the > > following line to your platform_macros.GNU file. > > templates = implicit > > This is until we release x.4.4., right? Yes, with x.4.4 this will be done correctly. Johnny ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Jin, >> I rebuild the ACE package according the instruction above,but get >> the same result. It doesn't look to me like you've added -DACE_HAS_X86_STAT_MACROS to the build-line as recommended by Johnny Willemsen. >> my platform_macros.GNU file has the following lines: >> >> templates = implicit >> include $(ACE_ROOT)/include/makeinclude/platform_sunos5_sunc++.GNU >> >> When i rebuild the ACE library,get the following compile errors: >> $ make inline=0 -j 2 -k -f GNUmakefile.ACE >> ... >&...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Jin, Thanks for using the PRF. >> ACE VERSION: 5.4.3 >> >> HOST MACHINE and OPERATING SYSTEM: >> Solaris 10 x86 >> >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> Sun Studio 9 (Sun CC 5.6) As we've mentioned several times now, we don't have this compiler installed yet on this hardware platform, so if you want things to be fixed soon I recommend you figure out what's going wrong and send us the patches. Otherwise, pl...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi > > ACE VERSION: 5.4.3 > > > > HOST MACHINE and OPERATING SYSTEM: > > Solaris10 X86 > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > > COMPILER NAME AND VERSION (AND PATCHLEVEL): > > Compiler: SUN CC 5.6 ^^^^^^^^^^^^^^^^^^^^^^^^ I don't think the DOC group supports this compiler anymore.. More particularly this compiler is buggy and you may land up with unresolved symbols even if you get past this part. My $0.02. Thanks Bala > > Make: ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Everyon: My SunBlade 150 is back up and available, and has a Sun CC license, though I don't have a lot of bandwidth to admin it. Bala know where it is and has the root password. I'll probably move it into the server room once I have a chance to talk to Dan about it, but I my be out of town this week. [dhinton@blade DRM]$ uname -a SunOS blade 5.9 Generic_112233-03 sun4u sparc SUNW,Sun-Blade-100 Solaris [dhinton@blade DRM]$ CC -V CC: Forte Developer 7 C++ 5.4 2002/03/09 [dhinton@blade DRM]$ gcc --version gcc (GCC) 3.4.2 Copyright (C) 2004 Free Software Foundation, ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
> > Ok, the problem is in platform_sunos5_sunc++.GNU, when a > not known forte > > version is found, it defaults to explicit. I am updating > right now, for 4.2 > > and 5.3 we default to explicit, for all others to implicit This sounds good. > Is this necessary? I mean make it implicit by default. The > explicit is > not even supported, and has no chance to work cleanly. Why > should we patch > broken stuff. Just a thought? At least for ACE 5.5, Riverace supports the Forte compiler that requires explicit. After that, we can drop it....

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > >> It's almost up. There are some issues with installing software as > >> we don't have the media in a compatible form yet. We also don't > >> have Sun CC, and we need to purchase a licence if we need to > >> support Sun CC. > > Ok, that's fine - thanks for the update. I think some other folks > (e.g., LMCO ATL and Remedy) have Solaris 9/10 and Sun CC, so we may > not need to worry about running Sun CC on our machine. Johnny/Gautam, > can you folks please confirm/deny whether you've got Sun CC on Solar...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Steve, > > Is this necessary? I mean make it implicit by default. The > > explicit is > > not even supported, and has no chance to work cleanly. Why > > should we patch > > broken stuff. Just a thought? > > At least for ACE 5.5, Riverace supports the Forte compiler that > requires explicit. After that, we can drop it. Ok. Steve, could you maybe make clear with the build names which builds use explicit templates? Explicit templates in TAO are known to be broken at this moment. Johnny ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Johnny- > > > > ACE VERSION: 5.4.3 > > > > > > > > HOST MACHINE and OPERATING SYSTEM: > > > > Solaris10 X86 > > > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > > > > COMPILER NAME AND VERSION (AND PATCHLEVEL): > > > > Compiler: SUN CC 5.6 > > ^^^^^^^^^^^^^^^^^^^^^^^^ > > > > I don't think the DOC group supports this compiler anymore.. More > > particularly this compiler is buggy and you may land up with ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Johnny- > Ok, the problem is in platform_sunos5_sunc++.GNU, when a not known forte > version is found, it defaults to explicit. I am updating right now, for 4.2 > and 5.3 we default to explicit, for all others to implicit Is this necessary? I mean make it implicit by default. The explicit is not even supported, and has no chance to work cleanly. Why should we patch broken stuff. Just a thought? > Qinghuajin and other Forte 9 users, you can work around this by added the > following line to your platform_macros.GNU file. > templates = implicit This is until w...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > > ACE VERSION: 5.4.3 > > > > > > HOST MACHINE and OPERATING SYSTEM: > > > Solaris10 X86 > > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > > > COMPILER NAME AND VERSION (AND PATCHLEVEL): > > > Compiler: SUN CC 5.6 > ^^^^^^^^^^^^^^^^^^^^^^^^ > > I don't think the DOC group supports this compiler anymore.. More > particularly this compiler is buggy and you may land up with > unresolved > symbols even if you get past this pa...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > > I don't think the DOC group supports this compiler anymore.. More > > > particularly this compiler is buggy and you may land up with > > > unresolved > > > symbols even if you get past this part. > > > > I missed the compiler version. But, Forte 8 gives output of > SUN C++ 5.5. Ok, the problem is in platform_sunos5_sunc++.GNU, when a not known forte version is found, it defaults to explicit. I am updating right now, for 4.2 and 5.3 we default to explicit, for all others to implicit Qinghuajin and other Forte...

[ace-bugs] Re: [ace-users] ACE 5.4.1 compilation failure on FreeBSD 5.2
Hi Jarek, >> Has anyone built ACE 5.4.1 with Proactor on FreeBSD 5.2-RELEASE ? I don't think we have access to this platform. If you can send us a patch that fixes the problem that would be great! Thanks, Doug >> ACE VERSION: 5.4.1 >> >> HOST MACHINE and OPERATING SYSTEM: >> >> FreeBSD 5.2-RELEASE >> >> $ uname -a >> FreeBSD skorpion 5.2-RELEASE FreeBSD 5.2-RELEASE #0: Sat Jan 17 20:17:52 CET >> 2004 jarek@skorpion:/usr/src/sys/i386/compile/JAREK_1 i386 >> >> TA...

Re: [ace-users] compile ace-5.5.7 error on redhat enterprise linux 5 #2
Hi, I don't think an older release will also not work. This is a new OS with a new compiler, I would expect the define to work, but strangely it doesn't work. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl "Zhang Liming" <xphenix.cn@gmail.com> wrote in message news:<f06r86$e2o$1@news.yaako.com>... > Johnny Willemsen ??: > > Hi, > > > >> thanks for your advice, but I'm very sorry to say that it still not > >> work ,I got the same errors as I described earlier. > > > > Have you done a full rebuild of the ACE library? > > > > johnny > > > Surely I did. Maybe I should try the older release.... > > This is a multi-part message in MIME format. --------------040607020902010404080705 Content-Type: text/plain; charset=GB2312 Content-Transfer-Encoding: 8bit Johnny Willemsen �: > Hi, > > I don't think an older release will also not work. This is a new OS with a > new compiler, I would expect the define to work, but strangely it doesn't > work. > > Regards, > > Johnny Willemsen > Remedy IT > Postbus 101 > 2650 AC Berkel en Rodenrijs > The Netherlands > www.theaceorb.nl / www.remedy.nl > > > "Zhang Liming" <xphenix.cn@gmail.com> wrote in message > n...

RE: [tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > > Hi Lothar > > > > > � � ACE VERSION: 5.4.5 > > > > Thanks for using the PRF form. Could you try to find the > problem and send > > us patches to fix this? > > > > Regards, > > > > Johnny Willemsen > > I have no problem committing some time to the problem. I do > however know as > much as nothing about the ACE XML parser and it's recent > changes. It seems to > me that (some) of the recent changes might have caused the > test failures. So > if someone working actively on ACEXML gives me directions I > am willing to > spend my time investigating the problem. I can't remember that work has been done the last months so I am also amazed things broke. Nobody is actively working on it, so I think there are not much directions at this moment. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl On Wednesday 18 May 2005 11:01, Johnny Willemsen wrote: > Hi, > I can't remember that work has been done the last months so I am also > amazed things broke. Nobody is actively working on it, so I think there are > not much directions at this moment. Well, it did definiteley work with 5.4.4. So any changes that broke it must have been made between 5.4.4 and 5.4.5. I also read in the release email of 5.4.5 in the CIAO...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads. #2
Hi Ashish, >> One more observation. The problem occurs only when the entry in the services file has >> 8888 or 6888 or 8887 or 7886. i.e Basically when the entry has two '8' in the second two digits in the port number. This problem was not encountered with ACE 5.1. >> It is quite a strange occurence. >> We are using ACE_INET_Addr("ipname","portname") constructor. >> >> Please do let us know if there is any workaround for the same. This does indeed sound very strange! We (i.e., the members of the DOC group at VU/UCI...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads. #2
Hi Ashish, >> Thankyou very much for your reply. >> As per our analysis, in Inet_Addr.cpp file, for some reason port_number variable is set to some negative value because of which, in the set function at line number 396 control is going in the if loop >> if (port_number < 0 ) >> { >> ACE_UNUSED_ARG(inet_address); >> ACE_NOTSUP_RETURN(-1); >> } >> which is returning -1 and that is why we are getting value of port as 0000.0000 in our application. >> This may be because port_number is not in the network byte order. R...

Re: [ace-users] ACE 5.4 does not read entries from the services file but ACE 5.1 reads. #2
--0-1676139888-1099299995=:70132 Content-Type: multipart/alternative; boundary="0-1128690004-1099299995=:70132" --0-1128690004-1099299995=:70132 Content-Type: text/plain; charset=us-ascii Note: forwarded message attached. --------------------------------- Do you Yahoo!? Yahoo! Mail - Helps protect you from nasty viruses. --0-1128690004-1099299995=:70132 Content-Type: text/html; charset=us-ascii <DIV><BR><BR>Note: forwarded message attached.</DIV><p> <hr size=1>Do you Yahoo!?<br> <a href="http://us.rd.yaho...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi, >> ACE VERSION: 5.4.3 Thakns for using the PRF! >> HOST MACHINE and OPERATING SYSTEM: >> Solaris10 X86 We (i.e., the DOC groups at UCI/VU/WU) don't have Solaris running on an x86 box (yet). It would therefore be great if you could figure out what patches need to be applied so that ACE compiles properly on this platform. BTW, Kitty/Bala, weren't we planning on running Solaris on an AMD box at some point? Thanks, Doug >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPIL...

Web resources about - RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2 - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/5/2016 9:12:08 AM