f



Re: [ace-users] Errors untarring ACE+TAO 5.5.4

Hi,

Thanks for usign the PRF form. This issue was something that got reported
also with x.5.3 and which I stored in bugzilla as bug 2680. This morning I
did retest it with x.5.4 and found that it also happened with this version.
I have fixed this in the release scripts, with x.5.5 this should not happen
anymore.

Regards,

Johnny Willemsen
Remedy IT
Postbus 101
2650 AC  Berkel en Rodenrijs
The Netherlands
www.theaceorb.nl / www.remedy.nl  


<chris.fairles@gmail.com> wrote in message
news:<1164293719.961967.33560@l39g2000cwd.googlegroups.com>...
> ACE VERSION: 5.5.4
> 
>  HOST MACHINE and OPERATING SYSTEM: CentOS 4.3
>  COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc (GCC) 3.4.6 20060404
> (Red Hat 3.4.6-3)
>  THE $ACE_ROOT/ace/config.h FILE: config_linux.h
>  THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE:
> platform_linux.GNU
>  CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/default.features:
> qos=1, ssl=1
> 
> SYNOPSIS:
> tar -x exits with non-zero with either ACE+TAO.bz2 or ACE+TAO.gz. This
> causes errors in rpm spec files where the setup script tests the return
> status of tar for successful completion.
> 
> 
> DESCRIPTION:
> 
> Upon running "tar xzf /usr/src/redhat/SOURCES/ACE+TAO.tar.gz" I get the
> following errors:
> 
> tar: ACE_wrappers/TAO/TAO_ACE.sln: Cannot hard link to
> `ACE_wrappers/TAO/TAO_ACE.sln': No such file or directory
> tar: ACE_wrappers/TAO/TAO_ACE_vc8.TAO_ACE.sln: Cannot hard link to
> `ACE_wrappers/TAO/TAO_ACE_vc8.TAO_ACE.sln': No such file or directory
> tar: Error exit delayed from previous errors
> 
> This causes tar to exit with non-zero return which causes things like
> the %setup script in an rpm spec file to error out.
> 
> error: Bad exit status from /var/tmp/rpm-tmp.98751 (%prep)
> RPM build errors:
>     Bad exit status from /var/tmp/rpm-tmp.98751 (%prep)
> 
> SAMPLE FIX/WORKAROUND:
> I have to go into the spec and re-write the %setup script to NOT check
> for the exit status of the untar command.
> 
> i.e. remove the check in the following code:
> 
> tar -xjff $RPM_SOURCE_DIR/ACE+TAO.tar.bz2
> if [ $? -ne 0 ]; then
>     exit $?
> fi
> 
> Note: --check-links and --ignore-failed-read don't do anything useful.
> 
> Cheers.
> 

0
Johnny
11/23/2006 3:00:27 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
516 Views

Similar Articles

[PageSpeed] 52

Reply:

Similar Artilces:

RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5
Hi, > ACE VERSION: 5.5 Thanks for using the PRF form. > HOST MACHINE and OPERATING SYSTEM: > > Intel, WindowsXp, Windows 2003 An important bit information is missing, which compiler did you use. > AREA/CLASS/EXAMPLE AFFECTED: > The only problem we encountered was a compilation error > when construction ACE_Time_Value. > > The ACE_Time_Value cannot be constructed anymore from an integer. > > For example: ACE_Time_Value( 5 ) --> Compile error Great to hear things work without problems. This errors sounds strange, we do have test cases like this in tests/Time_Value_Test.cpp. We do have made all constructors of ACE_Time_Value explicit. As a result if you have a method that expects a ACE_Time_Value&, you just can't pass for example 5, you have to pass an ACE_Time_Value(5). Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

RE: [tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > > Hi Lothar > > > > > � � ACE VERSION: 5.4.5 > > > > Thanks for using the PRF form. Could you try to find the > problem and send > > us patches to fix this? > > > > Regards, > > > > Johnny Willemsen > > I have no problem committing some time to the problem. I do > however know as > much as nothing about the ACE XML parser and it's recent > changes. It seems to > me that (some) of the recent changes might have caused the > test failures. So > if someone working active...

Re: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2
Hi Ishay, >> Sorry, we are using DevStudio 7.1 (2003) We use this too. Please see ACE_ROOT/tests/Time_Value_Test.cpp for lots of examples that use ACE_Time_Value with integers. Please see if this works on your OS/compiler platform. Thanks, Doug >> ~ Ishay >> >> Software Architect >> Onigma Ltd. >> Tel: +972-3-6877315 >> Fax: +972-3-6877128 >> Mobile: +972-54-2325090 >> Email: ishay@onigma.com >> >> -----Original Message----- >> From: Johnny Willemsen [mailto:jwillemsen@remedy.nl] >> Sent: Tuesday, March 07, 2006 2:42 PM >> To: 'Ishay Green'; ace-users@cs.wustl.edu >> Subject: RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 >> >> Hi, >> >> > ACE VERSION: 5.5 >> >> Thanks for using the PRF form. >> >> > HOST MACHINE and OPERATING SYSTEM: >> > >> > Intel, WindowsXp, Windows 2003 >> >> An important bit information is missing, which compiler did you use. >> >> > AREA/CLASS/EXAMPLE AFFECTED: >> > The only problem we encountered was a compilation error >> > when construction ACE_Time_Value. >> > >> > The ACE_Time_Value cannot be constructed anymore from an integer. >> > >> > For example: ACE_Time_Value( 5 ) --> Compile error >>...

RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 #2
Hi, Sorry, we are using DevStudio 7.1 (2003) ~ Ishay Software Architect Onigma Ltd. Tel: +972-3-6877315 Fax: +972-3-6877128 Mobile: +972-54-2325090 Email: ishay@onigma.com -----Original Message----- From: Johnny Willemsen [mailto:jwillemsen@remedy.nl] Sent: Tuesday, March 07, 2006 2:42 PM To: 'Ishay Green'; ace-users@cs.wustl.edu Subject: RE: [ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5 Hi, > ACE VERSION: 5.5 Thanks for using the PRF form. > HOST MACHINE and OPERATING SYSTEM: > > Intel, WindowsXp, Windows 2003 An important bit information is missing, which compiler did you use. > AREA/CLASS/EXAMPLE AFFECTED: > The only problem we encountered was a compilation error > when construction ACE_Time_Value. > > The ACE_Time_Value cannot be constructed anymore from an integer. > > For example: ACE_Time_Value( 5 ) --> Compile error Great to hear things work without problems. This errors sounds strange, we do have test cases like this in tests/Time_Value_Test.cpp. We do have made all constructors of ACE_Time_Value explicit. As a result if you have a method that expects a ACE_Time_Value&, you just can't pass for example 5, you have to pass an ACE_Time_Value(5). Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

[tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi Lothar > � � ACE VERSION: 5.4.5 Thanks for using the PRF form. Could you try to find the problem and send us patches to fix this? Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > > � � HOST MACHINE and OPERATING SYSTEM: > uname -a > Linux janus 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC > 2005 x86_64 x86_64 > x86_64 GNU/Linux > > � � TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > � � COMPILER NAME AND VERSION (AND PATCHLEV...

[ace-users] [ACE 5.5] Upgrade from ACE 5.4.7 to ACE 5.5
This is a multi-part message in MIME format. --Boundary_(ID_ogLNJ2XjtOnI/qoGYuqYNQ) Content-type: text/plain; charset=us-ascii Content-transfer-encoding: 7BIT ACE VERSION: 5.5 HOST MACHINE and OPERATING SYSTEM: Intel, WindowsXp, Windows 2003 AREA/CLASS/EXAMPLE AFFECTED: Our team has upgraded from ACE 5.4.7 to ACE 5.5. I am submitting this email as a service for the ace members that considure upgrading to ACE 5.5 and using the same platform and features we are using from the ACE Frameworks library. After running a regression test the upgrade seemed to work without any problems. The only problem we encountered was a compilation error when construction ACE_Time_Value. The ACE_Time_Value cannot be constructed anymore from an integer. For example: ACE_Time_Value( 5 ) --> Compile error DESCRIPTION: We are using ACE_WIN32_Proactor with sockets, pipes and directory changes. BOTTOM LINE: If you are an ace user who are using the same platform and architecture you could upgrade to the new framework knowing that somewhere in the world (Israel/Onigma) the upgrade worked perfectly and nightly. ~ Ishay Software Architect Onigma Ltd. Tel: +972-3-6877315 Fax: +972-3-6877128 Mobile: +972-54-2325090 Email: ishay@onigma.com --Boundary_(ID_ogLNJ2XjtOnI/qoGYuqYNQ) Content-type: text/html; charset=us-ascii Content-transfer-encoding: 7BI...

RE: [tao-users] Re: [ace-users] Re: Announcing the release of the new beta (ACE-5.4.10, TAO-1.4.10 and CIAO-0.4.10)
Hi, > > >> We encourage you to download the new beta, use it with your > > >> applications, and let us know soon if you encounter any problems > > >> since we plan to cut the x.5 release by February 28th. > > > > As per Wallace's comments, we have an aggressive schedule > for the x.5 > > release to meet the needs of some major sponsors. If > people can give > > x.4.10 a "test drive" in the next couple of days and report problems > > they encounter we'll try to ensure that we fix any > showstoppers before > > According to bugzilla bug 2323 is not fixed yet. > > http://deuce.doc.wustl.edu/bugzilla/show_bug.cgi?id=2323 > > For us it is a show stopper. We use the OCI version which does not > have problems related to this bug but it would be nice to be able to > use the latest version with more fixes. FYI, the reason that this test now fails is because Ossama added several new test cases which wheren't in the test in the past, this uncovered some bugs which according to our information where already there a long time. Johnny "Johnny Willemsen" <jwillemsen@remedy.nl> writes: > > > >> We encourage you to download the new beta, use it with your > > > >> applications, and let us know soon if you encounter any problems > > > >> sinc...

RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > Well, it did definiteley work with 5.4.4. So any changes that > broke it must > have been made between 5.4.4 and 5.4.5. I also read in the > release email of > 5.4.5 in the CIAO section: > > The Config Handlers have been modified to use XML parsing code > � generated by the XML Schema Compiler (XSC). �Binary releases of XSC > � can currently be found at > (http://www.dre.vanderbilt.edu/~boris/xsc), > � and a recent snapshot of the CVS repository can be found at > � (http://www.dre.vanderbilt.edu/~wotte/xsc.tbz2). �We plan > to ...

Re: [ace-users] g++ 3.4.3 and ACE 5.5 & TAO 1.5
Hi, Please upgrade to ACE/TAO 1.5.3 which you can obtain from http://download.dre.vanderbilt.edu. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl "M@uro!!" <mauro.gaddo@gmail.com> wrote in message news:<1161692263.239945.111960@m7g2000cwm.googlegroups.com>... > During compiling on HP-UX 11.11 with g++ i have the following error: > > g++ -DHAVE_CONFIG_H -I../.. -I.. -DACE_HAS_ACE_TOKEN > -DACE_HAS_ACE_SVCCONF -DACE_BUILD_DLL -DHPUX_VERS=1111 -w -W -Wall > -Wpointer-arith -g -O2 -pthread -pipe -I. -I.. -MT > libACE_la-OS_NS_stdio.lo -MD -MP -MF .deps/libACE_la-OS_NS_stdio.Tpo -c > ../../ace/OS_NS_stdio.cpp -fPIC -DPIC -o .libs/libACE_la-OS_NS_stdio.o > ../../ace/OS_NS_stdio.cpp: In function `int ACE_OS::fprintf(FILE*, > const wchar_t*, ...)': > ../../ace/OS_NS_stdio.cpp:242: error: `::vfwprintf' has not been > declared > > Can someone helps me? > > Thanks!! > M. > ...

RE: [ace-users] ACE-5.4+TAO-1.4 compilation error.
Hi, > ACE VERSION: 5.4 Thanks for using the PRF form. This version is old, try the x.4.2 release you can download from http://deuce.doc.wustl.edu/Download.html. Be ware that the doc_group doesn't support VxWorks, we as Remedy IT are planning to get the VxWorks port up to shape, see www.theaceorb.nl/en/vxworks.html for the plans we have, if you are interested contact us directly. > HOST MACHINE and OPERATING SYSTEM: > cygwin on w2k Never, never install Cygwin when using VxWorks, yes, I know the documents describe it, but it gives more problems th...

[ace-users] Re: [tao-support] Has ACE 5.4.4/TAO 1.4.4 been built with gcc 4.0.0 yet
Hi Robert, > When building ACE 5.4.4/TAO 1.4.4 using gcc 4.0.0 under fedora core > 4 test 2 on an x86 platform I get a lot of errors mainly to do with > template instantiations. Has anyone successfully build TAO/ACE using > the latest gcc ? We just added GCC 4.0.0 support to ACE+TAO recently. The forthcoming x.4.5 beta should work nicely with GCC 4.0.0. We hope to have this available very shortly (there's just one remaining snag with typecodes that should be fixed in the next day or so). If you'd like to give things a try before we release x.4.5 please download the contents of ACE+TAO from our CVS repo at http://cvs.doc.wustl.edu/ and see if it works for you on your platform. If not, please let us know and we'll try to make sure that it's working before we put out the beta release. Thanks, Doug I've tried the CVS version on macosx 10.4, with gcc4.0 and still got the same intantiation problem. On 5/9/05, Douglas C. Schmidt <schmidt@cs.wustl.edu> wrote: > > Hi Robert, > > > When building ACE 5.4.4/TAO 1.4.4 using gcc 4.0.0 under fedora core > > 4 test 2 on an x86 platform I get a lot of errors mainly to do with > > template instantiations. Has anyone successfully build TAO/ACE using > > the latest gcc ? > > We just added GCC 4.0.0 support to ACE+TAO recently. The forthcoming > x.4.5 beta should work nicely with GCC 4.0.0. We hope to ha...

RE: [ace-users] Error compiling ACE 5.4 in Solaris 5.8
I'm trying to compile JAWS but the compiler throws the next message: make -f Makefile SUBDIR_TARGET=all server.subdir clients.subdir make[1]: Entering directory `/usr/fborja/ACE541/ACE_wrappers/apps/JAWS' cd server && make -f Makefile all make[2]: Entering directory `/usr/fborja/ACE541/ACE_wrappers/apps/JAWS/server' Makefile: /usr/fborja/ACE541/ACE_wrappers/apps/JAWS/server/Makefile g++ -W -Wall -Wpointer-arith -O3 -g -pipe -fno-exceptions -fcheck-new -D_REENTRANT -I/usr/fborja/ACE541/ACE_wrappers -D__ACE_INLINE__ -L/usr/fborja/ACE541/ACE_wrappers/ace...

Re: [ace-users] Errors while compiling c++ 3.4.2
Hi Eyal, I believe we've fixed these problems in the latest version of ACE that's tucked inside our CVS repository. Can you please take a look at this version available in http://deuce.doc.wustl.edu/Download.html and see if things work better. If not, please let us know so we can fix them before we release ACE 5.4.3 in a week or so. Thanks, Doug >> I get the following while compiling: >> >> /usr/bin/c++ -D_POSIX_C_SOURCE=199506L -DNDEBUG -DUSING_GCC >> -D_POSIX_PTHREAD_SEMANTICS -DLINUX -I../inc >> -I../3rd_party...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi, >> ACE VERSION: 5.4.3 Thakns for using the PRF! >> HOST MACHINE and OPERATING SYSTEM: >> Solaris10 X86 We (i.e., the DOC groups at UCI/VU/WU) don't have Solaris running on an x86 box (yet). It would therefore be great if you could figure out what patches need to be applied so that ACE compiles properly on this platform. BTW, Kitty/Bala, weren't we planning on running Solaris on an AMD box at some point? Thanks, Doug >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: >> COMPIL...

[ace-users] Re: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86
Hi Jin, >> The solaris 9/10 for sparc is not the same as solaris 9/10 for >> Intel X86,although it is almost free,and the SunStudio 9 (CC >> 5.6)for sparc is not the same as SunStudio 9(CC 5.6) for Intel X86. This is yet one more reason why you'll need to do the legwork on this. Please let us know what you find out. Thanks, Doug -- Dr. Douglas C. Schmidt, Professor TEL: (615) 343-8197 Electrical Engineering and Computer Science FAX: (615) 343-7440 Vanderbilt University WEB: www.cs.wustl.edu/~schmidt/ Nashvil...

[ace-users] Re: Upgrading project from ACE 5.2.8 to ACE 5.4 version
Hi Sekhar, Thanks very much for your email. Please make sure to send all questions related to TAO or ACE to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly since I travel frequently and often don't have ready access to email. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. > I got problems when building my project with latest ACE 5.4 version > but my project has no problems while building with ACE 5.2.8 > version. I need help to upgrade my project to build with ACE 5.4 > version. >...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Steve, > > Is this necessary? I mean make it implicit by default. The > > explicit is > > not even supported, and has no chance to work cleanly. Why > > should we patch > > broken stuff. Just a thought? > > At least for ACE 5.5, Riverace supports the Forte compiler that > requires explicit. After that, we can drop it. Ok. Steve, could you maybe make clear with the build names which builds use explicit templates? Explicit templates in TAO are known to be broken at this moment. Johnny ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Johnny- > Ok, the problem is in platform_sunos5_sunc++.GNU, when a not known forte > version is found, it defaults to explicit. I am updating right now, for 4.2 > and 5.3 we default to explicit, for all others to implicit Is this necessary? I mean make it implicit by default. The explicit is not even supported, and has no chance to work cleanly. Why should we patch broken stuff. Just a thought? > Qinghuajin and other Forte 9 users, you can work around this by added the > following line to your platform_macros.GNU file. > templates = implicit This is until w...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > Ok, the problem is in platform_sunos5_sunc++.GNU, when a > not known forte > > version is found, it defaults to explicit. I am updating > right now, for 4.2 > > and 5.3 we default to explicit, for all others to implicit > > Is this necessary? I mean make it implicit by default. The > explicit is > not even supported, and has no chance to work cleanly. Why > should we patch > broken stuff. Just a thought? I have thought also about this, but maybe there are users around we don't know if. We can drop all this after x.5 is released, until that time, I just keep it there, just as we have a lot of other stuff that is probably broken. > > Qinghuajin and other Forte 9 users, you can work around > this by added the > > following line to your platform_macros.GNU file. > > templates = implicit > > This is until we release x.4.4., right? Yes, with x.4.4 this will be done correctly. Johnny ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
> Ok. Steve, could you maybe make clear with the build names > which builds use explicit templates? I'll try to get this clarified. > Explicit templates in TAO are known to be broken at this > moment. None of the tests at Riverace try to build TAO. -Steve ...

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Johnny- > > > > ACE VERSION: 5.4.3 > > > > > > > > HOST MACHINE and OPERATING SYSTEM: > > > > Solaris10 X86 > > > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > > > > COMPILER NAME AND VERSION (AND PATCHLEVEL): > > > > Compiler: SUN CC 5.6 > > ^^^^^^^^^^^^^^^^^^^^^^^^ > > > > I don't think the DOC group supports this compiler anymore.. More > > particularly this compiler is buggy and you may land up with ...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi, > > > I don't think the DOC group supports this compiler anymore.. More > > > particularly this compiler is buggy and you may land up with > > > unresolved > > > symbols even if you get past this part. > > > > I missed the compiler version. But, Forte 8 gives output of > SUN C++ 5.5. Ok, the problem is in platform_sunos5_sunc++.GNU, when a not known forte version is found, it defaults to explicit. I am updating right now, for 4.2 and 5.3 we default to explicit, for all others to implicit Qinghuajin and other Forte...

RE: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
> > Ok, the problem is in platform_sunos5_sunc++.GNU, when a > not known forte > > version is found, it defaults to explicit. I am updating > right now, for 4.2 > > and 5.3 we default to explicit, for all others to implicit This sounds good. > Is this necessary? I mean make it implicit by default. The > explicit is > not even supported, and has no chance to work cleanly. Why > should we patch > broken stuff. Just a thought? At least for ACE 5.5, Riverace supports the Forte compiler that requires explicit. After that, we can drop it....

Re: [ace-users]: ACE 5.4.2 and ACE 5.4.3 compile failed on Solaris 9 x86 and Solaris 10 x86 #2
Hi Jin, >> I rebuild the ACE package according the instruction above,but get >> the same result. It doesn't look to me like you've added -DACE_HAS_X86_STAT_MACROS to the build-line as recommended by Johnny Willemsen. >> my platform_macros.GNU file has the following lines: >> >> templates = implicit >> include $(ACE_ROOT)/include/makeinclude/platform_sunos5_sunc++.GNU >> >> When i rebuild the ACE library,get the following compile errors: >> $ make inline=0 -j 2 -k -f GNUmakefile.ACE >> ... >&...

Web resources about - Re: [ace-users] Errors untarring ACE+TAO 5.5.4 - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/5/2016 5:52:10 AM