f



Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2 #2

Hi,

> Did you recommend to use VxWorks 6.4 with ACE+TAO 5.5.1a patch 4?

VxWorks 6.4 is more stable then VxWorks 6.2, but still has its known
problems. The p4 is so far as I know only a backport of the
config-vxworks6.4.h that is part of the doc_group version 1.6.1. We are
currently doing some work on VxWorks 6.4 kernel mode for PPC604. As part of
this work we have made several improvements to the VxWorks 6.4 support which
will be part of the upcoming 1.6.2 version. 

Regards,

Johnny Willemsen
Remedy IT
Postbus 101
2650 AC  Berkel en Rodenrijs
The Netherlands
www.theaceorb.nl / www.remedy.nl  

*** Integrated compile and test statistics see
http://scoreboard.theaceorb.nl ***
*** Commercial service and support for ACE/TAO/CIAO             ***
*** See http://www.theaceorb.nl/en/support.html                 ***

0
Johnny
11/4/2007 7:56:25 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
833 Views

Similar Articles

[PageSpeed] 43

Reply:

Similar Artilces:

Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2
Hi, > SYNOPSIS: > What is the differences in linkage between compilation of ACE+TAO with > or without (RTP, PTHREAD), when we allow or disallow both of them > together? We can't allow RTP at our project. If we disallow RTP and > PTHREAD we have a problems with linkage with some TAO libraries. For differences check the VxWorks documentation. There are also runtime differences when you build rtp/pthread mix. We as Remedy IT can assist with this decision and give you information which combinations do behave better then others. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl *** Integrated compile and test statistics see http://scoreboard.theaceorb.nl *** *** Commercial service and support for ACE/TAO/CIAO *** *** See http://www.theaceorb.nl/en/support.html *** ...

[ace-users] ACE 6.2.6/TAO 2.2.6 RPMs available on OBS
Hi, Through the OpenSuSE build service we are providing RPMs for ACE/TAO. We have updated OBS this morning, RPMs for the various distributions are appearing online. For more details see http://www.orbzone.org/node/344 Best regards, Johnny Willemsen Remedy IT Support and services for ATCD http://www.theaceorb.nl ...

[ace-users] RE: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6 #2
Hi, > -----Original Message----- > From: Douglas C. Schmidt [mailto:schmidt@cse.wustl.edu] > Sent: Monday, March 27, 2006 9:09 AM > To: nealweston@bellsouth.net; ace-users@cs.wustl.edu; > parsons@dre.vanderbilt.edu > Subject: Re: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6 > > Hi Neal, > > >> I am trying to build ACE-5.5 and TAO-1.5 on a SPARC > Solaris 2.8 system > >> using gcc 3.3.6 and GNU make 3.80. > >> > >> The build is failing in > ACE_wrappers/build/TAO/orbsvcs/orbsvcs (output > ...

[ace-users] ACE 6.0.2 and TAO 2.0.2 RPMs available #2
Hi all, ACE 6.0.2 and TAO 2.0.2 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE 11.2/11.3/11.4/Factory/Tumbleweed Regards, Johnny Willemsen Remedy IT http://scoreboard.theaceorb.nl/ http://www.orbzone.org http://www.theaceorb.nl ...

[ace-users] ACE 6.0.2 and TAO 2.0.2 RPMs available
Hi all, ACE 6.0.2 and TAO 2.0.2 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE /11.2/11.3/11.4/Factory/Tumbleweed Regards, Johnny Willemsen Remedy IT Check out the ORBzone community portal at http://www.orbzone.org ...

[ace-announce] ACE 6.2.6/TAO 2.2.6 RPMs available on OBS
Hi, Through the OpenSuSE build service we are providing RPMs for ACE/TAO. We have updated OBS this morning, RPMs for the various distributions are appearing online. For more details see http://www.orbzone.org/node/344 Best regards, Johnny Willemsen Remedy IT Support and services for ATCD http://www.theaceorb.nl ...

[ace-users] Re: ACE on VxWorks 6 #2
Hi, At Remedy IT we are currently involved in a (sponsored) effort to upgrade VxWorks support for ACE/TAO to the 6.x version. This effort will concentrate on the new 'real time process' type of applications for VxWorks 6.x with a target date of February 2006 for full availability of this support in the DOC-group version (so probably in a x.5.x release). Do you require RTP support or rather kernel mode apps? If you require the latter and you are willing to work on getting this to work yourself we would be happy to help you integrate that with the RTP support based on...

[ace-users] Re: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6
Hi Neal, >> I am trying to build ACE-5.5 and TAO-1.5 on a SPARC Solaris 2.8 system >> using gcc 3.3.6 and GNU make 3.80. >> >> The build is failing in ACE_wrappers/build/TAO/orbsvcs/orbsvcs (output >> included below) and I was wondering if anyone had any suggestions as to >> what the problem may be. >> >> What is puzzling to me is that the lines in question are all comment >> lines. For example the "01.ps" invalid token on line 15 of >> CosProperty.idl is from the following comment line: >> >> //...

Re: [ace-users] Problem with ACE-5.4.2 #2
Hi Peter: > I'm still confused about the missing $ACE_ROOT/configure script: > Balachandran Natarajan writes: > > > > Also there is no "configure" script as suggested in ACE-INSTALL. > > > > > > Ossama? Shouldn't there have been a configure script? > > > > Not for ACE+TAO.tar.gz. Please see $ACE_ROOT/ACE-INSTALL.html for details. > > We only supported autoconf for ACE with x.4.2. I agree that things are > > changing as we speak. > > > I downloaded "ACE+TAO.tar.gz" and "...

Re: [ace-users] Problem with ACE-5.4.2 #2
Hi Peter: > ACE VERSION: 5.4.2 Thanks for using the PRF... > > HOST MACHINE and OPERATING SYSTEM: > Sun-Fire-280R, Solaris 8 > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > COMPILER NAME AND VERSION (AND PATCHLEVEL): > > CONTENTS OF $ACE_ROOT/ace/config.h: #include "ace/config-sunos5.8.h" > > CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU (unless > this isn't used in this case, e.g., with Microsoft Visual C++): > include $(ACE_ROOT)/include/makeincl...

Re: [ace-users] Problem with ACE-5.4.2 #2
Hi > > When we released x.4.2, autoconf support was available only for ACE. > > TAO and CIAO were not completely supported. Therefore we bundle > > autoconf only with ACE distribution, i.e., with ACE.tar.gz, ACE.tar.bz2 > > etc. Does this make sense? Probably for the next beta TAO would have > > autoconf support. > > BTW, I see the NEWS file isn't included on the ACE.zip nor the > ACE.tar.bz2 archives for 5.4.2. I 've downloaded Am I Right on this > or do I have some problem with the versions of the (de)archiving > utiliti...

Re: [ace-users] Problem with ACE-5.4.2 #2
Hi > I was using GNU tar 1.13; that is causing problems extracting the > ACE source distribution. Switching to version 1.14 fixed some problems > : now the directory tree appears to be correct. I'm still getting old > dates for extracted files and directories; that shouldn't affect > compilation. That is mystery to me. More mysterious is the fact that only certain files and directories have 1970. Some of them have 1999 and 2000. I am completely stumped. :(! > I downloaded "ACE+TAO.tar.gz" and "ACE-5.4.2+TAO-1.4.2.tar.gz" from &...

[tao-users] ACE 6.2.6/TAO 2.2.6 RPMs available on OBS
Hi, Through the OpenSuSE build service we are providing RPMs for ACE/TAO. We have updated OBS this morning, RPMs for the various distributions are appearing online. For more details see http://www.orbzone.org/node/344 Best regards, Johnny Willemsen Remedy IT Support and services for ATCD http://www.theaceorb.nl ...

[ace-users] ACE/TAO 6.2.5/2.2.5 supported with Embarcadero C++ Builder XE6!
Hi, Embarcadero has just released their new XE6 release and we are pleased to announce that ACE/TAO 6.2.5/2.2.5 is supported with this new release out of the box! Remedy IT participated actively in the beta program and made sure that the XE6 bcc32 compiler is supported in debug and release mode as part of ACE/TAO 6.2.5/2.2.5. For an overview of all supported Embarcadero C++ compilers see our website at http://www.theaceorb.nl/en/ace-tao-ciao-dance-prod/support/53-borlandcodegearph Best regards, Johnny Willemsen Remedy IT http://www.theaceorb.nl ...

Problems at linkage of TAO to ACE, target VxWorks 6.2
CE VERSION: 5.6.1 HOST MACHINE and OPERATING SYSTEM: Solaris TARGET MACHINE and OPERATING SYSTEM, if different from HOST: COMPILER NAME AND VERSION (AND PATCHLEVEL): VxWorks 6.2 THE $ACE_ROOT/ace/config.h FILE [if you use a link to a platform- specific file, simply state which one]: #define ACE_LACKS_PTHREAD_ATTR_SETSTACK #include "config-vxworks6.2.h" THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE [if you use a link to a platform-specific file, simply state which one (unless this isn't used in this case, e.g., with Microsoft Visual C++)]: debug ?= 0 rtp ?= 0 pthread ?= 1 shared_libs = 1 CONTENTS OF $ACE_ROOT/bin/MakeProjectCreator/config/ default.features (used by MPC when you generate your own makefiles): AREA/CLASS/EXAMPLE AFFECTED: [What example failed? What module failed to compile?] DOES THE PROBLEM AFFECT: EXECUTION - YES SYNOPSIS: What is the differences in linkage between compilation of ACE+TAO with or without (RTP, PTHREAD), when we allow or disallow both of them together? We can't allow RTP at our project. If we disallow RTP and PTHREAD we have a problems with linkage with some TAO libraries. DESCRIPTION: If I compile ACE with no pthread, I have a problems at linkage of libTAO_Valuetype.so, it have a lot of undefined symbols, that are included wh...

[ace-announce] ACE 6.0.2 and TAO 2.0.2 RPMs available #2
Hi all, ACE 6.0.2 and TAO 2.0.2 RPMs are now available at OpenSuSE build service. OBS provides currently RPMs for: - CentOS 5 - Fedora 12/13/14 - Mandriva 2009.1/2010/2010.1 - RHEL 4/5/6 - SLES 9/11/11SP1 - OpenSuSE 11.2/11.3/11.4/Factory/Tumbleweed Regards, Johnny Willemsen Remedy IT http://scoreboard.theaceorb.nl/ http://www.orbzone.org http://www.theaceorb.nl ...

RE: [ace-users] Problem compiling application with ACE 5.4.2 #2
I stand corrected... Thanks for the solution, Neil! -Steve -- Steve Huston, Riverace Corporation Adding Service to Open Source Software ACE book info at http://www.riverace.com/acebooks/ > -----Original Message----- > From: Neil B. Cohen [mailto:nbc@cisco.com] > Sent: Wednesday, December 01, 2004 8:58 AM > To: Steve Huston > Cc: 'Johnny Willemsen'; ace-users@cs.wustl.edu > Subject: RE: [ace-users] Problem compiling a...

[ace-users] RE: ACE 5.4 with SUNWspro workshop 6.2 #2
Hi Israel, > I am unable to post messages that to ace-users, can you help ? > We are unable to deliver the message from <Israel_Lavi@bmc.com> to > <ace-users@egroups.com>. > > The ace-users group is for archival use only and does not accept direct > postings. If you want to post to the actual email list, please send your > message to > > ace-users@egroups.com > > For further assistance, please visit http://help.yahoo.com/help/us/groups/ I don't know where you got those instructions, but they are wrong. Please see htt...

RE: [ace-users] Problem compiling application with ACE 5.4.2 #2
Hi Neil, We run Solaris 8, Sun CC 5.3 regularly and don't see this problem. But we don't use STLport... Maybe that's a factor. We can do support for you at 5.4b (available at Riverace's web site). For other versions, please contact me. Thanks, -Steve -- Steve Huston, Riverace Corporation Adding Service to Open Source Software ACE book info at http://www.riverace.com/acebooks/ > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Neil B. Cohen > Sent: Tuesday, November 30, 2004 1:19 PM > To: ace-users@cs.wustl.edu > Subject: [ace-users] Problem compiling application with ACE 5.4.2 > > > Just an FYI followup to my question from earlier today... > > As per the advice I got this morning, I tried downloading 5.4.2 and > compiling that. I am using the Sun CC 5.3 compiler, which the > documentation says has problems (and don't I know that... :)) But the > optimized version of ACE compiled, while the debug version failed to > compile at all - I never did get to my application this time. > Same type > of error though - I got this output: > > gmake[1]: Entering directory `/auto/vsc- > tools/ACE/ACE.5.4.2/ACE_wrappers/build_Sol8_dbg/ace' > gmake[2]: Entering directory `/auto/vsc- > tools/ACE/ACE.5.4.2/ACE_wr...

RE: [ace-users] Problem compiling application with ACE 5.4.2 #2
The closesocket() thing sounds like a macro is getting in the way during your app build. Removing ACE_HAS_INLINED_OSCALLS forces ACE to include the method rather than have your app inline it, and the macro isn't in the way then. -Steve -- Steve Huston, Riverace Corporation Adding Service to Open Source Software ACE book info at http://www.riverace.com/acebooks/ > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Johnny Willemsen > Sent: Wednesday, De...

RE: [ace-users] Problem compiling application with ACE 5.4.2 #2
Hi, > Fair enough - is there a schedule or hoped-for date when 5.4.3 will be > available?? This month, before Xmas. > Also - after building the library, I ran into the same problem with my > application - it tells me that closesocket is not a member of the ACE > namespace. I'll play around with adding the include files to > get rid of > that. The workaround I had was to undefine the ACE_HAS_INLINED_OSCALLS > and I don't like that - feels like a real kludge... Maybe you have to add some includes. If you have fixes, share them with the mailing ...

RE: [ace-users] Problem compiling application with ACE 5.4.2 #2
Hi, I quickly scanned your changes. In the upcoming x.4.3 version this will be already available but then guarded with ACE_HAS_STREAM_PIPES, SunOS has that define set. So, when x.4.3 is available, download that and use it, then you don't have to patch anymore. Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl > <snip> > > I've had to make quite a number of changes to get ACE 5.4.2 to compile > in debug mode. All the changes appear to be similar to the one Johnny > sug...

RE: [ace-users] Re: [ace] compile error in mingw 3.2-rc1 (or w32api-3.2) #2
Hi, Please upgrade your mingw version to 3.7. This has been released today and contains the following fix below, they removed all defines which are just there to fool people. Your problems with MinGW should be gone now. Johnny 2005-01-13 Earnie Boyd <earnie@users.sf.net> * include/sys/stat.h (_S_IFLNK, S_IFLNK, _S_ISLNK, S_ISLNK, _lstat, lstat): Remove. * include/errno.h (ELOOP): Ditto. * include/_mingw.h: Increment version to 3.7. * Makefile.in: Ditto. > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cs...

Re: [ace-users] Re: [ace] compile error in mingw 3.2-rc1 (or w32api-3.2) #2
Hi, > oh. sorry. I just use ACE at studying. so I don't interested in > commercial support. (bad english. sorry. -_-) No problem with the English. Good that you are looking at ACE, it is very powerful, only the bad thing is you are using a new MinGW version that cause problems. > furthermore, I found cause about this error. it's placed in new > w32api's sys/stat.h. it define lstat as stat, so this make all > "lstat"s in ACE sources replace "stat". -_-a > > I tryed two modification (sorry for handy patch..) > 1. ace/conf...

Web resources about - Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2 #2 - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/5/2016 2:25:44 AM