f



Re: [ace-users] [tests] : questions about ACE and TAO tests #2

Hi Lloyd,

>>  I am running the latest ACE+TAO release on a Windows XP platform
>> with Windows Visual Studio.NET 2003 Pro.

Please be more specific since "latest" doesn't mean anything!  Please
fill out the appropriate problem report form (PRF), which is in

$ACE_ROOT/PROBLEM-REPORT-FORM
$TAO_ROOT/PROBLEM-REPORT-FORM

since otherwise we have to "guess" what
version/platform/compiler/options you've using, which is error-prone
and slows down our responsiveness.

>> I have built the TAOACE solution
>> (after removing the SSL projects and declaring ACEXML a dependency of
>> ACEXML_Parser), but I am having problems with the ACE and TAO tests.
>> 
>> The ACE tests don't generate any output when the EXE files are run (in a
>> DOS box).
>> 
>> When I open the TAO test workspace and convert the projects, I get a lot
>> of "The project XXX cannot be added to the current solution because a
>> project with the same name or project filename already exists in the
>> solution."
>> 
>> Certain projects (like Param_Test) are not appearing in the TAO_tests
>> solution. Is the TAO_tests workspace supposed to have all the TAO tests?

Jeff, can you please address this?

>> Is there any doumentation about the tests? I didn't see any in the
>> Doxygen files or on the ACE website.

Please see

$ACE_ROOT/tests/README

for info on the ACE tests.  There should be individual README files in
each of the TAO test directories.

Thanks,

        Doug
-- 
Dr. Douglas C. Schmidt                       Professor and Associate Chair
Electrical Engineering and Computer Science  TEL: (615) 343-8197
Institute for Software Integrated Systems    WEB: www.dre.vanderbilt.edu/~schmidt
Vanderbilt University, Nashville TN, 37203   NET: d.schmidt@vanderbilt.edu

0
Douglas
4/22/2005 11:09:37 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
642 Views

Similar Articles

[PageSpeed] 19

Reply:

Similar Artilces:

RE: [ace-users] [tests] : questions about ACE and TAO tests #2
Hi Lloyd, > I am running the latest ACE+TAO release on a Windows XP platform with > Windows Visual Studio.NET 2003 Pro. I have built the TAOACE solution > (after removing the SSL projects and declaring ACEXML a dependency of > ACEXML_Parser), but I am having problems with the ACE and TAO tests. > > The ACE tests don't generate any output when the EXE files > are run (in a DOS box). The tests themselves record all their output in $ACE_ROOT/tests/log. If you cd to $ACE_ROOT/tests, insure that $ACE_ROOT/lib is in your PATH, and run run_test.pl, you should get output. > When I open the TAO test workspace and convert the projects, > I get a lot > of "The project XXX cannot be added to the current solution because a > project with the same name or project filename already exists in the > solution." > > Certain projects (like Param_Test) are not appearing in the TAO_tests > solution. Is the TAO_tests workspace supposed to have all the > TAO tests? I'm not sure about TAO... Maybe someone who knows TAO will have more information. > Is there any doumentation about the tests? I didn't see any in the > Doxygen files or on the ACE website. There should be something in $ACE_ROOT/ACE-INSTALL.html. Best regards, -Steve -- Steve Huston, Riverace Corporation New! ACE Training - http://www.riverace.com/training.htm ACE book info at http://www.riverace.com/acebo...

RE: [ace-users] [tests] : questions about ACE and TAO tests #2
I am running the latest ACE+TAO release on a Windows XP platform with Windows Visual Studio.NET 2003 Pro. I have built the TAOACE solution (after removing the SSL projects and declaring ACEXML a dependency of ACEXML_Parser), but I am having problems with the ACE and TAO tests. The ACE tests don't generate any output when the EXE files are run (in a DOS box). When I open the TAO test workspace and convert the projects, I get a lot of "The project XXX cannot be added to the current solution because a project with the same name or project filename already exists in the solution." Certain projects (like Param_Test) are not appearing in the TAO_tests solution. Is the TAO_tests workspace supposed to have all the TAO tests? Is there any doumentation about the tests? I didn't see any in the Doxygen files or on the ACE website. -Thanks! Lloyd Matthews ...

RE: [ace-users] [tests] : questions about ACE and TAO tests
Hi, To ensure that we have proper version/platform/compiler information, please make sure you fill out the appropriate problem report form (PRF), which is in $ACE_ROOT/PROBLEM-REPORT-FORM $TAO_ROOT/PROBLEM-REPORT-FORM or in $ACE_ROOT/BUG-REPORT-FORM $TAO_ROOT/BUG-REPORT-FORM in older versions of ACE+TAO. Make sure to include this information when asking any questions about ACE+TAO since otherwise we have to "guess" what version/platform/compiler/options you've using, which is error-prone and slows down our responsiveness. > I am running the latest ACE+TAO release on a Windows XP platform with > Windows Visual Studio.NET 2003 Pro. I have built the TAOACE solution > (after removing the SSL projects and declaring ACEXML a dependency of > ACEXML_Parser), but I am having problems with the ACE and TAO tests. > > The ACE tests don't generate any output when the EXE files > are run (in a > DOS box). That is correct, see the log directory for the output of the tests > When I open the TAO test workspace and convert the projects, > I get a lot > of "The project XXX cannot be added to the current solution because a > project with the same name or project filename already exists in the > solution." That is solved in the x.4.4 release. > Certain projects (like Param_Test) are not appearing in the TAO_tests > solution. Is the TAO_tests workspace supposed to have a...

[ace-users] [ACE] ACE tests fails when running test suite coming along with the ACE package.
------=_Part_15751_29314851.1158178144544 Content-Type: text/plain; charset=ISO-8859-1; format=flowed Content-Transfer-Encoding: 7bit Content-Disposition: inline Hi, I had sent this mail yesterday before I subscribed the mail list. Since it did not show in the daily digest, I'm wondering if the email has been received. So hereby I'm sending the report again. If you guys have already got the previous one, just discard this email and I appologize for the duplicate. Hai Hi, I'm not a direct ACE user. In my current project I'm using a IEEE1451.1 lib that is built upon ACE 5.2. Since ACE 5.2 produced a lot compile and link error when using my current machine and OS, I turned to ACE 5.5 thinking it should be compatible with v5.2. I downloaded the ACE 5.5 package from the website. There was no trouble compiling and linking the code. However, to make sure the lib is usable, I ran the test suite that comes along with the package (under the directory $ACE_ROOT/tests/) using ./run_test.pl. There are four tests reported errors. I'm wondering if that indicates bugs in the current building and if the built lib still usable? The following are the problem discription in the bug report form. Please let me know if you need any other information. Thanks if any of you could help. ACE VERSION: 5.5 HOST MACHINE and OPERATING SYSTEM: Linux r3-mobile 2.6.14-1.1644_2.FC4.cubbi_swsusp2_rcubed (Fedora Core 4) TARGET MAC...

[ace-bugs] [ACE tests]:ACE tests timing out
ACE VERSION: 5.3.3 HOST MACHINE and OPERATING SYSTEM: Solaris 8 (5.8) TARGET MACHINE and OPERATING SYSTEM, if different from HOST: SAME COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc 3.0.3 GNU MAKE 3.8 CONTENTS OF $ACE_ROOT/ace/config.h: config-sunos5.8.h CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU): platform_sunos5_g++.GNU AREA/CLASS/EXAMPLE AFFECTED: Running Message_Queue_Test_Ex and Proactor_Test Fails DOES THE PROBLEM AFFECT: COMPILATION? no LINKING? no ...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Hi Steve, At this moment getting some TAO refactoring in the archive is my highest priority, I don't have time at this moment to look into this. We have extended the scoreboard config page so that at least we can see which Windows 2003 version is being used on the build systems. Regards, Johnny > -----Original Message----- > From: Steve Huston [mailto:shuston@riverace.com] > Sent: donderdag 18 augustus 2005 17:36 > To: 'Adrian Tulloch'; jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [ace-users] Has ACE been tested on Win2003 SP1 > > Is someone adding this idea (or checking to see it's effectively > tested already) in Recursive_Condition_Test or > Recursive_Condition_Bug_Test? > > -Steve > > -- > Steve Huston, Riverace Corporation > "How to Use ACE Effectively" class Oct 17-19! > See http://www.riverace.com/training.htm > > > > -----Original Message----- > > From: owner-ace-users@cse.wustl.edu > > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Adrian Tulloch > > Sent: Thursday, August 18, 2005 7:45 AM > > To: jwillemsen@remedy.nl > > Cc: ace-users@cs.wustl.edu > > Subject: RE: [ace-users] Has ACE been tested on Win2003 SP1 > > > > > > Johnny Willemsen said: > > > > > There are daily builds on Windows 2003 > > > > Are any of thes...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Hi Adrian, > Anyway, getting back to my original question about ACE and > Win2003 SP1, > I see from the scoreboard that all the 2003 machines are running TAO > tests. Does this mean that they're only running the TAO test > cases, or > are the ACE tests considered a subset of TAO? I'm asking > because I was > planning on moving my critical section repro code into to the ace > tests, but, if it turns out that these tests aren't executed on 2003 > SP1, I wouldn't achive al that much. I encourage you to add your case to the ACE_wrappers/tests/Recursive_Mutex_Test.cpp test. Even if it doesn't show the failure now (though, as Johnny says, all the test runs should run the ACE tests) it establishes a base from which regressions can be seen across all platforms. Thanks! -Steve -- Steve Huston, Riverace Corporation "How to Use ACE Effectively" class Oct 17-19! See http://www.riverace.com/training.htm ...

Re: [ace-users] Has ACE been tested on Win2003 SP1 #2
Hi Adrian, Can you please create/extend an ACE_ROOT/tests/*_Test.cpp that will illustrate this problem? Steve Huston and OCI - can you guys take the lead on fixing this if it's a problem? Thanks, Doug >> I wondered whether ACE has been tested with the recently released >> Service Pack 1 for Windows Server 2003. I'm asking because the Service >> Pack introdued a change which I think will cause ACE applications to >> hang in some (hopefully uncommon) circumstances. >> >> As described in >> http://blogs.msdn.com/oldnewthing/archive/2005/07/01/434648.aspx, SP1 >> changed how the fields of the CRITICAL_SECTION structure are >> interpreted. The new interpretation of the structure is described in >> the windbg documentation; I've attached a copy of their description to >> this mail. The important point is that they've change the LockCount >> field in SP1 -- a LockCount smaller than -1 means that one or more >> thread is waiting for the critical section. This breaks ACE's >> recursive condvars (something which on my mind right now...). As I >> mentioned in an earlier posting to ace-bugs, >> ACE_OS::recursive_mutex_cond_uļæ½nlock looks like this (after removing >> some ifdefs and comments): >> >> ACE_INLINE int >> ACE_OS::recursive_mutex_cond_unlock (ACE_recursive_thread_mutex_t *m, >&g...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Hi, > > There are daily builds on Windows 2003 > > Are any of these on Service Pack 1? The web page only > reports that the > 2003 machines (which seem to be running TAO tests, not ACE) have an OS > of "Microsoft Windows [Version 5.2.3790]". I think that all Win2003 > machines give that output in response to the "ver" command, regardless > of what service pack or hotfixes they contain. > > By the way, to whoever is responsible for the scoreboard web > pages, you > may want to look at using the output of systeminfo .exe instead of > using ver. systeminfo | grep ^OS produces this output on my desktop: > OS Name: Microsoft Windows XP Professional > OS Version: 5.1.2600 Service Pack 2 Build 2600 > OS Manufacturer: Microsoft Corporation > OS Configuration: Standalone Workstation > OS Build Type: Multiprocessor Free > > which is probably more useful than the string "Microsoft Windows XP > [Version 5.1.2600]" which ver produces. Ok, with some help of other people I changed the OS version output for Windows. Now we are using systeminfo and print out the OS info as above. Besides this I decided to print out also processor and memory information because that info is usable for comparing the speed of builds. > > It would help if you can extend one of the ACE tests to > demonstra...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Johnny Willemsen wrote: > FYI, on the config pages of the builds you will now see much more info of > the windows build systems. You can see there with SP they are using. Great! Thanks for making that change, Johnny. It's very cool that your change also means that we can also see information like whether or not the test machines are multi-processor or not. Anyway, getting back to my original question about ACE and Win2003 SP1, I see from the scoreboard that all the 2003 machines are running TAO tests. Does this mean that they're only running the TAO test cases, or are the ACE tests considered a subset of TAO? I'm asking because I was planning on moving my critical section repro code into to the ace tests, but, if it turns out that these tests aren't executed on 2003 SP1, I wouldn't achive al that much. Adrian ...

Re: [ace-users] Has ACE been tested on Win2003 SP1 #2
Hi, FYI, on the config pages of the builds you will now see much more info of the windows build systems. You can see there with SP they are using. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Hi, > > FYI, on the config pages of the builds you will now see > much more info of > > the windows build systems. You can see there with SP they are using. > > Great! Thanks for making that change, Johnny. It's very > cool that your > change also means that we can also see information like whether or not > the test machines are multi-processor or not. > > Anyway, getting back to my original question about ACE and > Win2003 SP1, > I see from the scoreboard that all the 2003 machines are running TAO > tests. Does this mean that they're only running the TAO test > cases, or > are the ACE tests considered a subset of TAO? I'm asking > because I was > planning on moving my critical section repro code into to the ace > tests, but, if it turns out that these tests aren't executed on 2003 > SP1, I wouldn't achive al that much. The TAO builds should also run the ACE tests, if they are not running, let us know which build, then we will reconfigure that build so that things are tested on win2003. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl ...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Is someone adding this idea (or checking to see it's effectively tested already) in Recursive_Condition_Test or Recursive_Condition_Bug_Test? -Steve -- Steve Huston, Riverace Corporation "How to Use ACE Effectively" class Oct 17-19! See http://www.riverace.com/training.htm > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Adrian Tulloch > Sent: Thursday, August 18, 2005 7:45 AM > To: jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [ace-users] Has ACE been tested on Win2003 SP1 > > > Johnny Willemsen said: > > > There are daily builds on Windows 2003 > > Are any of these on Service Pack 1? The web page only > reports that the > 2003 machines (which seem to be running TAO tests, not ACE) have an OS > of "Microsoft Windows [Version 5.2.3790]". I think that all Win2003 > machines give that output in response to the "ver" command, regardless > of what service pack or hotfixes they contain. > > By the way, to whoever is responsible for the scoreboard web > pages, you > may want to look at using the output of systeminfo .exe inste...

RE: [ace-users] Has ACE been tested on Win2003 SP1 #2
Johnny Willemsen said: > There are daily builds on Windows 2003 Are any of these on Service Pack 1? The web page only reports that the 2003 machines (which seem to be running TAO tests, not ACE) have an OS of "Microsoft Windows [Version 5.2.3790]". I think that all Win2003 machines give that output in response to the "ver" command, regardless of what service pack or hotfixes they contain. By the way, to whoever is responsible for the scoreboard web pages, you may want to look at using the output of systeminfo .exe instead of using ver. systeminfo | grep ^OS produces this output on my desktop: OS Name: Microsoft Windows XP Professional OS Version: 5.1.2600 Service Pack 2 Build 2600 OS Manufacturer: Microsoft Corporation OS Configuration: Standalone Workstation OS Build Type: Multiprocessor Free which is probably more useful than the string "Microsoft Windows XP [Version 5.1.2600]" which ver produces. > It would help if you can extend one of the ACE tests to demonstrate this problem. I'm sorry, but I don't know how to extend the ACE tests. I can give you a repro program which fails on SP 1, but works on plain 2003 (it's at the end of this mail). However, I've got no idea how to get this into the ACE tests. Can you help with that? Here's the repro code. If you call testCondvars() on a non-SP1 machine, the call return...

[ace-bugs] Re: [ace-users] Ace_Task Putq question for ACE gurus #2
Hi Kevin, >> Is this errno variable per thread?? It depends on how you configure your system, but generally the answer is "yes." Please see the Thread-Specific Storage pattern in Chapter 5 of POSA2 <www.cs.wustl.edu/~schmidt/POSA/> for information on how errno works. Thanks, Doug >> >> Thanks >> Kevin >> --- "Douglas C. Schmidt" <schmidt@cs.wustl.edu> wrote: >> > >> > Hi Kevin, >> > >> > > My question is more pertaining to usage rather >> > than an...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO #2
Hi, See http://www.remedy.nl/en/borland.html for an overview of the supported Borland products with TAO. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > -----Original Message----- > From: Espen Harlinn [mailto:espen@harlinn.no] > Sent: donderdag 2 februari 2006 18:06 > To: jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO > > Hi, > > I'm curious about the current status of ACE/TAO and C++ Builder 2006. > Borland shipped the promised fix/update some time ago, but I > couldn't find > anything about how it works with ACE/TAO. > > Regards > Espen Harlinn > > ...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO #2
Hi, The x.4.8 version of ACE/TAO is supported with BCB2006, we have some linker warnings/errors in some configurations, Borland is working on these for Update2, but these are not causing a problem. See ACE_wrappers/ACE-INSTALL.html for info about how to use it. We deliver also commercial support for using BCB2006 with ACE/TAO. See www.theaceorb.nl for our services. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > -----Original Message----- > From: Espen Harlinn [mailto:espen@harlinn.no] > Sent: donderdag 2 februari 2006 18:06 > To: jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO > > Hi, > > I'm curious about the current status of ACE/TAO and C++ Builder 2006. > Borland shipped the promised fix/update some time ago, but I > couldn't find > anything about how it works with ACE/TAO. > > Regards > Espen Harlinn > > ...

RE: [ace-users] ACE Tests : Basic_Types_Test fails on Intel EM64T (Nocona) #2
Hi Robert, I was in the process of sending an answer and checked the latest ACE code. In cvs there is already about 4 weeks the following code. It is added to support Opteron, so it also is valid for Intel EM64T. So, it seems this bug has been fixed already some time ago. # if defined (__ia64) || defined (__x86_64) # define ACE_SIZEOF_LONG_DOUBLE 16 # else /* ! __ia64 */ Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl > Hi Johnnly and alls, > > From me and Dan Sh...

Re: [ace-users] Some questions about ACE-TAO
Yateen- > > Can I get short answers to following questions regarding ACE-TAO > if I am required to use it for my development work? I have tried > answers for the same in the archives, but could not get much > information. Will appreciate your help here. > > 1. What is the maximum and minimum executable size? Please see http://www.dre.vanderbilt.edu/stats/simple_footprint.shtml for some idea on the minimum size. The max size is dependant on the application (based on the number of features that the application uses). The data has been collected from ORB_init and ORB_destroy tests that are part of the TAO distribution. > 2. Does it provide linkage with pthread? Yes, on platfroms that support pthreads. > 3. Does it have any runtime license checks (even if it is open source)? Nope! > 4. It has a binging with C++. Does it support C++ STL as well as > design patterns? We don't use C++ STL internally within ACE+TAO code. But applications can use STL and we don't prevent that. > 5. Is it compatible with LINUX MIPS? We (ie the DOC group) hasn't ported ACE+TAO on Linux MIPS. But I think there may be users who would have tried this. > 6. Can one start and stop the CORBA services inside the process? Not sure what you mean here. I would say it is possible to initialize and terminate a CORBA service if the application can write some code. > 7. Does it work across firew...

Re: [ace-users] question about ACE+TAO
Hi Yunier, > I am working in a distributed control system on linux and windows, using ACE-TAO for transport. I am comunication server > and clients application througth firewalls. I am using Name Service for register my objects for RPC. The Name Service is > sarted done with an IP and Port properly ( "-ORBListenEndpoints iiop://ip:port" ). I need to know if the Name Service use > some internal partucular port, bicause the clients found de Name Services and the object but can not call remote methods. > Does exist another port to configure in the firewall? > > Please tell me what do you think Thanks very much for your email. Please make sure to send all questions related to TAO or ACE to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly since I travel frequently and often don't have ready access to email. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. In addition, to ensure that we have proper version/platform/compiler information, please make sure you fill out the appropriate problem report form (PRF), which is in $ACE_ROOT/PROBLEM-REPORT-FORM $TAO_ROOT/PROBLEM-REPORT-FORM or in $ACE_ROOT/BUG-REPORT-FORM $TAO_ROOT/BUG-REPORT-FORM in older versions of ACE+TAO. Make sure to include this information when asking any questions about ACE+TAO since otherwise we have to "guess" what version/platform/compiler/options you...

[ace-users] Re: ACE Question #2
Hi David, > I have a simple ACE question, least I think it?s rather simple. Thanks very much for your email. Please make sure to send all questions related to TAO or ACE to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly since I travel frequently and often don't have ready access to email. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. > We have a Win32 console application that is our server using ACE. > We followed the example programs and catch SIGINT so we shut down > nicely when someone does Ctrl-C. > > However, that?s the only nice case. How can we handle catching the > user terminating the app in all the other ways? Such as clicking > the close icon in the console title bar, task manager, or if a > service starts and stops our exe? The answer to this question depend on what OS platform you're running on and how a user shuts down your app. In some cases (e.g., sending a SIGKILL on Unix or making a TerminateProcess() call on Windows) there is is simply NO way to catch users terminating the apps. In general, to ensure that we have proper version/platform/compiler information, please make sure you fill out the appropriate problem report form (PRF), which is in $ACE_ROOT/PROBLEM-REPORT-FORM $TAO_ROOT/PROBLEM-REPORT-FORM or in $ACE_ROOT/BUG-REPORT-FORM $TAO_ROOT/BUG-REPORT-FORM in older versions of ACE+TAO. Make...

Re: [ace-users] Re: ACE/TAO corba: 4 questions
Dr. Schmidt- > >> 1. I have to switch to bidirectional connection model because > >> clients behind NAT/firewall can not be called back by server. I do > >> not really know how to change my application to use bidirectional > >> TCP connections. Do I have to add some ORB parameter for > >> client/server? Do I have to change client/server source code or > >> something else? > > Please see > > $TAO_ROOT/tests/BiDirectional/ > $TAO_ROOT/tests/BiDirectional_MultipleORB/ > $TAO_ROOT/tests/BiDirectional_NestedUpca...

[ace-users] Re: ACE Build / Test Problems AIX 5.2 using gcc
Hi Don, Thanks for using the PRF. >> ACE VERSION: 5.4.7 >> >> HOST MACHINE and OPERATING SYSTEM: >> AIX 5.2 / PowerPC We (i.e., the DOC groups at UCI/WU/VU) don't have AIX, so we can't help you. I recommend you contact Steve Huston <shuston@riverace.com> or Johnny Willemsen <jwillemsen@remedy.nl> for commercial support. Thanks, Doug >> TARGET MACHINE and OPERATING SYSTEM, if different from HOST: same >> as host >> >> COMPILER NAME AND VERSION (AND PATCHLEVEL): gcc version 3.3.2 >> >> CONTENTS OF $ACE_ROOT/ace/config.h: >> >> >> CONTENTS OF $ACE_ROOT/include/makeinclude/platform_macros.GNU >> #include "config-aix-5.x.h" >> >> >> AREA/CLASS/EXAMPLE AFFECTED: >> ace directory >> >> DOES THE PROBLEM AFFECT: >> COMPILATION? NO >> LINKING? YES >> On Unix systems, did you run make realclean first? >> EXECUTION? YES >> OTHER (please specify)? >> Application. Exception handle not working. >> >> SYNOPSIS: >> Link warnings and sample tests runtime >> >> >> DESCRIPTION: >> >> Get the following when trying to build ace. The libACE.a.5.4.7 builds, >> but get the follo...

[ace-bugs] Re: [ace-users] Moving to ACE? #2
Hi Roger, >> Could you please explain these kernel problems on Linux? I think there are two problems: .. There are (were) bugs in the Linux implementation of the aio_*() functions. These manifested themselves by failures of the $ACE_ROOT/tests/Proactor_Test.cpp on Linux. .. The Linux kernel implements the aio_*() functions by spawning a thread for each asynchronous request, which sort of defeats the point of asynchronous I/O! Take care, Doug -- Dr. Douglas C. Schmidt, Professor TEL: (615) 343-8197 Electrical Engineeri...

Web resources about - Re: [ace-users] [tests] : questions about ACE and TAO tests #2 - comp.soft-sys.ace

Samsung Galaxy Ace 4 User Reviews
Samsung Galaxy Ace 4 reviews written by Phone Arena users. You can read the opinion of each user and how they rate the phone in 11 categories. ...

Samsung Galaxy Ace 3 official: iPhone-alike size for the new user
Samsung has revealed another in its Galaxy series, the Galaxy Ace 3, now targeting entry-level smartphone users who want a pocket-friendly 4-inch ...

Resources last updated: 3/5/2016 4:44:13 PM