f



Re: [tao-users] Re: ACE/TAO call back problem #2

This is a multipart message in MIME format.
--=_alternative 0025F9B5C1256F63_=
Content-Type: text/plain; charset="us-ascii"

I had a similar problem a long time ago :-). In my case, the IOR passed by 
the client to the server contained a hostname which was unknown in the 
server. We did not use a DNS. The server used a hosts file. In our case, 
using ORBDottedDecimalAddresses 1 was the solution.
Best wishes 
--=_alternative 0025F9B5C1256F63_=
Content-Type: text/html; charset="us-ascii"


<br><font size=2 face="sans-serif">I had a similar problem a long time ago :-). In my case, the IOR passed by the client to the server contained a hostname which was unknown in the server. We did not use a DNS. The server used a hosts file. In our case, using ORBDottedDecimalAddresses 1 was the solution.</font>
<br><font size=2 face="sans-serif">Best wishes </font>
--=_alternative 0025F9B5C1256F63_=--

0
keith
12/7/2004 7:01:07 AM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
907 Views

Similar Articles

[PageSpeed] 53

Reply:

Similar Artilces:

Re: [tao-users] Re: ACE/TAO call back problem
Hi > > HOST MACHINE: Redhat 9 > > TARGET MACHINE: Windows 2000 SP4 > > COMPILER NAME AND VERSION (AND PATCHLEVEL): C++ Builder 6.0 build > > 10.155, gcc 3.2.2 > > > > > > AREA/CLASS/EXAMPLE AFFECTED: > > Callback from server to client > > > > > > DOES THE PROBLEM AFFECT: > > COMPILATION? > > no > > LINKING? > > no > > EXECUTION? > > yes > > > > > > SYNOPSIS: > > Sever can not call back client. This call simply fails. All machines > > have local IP addresses (192.168.1.*) Do you have a local firewall running on the box where the call is coming in? > > DESCRIPTION: > > I am starting server on linux machine then client(s) on windows. There > > is no problem with connecting client to server. All functions that do > > not require callback work perfectly. However when server needs to send > > callback information to client(s) this call always fails. No tcp > > connection is created and no packages are sent. This could probably be due to a firewall on the Win32 side. This has bitten us too much in the past few weeks here at the DOC group ;(! Please check whether you have firewall enabled on Windows and try to relax it for the test. > > However I compiled same server source code on windows machine (under > > Builder 6) and when I start server and client(s)...

[tao-users] Re: ACE/TAO call back problem
Hoi, > TAO VERSION: 1.4 > ACE VERSION: 4.285 This can't be correct, ACE/TAO versions should always have the same minor versions. The most common problem is DNS problems, the server tries to resolve the clients using their hostnames. Try to start server and client with -ORBDottedDecimalAddresses 1 as commandline option. Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl > HOST MACHINE: Redhat 9 > TARGET MACHINE: Windows 2000 SP4 > COMPILER NAME AND VERSION (AND PATCHLEVEL): C++ Builder 6.0 build > 10.155, gcc 3.2.2 > > > AREA/CLASS/EXAMPLE AFFECTED: > Callback from server to client > > > DOES THE PROBLEM AFFECT: > COMPILATION? > no > LINKING? > no > EXECUTION? > yes > > > SYNOPSIS: > Sever can not call back client. This call simply fails. All machines > have local IP addresses (192.168.1.*) > > DESCRIPTION: > I am starting server on linux machine then client(s) on windows. There > is no problem with connecting client to server. All functions that do > not require callback work perfectly. However when server needs to send > callback information to client(s) this call always fails. No tcp > connection is created and no packages are sent. > However I compiled same server source code on windows machine (under > Builder 6) and when I start ser...

Re: [ace-users] Re: [tao-users] Re: difficulties compling TAO with mingw and msys #2
Hi, > > Great, when we get time we will try to upgrade to a newer version of MinGW, > > but it is still a candidate. Just keep an eye on the scoreboard, when we > > upgrade you will see it there. As you can see on the scoreboard, there are > > no issues with the 3.2.3 version > > I have run all but a few of the provided tests, and all looks well. We run all ACE tests, no issues there, we are working on the TAO tests, some of the tests are able to freeze our build system > Out of curiosity, what is required for eliminating the > inline/dlli...

RE: [tao-users] Re: [ace-users] Re: Announcing the release of the new beta (ACE-5.4.10, TAO-1.4.10 and CIAO-0.4.10)
Hi, > > >> We encourage you to download the new beta, use it with your > > >> applications, and let us know soon if you encounter any problems > > >> since we plan to cut the x.5 release by February 28th. > > > > As per Wallace's comments, we have an aggressive schedule > for the x.5 > > release to meet the needs of some major sponsors. If > people can give > > x.4.10 a "test drive" in the next couple of days and report problems > > they encounter we'll try to ensure that we fix any > showstoppers before > > According to bugzilla bug 2323 is not fixed yet. > > http://deuce.doc.wustl.edu/bugzilla/show_bug.cgi?id=2323 > > For us it is a show stopper. We use the OCI version which does not > have problems related to this bug but it would be nice to be able to > use the latest version with more fixes. FYI, the reason that this test now fails is because Ossama added several new test cases which wheren't in the test in the past, this uncovered some bugs which according to our information where already there a long time. Johnny "Johnny Willemsen" <jwillemsen@remedy.nl> writes: > > > >> We encourage you to download the new beta, use it with your > > > >> applications, and let us know soon if you encounter any problems > > > >> sinc...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO #2
Hi, See http://www.remedy.nl/en/borland.html for an overview of the supported Borland products with TAO. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > -----Original Message----- > From: Espen Harlinn [mailto:espen@harlinn.no] > Sent: donderdag 2 februari 2006 18:06 > To: jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO > > Hi, > > I'm curious about the current status of ACE/TAO and C++ Builder 2006. > Borland shipped the promised fix/update some time ago, but I > couldn't find > anything about how it works with ACE/TAO. > > Regards > Espen Harlinn > > ...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO #2
Hi, The x.4.8 version of ACE/TAO is supported with BCB2006, we have some linker warnings/errors in some configurations, Borland is working on these for Update2, but these are not causing a problem. See ACE_wrappers/ACE-INSTALL.html for info about how to use it. We deliver also commercial support for using BCB2006 with ACE/TAO. See www.theaceorb.nl for our services. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > -----Original Message----- > From: Espen Harlinn [mailto:espen@harlinn.no] > Sent: donderdag 2 februari 2006 18:06 > To: jwillemsen@remedy.nl > Cc: ace-users@cs.wustl.edu > Subject: RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO > > Hi, > > I'm curious about the current status of ACE/TAO and C++ Builder 2006. > Borland shipped the promised fix/update some time ago, but I > couldn't find > anything about how it works with ACE/TAO. > > Regards > Espen Harlinn > > ...

Re: [ace-users] Re: [tao-users] Re: difficulties compling TAO with mingw and msys
Hi, Great, when we get time we will try to upgrade to a newer version of MinGW, but it is still a candidate. Just keep an eye on the scoreboard, when we upgrade you will see it there. As you can see on the scoreboard, there are no issues with the 3.2.3 version Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl "William Lederer" <wgl@localhost.localdomain> wrote in message news:<m3pt4yrtfx.fsf@localhost.localdomain>... > Thanks! > > I followed your advice in your earli...

Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2 #2
Hi, > Did you recommend to use VxWorks 6.4 with ACE+TAO 5.5.1a patch 4? VxWorks 6.4 is more stable then VxWorks 6.2, but still has its known problems. The p4 is so far as I know only a backport of the config-vxworks6.4.h that is part of the doc_group version 1.6.1. We are currently doing some work on VxWorks 6.4 kernel mode for PPC604. As part of this work we have made several improvements to the VxWorks 6.4 support which will be part of the upcoming 1.6.2 version. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl *** Integrated compile and test statistics see http://scoreboard.theaceorb.nl *** *** Commercial service and support for ACE/TAO/CIAO *** *** See http://www.theaceorb.nl/en/support.html *** ...

[tao-users] RE: [ace-users] Re: How to use Any>>=OctetSeq in TAO 1.3.6? #2
Hi, > > Heiko, could you try to add TAO_Export to front of the operators in > > OctetSeqA.h and then rebuild TAO and you app. I think the linker > > errors should be gone. > > this is the solution! Thank you :-) Thanks for the feedback. I have just committed the fix into the repo and this will be in the 1.4 release. Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl ...

RE: [tao-users] RE: [ace-users] XML service configuration no longer works with ACE/TAO 5.4.5/1.4.5
Hi, > > Hi Lothar > > > > > � � ACE VERSION: 5.4.5 > > > > Thanks for using the PRF form. Could you try to find the > problem and send > > us patches to fix this? > > > > Regards, > > > > Johnny Willemsen > > I have no problem committing some time to the problem. I do > however know as > much as nothing about the ACE XML parser and it's recent > changes. It seems to > me that (some) of the recent changes might have caused the > test failures. So > if someone working actively on ACEXML gives me directions I > am willing to > spend my time investigating the problem. I can't remember that work has been done the last months so I am also amazed things broke. Nobody is actively working on it, so I think there are not much directions at this moment. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl On Wednesday 18 May 2005 11:01, Johnny Willemsen wrote: > Hi, > I can't remember that work has been done the last months so I am also > amazed things broke. Nobody is actively working on it, so I think there are > not much directions at this moment. Well, it did definiteley work with 5.4.4. So any changes that broke it must have been made between 5.4.4 and 5.4.5. I also read in the release email of 5.4.5 in the CIAO...

[ace-users] RE: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6 #2
Hi, > -----Original Message----- > From: Douglas C. Schmidt [mailto:schmidt@cse.wustl.edu] > Sent: Monday, March 27, 2006 9:09 AM > To: nealweston@bellsouth.net; ace-users@cs.wustl.edu; > parsons@dre.vanderbilt.edu > Subject: Re: ACE/TAO build problems on Solaris 2.8 using gcc 3.3.6 > > Hi Neal, > > >> I am trying to build ACE-5.5 and TAO-1.5 on a SPARC > Solaris 2.8 system > >> using gcc 3.3.6 and GNU make 3.80. > >> > >> The build is failing in > ACE_wrappers/build/TAO/orbsvcs/orbsvcs (output > >> included below) and I was wondering if anyone had any > suggestions as to > >> what the problem may be. > >> > >> What is puzzling to me is that the lines in question are > all comment > >> lines. For example the "01.ps" invalid token on line 15 of > >> CosProperty.idl is from the following comment line: > >> > >> // ftp://ftp.omg.org/pub/docs/1995/95-06-01.ps > >> > >> If I replace the "//" style comments with "/* ... */" > style comments > >> the errors go away. > > Wow, that's pretty weird. I recommend you upgrade to a newer version > of GCC - perhaps there's a problem with the version of CPP that's > being used on your platform since that's what the TAO IDL compiler > uses under the hood ...

[tao-users] RE: [ace-users] ACE/TAO on Solaris 10
Hi, There have been some replies. People do have things working on Solaris and there have been made fixes in ACE/TAO. Could you wait another week or so and try the x.4.8 or try cvs, see http://cvs.doc.wustl.edu Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > Dear list members, > > (I sent this message couple of days ago and am unsure if it > was distributed, > thus re-sending it again. I apologize if you received it more > than once) > > I would like to give feedback regarding availability of > ACE/TAO (versions > 5.4.7 and 1.4.7 respectively) on OpenSolaris (Solaris 10) > Intel platform. > > Sun is selectively releasing source code of the Solaris 10 under an > open-source license. Details of this project and installable Solaris > binaries can be found on here: > http://www.opensolaris.org > > Sun has also released Forte compiler set in binary form to > the OpenSolaris > community. A Quote from their website: "Sun Studio 10 > software is freely > available to participants in the OpenSolaris community for > development on > both OpenSolaris and Solaris[tm] Operating Systems on > SPARC-based systems > and x86-based systems, as well as on Linux." You can get > access to Forte > compilers from the OpenSolaris website as well but you should register...

RE: [ace-users] Re: what version tao/ace for AIX 5.2 posix aio
Hi Duane, I can't speak for TAO's use of AIO, but ACE 5.4 does support AIO on AIX 5.2. -Steve -- Steve Huston, Riverace Corporation Co-author of "C++ Network Programming" and "The ACE Programmer's Guide" Books, ACE kit and support info at http://www.riverace.com/ > -----Original Message----- > From: owner-ace-users@cse.wustl.edu > [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Douglas C. Schmidt > Sent: Sunday, July 04, 2004 2:49 PM > To: shuston@riverace.com; ace-users@cs.wustl.edu > Subject: [ace-user...

[tao-users] Re: [ace-users] How to use c++ native exception handling instead of ACE's while building ACE+TAO
Hi, >> My only guess is that all of the libs you are linking in your >> builds were not compiled with a consistent set of options. Right, my recommendation would be to completely blow away your existing ACE+TAO x.5 directory, download a fresh version, and start from a clean slate. It sounds like you may have things lying around from previous build attempts. Thanks, Doug -- Dr. Douglas C. Schmidt Professor and Associate Chair Electrical Engineering and Computer Science TEL: (615) 343-8197 Institute for Software Integrated Systems WEB: www.dre.vanderbilt.edu/~schmidt Vanderbilt University, Nashville TN, 37203 NET: d.schmidt@vanderbilt.edu ...

Re: [ace-users] Problems at linkage of TAO to ACE, target VxWorks 6.2
Hi, > SYNOPSIS: > What is the differences in linkage between compilation of ACE+TAO with > or without (RTP, PTHREAD), when we allow or disallow both of them > together? We can't allow RTP at our project. If we disallow RTP and > PTHREAD we have a problems with linkage with some TAO libraries. For differences check the VxWorks documentation. There are also runtime differences when you build rtp/pthread mix. We as Remedy IT can assist with this decision and give you information which combinations do behave better then others. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl *** Integrated compile and test statistics see http://scoreboard.theaceorb.nl *** *** Commercial service and support for ACE/TAO/CIAO *** *** See http://www.theaceorb.nl/en/support.html *** ...

[ace-users] Re: [tao-users] Problem with removing event handler #2 #2
Hi Rob, > I figured that out, and removed ACE_Event_Handler::DONT_CALL from my > remove_handler call this morning. As far as I can tell handle_close is > still not getting called. Perhaps you're not defining handle_close() with the right signature? At any rate, there's no good reason for this not to work, so I recommend you crank up the debugger and figure out what's going on. thanks, doug ...

RE: [ace-users] Re: ACE-TAO subesetting
Thanks Don, Yes I do intend to follow up on the material you have alluded to in the mail. And I stumbled upon your contact during some initial reading on this subject. <snip><http://www.cs.wustl.edu/~schmidt/ACE_wrappers/docs/ACE-subsets.html> Anyone interested in contributing time or funding to these efforts should please contact d.hinton@vanderbilt.edu <snip> /Gaurav -----Original Message----- From: Don Hinton [mailto:don.hinton@vanderbilt.edu] Sent: Friday, November 19, 2004 10:42 AM To: Gaurav Khanna Cc: ace-users@cs.wustl.edu Subject: [ace-users] Re: ACE-TAO subesetting Hi Gaurav: > How do i plug into the latest state of efforts on ACE/TAO subsetting?. > I am trying to investigate opportunities of footprint/memory usage > reduction in typical use. Thanks very much for your email. Please make sure to send all questions related to ACE or TAO to the ACE mailing list or ACE+TAO newsgroup, rather than to me directly. See http://www.cs.wustl.edu/~schmidt/ACE-mail.html for more info on how to access these resources. For the latest information on ACE+TAO subsetting, please see http://www.cs.wustl.edu/~schmidt/ACE_wrappers/docs/ACE-subsets.html If you'd like to contribute to - or sponsor - efforts on ACE+TAO subsetting please send email to Doug Schmidt <d.schmidt@vanderbilt.edu>. Thanks very much, Don ...

RE: [tao-users] Problems building ACE and TAO on SuSE Linux 9.0 #2
Hi, Just to report that this problem was solved by simply using the .tar.gz download rather than the .zip. Everything works first time using that download (obviously). Using "unzip xxx.zip -d ACE" with the .zip file results in files that have the wrong end of line terminators. Its obviously a beginners error- sorry! In my defence, this only causes a problem when the build completes the first compiling & linking parts and gets to the scripting stage - a bit baffling for a beginner. I can only offer that the downloads page doesn't explicitly say that the .zip is for Windows...

[tao-users] RE: [ace-users] Tao_idl core dumps during ACE/TAO build
Hi, Please upgrade to ACE+TAO x.4.7, which you can download from http://deuce.doc.wustl.edu/Download.html under the heading "latest beta kit". The DOC groups at Washington University, UC Irvine, and Vanderbilt University only provide "best effort" support for non-sponsors for the latest beta kit, as described in http://www.cs.wustl.edu/~schmidt/ACE_wrappers/docs/ACE-bug-process.html Thus, if you need more "predictable" help, I recommend that you check out http://www.cs.wustl.edu/~schmidt/commercial-support.html for a list of companies that will provide you with ACE+TAO commercial support. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl > TAO VERSION: 1.4.1 > ACE VERSION: 5.4.1 > > HOST MACHINE and OPERATING SYSTEM: > Dell PowerEdge750, Slackware Linux 10.1.0 > > TARGET MACHINE and OPERATING SYSTEM, if different from HOST: > COMPILER NAME AND VERSION (AND PATCHLEVEL): > gcc version 3.3.4 > > AREA/CLASS/EXAMPLE AFFECTED: > CosConcurrencyControl.idl failed due to tao_idl core dump > > DOES THE PROBLEM AFFECT: > COMPILATION? Yes > $ACE_ROOT/ace/config.h and > $ACE_ROOT/include/makeinclude/platform_macros.GNU > included below > LINKING? No > EXECUTION? No > OTHER (please specify)? No > > SYNOPSIS: > TAO fails to build because tao_...

[ace-users] RE: [tao-users] Borland Developer Studio 2006 with ACE/TAO
Hi, I'm curious about the current status of ACE/TAO and C++ Builder 2006. Borland shipped the promised fix/update some time ago, but I couldn't find anything about how it works with ACE/TAO. Regards Espen Harlinn ...

[ace-users] Re: [tao-users] Re: difficulties compling TAO with mingw and msys
Hi, > Sorry about the wrong PRF file. > > I have been using the -mtune as you can check for further down the > excessively-long compile log; it gets rid of one of the complaints the > compiler has. Ok, I changed that last week, with 3.4 we use -mtune now. >I followed your suggestion regarding the include file and it gets past > the problem. > > However, it seems like such a fundamental include, why does it work on > other envionments (like the linux one that was a full successful > compile for me)? I really don't know, maybe a compile...

[tao-users] Re: [ace-users] timestamps incorrect in ACE+TAO .tar.gz
Hi > It has just come to my attention that there are many files in the > ACE+TAO .tar.gz file with timestamps showing '1970-01-05'. Obviously > this is wrong and is the only reason why my packages have been > rejected from Debian ("file(s) with a time stamp too ancient"). > > Is there a possibility that this will be fixed. Or should I just > 'touch' all the problematic files? Could you please run a touch on them? I don't know how this happened. Strange. Opening and fiddling with the distribution would make quite a few things goofy! If ...

Re: [ace-users] [tao-users] ACE/TAO ported to Sun Studio 12
Hi, > is this change included in the official release of ACT/TAO (and if yes > since which version)? This change will be part of the upcoming x.6.2 version. I am creating x.6.2 at this moment, when everything runs fine it will be available at the end of today. Regards, Johnny Willemsen Remedy IT Postbus 101 2650 AC Berkel en Rodenrijs The Netherlands www.theaceorb.nl / www.remedy.nl *** Integrated compile and test statistics see http://scoreboard.theaceorb.nl *** *** Commercial service and support for ACE/TAO/CIAO *** *** See http://www.theaceorb.nl/en/support.html *** ...

[ace-bugs] Re: [tao-users] ACE/TAO without network adapter and TCP/IP stack on windows 95 execution problem
Hi Migel, >> I debug ACE/TAO and found that `SHMIOP` transport protocol based on = >> socket API and don't work if socket API failed :( >> >> Inside `TAO_SHMIOP_Connector::open` I can see = >> `this->base_connector_.open` call. `base_connector_` is `ACE_SOCK` class = >> and this class don't work fine if network not present (configured) on a = >> computer (`ACE_OS::socket` call failed). >> >> Does anybody know what I can do to fix my stupid situation and run my = >> program on windows 95 without network support...

Web resources about - Re: [tao-users] Re: ACE/TAO call back problem #2 - comp.soft-sys.ace

Resources last updated: 3/6/2016 12:45:00 AM