f



Matlab with NI GPIB-USB-HS on Mac OS X 10.6.2

I'm trying to open a GPIB connection from Matlab 2009b using a National Instruments GPIB-USB-HS converter on Mac OS X 10.6.2. Whenever I try

TDR25=gpib('ni',0,25)

I get the error

??? Error using ==> gpib.gpib at 142
The specified VENDOR adaptor could not be found.

The offending input line is:

pathToDll = localFindAdaptor(name, ext);

I know that OS X 10.6.2 isn't officially supported by NI and after installing the driver (versions 2.5.5 and 2.5.6) I get the message that the system extension cannot be used. Nevertheless, I can communicate with my devices via the Interactive Controle.command installed with the NI-488.2 driver and the GPIB also sees the GPIB controller.

So why can't Matlab open the GPIB connection?
0
Rudi
11/23/2009 10:56:03 PM
comp.soft-sys.matlab 211266 articles. 25 followers. lunamoonmoon (257) is leader. Post Follow

2 Replies
1183 Views

Similar Articles

[PageSpeed] 25

"Rudi Pfeiffer" <rpfeiffer@caltech.edu> wrote in message 
news:hef3u3$j4h$1@fred.mathworks.com...
> I'm trying to open a GPIB connection from Matlab 2009b using a National 
> Instruments GPIB-USB-HS converter on Mac OS X 10.6.2. Whenever I try
>
> TDR25=gpib('ni',0,25)
>
> I get the error
>
> ??? Error using ==> gpib.gpib at 142
> The specified VENDOR adaptor could not be found.
>
> The offending input line is:
>
> pathToDll = localFindAdaptor(name, ext);
>
> I know that OS X 10.6.2 isn't officially supported by NI and after 
> installing the driver (versions 2.5.5 and 2.5.6) I get the message that 
> the system extension cannot be used. Nevertheless, I can communicate with 
> my devices via the Interactive Controle.command installed with the 
> NI-488.2 driver and the GPIB also sees the GPIB controller.
>
> So why can't Matlab open the GPIB connection?

The NI drivers are limited to 32 bit user space so you will need to install 
32 bit MATLAB.   Everything should work after that.



0
Trent
11/24/2009 3:35:47 PM
> The NI drivers are limited to 32 bit user space so you will need to install 
> 32 bit MATLAB.   Everything should work after that.

That solved the problem, thanks!
0
Rudi
11/24/2009 6:07:19 PM
Reply: