f



Problem running exe compiled using Matlab Compiler 7.6 on a PC with Matlab 6.5

Hi,

I have some Matlab code which I compiled using Matlab 
Compiler 7.6. Using the MCRInstaller and the Visual C++ 
Runtime library, I was able to install MCR 7.6 on the 
client machine.

However, the client machine already had Matlab 6.5. Now 
when I try to run my exe, I get the following error message:

Fatal error finding symbol mxCalcSingleSubscript_76 in 
c:\matlab6p5\bin\win32\libmx.dll

I understand that the error shows up since the exe tries to 
go and look for the necessary information in the win32 
folder for Matlab 6.5 rather than the v76 folder for the 
runtime. 

Can anyone give me any suggestions on how to fix this 
problem without having to uninstall the already existing 
Matlab 6.5?

Thanks,
Millie
0
millies (1)
10/29/2007 9:07:36 PM
comp.soft-sys.matlab 211266 articles. 15 followers. lunamoonmoon (258) is leader. Post Follow

2 Replies
1876 Views

Similar Articles

[PageSpeed] 50

Check to make sure that the 7.6 resources are listed first 
in the Windows path environment.  You might have to do some 
shuffling to get the 7.6 resources found first.

As it is now, it finds the 6 stuff first (which is 
incompatible with the 7. resources).
0
10/30/2007 1:03:17 AM
Check to make sure that the 7.6 resources are listed first 
in the Windows path environment.  You might have to do some 
shuffling to get the 7.6 resources found first.

As it is now, it finds the 6 stuff first (which is 
incompatible with the 7. resources).
0
10/30/2007 1:03:28 AM
Reply: