RGB2GRAY error??????????????

Hi all,

i am building an OCR system,First stage i separate the lines on the
imagefile and then separate the character and get features for each
character...

using moment in variant, any way i am using RGB2GRAY level on my
system,

the problem is : when i separate the character and try to use
RGB2GRAY on the separated character image,this error appears :

??? Error using ==> rgb2gray>parse_inputs
MAP must be a m x 3 array.

whatis that? when i use the RBG2GRAY on the image of separated line
from the sameimage, it works fine...!!!!!!

wats wrong, how i can solve this problem????????
0
mmsa12 (7)
6/25/2006 11:40:46 AM
comp.soft-sys.matlab 207282 articles. 1 followers. lunamoonmoon (258) is leader. Post Follow

1 Replies
983 Views

Similar Articles

[PageSpeed] 29
MMSA wrote:
> Hi all,
> 
> i am building an OCR system,First stage i separate the lines on the
> imagefile and then separate the character and get features for each
> character...
> 
> using moment in variant, any way i am using RGB2GRAY level on my
> system,
> 
> the problem is : when i separate the character and try to use
> RGB2GRAY on the separated character image,this error appears :
> 
> ??? Error using ==> rgb2gray>parse_inputs
> MAP must be a m x 3 array.
> 
> whatis that? when i use the RBG2GRAY on the image of separated line
> from the sameimage, it works fine...!!!!!!
> 
> wats wrong, how i can solve this problem????????

It seems that your image is not 3D (MxNx3). Make sure you extract the 
region properly.

-Herbert
0
6/26/2006 6:54:56 AM
Reply:
Similar Artilces:

error messages
I have an app running on over 20 different machines with no probs. 1 is on win me and A2000. It installed OK and ran fine for a couple of months. Then it started with 91 object variable error messages. I fixed that (or maybe it just went away <g>) then now its giving error 2110 can not go to control. message. I have tried the fix on the Ms web site (autocorrect set to No) but still not right. Any thoughts on what is going on TIA David B Hexham UK That is what i did to clear the first error. Havn`t been to the site since the second error was reported. DB Wayne Morgan <comprev_goth...

why does py_compile.compile() miss some errors in sourcefile?
where can I find some documentation, which errors will be found by 'py_compile.compile' and which will not be found. # t1.py # ===== import os.path import py_compile py_compile.compile(os.path.join(os.path.dirname(__file__), "t2.py"), doraise=True) # t2.py # ===== # following line is found as an error: # Class C: # <== 'SyntaxError: invalid syntax' class C: pass c = CC() # <== not found as an error from py_compile # but found as an error from python-executable: # 'NameError: name 'CC' is ...

Error Message %DBUS-3-BADEEPROM
i have this message when the cisco 7000 boot up. I don't have any experience with the cisco's world. I am a student and i try to work with that router. if anyone can help me ..... thanks ...

Error -50150 &quot;Cascade Failure&quot;: LabVIEW Bug?
Hello, &nbsp; I'm new to the forums here, so I apologize in advance for breaches of etiquette or various other newbie actions. ;) &nbsp; While using the DAQmx Create Channel VI in conjuction with my own custom unit scale, I keep running into a -50150 error for various combinations of slope and y-intercept. I've pared my problem down to the attached VI. As you can see, I'm setting up the linear scale with a slope and y-intercept, and then scaling the original +/- 10V range for&nbsp;an appropriate&nbsp;maximum and minimum. Upon running this VI as-is, I get the -50150 ...

spm 5 "error using ==>plot vector lengths?"
Hello All yes, this old chestnut again. please bear with me as I am a neuroscientist aka mathematical dummy. I am running a brain scan analysis using a matlab suite (SPM5) that incorporates 2 conditions (a pre and post exercise scan, hence I am running a paired t test with the following covariates gender (specified as 1 = male, 2 = female) age (specified in years 34.3, 56.2 etc) grey matter brain volumes (specified as 774.3, 667.8 etc) whilst I get everything working I am using data from just 3 subjects. I am entering 3 pre and 3 post measurements (3 pairs of scans), hence for each cov...

error in using jordan
Hi, I have a matrix equation: P = P0.*exp(K*t); P = [p1 p2 p3 p4]; P0 = [1 0 0 0]; K = 4*4 matrix of parameters; Now to solve this equation, I wanted to do jordan normal of K using jordan. So I used [Q,J]=jordan(K) However, its giving me following errors: ?? Error using ==> mupadfeval at 28 Error: Similarity matrix too large. [mljordan] Error in ==> sym.jordan at 38 out = mupadfeval('mljordan',A,'All'); Error in ==> jordan at 23 [V,J] = jordan(sym(A)); I dont know how else to solve this. Please suggest if you have solution for my e...

How to skip error when read an image
Hi: I want to use 'imread' function to read 100 image files. But maybe among these images, some images cannot be read because of error. Currently, if 'imread' read an error image, it displays 'Unable to determine the file format' and stops. But I want to skip the error image and continue procsessing the following images. How should I do? /Weihua Xiong weihua xiong wrote: > > > Hi: > > I want to use 'imread' function to read 100 image files. But maybe > among these images, some images cannot be read because of error. > > Currently, if...

exec error
Hi All, I saw an unexpected error while using exec command under Expect shell. > expect -v expect version 5.39.0 expect1.6> exec ps -ef | grep wkwang child process exited abnormally while executing "exec ps -ef | grep wkwang" Under UNIX shell, if grep finds nothing, the command "ps -ef | grep wkwang" just returned nothing, would not raise any error. Why under Expect shell, the command got "child process exited abnormally"? Can anybody confirm if it's a Expect defect? Thanks Peter Peter Wang wrote: > Hi All, > > I saw an unexp...

Solaris9 on Ultra5: BAD TRAP error
Hi! I'm using Solaris9 on my Ultra5, some days ago I switched to a 330Mhz CPU and I added two 64MB 60ns memory modules. My Ultra5 started hanging (after the boot or while using SSH) and writes in /var/adm/messages this data: [lorenzo@u5:~]$ cat /var/adm/messages | grep "BAD TRAP" Jul 23 21:21:38 u5 unix: [ID 799565 kern.notice] BAD TRAP: type=10 rp=2a100371340 addr=102db18 mmu_fsr=0 Jul 23 21:23:37 u5 savecore: [ID 570001 auth.error] reboot after panic: BAD TRAP: type=10 rp=2a100371340 addr=102db18 mmu_fsr=0 Jul 24 13:10:56 u5 unix: [ID 799565 kern.notice] BAD TRAP: type=10 rp=2...

Why no error?
Why no error on this code? <?php for ($i=0;$i<5;++$i) { if ($i==2) continue print "$i\n"; } ?> Output is "2". May be true must be "continue;"? That's weird and interesting. You're right, you need the semicolon. On Sep 23, 1:20=A0pm, "Andrew G. Koptyaev" <kopty...@gmail.com> wrote: > Why no error on this code? > > <?php > for ($i=3D0;$i<5;++$i) > { > =A0if ($i=3D=3D2) > =A0 continue > =A0print "$i\n";} > > ?> > > Output is "2". > May be true must be "...

Reg. Error Mesg.
Add the users to the power users group. This is will solve your current problem. Regards Ramesh Jayachandiran ...

why no result & no error from this recursion
Why does the following recursion produce neither a result nor an error message -- nor a system crash? Block[{$RecursionLimit=50002}, (If[#<1, "", "." <> #0[# - 1]] &)[50000]] I even tried setting $RecursionLimit=Infinity, but no change. I presume this is just bumping up against a hardware/OS limit, so I'm surprised to get no error message and no crash. -- Murray Eisenberg murray@math.umass.edu Mathematics & Statistics Dept. Lederle Graduate Research Tower phone 413 549-1020 (H) University of Massachusetts ...

Tape Drive SCSI error
I have a Sun Ultra1 Creator 3D running Solaris 9 8/03. I have a Sun SCSI card installed with a 12 gig array attached and 2 drives installed on the internal scsi adaptor. When I attach a tape drive to the internal SCSI adaptor I get a scsi drive train error message that prevent the system from booting. When I remove the tape drive the system boots and runs OK. Can any one provide any assistance to allow the system to boot with the tape drive? Howard Huntley Jr. MCP, MCSE MicroComputer Systems Specialist On Sun, 14 Sep 2003 13:41:17 -0400, Howard Huntley wrote: > I have a Sun Ultra1 Creator...

"no error" errors
What is with the "no error" errors in Win32 ? I encountered yet another case, with bitblt, where the return value indicates error (0), but the call to getlasterror returns the "no error" code. This has occurred on several other calls, and I have to work around it by ignoring the error. In all these cases, the function appeared to work correctly, despite the error return. Is it just that it is so uncommon for people to actually check the error returns that some of them don't work ? -- Samiam is Scott A. Moore Personal web site: http:/www.moorecad.com/sco...

Error DBFNTX/1020 Data type error with auto increment field and memo field
Hi All, When I try "APPEND FROM ..." from database with auto increment field and memo field occur error: Error DBFNTX/1020 Data type error: F_ID I use xHarbour (Latest CVS) and BCC 5.5. Simple example: *--------------------------------------------------------------------------= ---- * Function Main() *--------------------------------------------------------------------------= ---- * Local aStru:=3D{{'F_ID', '+', 4,0},; {'F_MEMO','M',10,0}} DbCreate('test',aStru) Use 'test' New Exclusive Append Blank ...

opatch error. Help please!
When I try to install a patch, I get: Problems with the lock file Lock file exists, details are: Interim Patch 2965263 is holding the lock, probably due to previous unsuccessful operation Yet, the $ORACLE_HOME/.patch_storage directory has a file called patch_free. I even checked the install log of 2965263 and all looks OK: Performing post-patch inventory update and removing working files. Patch 2965263 has been applied successfully. Help! I need to apply more patches! Thanks, Vince Laurent Oracle 9.2.0.3 on HPX 11.11 >Check read/write/execute permissions and...

Depfun Error in compiling
hi, I am geeting this error each time while using command mcc -m fun for creating a standalone file. But I am unable to do so since, following errors comes out each time: Warning: an error occurred while parsing class scribe.textbox: The '------------::::::::::::-------------:- os^<vpxd*>h os^<vpxd*>h------------... os^<vpxd*>h ' enumerated value is invalid. ??? Unable to create a class array for class scribe.textbox Depfun error: 'Unable to create a class array for class scribe.textbox ' ??? Error executing mcc, return status = 1. I even tried to r...

Question about SERVFAIL error
Hello~~ My name is KyoungHee Kim, in Korea. Our company has two dns. One is primary DNS and the other is secondary DNS. Currently, I'm experiencing some odd behavior on Primary DNS. Its bind version is BIND 9.2.4. Secondary DNS is well operated and its bind version is BIND 9.2.1 Only primary DNS can��t often resolve about certain site. Certain sites are ��techwing.co.kr�� and ��mail.chiptron.co.kr.�� Error message in Primary DNS is ��server can't find techwing.co.kr: SERVFAIL�� After I change name server through nslookup, name resolving is succe...

FZERO Error plus matrx dimensions
I cannot figure out why I keep getting this error: ??? Error using ==> fzero FZERO cannot continue because user supplied function_handle ==> @(Velocity)(0.5*C_D1*p*A_o*(Velocity^2)*((1000^2)/(3600^2)))+F_grav+F_rolling+Force_Car failed with the error below. Error using ==> plus Matrix dimensions must agree. here is part of my code: fun=@(t)8*x*(t^2)+Growth+Length+Width x = fzero(fun,1) Where growth, length, and width are the result of other equations in my code. I have this code in a for loop to find the value at which this function is zero at 30 different ...

FF error?
Hi at all, please take a look here. I have: <body onload="STT();"> <div id="panorama" style="width:100%; height:150px; border:1px solid red;overflow:hidden"> <img src="images/veylargeimage.jpg" alt="" /></div> This js code move automatically image up or down, left or right. It work fine wirh MSIE, Opera, Safara and Chrome but not with FireFox Why please? var rollo; var b=1; var c=1; function STT() { setInterval(function(){rollo=document.getElementById('PANORAMA');rollo.scrollTop+=b;rollo.scrollLeft+=c;if (rollo...

error discription and solution
HTTP Status 500 - Handler processing failed; nested exception is java.lang.NoClassDefFoundError: org/apache/commons/lang/ArrayUtils Navneet Mathpal wrote: > HTTP Status 500 - Handler processing failed; nested exception is java.lang.NoClassDefFoundError: org/apache/commons/lang/ArrayUtils http://sscce.org/ -- Lew On Thu, 20 Feb 2014 00:59:55 -0800 (PST), Navneet Mathpal <navneetmathpal93@gmail.com> wrote, quoted or indirectly quoted someone who said : >NoClassDefFoundError My condolences. This is my least favourite error message. see http://mindprod.com/jgloss...

C linking Error-Socket Programming
Hi I have written a server socket in C to receive images. I wnat to run this program in matlab and use image read to display the images. I tried to build a mex file, however there is a linking error. This is because when i compiled my c program i had to configure the compiler to add the winsock library. How do i add this library to matlab's c compiler to allow it to compile the C program? ...

E2900 error on boot: TL = 1, TT = 32. ERROR: Data Access Error -- Help?? #2
Can someone help decipher this error below? Had Sun CE install 32Gb memory into 2 system boards (64Gb total), and now we are getting this error. We tried powering it back up with each system board individually, and get same error no matter which board is in, or both. So we're pretty sure it's not a single dimm that is the problem Sun Fire E2900 OpenFirmware version 5.19.4 (01/19/06 18:06) Copyright 2006 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. SmartFirmware, Copyright (C) 1996-2001. All rights reserved. 32768 MB memory installed, TL = 1, TT = 3...

Sendmail Error 451 4.7.1 and illegal seek stopping queue
We have been having a problem lately with our two sendmail machines. We have had them for a long time, and they have always been reliable until recently. Currently these two sendmail machines are our outside relays. They accept mail, then relay to our spam box, which then relays to our Exchange server. This was all working correctly until recently. Now, several times a day, the two sendmail queues stop. It appears that an email comes into the queue and causes a "451 4.7.1 Please try again later" error. Once that error occurs then all the other emails that appear to come in behi...

Hauppauge 350 error message says unsupported.
I use this command, wine /mnt/cdrom/setup.exe, to open the setup window; which opens nicely and fast, but, the window says I'm running win95 and that it isn't supported. This is true, the 350 card requires at least win98SE. Is there some way to get the setup.exe to see a win98SE or later OS? Add the following lines to your config file, it's in your home directory in the .wine hidden directory. [Version] "Windows" = "win98" Ivan. ...