f



Access violation error

Hi,

I bought Powerbuilder 7.0 desktop version the original build (5039 I
think). I installed it on my PC which has windows NT 4.0 sp6. When I
run the application I've created from within the development
environment my application runs fine with no problems. When I compiled
the application into exe and dlls I was getting an access violation
error c0000005 in PBVM70.dll.

I read a few forums and found that this error was solved in version
7.0.3. I downloaded the maintenance release from the Sybase website
and followed the instructions for installing the release. Once I
installed the maintenance release I did a full rebuild of the
application. When I try to run the application now I get the same
error.

I inherited the code from a company who used Powerbuilder 7.0
Enterprise Edition.

Can anyone please help me, I'm really struggling to get to the bottom
of this problem?

Regards,

Chris
0
chris
10/14/2003 3:03:48 PM
comp.soft-sys.powerbuilder 802 articles. 0 followers. Post Follow

1 Replies
416 Views

Similar Articles

[PageSpeed] 59

Hi,

Just to let you know I managed to fix the error I was getting. I think
the problem was caused by multiple copies of the dlls.

I removed all Sybase products, rebooted the PC, removed any remaining
registry settings for Sybase, and then reinstalled Powerbuilder 7.0
Desktop version and rebuilt my application. I rebooted the PC, and
then applied the maintenance release 7.0.3, and rebuilt my
application. I then rebooted the PC and then rebuilt the application
again and then compiled my application to create the relevant exes and
dlls.

I then executed my application and it ran successfully on my PC. I
then tried it on another PC with the relevant runtime libraries and my
application executed successfully.

Regards,

Chris
0
chris
10/15/2003 8:46:55 AM
Reply: