f



SAS 6 dataset on MVS to SAS 9.1 dataset on Windows 2003

Hi! All members,

I'm quite new to SAS.
I created a sas dataset using SAS 6 on MVS and FTP to Windows
environment. The physicall file name is LossNot (no file extention).
When I tried to bring in this dataset using SAS 9.1 on Windows 2003
Server, I got the error:
NOTE: Input library MYXPORT2 is sequential.
ERROR: File MYXPORT2.ALL. is not a SAS data set.

Below are the codes on MVS SAS 6, Windows SAS 9.1 and the error
message.

Please advise!!!
Thanks!!

==== Codes on MVS  SAS 6 =============================================
//MyIDA  JOB (318,ILS,999,999,,RJE),abc,CLASS=C,                  
//          MSGCLASS=V,MSGLEVEL=(1,1),REGION=4M                       
//SAS       EXEC SAS
//SASDAT2   DD DSN=MyID.LOSSNOT,DISP=(NEW,CATLG,DELETE),           
//          UNIT=SYSDA,SPACE=(CYL,(10,10),RLSE)                       
//SYSIN     DD *                                                      
                                               
........
........
.....

PROC SORT DATA = LOSSNOT OUT = SASDAT2.LOSSNOT;  
     BY ACCTNO;                                   
RUN;                                          

LIBNAME DOWN2 XPORT 'MyID.XPT.LOSSNOT'        
    DISP=NEW SPACE=(CYL,(10,5),RLSE);            
                                                 
PROC COPY IN=SASDAT2 OUT=DOWN2 MEMTYPE=DATA;     
    SELECT LOSSNOT;                              
RUN;                                             

=====================================================

/**** Codes below run on SAS 9.1 on Windows 2003 Server****/
Libname MyLib  'I:\Dataset';
Libname MyXport2 xport 'I:\Dataset\LossNot';  /*File*/

proc copy in=MyXport2 out=MyLib;
	select LossNot;
run;


=====Error Message on SAS 9.1 ========================================
1    Libname MyLib  'I:\Dataset';
NOTE: Libref MYLIB  was successfully assigned as follows:
      Engine:        V9
      Physical Name: I:\Dataset

2    Libname MyXport2 xport 'I:\Dataset\LossNot';
NOTE: Libref MYXPORT2 was successfully assigned as follows:
      Engine:        XPORT
      Physical Name: I:\Dataset\LossNot
2  !                                                                  
                          /*File*/

3    proc copy in=myxport2 out=MyLib;
4        select LossNot;
5    run;

NOTE: Input library MYXPORT2 is sequential.
ERROR: File MYXPORT2.ALL. is not a SAS data set.
NOTE: Statements not processed because of errors noted above.
NOTE: PROCEDURE COPY used (Total process time):
      real time           0.01 seconds
      cpu time            0.01 seconds

NOTE: The SAS System stopped processing this step because of errors.
0
hunt_shop (3)
8/16/2004 8:25:48 PM
comp.soft-sys.sas 142828 articles. 3 followers. Post Follow

0 Replies
701 Views

Similar Articles

[PageSpeed] 37

Reply: