f



RISC_OSLib 3 to 4 problem

Hi,

I have some source code which required fontselect and fontlist from V3
of RISC_OSLib. I've looked in the headers for the version released
with StubsG and they don't appear to be in there. I am unsure if they
vanished between v3 and v4 or were just somehow omitted from the
StubsG release.

Does anyone know if the functions and structures that were in those
headers have been moved to another header file? They don't seem to be
in the fonts.h file.

TTFN

Paul
0
7/6/2003 1:24:56 PM
comp.sys.acorn.programmer 2499 articles. 0 followers. Post Follow

3 Replies
170 Views

Similar Articles

[PageSpeed] 38

In article <aafa8d1c.0307060524.585efee4@posting.google.com>,
paulf.johnson@ukonline.co.uk (Paul F. Johnson) wrote:
 
> I have some source code which required fontselect and fontlist from V3
> of RISC_OSLib. I've looked in the headers for the version released
> with StubsG and they don't appear to be in there. I am unsure if they
> vanished between v3 and v4 or were just somehow omitted from the
> StubsG release.
> 
> Does anyone know if the functions and structures that were in those
> headers have been moved to another header file? They don't seem to be
> in the fonts.h file.
> 
  h.fontlist and h.fontselect are in the version of RISC_OSLIB supplied with
the 32bit version of C/C** by Castle. They are also in my copy of Acorn
C/C++ Update 1, manual dated December 1994, C version 5.09.


-- 
John (Hampshire UK)    jfo@argonet.co.uk


0
mijassw (10)
7/6/2003 11:51:27 PM
In message <pan.2003.07.07.07.00.30.711640@ukonline.co.uk>
          "Paul F. Johnson" <paulf.johnson@ukonline.co.uk> wrote:

> Hi,
> 
> By the process of poking various fingers onto keys John Evans generated
> this:
>  
> >   h.fontlist and h.fontselect are in the version of RISC_OSLIB supplied
> >   with
> > the 32bit version of C/C** by Castle. They are also in my copy of Acorn
> > C/C++ Update 1, manual dated December 1994, C version 5.09.
> 
> Looks like the one supplied with StubsG is missing it then. I have a
> feeling that I'm on Justin's killfile list (for a past naughtiness) -
> would someone mind poking him to see if this the case and if a future
> version will include them? They're kinda important ;-)
> 
> TTFN
> 
> Paul

If you have the Castle's 32bit version of C why not use that?

-- 
Colin Ferris Cornwall UK
0
cferris (978)
7/7/2003 9:05:54 AM
Hi,

By the process of poking various fingers onto keys cferri generated this:

> If you have the Castle's 32bit version of C why not use that?

I would rather use the 26/32 bit neutral version to avoid having to do the
upgrades to the new version of Clib.

(There is a bit more to it than that though)

TTFN

Paul
0
7/7/2003 9:36:47 AM
Reply:

Similar Artilces:

problem with KDE 3.4 and QT 3.3.4
Hello, I have recently felt the need for a specific application under KDE and decided to install it on one of our machines at work. I can't access this NG from work so I'll try to be as precise as I can but I might forget something. OK, here is my problem. I needed to install the new version of QT, but I still needed to preserve the one installed on our network (/usr/local is actually a symbolic link to a directory where all our machines access). For that I created a new "/usr/local.org" (this one being physically on my machine) and compiled QT 3.3.4 in /usr/local.org/qtXXXXXX and added a symbolic "qt" in the same directory for the convienience. I changed all my $QTDIR and $LD_LIBRARY_PATH and so.I was able to compile the examples and play with it. Then, I used apt-get to install kdelibs, and kde. The installation is a success, I restart my X-org, and can start KDE 3.4 (great !!). However, when I try to compile a simple program (such as Kbiff), the configure file tells me that I have a problem with UIC. I've looked on the net for a solution and found many references (sometimes several year old) and they said that the kdelibs needed to be recompile with the new QT installation. So I check the libraries of KDE and in fact the path used for the QT directory is still the one on the network (/usr/local/XXX/qt). Bingo ! I tried to reinstall kdelibs after I installed QT 3.3.4, and still no changes...) Is there a way of specifying the QT direc...

Problem updating PHP 4.3.0 DEV to PHP 4.3.3
Hi! I had Apache 2.0.47 and PHP 4.3.0 DEV running successfully on a W2k Server. For some reason, I couldn't get PHP to read XML-Attributes with the DOM XML -functions. So I thought, it would be time to update PHP to a newer version. So I simply replaces the old php-files with the new ones and of course kept the php.ini. But now, PHP doesn't work anymore. As soon as I request a page with php code, I get a "document contains no data" error after a while. (Apache's error log looks like the excerpt at the end of this message) If I install PHP5, I can't even start Apache. Does anyone have an idea, what may go wrong here? Thanks in advance, Tobias [...] [Wed Sep 24 20:46:56 2003] [debug] child.c(695): Child 3196: Worker thread 248 starting. [Wed Sep 24 20:46:56 2003] [debug] child.c(695): Child 3196: Worker thread 249 starting. [Wed Sep 24 20:47:24 2003] [notice] Parent: child process exited with status 3221225477 -- Restarting. [Wed Sep 24 20:47:25 2003] [notice] Parent: Created child process 3032 [Wed Sep 24 20:47:25 2003] [debug] mpm_winnt.c(505): Parent: Sent the scoreboard to the child [Wed Sep 24 20:47:25 2003] [notice] Child 3032: Child process is running [Wed Sep 24 20:47:25 2003] [info] Parent: Duplicating socket 220 and sending it to child process 3032 [Wed Sep 24 20:47:25 2003] [debug] mpm_winnt.c(426): Child 3032: Retrieved our scoreboard from the parent. [Wed Sep 24 20:47:25 2003] [debug] mpm_winnt.c(623): Parent: Sent 1 listeners to chi...

compile problem gcc-3.4.4 with -maix64 on aix 5.3
Hi, We are trying to compile gcc-3.4.4 with -maix64 on aix 5.3. here is the setup: We are using the 32bit gcc 3.3.2 rpm binaries that are available from IBM to do this. setenv make /opt/freeware/bin/make setenv CONFIG_SHELL /opt/freeware/bin/bash setenv CFLAGS -maix64 setenv CC /opt/freeware/bin/gcc cd objectdir/ .../gcc-3.4.4/configure --prefix=/usr/local/opt/gcc-3.4.4 --with- as=/usr/bin/as --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++ --en able-threads --enable-version-specific-runtime-libs After this is done I edit the Makefile created in objectdir to add these line...

[ace-users] Re: ACE 5.4 compiling problems with g++ 3.4.3
Hi Klaus, First, please use the problem-report-form when asking questions. ACE 5.4 is not supported with newer GCC versions. All these issues are resolved in the upcoming x.4.3 release. For the time being, try to add the following to your config.h # if (__GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 4)) # define ACE_EXPLICIT_TEMPLATE_DESTRUCTOR_TAKES_ARGS # endif /* __GNUC__ >= 3.4 */ You are correct, the download link doesn't work. Bala, do you have an idea what is happening with the download links. Regards, Johnny Willemsen Remedy IT Leeghwaterstraat 25 2811 DT Reeuwijk The Netherlands www.theaceorb.nl / www.remedy.nl "Klaus Hachmeister" <klaus.hachmeister@bigfoot.de> wrote in message news:<80eeed90.0412162346.246f6b85@posting.google.com>... > Hello anybody, > i had downloaded and compiled successfully the latest release version > of ACE (5.4) with gcc <= 3.3 in earlier times. > > Now i have to use the gcc 3.4.3 and get error messages in the > beginning of compiling ACE: > > --------------------------------------------------------------- > gmake -f Makefile -C ace all > gmake[2]: Entering directory `/home/klaus/NetDCU5/ace_root/ace' > gmake[3]: Entering directory `/home/klaus/NetDCU5/ace_root/ace' > > Makefile: /home/klaus/NetDCU5/ace_root/ace/Makefile.ace > > arm-linux-g++ -W -Wall -Wpointer-arith -pipe -O3...

Problems compiling STLPORT 4.5.3 with g++ 3.3
I am trying to compile the STLPORT 4.5.3 using g++ 3.3 compiler on sun. I have modified the stl_gcc.h file to point to the correct include path for the compiler. I am getting the following errors: In file included from /opt/nortel/gcc-3.3/backward/iostream.h:31, from /export/home/rch034/garyla/stlport/wrap_std/h/iostream.h:5, from /export/home/rch034/garyla/stlport/iostream.h:107, from /export/home/rch034/garyla/stlport/wrap_std/iosfwd:64, from /export/home/rch034/garyla/stlport/iosfwd:45, from /export/home/rch034/garyla/stlport/stl/_string_fwd.h:23, from /export/home/rch034/...

Problem in bundling IBM_AIX 4.3.3 JRE1.3.1 ..!
Dear, I have downloaded the IBM-AIX4.3.3 JRE from IBM web site (jre131.tar.gz :: http://www-106.ibm.com/developerworks/java/jdk/aix/index.html). My requirement is to bundle the JRE with our Java based Application, for that I extracted the jre131.tar.gz and bundle the same with our application with directory structure as <APPLICATION_INSTALL_DIR>/jre1.3.1/. But, after installing our application to a directory, then invoking the java or any other executable in the JRE is not working, it throws following error, ========= bash-2.05a# ./jre1.3.1/bin/java Unable to dlopen libjava.a: No suc...

Is there any difference of g++ 3.4.3 and g++ 3.3.4 ?
HI, my source code was compiled ok in g++ 3.3.4 . But when I try to use 3.4.3 to compile, I get the following error: Utility.h: In constructor `Buffer<size>::Buffer(const char*)': Utility.h:174: error: `buffer' undeclared (first use this function) Utility.h:174: error: (Each undeclared identifier is reported only once for each function it appears in.) Utility.h:176: error: no matching function for call to `strchr(<type error>, char)' /usr/include/iso/string_iso.h:130: note: candidates are: char* strchr (const char*, int) /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/.....

Re: [ace-users] Re: ACE 5.4 compiling problems with g++ 3.4.3
Hi > First, please use the problem-report-form when asking questions. ACE 5.4 is > not supported with newer GCC versions. All these issues are resolved in the > upcoming x.4.3 release. > > For the time being, try to add the following to your config.h > > # if (__GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 4)) > # define ACE_EXPLICIT_TEMPLATE_DESTRUCTOR_TAKES_ARGS > # endif /* __GNUC__ >= 3.4 */ > > You are correct, the download link doesn't work. Bala, do you have an idea > what is happening with the download links. Should be fine now! Please let us know if there are still problems. Thanks Bala ...

Problem of php_ldap.dll in appserv 2.4.3 and Problem of Apache server in appserv 2.5.3
when I used appserv-win32-2.4.3, everything is ok, but there is no ldap related functions support, I uncommented extension=php_ldap.dll in c:\winnt\php.ini, and thought everything will be allright, but I found there is no php_ldap.dll in $appserv\php\extensions\ or $appserv\php\ext\. Then I took php_ldap.dll of Appserv-win32-2.5.3 and tried to use it, but it is not work, so I reinstalled appserv-win32-2.5.3, but there is no response when I use http://localhost, http://localhost/test1.php is also no response, but under command line, I executed d:\>php test1.php works. How can I solve this problem? Thanks in advanced. -jiing- ...

Problems with Kde 3.4.3
Hello all, I'm using kde 3.4.3 (a custom built KDE on Ubuntu, I believe) in my department. I'm facing a weird problem: * Starting fresh, when I delete my .bashrc, .kde and .kderc and start my KDE session, everything is normal. * However, I notice that after a few days (I do xlock my screen etc), I notice the KDE menu and the toolbar gets messed up - what I mean is, the menu is NOT fully populated and when I open kcontrol, the menu on the left is absolutely empty and so on. * When I again delete my .bashrc and .kde*, and restart kde things are fine. Could someone tell me what might be wrong? Since it's my departmental machine, I don't have a say over which kde they use. Please let me know if you need more information. Regards, G.Sibi On 2007-03-30, Sibi <ssshayagriva@gmail.com> rambled on thusly: > I'm using kde 3.4.3 (a custom built KDE on Ubuntu, I believe) in my > department. I'm facing a weird problem: > * Starting fresh, when I delete my .bashrc, .kde and .kderc and start > my KDE session, everything is normal. First, have you tried just deleting your .bashrc and see what happens? If the problem still occurs, delete only .kderc and see what happens? If problems still exist, look in .kde for any files modified between when things were okay and when the problems started happening. The key is to track down where the problem is occurring. If I had to guess, I'd say it's probably under .kde/. But that's just a ...

Problem with Apache 1.3.28/PHP 4.3.3 on XP
Hi, I've got a strange query that I can't figure out. I've got a new installation of Apache 1.3.28 and PHP 4.3.3 on my laptop, but it doesn't appear to be processing URLs correctly. I've tried to do a direct copy of my config on my desktop (which is Apache 1.3.27 and PHP 4.3.1, I think), but I don't have access to it any more to check the config files. Apache works fine, I installed it first and tested it with several pages. They all get served nicely. PHP itself works fine, it processes and serves files correctly, with only one apparent problem. If you pass a URL such as : http://127.0.0.1/gallery/canada_0303/imgquery.php?PID=F1P02&mode=Photo I still get the same result as if i'd typed in : http://127.0.0.1/gallery/canada_0303/imgquery.php I added a line to print out the variables at the top of the page, and all of them are empty. Regardless of what you put in. If you need an example : http://www.novaldex.com/gallery/canada_0303/imgquery.php this is the same file (with only mods for usernames/passwords for different servers) and it works perfectly on my webhost. Click on the 'Next' and 'Prev' photos on the right to scroll through the pictures. Here is the primary code that is of concern : <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=windows-1252"> <title>Image Viewer</title> <base target="_self"> </head> <body b...

enscript problem on upgrade from AIX 4.3.3 to AIX 5.3
Did an upgrade yesterday from AIX 4.3.3 to AIX 5.3. We have some old code that uses the enscript command and now we are getting a banner page between each enscript command which we weren't getting under AIX 4.3.3. I can't find anything in the documentation about shutting off this banner page. Can anyone tell how, or if it's even possible, to shut off the banner page with enscript. Thx. Marv ...

Apache 2.0.48+Php 4.3.4+Aix 4.3.3
Hello. I'm trying to compile this version of apache with php support on Aix 4.3.3ML11. I use gcc 3.2.1 compiler and all seems to go right. But when i try to access to a php page apache shows segmentation fault and doesn't answer. Any idea ? Thanks. ...

Apache 2.0.48+php 4.3.4+Aix 4.3.3
Hello. I'm trying to compile this version of apache with php support on Aix 4.3.3ML11. I use gcc 3.2.1 compiler and all seems to go right. But when i try to access to a php page apache shows segmentation fault and doesn't answer. Any idea ? Thanks. > Hello. > I'm trying to compile this version of apache with php support on Aix > 4.3.3ML11. > I use gcc 3.2.1 compiler and all seems to go right. > But when i try to access to a php page apache shows segmentation fault and > doesn't answer. > > Any idea ? Does Apache also segfaults wh...

Problem building php 4.4.6 and apache 1.3.37 on RHEL 4
Folks, Trying to build php 4.4.6 and apache 1.3.37 on RHEL 4. Each of them builds and installs okay, but when we start apache we get: Syntax error on line 238 of /usr/local/etc/httpd/conf/httpd.conf: API module structure `php4_module' in file /usr/local/etc/httpd/libexec/libphp4.so is garbled - perhaps this is not an Apache module DSO? I've checked this out, got some hint that we need to use the apxs that came with RedHat, not the one built in the Apache distribution? RedHat does have an http-devel package which includes apxs but that is for Apache 2.x Last time we did this on RHEL 4 is was Apache 1.3.34 and php 4.4.1 and it went fine, we are using the same procedures. Not sure if some RHEL 4 libraries changed? Has anyone been able to build that combination? Below are some excerpts on what we are using for configure. Thanks! For apache: ../configure --with-layout=Apache --prefix=/usr/local/etc/httpd --enable-suexec .... some deleted... --disable-module=asis --enable-shared=max --enable-rule=SHARED_CORE --enable-module=so For php: CPPFLAGS="-DLINUX=22 -DEAPI" \ ../configure \ --enable-static \ --disable-shared \ --with-config-file-path=/usr/local/etc/httpd/conf \ --with-apxs=/usr/local/etc/httpd/bin/apxs \ .... some deleted. --enable-mbstring=all \ --with-mhash=/export/tools/apache/php/ext/mhash -- John ___________________________________________________________________ John Murtari...

compilation problem in g++ 3.4.3
I was not able to compile the following code on g++ 3.4.3. g++ 3.3.2 happily accepted the code. Can someone help me why this code does not compile in g++ 3.4.3? enum TYPES { A, B }; template <TYPES v> struct Test { static int i; }; int Test<A>::i = 1; int Test<B>::i = 2; int main() {} --lsu ps: [suresh@archer pint]$ g++ -o a a.cpp a.cpp:8: error: too few template-parameter-lists a.cpp:8: error: expected `,' or `;' before '=' token a.cpp:9: error: too few template-parameter-lists a.cpp:9: error: expected `,' or `;' before '=' token ...

Problem with Slave Printer and 4.3.3
I have a dot-matrix printer that is slaved to a PC requesting receipts from our RS/6000 and just recently started having some print problems. It has worked for over 10 years with no problems, other than having to replace worn out printers. The printer is used to print receipts and may not be used for a period of time depending on how busy we are. If the time is less than about 30 minutes the receipts print properly, but after that time the receipt may be corrupted. By corrupted I mean lines missing, lines in the wrong order, etc. I am not sure where to start in looking for the problem...

Sendmail problem in AIX 4.3.3
Hi After upgraded sendmail 8.8 to 8.12.9 it's stopped working. I am using AIX 4.3.3 with latest Fixes. DNS is configured in my box. Please help me. Also want to know is there any way to use sendmail without using nameresolver. Thanks in advance Chiku -- Posted via http://dbforums.com Khee-Seng Yeo <kyeo@nyx.net> wrote in message news:<1058453840.726970@irys.nyx.net>... > Terry Polzin <t_polzin@yahoo.com> wrote: > : subhasbothra <member33505@dbforums.com> wrote in message news:<3120641.1058430831@dbforums.com>... > : > After upgraded sendmail ...

Installation problem - 4.3.0
I've tried installing php 4.3.0 and .4 and keep getting the same problem. When I 'make' the install I end up with an error: /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:22:19: httpd.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:23:25: http_config.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:33:23: http_core.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:34:23: http_main.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:35:27: http_protocol.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:36:26: http_request.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:37:25: http_log.h: No such file or directory /usr/local/src/webserver/php-4.3.0/sapi/apache/php_apache_http.h:38:25: util_script.h: No such file or directory make: *** [sapi/apache/sapi_apache.lo] Error 1 has anyone else experienced this? I don't understand this error and the files are there. my server is an apache 1.3.29 ...

Problem with GCC 3.4.3 and libgcj
Hello, I am working with a host / target machine setup. The cpu arch is the same on both, x86_64 (athlon64), the only real difference is size, ie. my host has a 80GB HD, my targets have 1GB compact flash disks (need this for mechanical vibration reasons). I have CentOS 3.4-x86_64 fully installed on my host, and my target machines have the same OS just with a much smaller package list. I am trying to get GCC 3.4.3 compiled into a relatively small footprint (< 200 Mb), so I can use it on my targets. I only want c, c++ and java installed. I downloaded the gcc-core .tar and ran the...

Is there a g++ 3.4.3 (or better) binary available for AIX 4.3.3 ?
Have tried compiling gcc/g++ 3.4.3 from the UCLA Web site but after resolving several problems got stuck in building libstdc++.a: Assembler: /tmp//ccYxSLZd.s: line 4674: .set operand undefined or forward reference /tmp//ccYxSLZd.s: line 4675: .set operand undefined or forward reference /tmp//ccYxSLZd.s: line 4705: .set operand undefined or forward reference Any suggestions? TIA Jeffrey j3 wrote: > Have tried compiling gcc/g++ 3.4.3 from the UCLA Web site but after > resolving several problems got stuck in building libstdc++.a: > Assembler: > /tmp//ccYxSLZd...

lex problem migrating from AIX 4.3.3 to AIX 5.3 (NCH was 256 is 4096)
I am migrating a large application from AIX 4.3.3 to AIX 5.3 and have hit a problem with lex. In AIX 4.3.3 lex compiles many files sucessfully, but in AIX 5.3 it does not. The problem is that the number of transitions has increased markedly for the same lex source file. this seems to be caused by the "#define NCH 4096" on line 6 of the generated C file. (The value was 256 under AIX 4.3.3.) There is a corresponding increase in generated tables in the C file (with 4096 lines of table data as opposed to 256 previously). If I run AIX 5.3 lex against my lex source file I get the follo...

MIME encoding change in Python 2.4.3 (or 2.4.2? 2.4.1?)
I have an application that processes MIME messages. It reads a message from a file, looks for a text/html and text/plain parts in it, performs some processing on these parts, and outputs the new message. Ever since I recently upgraded my Python to 2.4.3, the output messages started to come out garbled, as a block of junk characters. I traced the problem back to a few lines that were removed from the email package: The new Python no longer encodes the payload when converting the MIME message to a string. Since my program must work on several computers, each having a different version of Pyth...

Re: ixfr (?) problems in 8.3.4 #3
>>>>> ">>" == Someone Somewhere <spam@txrx.org> writes: > Please post your config file. And don't change anything in the > posting. I doubt that you are using the abc.com zone. >> Indeed I'm not using abc.com, but it is a 3 letter .com zone >> we're talking about. Below is the config file from the master, >> with the only change being a regexp to replace the 3 letters of >> the domain name. First of all, please put a proper email address in the To: header. The newsgroup is gatewayed into a mailing list. If you put crap in the headers, people on the list can't reply to you. That's your loss. Secondly, stop this "abc.com" nonsense. There's no need to conceal the real domain name. What are you trying to hide? Why? What benefit do you think this brings? Providing the config files in the way you did was utterly pointless. We're not seeing *exactly* what your name server sees. And for all we know, your efforts to conceal the actual domain names may have caused other inadvertent changes to the files. Someone already asked you to do that. You didn't. So why should anyone bother to try to help you if you won't provide the information that was requested? Finally, if you want to use incremental zone transfer, you should be running BIND9, not BIND8. Come to think of it, everybody using BIND should really be running BIND9...

Web resources about - RISC_OSLib 3 to 4 problem - comp.sys.acorn.programmer

Resources last updated: 3/25/2016 11:41:24 AM