f



BBS Server 0.7 & Novaterm 9.6 BBS Mode

I am trying out Leif's BBS Server 0.7e for the first time today.  For a
quick hardware test, I've got NovaTerm 9.6 running in BBS mode, connected
via null modem to my Win98 box with an Aprotek RS232 UserPort<->Serial
interface.  Prior to trying all of this, I was able to transfer files via
zmodem with Hyperterminal and Novaterm in receive mode.

I'm trying to troubleshoot the following:

1. The BBS *always* thinks someone is connected.  If I "hangup" from the
BBS, the BBS just keeps sending '+++ath' commands to my PC.  The BBS Server
documentation mentioned something about this problem, but I don't understand
it/how to apply the workaround to NovaTerm.

2. The lower and upper case characters are reversed.  What is the proper
config setting to fix this?

3. BBS Server doesn't appear to be able to 'disconnect' from the BBS.  Let's
say I'm at the main menu of the BBS.  If I exit out of CGTerm 1.5, the BBS
just sits there at the main menu.

I have perused the BBS Server online docs, but the troubleshoot guide
section has not helped.

So, is it a BBS Server config issue, a Novaterm BBS mode config issue,
and/or a Novaterm BBS limitation?

Thanks
Jeff



0
microman (10)
12/28/2003 12:55:41 AM
comp.sys.cbm 14331 articles. 0 followers. dunric (341) is leader. Post Follow

9 Replies
770 Views

Similar Articles

[PageSpeed] 14

Some updated observations:

1. I observe the same behavior with a VIC-1011A interface as I did with the
Aprotek interface (so now I know it is not an interface problem).  When the
Novaterm BBS mode starts, a 2400 baud detection is immediately recognized,
even though I have not even started HyperTerminal.  In fact, if I boot
Novaterm BBS before I boot my Win box, a 2400 baud connection is detected
during the Win98 boot sequence.  It's as if Win98 is raising the relevant
RS232 signals to make a connection.

2.  I also noticed that the version of BBS Server I got from Leif's site is
not the same as what he actually runs for his BBS.  I'm not prompted to
select between ANSI or Commodore C/G.

My next test will be to connect with Centipede 128 rather than Novaterm BBS.


0
microman
12/28/2003 8:06:51 PM
Hi Jeff,

You could have emailed me directly!  :-)  Use  bbs<at>leifbloomquist<dot>net

Anyway, I'm still 'testing' version 0.8 on my system - seems pretty stable, have
been running it at least month.  I'll post the new version and the source
sometime this week.

Note that my software doesn't do any Hayes modem emulation.

It "calls" the BBS by setting the RTS line high, and that's all.   (This goes to
the Ring Indicator line on the C64).

It knows that the BBS has hung up when Carrier Detect goes low.

If you send me a .d64 of Novaterm, I can try to reproduce the problem and find a
fix.  I don't have a 128 so I won't be able to do any tests with Centipede
itself, but maybe something will be learned with Novaterm.

Regards
Leif

PS got your feedback note on the BBS as well.  Sorry for the delay, was on
holiday (far from any computers) over Christmas.


--
Call Negative Format BBS - Hosted on a real C64!
Telnet to  c64bbs.no-ip.com  or 209.151.141.59   Port 23
http://home.ica.net/~leifb/bbs/




microman wrote:

> Some updated observations:
>
> 1. I observe the same behavior with a VIC-1011A interface as I did with the
> Aprotek interface (so now I know it is not an interface problem).  When the
> Novaterm BBS mode starts, a 2400 baud detection is immediately recognized,
> even though I have not even started HyperTerminal.  In fact, if I boot
> Novaterm BBS before I boot my Win box, a 2400 baud connection is detected
> during the Win98 boot sequence.  It's as if Win98 is raising the relevant
> RS232 signals to make a connection.
>
> 2.  I also noticed that the version of BBS Server I got from Leif's site is
> not the same as what he actually runs for his BBS.  I'm not prompted to
> select between ANSI or Commodore C/G.
>
> My next test will be to connect with Centipede 128 rather than Novaterm BBS.

0
Leif
1/3/2004 7:46:42 PM
Leif Bloomquist wrote ...

>Hi Jeff,
>
>You could have emailed me directly!  :-)  Use
>bbs<at>leifbloomquist<dot>net

Heh, I tried to answer his post but my news server refused the post.  Then I
tried to email a reply but my email server refused that message.  Very
strange...

Best regards,

Sam Gillett aka Mars Probe @ Starship Intrepid 1-972-221-4088
    From todays headlines:
Mars Probe Landing Today



0
Sam
1/3/2004 8:54:42 PM
Sam Gillett wrote:

> Heh, I tried to answer his post but my news server refused the post.  Then I
> tried to email a reply but my email server refused that message.  Very
> strange...

Did you change my reply address?   xxxx@127.0.0.1 is the special loopback IP
address, which, in theory, sends emails back to the ISP's email server.   Used
to confound spammers.   :-)

ttyl
Leif


--
Call Negative Format BBS - Hosted on a real C64!
Telnet to  c64bbs.no-ip.com  or 209.151.141.59   Port 23
http://home.ica.net/~leifb/bbs/





0
Leif
1/3/2004 9:17:07 PM
Sam Gillett wrote:

> Heh, I tried to answer his post but my news server refused the post.  Then I
> tried to email a reply but my email server refused that message.  Very
> strange...

Did you change my reply address?   xxxx@127.0.0.1 is the special loopback IP
address, which, in theory, sends emails back to the ISP's email server.   Used
to confound spammers.   :-)

ttyl
Leif


--
Call Negative Format BBS - Hosted on a real C64!
Telnet to  c64bbs.no-ip.com  or 209.151.141.59   Port 23
http://home.ica.net/~leifb/bbs/





0
Leif
1/3/2004 9:17:34 PM
Leif Bloomquist wrote ...

>Sam Gillett wrote:
>
>> Heh, I tried to answer his post but my news server refused the post.
>> Then I tried to email a reply but my email server refused that message.
>> Very strange...
>
>Did you change my reply address?   xxxx@127.0.0.1 is the special loopback
>IP address, which, in theory, sends emails back to the ISP's email server.
>Used to confound spammers.   :-)

No, it was Microman's post I tried to reply to.  Had a couple of ideas about
Novaterm configuration that could have caused some of his problems.
Hopefully he will get all his problems ironed out and get his BBS on Telnet.

Best regards,

Sam Gillett aka Mars Probe @ Starship Intrepid 1-972-221-4088
    From todays headlines:
Mars Probe Landing Today



0
Sam
1/4/2004 3:52:07 AM
"Leif Bloomquist" <abuse@127.0.0.1> wrote in message
news:3FF71C21.395C977B@127.0.0.1...
>
> It "calls" the BBS by setting the RTS line high, and that's all.   (This
goes to
> the Ring Indicator line on the C64).

Ok, I hope this will work with Centipede.  Centipede has an option to
monitor the DTR line to detect a disconnect (the documentation specifically
states that this was added to the BBS to work with as many modems as
possible.)  I can't recall how null cables are wired up, hopefully the RTS
line is wired to the DTR pin on the BBS end.

I'll be trying this out either tomorrow or Monday.

-Jeff


0
microman
1/4/2004 7:26:32 AM
microman wrote:

> Ok, I hope this will work with Centipede.  Centipede has an option to
> monitor the DTR line to detect a disconnect (the documentation specifically
> states that this was added to the BBS to work with as many modems as
> possible.)  I can't recall how null cables are wired up, hopefully the RTS
> line is wired to the DTR pin on the BBS end.

Make sure your null modem cable actually passes all the signals through.  Some
just send TX, RX, and carrier/ground.

Also, EBBS had an "RS-232 modem" option, and in that mode it doesn't use any
init strings etc.   Centipede may have a similar option.  If not, that gives me
incentive to actually add some Hayes functionality to my program :-)

Regards
Leif




0
Leif
1/4/2004 8:56:17 PM
Just to let everyone know, Leif got NovaTerm working with BBS Server @ 2400
BPS last night, here's his layout that he sent me, I will test with
Centipede tomorrow evening.

(from Leif)
>I built a cable, with just these 4 wires:

>PC-64 (VIC-1011A)
>2-2  rx/tx
>3-3  tx/rx
>5-7  gnd
>7-8  rts/dcd
>
>Also had to switch Novaterm to "Normal" Carrier Detect, as mentioned
>before.  And now...it works!  This is the first time I've run my server
>program at 2400 baud, very cool :)  I'll leave it up for a day or so,
>and it should be OK unless the cats eat the cable.


0
microman
1/13/2004 5:47:29 PM
Reply:

Similar Artilces:

Operational Notification -- Segmentation Fault in resolver.c Affects BIND 9.6-ESV-R6, 9.7.5, 9.8.2, & 9.9.0
Operational Notification -- Segmentation Fault in resolver.c Affects BIND 9.6-ESV-R6, 9.7.5, 9.8.2, & 9.9.0 Summary: ISC has discovered a race condition in the resolver code that can cause a recursive nameserver running BIND 9.6-ESV-R6, 9.7.5, 9.8.2, or 9.9.0 to crash with a segmentation fault. Authoritative-only servers are not affected, but recursive-only or recursive-authoritative hybrid servers are at risk of crashing because of this bug. Posting date: 30 April 2012 Program Impacted: BIND Versions affected: 9.6-ESV-R6, 9.7.5, 9.8.2, 9.9.0. Descript...

7.0.1.0 to 7.1.0.9 in Paid Mode
I have been using v7.0.1.0 in Paid Mode. Can I upgrade to v7.1.0.9 in Paid Mode? How? Many thanks. On Thu, 14 Jun 2007 17:45:24 -0500, Shel wrote: > I have been using v7.0.1.0 in Paid Mode. > > Can I upgrade to v7.1.0.9 in Paid Mode? How? Click: Help > Payment & Registration > "Find the latest versions" This will send an anonymous bit of info to the Eudora web site, which will then display your status, as to whether 7.1.0.9 will consider you as "Paid" using your existing registration. Final Eudora version 7.1.0.9 (and manuals) c...

[ANN] Rails 0.6.0, Active Record 0.9.3, Action Pack 0.7.9
I gather that most people are now familar with the RoR suite, so I'm skipping the formal introductions and will just bring you the meat. Get it all from http://www.rubyonrails.org, talk it up on #rubyonrails (FreeNet). Rails 0.6.0: AAC, Environments, Easier starts ============================================= This is a major upgrade to the Rails infrastructure. There's a new AbstractApplicationController that can hold filters and methods available to all controllers. There's a new concept of [[Environments]] that should make it much easier to write maintenance scripts and ...

PrintMaster 7.0 Classic broken in wine-0.9.34 & 0.9.35
Sad to say, PrintMaster 7.0 (Classic) is broken as of Wine 0.9.34. before that it was 99% functional (problems with card fonts being rendered in printout prevented full use) I have used this program under Win98 and it is fine, but under XP it won't print at all. Up to (I think) Wine 0.9.33 there was more or less steady improvement. To be clear - the present problem is preventing the app from running at all, i.e., totally broken. I remember there were always installation quirks, but now it may be broken in the installer and not able to run because of that. If you want me t...

Telnet BBS Server 0.7 Available
Hi all, I have made my BBS Server version 0.7 available for download. The new features in this version are: 1. A short *manual* has been written! http://home.ica.net/~leifb/bbs/docs/ 2. Customizable "Away Message" for when the BBS is down. 3. When people call while the BBS is busy, they will receive a message stating how long the current user has been online for, and how long the user has been idle. 4. Automatically disconnects users after 3 hours online or 15 minutes Idle (or Sysop-defined times). 5. Fully customizable realtime character translation (ie, ASCII <-> PET...

restoring 9.2.0.6 datafiles with 9.2.0.7 Oracle
Hello Is there potential problem ? we want to use old datafiles in 9.2.0.6 with a patched oracle in 9.2.0.7... Thank you nonor wrote: > Hello > > Is there potential problem ? we want to use old datafiles in 9.2.0.6 > with a patched oracle in 9.2.0.7... > > Thank you No, you don't want to do that. You want to solve some problem, for which you believe that to be the solution. What is the problem you are trying to solve? In answer to your question -- yes, I'd think there would be disasterous problems. So, again -- what is the problem you are trying to solve? ...

How can I convert a vi of 7.0 to 6.0/6.02 without using LabVIEW 7.0?
I have to work with some vi of LabVIEW 7.0, however i only got LabVIEW 6.02. How can I convert those vi files to 6.02? You not only would need 7.0, but you would also need 6.1 as well. Version 7 can only save to 6.1 and version 6.1 can only save to 6.0. Even if you downloaded the 7.0 evaluation copy, I don't know if the 6.1 evaluation is still available for download. Your best chance is to post the VIs and hope that someone with both versions can do the conversion for you. You should also be aware that there are numerous differences between 7.0 and 6.0 and that a conversion might not even...

Moving a single instance 9.2.0.7 database to a clustered 9.2.0.6 database environment
HI, I have the following situation: We have Veritas cluster setup , and there are 2 solaris servers on which VCS is set up. On this set up we have about 8 databases all of which are 9.2.0.6 version. Now we have one stand alone solaris server, and it has a 9.2.0.7 database. This database is for a third party application -Clear Case & Clear Quest. Now it is required to move the single instance database to clustered environment. Since in the clustered environment we have 9.2.0.6 version, is it AT ALL POSSIBLE to move this database, which is 9.2.0.7 to that enviroment? I guess not, and i...

RENEW 0.8.6.1.7.9.4.3.0.3.9.4.e164.arpa.
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 ProvID: DENIC-24 Enum-Domain: 0.8.6.1.7.9.4.3.0.3.9.4.e164.arpa. Action: RENEW Enum-Holder: DENIC-24-KF108 Admin-C: DENIC-24-KF108 Tech-C: DENIC-24-TSB4 Zone-C: DENIC-24-TSB4 Nserver: ns.dnsnglab.ipv6.berkom.de. Nserver: ns2.dnsnglab.ipv6.berkom.de. Remarks: TSI ENUM-Trial Teilnehmer -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.1 (GNU/Linux) iD8DBQFBRXqOS9pACF8jgjwRArEvAJ4jBAdqTC8AKL+c0LL4RgXZ7J1f5gCgwXVo FgJZgHLnEk64xIRCM+S5XuI= =dC1s -----END PGP SIGNATURE----- ...

Oracle server 9.2.0.1.0, Client 9.2.0.4.0, Red Hat Linux enterprise advanced server 2.1
Hi Everybody, My Database server is running on Red Hat Linux enterprise advanced server 2.1, And my Oracle version is 9.2.0.1.0. My Client mechine also Red Hat Linux enterprise advanced server 2.1 , Oracle client version is 9.2.0.4.0. I am running a web application. Our application is in Magic edeveloper. I connect to Oracle using oracle gateway to my application. My Problem is my application is is becoming slow. I am not able to trace where the problem is. Before our application was running fine. recently i upgraded Oracle client version to 9.2.0.4.0. My Oracle client & server versi...

Moving a single instance 9.2.0.7 database to a clustered 9.2.0.6 database environment #2
HI, I have the following situation: We have Veritas cluster setup , and there are 2 solaris servers on which VCS is set up. On this set up we have about 8 databases all of which are 9.2.0.6 version. Now we have one stand alone solaris server, and it has a 9.2.0.7 database. This database is for a third party application -Clear Case & Clear Quest. Now it is required to move the single instance database to clustered environment. Since in the clustered environment we have 9.2.0.6 version, is it AT ALL POSSIBLE to move this database, which is 9.2.0.7 to that enviroment? I guess not, and i...

voodoo spell VASHIKARAN specialist aghori baba 0/9/6/3/6/4/2/2/7/0/2
love vashikaran specialist aghori baba ji 09636422702 vashikaran mantra vashikaran specialist lost love back by vashikaran get your love vashikaran vazifa specialist +919636422702 the great vashikaran powered by vashikaran vazifa jadu tona black magic voodoo spell dispuat husband wife reletons vashikaranspecialistcall.com 09636422702 vashikaran specialist aghori baba 09636422702 love vashikaran specialist marriage problams get your love vashikaran vazifa specialist http://vashikaranspecialistcall.com lost love vashikaran mantra vashikaran mantra specialist aghori baba ji 9636422...

upgrate from 9.2.0.1.0 to 9.2.0.7.0
how to upgrade.... storm pixie wrote: > how to upgrade.... You grab the upgrade download and install it. Or you re-install from a complete base version. No rocket science, just follow the instructions. On 17 May 2006 17:55:59 -0700, "storm pixie" <amit.dba@gmail.com> wrote: >how to upgrade.... go to metalink download patch. find readme.html in the patch dowloaded follow test on non-production system first when it doubt, re-read the readme. ........ We run Oracle 9iR2,10gR1/2 on RH4/RH3 remove NSPAM to email Download patch or request a cd from oracle supp check the ...

Eudora 6.2.1.2 sponsored mode & PGP Desktop 9.0
It seems that Eurora is not working properly with the PGP Desktop. Can anyone help me how to sign a message? Thanks! On Sun, 5 Jun 2005 16:15:23 +0200, "Florian Burg" <f.burg@gmx.de> wrote: >It seems that Eurora is not working properly with the PGP Desktop. Can >anyone help me how to sign a message? >Thanks! My solution has been to go back to 6.0.1.1. Eudora 6.0.11 has no problem with PGP. The Eudora people continue to ignore its users' pleas to fix the relationship between a current Eudoras and PGP. Perhaps they have more important issu...

Web resources about - BBS Server 0.7 & Novaterm 9.6 BBS Mode - comp.sys.cbm

Strobe's c64 Stuff
Novaterm 10 My improved version of Novaterm 10, the 64/128 terminal program by Nick Rossi Unzip64v2 & Unzip128v2 Extracts pkzip2.xx / Infozip2.xx ...

Two retro successes with a Commodore 64
... order of business was getting the C64 talking to a PC with the help of a MAX232 serial IC and loading up 64HDD to transfer a copy of Novaterm. ...

Hack a day
These brave souls have proven their worth by getting a really, really old computer on the internet: How about some PowerPC action? [rusbus] ...

Internet surfing with c64 - Commodore 64 (C64) Forum
Actually, as time goes on that question gets _very_ detailed and complicated, so... I guess this calls for me to post my famous internet FAQ! ...

[ROM GUIDE] How to install Android on the HP TouchPad "The Easy Way" - Page 84 - HP Touchpad - RootzWiki ...
Page 84 of 363 - [ROM GUIDE] How to install Android on the HP TouchPad "The Easy Way" - posted in HP Touchpad: zip files in what folder are more ...

webOS Nation Forums - Search webOS Nation Forums
The #1 community for webOS, including the Touchpad, Pre, Pixi, Veer and more!

Testing WebOS, PhoneGap and Services - The WaterHobo
I wrote earlier about creating a WebOS app that called a node.js service that also was written with PhoneGap. However I did not go into how to ...

webOS Nation Forums - Search webOS Nation Forums
The #1 community for webOS, including the Touchpad, Pre, Pixi, Veer and more!

webOS Nation Forums - Search webOS Nation Forums
The #1 community for webOS, including the Touchpad, Pre, Pixi, Veer and more!

Portal:Accessing Linux - WebOS Internals
... is a Linux based device. Palm provides a simple method to access Linux running on the Pre or the Pre Emulator. A terminal program called novaterm ...

Resources last updated: 2/12/2016 10:18:24 PM