f



GCC 4.0.1 on Mac OS X 10.3.9 (PPC)

Hi,

I'll ask here if it is anyhow possible to get a more actual GCC
compiler than the Nov'04 update Release on ADC ?
( gcc-3.3 (GCC) 3.3 20030304 (Apple Computer, Inc. build 1671) )

I have trouble with a library that generates missing vtable entries,
known to work with GCC 4.0.1 (build 5247) on a MacBook Pro.
The code also works on a Windows Box.

Could I propably get it from CVS on ADC and build it ?

Thanks, Lothar

0
Lothar
10/27/2007 9:32:28 AM
comp.sys.mac.programmer.tools 504 articles. 0 followers. Post Follow

5 Replies
830 Views

Similar Articles

[PageSpeed] 8

"Lothar Behrens" <lothar.behrens@lollisoft.de> a �crit dans le message de 
news: 1193477548.089307.28220@v3g2000hsg.googlegroups.com...
> Hi,
>
> I'll ask here if it is anyhow possible to get a more actual GCC
> compiler than the Nov'04 update Release on ADC ?
> ( gcc-3.3 (GCC) 3.3 20030304 (Apple Computer, Inc. build 1671) )
>
> I have trouble with a library that generates missing vtable entries,
> known to work with GCC 4.0.1 (build 5247) on a MacBook Pro.
> The code also works on a Windows Box.
>
> Could I propably get it from CVS on ADC and build it ?
strange, I have the GCC 4 with ADC directly...

Armel


0
Armel
10/27/2007 10:54:41 AM
On 27 Okt., 12:54, "Armel Asselin" <armelasse...@hotmail.com> wrote:
>
> > Could I propably get it from CVS on ADC and build it ?
>
> strange, I have the GCC 4 with ADC directly...
>

Really on a Mac OS X 10.3.9 (PPC) ?

I tried getting XCode 2.4.1 and the GCC 4.0.1 package inside it wasn't
installable due to
something missing. It was yust a try if the compiler is installable at
least.

Where did you got your version and how installed ?

Thanks, Lothar

> Armel


0
Lothar
10/27/2007 12:54:31 PM
"Lothar Behrens" <lothar.behrens@lollisoft.de> a �crit dans le message de 
news: 1193489671.926176.277440@o80g2000hse.googlegroups.com...
> On 27 Okt., 12:54, "Armel Asselin" <armelasse...@hotmail.com> wrote:
>>
>> > Could I propably get it from CVS on ADC and build it ?
>>
>> strange, I have the GCC 4 with ADC directly...
>>
>
> Really on a Mac OS X 10.3.9 (PPC) ?
oops oops... on x86... sorry

> I tried getting XCode 2.4.1 and the GCC 4.0.1 package inside it wasn't
> installable due to
> something missing. It was yust a try if the compiler is installable at
> least.
compiling gcc 4 is rather easy, but i do not know how to install it on Mac 
OS X :-(
it is rather probable that a simple build will do everything you want.

Armel


0
Armel
10/27/2007 3:58:07 PM
Lothar Behrens <lothar.behrens@lollisoft.de> writes:

> Hi,
> 
> I'll ask here if it is anyhow possible to get a more actual GCC
> compiler than the Nov'04 update Release on ADC ?
> ( gcc-3.3 (GCC) 3.3 20030304 (Apple Computer, Inc. build 1671) )

Well, one way would be to upgrade to OS 10.4 (or even 10.5, now).


-- 
Thomas A. Russ,  USC/Information Sciences Institute
0
tar
10/30/2007 12:57:56 AM
On Oct 27, 4:32 am, Lothar Behrens <lothar.behr...@lollisoft.de>
wrote:
> Hi,
>
> I'll ask here if it is anyhow possible to get a more actual GCC
> compiler than the Nov'04 update Release on ADC ?
> ( gcc-3.3 (GCC) 3.3 20030304 (Apple Computer, Inc. build 1671) )
>
> I have trouble with a library that generates missing vtable entries,
> known to work with GCC 4.0.1 (build 5247) on a MacBook Pro.
> The code also works on a Windows Box.
>
> Could I propably get it from CVS on ADC and build it ?

Xcode 2.x and higher already use gcc 4.0.1 by default.  Are you using
an older version of Xcode than that?  Xcode 1.5 (which runs on the old
Panther OS and will not run on Tiger or Leopard) uses gcc 3.3 by
default, but I thought there was a way to switch it to gcc 4.0 even
back then.  In any case, you shouldn't be using Xcode 1.5 anymore,
since you need 2.2 or higher to generate universal binaries.

You need to upgrade to Mac OS X 10.4 Tiger or higher to run Xcode 2.x
and Mac OS X 10.5 Leopard to run Xcode 3.0, each of which uses gcc
4.0.1.  The latest version of Xcode 2 is 2.5 which runs on either.

Regards,

Jonathan Hoyle
http://www.jonhoyle.com

0
Jonathan
11/1/2007 8:32:45 PM
Reply:

Similar Artilces:

wxWidgets 2.6.3 on Intel Mac with OS X 10.0.4 (Tiger), gcc 4.0.1
Hello, I have recently started porting our application to Mac OS X. Application was developed for Microsoft Windows using wxWidgets. I have installed wxWidgets 2.6.3 on my Mac using darwinports system. Compilation completed successfully and without any warnings/errors. I am able to compile same programs included in library archive, but started application does not receive ANY user input - I am even unable to move application window. Program is stripped to bare bones: #include "wx/wx.h" #include <iostream> class MyApp : public wxApp { public: virtual boo...

Mac OS X 1.0 x86 and Mac OS X 10.4 x86
I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or earlier x86 versions of NEXTSTEP... There should be some interesting error messages to find. I'll try it out with OmniWeb 3 one day... -- Andrew J. Brehm Marx Brothers Fan PowerPC/Macintosh User Supporter of Chicken Sandwiches In article <1gxrpng.qcld42zk38uoN%ajbrehm@gmail.com>, ajbrehm@gmail.com (Andrew J. Brehm) wrote: > I wonder of OS X on Intel runs binaries made for Mac OS X Server 1.0 or > earlier x86 versions of NEXTSTEP... > > There should be some interesting error messages to find. &...

[wx 2.6.3, Mac OS X 10.4.8, gcc 4.0.1] extremely slow wxStyledTextCtrl::Colourise()
Hello, I'm developing a multi-platform source code editor with syntax-highlighting based on wxWidgets. I have a problem with the wxStyledTextCtrl::Colourise() function on the Mac platform. This function is extremely slow on Mac, e.g. it takes about 40 seconds to do the lexing of a file of 500 lines of c++ code, while the same function returns within 1 second on the Windows and Linux platforms using the same version of wxWidgets. (I'm using the wxSTC_LEX_CPP lexer). The problem appears when the user wants to scroll down the wxStyledTextCtrl : the slider blocks and th...

Your Mac won't start up in Mac OS X (Mac OS X 10.3.9 or earlier)
Your Mac won't start up in Mac OS X (Mac OS X 10.3.9 or earlier) Nothing can be more frustrating than turning on your Mac only to find that it won't start up. Instead of seeing the Finder, you see a blue or gray screen, an icon of a broken folder, a kernel panic, a flashing question mark, or a computer that just sits there. What can you do? Don't worry. It could be a simple issue that you can fix yourself. Note: This article applies to Mac OS X 10.3.9 or earlier. Tip: If your computer won't start at all, skip to "You see a blank, gray screen" below. The first step ...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4
Hi Jason, Thanks for using the PRF. >> ACE VERSION: 5.3.1 This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 beta should work "out of the box" for Mac OS X Tiger. If you want a preview, please download the version in our CVS repo at http://cvs.doc.wustl.edu/ take care, Doug >> HOST MACHINE and OPERATING SYSTEM: Mac OS X 10.4.2 >> COMPILER NAME AND VERSION (AND PATCHLEVEL): >> powerpc-apple-darwin8-gcc-4.0.1 >> >> CONTENTS OF $ACE_ROOT/ace/config.h: >> >> /* -*- C++ ...

Re: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, >> I know it isn't the most recent version available, but this version >> is used extensively across the corporation. Changing the version of >> ACE all these products used will cause the architect's heads to >> explode ;) >> >> Is it your opinion that 5.3.1 is hopeless cause on Tiger? It'll take some work, but companies like Riverace, Remedy, and OCI can help out with this stuff if staying with 5.3.1 is essential. Please see http://www.cs.wustl.edu/~schmidt/commercial-support.html for help with this stuff. >>...

RE: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Jason, > > >> ACE VERSION: 5.3.1 > > > > This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 > beta should > > work "out of the box" for Mac OS X Tiger. If you want a preview, > > please download the version in our CVS repo at > > I know it isn't the most recent version available, but this > version is used > extensively across the corporation. Changing the version of > ACE all these > products used will cause the architect's heads to explode ;) ;-) Right - this is where the value...

RE: Subject: Building ACE 5.3.1 on Mac OS X (Tiger) 10.4.2 was [ace-users] Building ACE on Mac OSX 10.4 #2
Hi Doug, > > Thanks for using the PRF. > > >> ACE VERSION: 5.3.1 > > This version of ACE is ANCIENT. The forthcoming ACE 5.4.8 beta should > work "out of the box" for Mac OS X Tiger. If you want a preview, > please download the version in our CVS repo at I know it isn't the most recent version available, but this version is used extensively across the corporation. Changing the version of ACE all these products used will cause the architect's heads to explode ;) Is it your opinion that 5.3.1 is hopeless cause on ...

Compiling 8.13.4 with GCC 3.3--error, stdarg.h v. varargs.h on Mac OS X 10.4.1?
I'm trying to compile Sendmail 8.13.4 on Mac OS X 10.4.1, using GCC 3.3. I'm getting the message that GCC no longer supports varargs.h and code should be updated to use stdarg.h. I know this is a long-standing problem, and I used to be able to solve it (with Sendmail 8.12.x on Mac OS X 10.2.x and 10.3.x) by reverting to GCC 3.1. Unfortunately, GCC 3.1 is not installed on Mac OS X 10.4. The weird thing is that the last machine I build this way was Sendmail 8.13.3 on Mac OS X 10.3.7 and it compiled just fine with GCC 3.3. Possibly this had something to do with the fact that GCC 3...

Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio Popcorn
Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio Popcorn 3 for Mac, MapleSoft Maple 11.01.303882 Pro for Mac, other Mac Stuff CDs, A to Z, updated 2007/10/15, and Win & Mac programs, 'WinMac', 'PC/ MaC', 'Win-Mac', 'Multi', 'Multi-Platform', 'MultiFormat', 'MULTIOS', 'HYBRID' please send e-mail to : ola 'AT' mail 'DOT' gr , ola3 'AT' mailbox 'DOT...

Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio Popcorn
Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio Popcorn 3 for Mac, MapleSoft Maple 11.01.303882 Pro for Mac, other Mac Stuff CDs, A to Z, updated 2007/10/15, and Win & Mac programs, 'WinMac', 'PC/ MaC', 'Win-Mac', 'Multi', 'Multi-Platform', 'MultiFormat', 'MULTIOS', 'HYBRID' please send e-mail to : ola 'AT' mail 'DOT' gr , ola3 'AT' mailbox 'DOT' gr ...

Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio P
Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio Popcorn 3 for Mac, MapleSoft Maple 11.01.303882 Pro for Mac, other Mac Stuff CDs, A to Z, updated 2007/10/15, and Win & Mac programs, 'WinMac', 'PC/ MaC', 'Win-Mac', 'Multi', 'Multi-Platform', 'MultiFormat', 'MULTIOS', 'HYBRID' please send e-mail to : ola 'AT' mail 'DOT' gr , ola3 'AT' mailbox 'DOT' gr ...

Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio P #2
Microsoft Office 2008 for Mac, MacDrive 7.0.10, Apple Mac OSX Tiger 10.4.10 for Mac Intel, Propellerheads.Reason.v4.0.HYBRID, Maya Unlimited 2008 for Mac, FXpansion GURU 1.1.280 for Mac, Roxio Popcorn 3 for Mac, MapleSoft Maple 11.01.303882 Pro for Mac, other Mac Stuff CDs, A to Z, updated 2007/10/15, and Win & Mac programs, 'WinMac', 'PC/ MaC', 'Win-Mac', 'Multi', 'Multi-Platform', 'MultiFormat', 'MULTIOS', 'HYBRID' please send e-mail to : ola 'AT' mail 'DOT' gr , ola3 'AT' mailbox 'DOT' gr ...

Mac os X 10.3.9 G4 USB 1.1 firmware upgrade --> USB 2.0
Hi i have a imac G4 and i was wondering if there is a firmware upgrade or something for USB 1.1 ports to be put so they can be USB 2.0? Would i be able to buy a firewire to USB 2.0 converter? if so where, i live in New Zealand, Hastings. and can i upgrade my GeForce4 MX graphics card VRAM up from 32MB? And last of all how much would it cost ruffly to buy a 512 SDRAM for my mac, (would i be able to put DDR ram in?) Heres my iMacs specs: Hardware: Hardware Overview: Machine Model: iMac CPU Type: PowerPC G4 (2.1) Number Of CPUs: 1 CPU Speed: 800 MHz L2 Cache (per CPU): 256 KB ...

Web resources about - GCC 4.0.1 on Mac OS X 10.3.9 (PPC) - comp.sys.mac.programmer.tools

GCC IP
Welcome to the GCC-IP Website. Click this logo any time you want to return to the home page

GCC, the GNU Compiler Collection - GNU Project - Free Software Foundation (FSF)
... front ends for C , C++ ,Objective-C, Fortran , Java , Ada, and Go, as well as libraries for theselanguages ( libstdc++ , libgcj,...).GCC was ...

Breaking News, UAE, GCC, Middle East, World News and Headlines - Emirates 24/7
... news, business, entertainment, lifestyle, sports, weather, real estate and more. Emirates247.com provides real time reports on UAE, GCC, Middle ...

IT JOBS Middle East GCC Gulf UAE Dubai Qatar Saudi Arabia Bahrain Kuwait Oman
Information Technology IT Developer DBA PMP IBM Storage ERP SAP .NET PMP Microsoft Java PL/SQL C# ASP PHP HTML WEB Linux CRM Consultant Contractor ...

How It All Ends: Mechanics of GCC (pt 1 of 3) - YouTube
Part of the "Expansion Pack" of videos accompanying the video "How It All Ends." See "How It All Ends: Index" for a roadmap to guide you through ...

GCC ministers condemen ISIL - The National
Concerns over ISIL appear to be bringing Gulf states closer together, writes Taimur Khan. GCC ministers condemned ISIL extremists at a summit ...

GCC seek UN arms embargo on Yemen rebels
The Gulf Co-ordination Council member states want a UN Security Council arms embargo imposed against the Houthi rebels in Yemen.

Chinese President meets GCC delegation
People's Daily Online Chinese President meets GCC delegation People's Daily Online Xi described China and the GCC as good brothers, friends ...

Good call: UAE calls for greater GCC economic integration - Al Bawaba
Good call: UAE calls for greater GCC economic integration

US to GCC: We still have your back
As the Iran nuke deal rattles Arab leaders, Washington sees value in cheerleading Riyadh's efforts in Yemen.

Resources last updated: 2/12/2016 10:29:57 PM