f



"Couldn't find header file arial.ttf", how to solve this problem?

I am writing my thesis with Latex.

The files compile smoothly in the step

latex thesis

however, in the following step

dvipdf thesis

It does not work and reports an error as follows:

"Couldn't find header file arial.ttf"

How to solve this problem?

Thanks a lot!
0
zhang.xi.cn (102)
5/28/2008 2:47:23 PM
comp.text.tex 39029 articles. 3 followers. Post Follow

6 Replies
1024 Views

Similar Articles

[PageSpeed] 52

I guess this is because that arial.ttf has not been installed in my
system.

Then I searched synaptic and found this package: "Installer for
Microsoft TrueType core fonts"

I installed and now I have an arial.ttf in computer, located in:

/usr/share/fonts/truetype/msttcorefonts/arial.ttf

But I don't know how to add this path to the searching path of dvipdf.
Still, dvipdf cannot find this file and report the same error.
0
zhang.xi.cn (102)
5/28/2008 2:53:30 PM
Am Wed, 28 May 2008 07:47:23 -0700 (PDT) schrieb xz:

> I am writing my thesis with Latex.
> 
> The files compile smoothly in the step
> 
> latex thesis
> 
> however, in the following step
> 
> dvipdf thesis
> 
> It does not work and reports an error as follows:
> 
> "Couldn't find header file arial.ttf"
> 
> How to solve this problem?

Last time I have seen such a message a map entry meant for pdftex only
had crept in the map files for dvips. 

Search the psfonts.map of dvips, remove all lines with arial.ttf and try
if the error disappear. If yes you should find the entries in the
updmap.cfg which are reponsible and remove them. 

-- 
Ulrike Fischer 
0
news21630 (1434)
5/28/2008 2:57:49 PM
On May 28, 9:57=A0am, Ulrike Fischer <ne...@nililand.de> wrote:
> Am Wed, 28 May 2008 07:47:23 -0700 (PDT) schrieb xz:
>
> > I am writing my thesis with Latex.
>
> > The files compile smoothly in the step
>
> > latex thesis
>
> > however, in the following step
>
> > dvipdf thesis
>
> > It does not work and reports an error as follows:
>
> > "Couldn't find header file arial.ttf"
>
> > How to solve this problem?
>
> Last time I have seen such a message a map entry meant for pdftex only
> had crept in the map files for dvips.
>
> Search the psfonts.map of dvips, remove all lines with arial.ttf and try
> if the error disappear. If yes you should find the entries in the
> updmap.cfg which are reponsible and remove them.
>
> --
> Ulrike Fischer

Thank you for your reply.

But since now I already installed the arial.ttf, do I really need to
do what you said?

I guess there may be a way that I can add the path of the arial.ttf
that I just installed into the searching path of dvipdf?
0
zhang.xi.cn (102)
5/28/2008 4:00:32 PM
Am Wed, 28 May 2008 09:00:32 -0700 (PDT) schrieb xz:


>>> dvipdf thesis
>>
>>> It does not work and reports an error as follows:
>>
>>> "Couldn't find header file arial.ttf"

>> Last time I have seen such a message a map entry meant for pdftex only
>> had crept in the map files for dvips.
>>
>> Search the psfonts.map of dvips, remove all lines with arial.ttf and try
>> if the error disappear. If yes you should find the entries in the
>> updmap.cfg which are reponsible and remove them.

 
> But since now I already installed the arial.ttf, do I really need to
> do what you said?

Yes.

 
> I guess there may be a way that I can add the path of the arial.ttf
> that I just installed into the searching path of dvipdf?

As far as I know dvipdf use dvips. dvips can't handle ttf and it don't
like entries in the map file that tries to include ttf. You will have to
correct the map. 


-- 
Ulrike Fischer 
0
news21630 (1434)
5/28/2008 4:17:00 PM
Thank you for the explanation and suggestions.

However, I prefer not to touch original configuration files given that
I am a newbie.

I figured out that the problem was due to several eps files generated
by ChemDraw that used Arial font.

Then I adopted some stupid dummy's method to solve this.

I generated the files in png format so that the letters in the figure
were purely shapes in the figure, not letters+fonts.
0
zhang.xi.cn (102)
5/28/2008 9:31:18 PM
Am Wed, 28 May 2008 14:31:18 -0700 (PDT) schrieb xz:

> Thank you for the explanation and suggestions.
> 
> However, I prefer not to touch original configuration files given that
> I am a newbie.

the psfonts.map are recreated each time you call updmap (or updmap-sys
depending of your tex system). If you install new fonts you will have to
change them (and to change the local configuration files for updmap). So
you should learn how to do it. If you fear to get into troubles: Make
somewhere a copy as backup, change the file and if somethings break move
the copy back. 



> 
> I figured out that the problem was due to several eps files generated
> by ChemDraw that used Arial font.
> 
> Then I adopted some stupid dummy's method to solve this.
> 
> I generated the files in png format so that the letters in the figure
> were purely shapes in the figure, not letters+fonts.

It is not a good idea to convert a vector graphic in a bitmap graphic. 


-- 
Ulrike Fischer 
0
news21630 (1434)
5/29/2008 8:20:25 AM
Reply:

Similar Artilces:

Problem with dvips "couldn't find header file 8r.enc" when using times or txfonts
I recently updated my MikTex installation using the tool they provide, and I believe that as a result something in dvips has broken. Up until this point, I have been using txfonts without difficulty. The stage to dvi still works, but when I attempt to use dvips I get the message couldn't find header file 8r.enc and dvips produces no output. This only happens when I use \usepackage{times} or \usepackage{txfonts}. Omitting these (i.e. using the default Compute Modern) results in perfectly successful PS output. I have looked and see that I have the files 8r.enc in \texmf\fonts\enc\dvip...

Problem with "Skip file types" in "Find Files".
I would like to search for text files based on some texts. And I want to exclude svn file (i.e. *.svn-base). So I add the extension .svn-base in "Skip file types" and expect Matlab "Find Files" GUI to skip the svn files. However, "Find Files" still returns the svn file. I think "Find Files" has problem with this kind of filename, eg. "abc.c.svn-base". Is it treating "c.svn-base" as extension? However, I try out the Matlab function FILEPARTS and it works fine. >> [pathstr, name, ext, versn] = fileparts('abc.c.svn-base') ...

error: "couldn't execute "date": no such file or directory" in Tk
hi, i am using the following code in a tcl script with the TK framework, and i get the above error on executing the file main file.. main file --------------- #!c:/tcl/bin/tclsh label .l -text "click to execute" button .b -text "Execute" -command "exec_script" proc exec_script {} { set inp 1 source sss.tcl puts $inp } pack .l .b sss.tcl ----------------------------- #!c:/tcl/bin/tclsh set inp 0 puts $inp set d [exec date] The error i get is "couldn't execute "date": no such file or directory" I am using Tk with Tcl and it is necessary to print the date along with along with my output. The "exec date" works perfect in a tcl script only. but when i use it along with TK i get the error... i will be glad if someone could please help me... thank you.. On 21 Feb., 12:42, "ronnie" <maninder....@gmail.com> wrote: > set d [exec date] > > The error i get is "couldn't execute "date": no such file or > directory" Since Tcl 7.6 or so, the [clock] function delivers date and time in a portable way. See http://www.tcl.tk/man/tcl8.4/TclCmd/clock.htm Examples: 53615 % clock format [clock seconds] Wed Feb 21 12:48:09 W. Europe Standard Time 2007 84 % clock format [clock seconds] -format %c Mittwoch, 21. Februar 2007 12:48:21 53 % clock format [clock seconds] -format %Y-%m-%d,%H:%M:%S 2007-02-21,12:49:42 That [exec date] does work at times, and not at ...

require "mkmf" ---> can't find header files for ruby?
I am reposting my request, in case it was not seen, buried in another post: the first line of extconf.rb is require "mkmf", which is also the first line in programming ruby, ed 2 page 277. If I just run that line, I get the same error message, ruby require "mkmf" can't find header files for ruby. I am using the ruby that comes with Tiger. I did not find a ruby.h file, only an OSX-ruby.h which came in the rubycocoa installation. ...

Help! Can't read file with the char's. " / " and "." !
&nbsp; Hi fellows! &nbsp; I got this file : example.&nbsp;&nbsp; &nbsp; 13-06-06 12:30:20,526&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-3,568&nbsp; 13-06-06 12:30:20,529&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-13,528 13-06-06 12:30:20,556&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-30,568 .. .. ..&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; My program writes this file, and in my program i also got a&nbsp; ReadFile.VI, to read this file and plot...

Why doesn't Python's "robotparser" like Wikipedia's "robots.txt" file?
For some reason, Python's parser for "robots.txt" files doesn't like Wikipedia's "robots.txt" file: >>> import robotparser >>> url = 'http://wikipedia.org/robots.txt' >>> chk = robotparser.RobotFileParser() >>> chk.set_url(url) >>> chk.read() >>> testurl = 'http://wikipedia.org' >>> chk.can_fetch('Mozilla', testurl) False >>> The Wikipedia robots.txt file passes robots.txt validation, and it doesn't disallow unknown browsers. But the Python pars...

TI & CCS
I've just recently moved from SHARC & Visual DSP to TIC6713 with Code Composer Studio. I am working through the tutorials and I have met a problem: In the second tutorial "Project Management" I follow the instructions but when I try to build the project I get: ===================================================== ------------------------- maxminlibrary.pjt - Debug ------------------------- Error, Don't know how to build file "C:\ti\tutorial\dsk6713\maxminmath \maxminlibrary.cmd" [maximumvalue.c] "c:\ti\c6000\cgtools\bin\cl6x" -g -q - fr"C...

Filter problem: "any header" doesn't really match any header
I'm using Eudora 7.1 in "paid mode." I have defined a filter which should match any message which has a certain domain name in any header, and send it to a particular folder. The filter isn't working consistently. Here's the background: I recently changed ISPs, and am trying to catch all email addressed to the old ISP so that I can notify the senders before my old account expires. Initially I defined a filter which matched any message whose "To" header ended with the old ISP's domain name. Some messages weren't being caught. I found that...

A problem about "[ ]" "( )" "="
I want to read several images saved in a director,and give them to I1,I2 ,I3....,using the following codes: filelist=dir(['c:\MATLAB701\work\...\*.jpg']); for i=1 :length(filelist) I=imread(fullfile('c:\MATLAB701\work\...',filelist(i).name)); end; but failed. Then I used I(i)=imread... ,still failed. How could I do? "John" <mailofww@126.com> wrote in message news:ef19e12.-1@webx.raydaftYaTP... >I want to read several images saved in a director,and give them to > I1,I2 ,I3....,using the following codes: > filelist=dir(['c:\MATLAB701\work\.....

Toad for MSSQL problem: closing script file doesn't "release" the file?
Hi all, After finishing a script in Toad for MSSQL, I saved and closed the file in Toad. I then kicked off our staging process which moves the file from the save location to somewhere else. The staging process choked, coming back with a "file in use" error. After verifying that I had closed the file in Toad, I simply exited out of Toad completely. The staging process was then able to complete the file-move process. Is there anything known about this phenomenon? My quick google turned up diddly-squat. Thanks for any info! ...

Problems with two toc's
Hi I am trying to add two tables of contents to my document using the memoir class. I would like tio have a short and a long toc like in the memoir manual. I however get an error I can't write on file 'twoTocs.toc' where twoTocs.tex is my test document. It seems that the file is locked by som eother process. I have used the example by Marting J=F8rgensen: http://groups.google.com/group/comp.text.tex/browse_thread/thread/c0bcc931b= c12c962/bb474c2704f83e4e?lnk=3Dgst&q=3Dmemmanadd.pdf#bb474c2704f83e4e Taken from memmanadd.pdf I have seen elsewhere that other people using windows have the same problem that the .toc-file is locked by the first \tableofcontents command, so when the second command is called, the file is locked by pdflatex. I am running MikTex+TeXnicCenter on Windows Vista Any suggestions? best regards Kim granly wrote: > Hi > > I am trying to add two tables of contents to my document using the > memoir class. I would like tio have a short and a long toc like in the > memoir manual. > > I however get an error > > I can't write on file 'twoTocs.toc' > > where twoTocs.tex is my test document. It seems that the file is > locked by som eother process. > > I have used the example by Marting J´┐Żrgensen: > > http://groups.google.com/group/comp.text.tex/browse_thread/thread/c0bcc931bc12c962/bb474c2704f83e4e?lnk=gst&q=memmanadd.pdf#bb474c2704f83e4e > > Taken from memmanad...

is there definition of "binary file" or "text file"
even so called "text file", acturally it's also stored in the binary format. niy38@hotmail.com (Niy) writes: > even so called "text file", acturally it's also stored in > the binary format. There isn't a difference on unix. Unix sees a file as simply a sequence of bytes, which it does not try to interpret. Interpretation of file formats is done at the application level. For example, a database program would expect a certain format, a text editor another format, but the standard I/O routines just deal with streams of bytes. What's the issue you...

"You don't have permission": Why won't this file download?
I just want people to click on a link to download a file. I've done it before, but this is a new computer and I must be missing something. (Possibly an Apache configuration setting?) Here is the source for the link that generates the error: <a href="./procedures/ODBC_installation.pdf">ODBC driver installation procedure</a><br /> The permissions on the file and the directory containing it are wide open! I've tried everything I can think of. Here is the error: ************************** begin error page ************************** For...

&quot;Save measurement to file&quot;-VI doesn't obey the &quot;Use next avaible file name&quot; setting
I'm using this express VI to store data. In it's properties, there's the "If a file already exists: Use next avaible file name" radio box which does not work. Instead, it appends everything to the one file it created on the first run. My VI has a while-loop with an embedded flat sequence with the writing-VI being in the last frame of the flat sequence. LV 8.5, Linux Hi There. Could You make a screendump of Your VI? I tried using the Express VI on both LV7 Express (Base,Win), and LV8.5 (Base, Win) , and it works perfectly.... &nbsp; I've attached my VI. Current...

problem configuring network ("host" works, "ping" doesn't)
Hi, I just downloaded and installed my very first OpenSolaris... and have problems with the very basic things like configuring network. Overall, connectivity works, I can ping remote hosts using IP addresses. Trying to ping using hostname (i.e. ping opensolaris.org) doesn't work - ping says that the host is unknown. On the other hand, "host opensolaris.org" returns a correct IP address - which proves that DNS is set OK in /etc/resolv.conf. What did I miss? I noticed I had to correct /etc/nsswitch.conf (to use dns for hosts), but other than that, I've no idea what I'm...

GNU Screen "No more PTYs" "Sorry can't find a PTY"
I built GNU screen from both GNU source and the source from the HP-UX port and archive center. In both cases I get an error on the screen console that "No more PTYs." and "Sorry can't find a PTY." Is there a non-admin user way to fix this issue? One issue that appears to be showing up with Google is missing PTYs in /dev. However there are ones there > ls /dev/pty ttya0 ttyae ttybc ttyca ttye8 ttyf6 ttyp4 ttyq2 ttyr0 ttyre ttysc ttyta ttyu8 ttyv6 ttyw4 ttyx2 ttyy0 ttyye ttyzc ttya1 ttyaf ttybd ttycb ttye9 ttyf7 ttyp5 ...

Can't "click through" Static Text even with 'HitTest' set to 'off'?
I've got a GUI with some static text labels that I created in an .m file using the uicontrol() function. I made sure upon creation to set 'HitTest' to 'off'. I can check the controls after the fact, and indeed they all have 'HitTest' set to 'off'. However, I have a ButtonDownFcn call for the entire figure (I'm trying to tell when the user clicks on a specific piece of static text, but the text controls are generated dynamicall). If the user clicks on the figure background, the function executes properly. However, when the static text controls ...

saving problem
I'm getting a strange error when trying to save fairly large matrices. I have enough RAM to create the matrices, but when I try to save them, it gives the error: ??? Error using ==> save Can't write file dailymeantemp.mat. According to this, http://www.mathworks.com/support/solutions/data/1-1QATRJ.html?product=ML&solution=1-1QATRJ it is because I have insufficient disk space; however, I have about 100GB of free disk space and the matrices are only about 35MB each (4 matrices total). I seem to be able to save them if they are only 23MB but as soon as I increase the size I cannot. Even after the error has come up, and the matrices are still in my workspace, I cannot save them. any ideas? thanks "Laurent " <guff69@hotmail.com> wrote in message news:glo30u$76e$1@fred.mathworks.com... > I'm getting a strange error when trying to save fairly large matrices. I > have enough RAM to create the matrices, but when I try to save them, it > gives the error: > > ??? Error using ==> save > Can't write file dailymeantemp.mat. > > According to this, > > http://www.mathworks.com/support/solutions/data/1-1QATRJ.html?product=ML&solution=1-1QATRJ > > it is because I have insufficient disk space; however, I have about 100GB > of free disk space and the matrices are only about 35MB each (4 matrices > total). I seem to be able to save them if they are only 23MB but as soon > as I increase the s...

id request: "Equation that couldn't be solved"
I remember this display font when it first came out -- distinguished by light-weight circles and lines, as if the visible guides by the font designer. They're faintly visible here: http://www.mariolivio.com/ Can anyone help me ID this font? thanks! dylan In article <2006032520504516807-dylan@aracnetcom>, Dylan McNamee <dylan@aracnet.com> wrote: > I remember this display font when it first came out -- distinguished by > light-weight circles and lines, as if the visible guides by the font > designer. They're faintly visible here: > > http://www.ma...

"find"can't find?
I've found very funny situation with my matlab6.5. a=0:0.1:1 b=find(a==0.3) Then, ans is supposed to be 4, however, >>Empty matrix: 1-by-0 On Apr 4, 5:43 pm, "Seungyong " <jsyw...@gmaildot.com> wrote: > I've found very funny situation with my matlab6.5. > a=0:0.1:1 > b=find(a==0.3) > > Then, ans is supposed to be 4, however, > > >>Empty matrix: 1-by-0 This is a variation on a frequently asked question. The answer is simply that the decimal number 0.3 cannot be represented exactly in the double precision floating point arithmetic use...

how to make ["a","b",["c","d"],"e"] into ['a', 'b', 'c', 'd', 'e'] ?
--001a11c34e8edbc7c404f6a94bbe Content-Type: text/plain; charset=ISO-8859-1 >>> x=["a","b",["c","d"],"e"] >>> y=x[2] >>> y ['c', 'd'] >>> x.insert(2,y[0]) >>> x ['a', 'b', 'c', ['c', 'd'], 'e'] >>> x.insert(3,y[1]) >>> x ['a', 'b', 'c', 'd', ['c', 'd'], 'e'] >>> del x[4] >>> x ['a', 'b', 'c', 'd', &#...

"SAMBA Client for OS/2" solves problems with old "File and print client"
I've done a quick test with beta 2 of SAMBA Client for OS/2 from <http://samba.netlabs.org/>. My fileserver is a Linux Red Hat system, my client is an eCS 1.1 system. The first impression is very good! The SAMBA client for OS/2 solves at least two irritating problems I have experienced with "File and print client" when accessing the SAMBA shares on this Linux system. With "File and print client" Lotus 1-2-3 (and some other apps) are not able to create new files, even if editing and saving existing files works ok. Picture-files with thumnails create...

"Thinking like CS" problem I can't solve
Hello. On page 124 of "Thinking like a Computer Scientist". There is an exercise to take the following code and with the use of TRY: / EXCEPT: handle the error. Can somone help me out? Here is the code: def inputNumber(n): if n == 17: raise 'BadNumberError: ', '17 is off limits.' else: print n, 'is a nice number' return n inputNumber(17) Alex Pavluck wrote: > Hello. On page 124 of "Thinking like a Computer Scientist". There is > an exercise to take the following code and with the use of TRY: / > EXCEPT:...

"Couldn't find package liece with version nil"
(Sorry to keep bothering, and thanks to all the maintainers for their hard work and support.) When I select Tools->Packages->Update Installed Packages, I get the error quoted in the subject line. It looks like my packages-package-list somehow contains a package absent from package-get-base. I tried reading the code to figure out why this might be, but I can't even tell where packages-package-list is being set. Any thoughts? --=-=-= Content-Transfer-Encoding: quoted-printable * Dejan Mircevski <Dejan.Mircevski@gmail.com> writes: > When I select Tools-...

Web resources about - "Couldn't find header file arial.ttf", how to solve this problem? - comp.text.tex

Resources last updated: 3/11/2016 6:55:41 AM