f



XLF 6.1 on AIX 5.1. Can it be done? Libary issues.

Hi guys,

I'm a newbie trying to learn AIX administration so I apologize if this 
is a dumb question. I got a used RS6000 and it has AIX 5.1. I have the 
original AIX 5.1 CDs. I also got an original unopened package of XLF 
6.1.

I used to use XLF 6.1 at work and I thought we were running it on AIX 
5.1, but when I installed it on the RS6000 at home, I ran into trouble.

The install was successful (although I did have to install bos.adt.libm 
from the AIX CD1, but I got that figured out). But when I try to 
compile/link something, it gives an error.

The error says it could not load libxlf90.a. The book says to export the 
right LIBPATH blah blah blah, but I don't think that'll do it. In fact, 
I don't think it should be necessary.

If I look at /usr/lib/libxlf90.a I find it is a link to
/usr/lpp/xlf/lib/libxlf90.a

That, in turn, is a link to /usr/lpp/xlf/lib/aix51/libxlf90.a

BUT, the aix51 directory does not exist. No surprise. XLF 6.1 came out 
before AIX 5.1 I think. There is an aix41, aix42, and aix43 directory.

So, in short, is there an update to the library for aix51, or maybe XLF 
6.1 really can't be supported on AIX 5.1 and I need to purchase a more 
recent version of XLF?

Any input would be helpful.

Thanks,
Dave
0
david5637 (22)
11/15/2004 4:10:57 AM
comp.unix.aix 10963 articles. 1 followers. drkirkby (98) is leader. Post Follow

4 Replies
695 Views

Similar Articles

[PageSpeed] 38

In article <41987169.MD-1.4.4.M.Kraemer@gsi.de>, M.Kraemer@gsi.de 
says...

> how about faking/adding some links ?
> 


I tried changing the link to point to aix43/libxlf90.a instead, but I 
guess it knew the file wasn't quite right because it said it failed to 
load libxlf90.a. So, the error message did change, but still it wasn't 
happy. It then went on to say it couldn't find another file. The other 
file is actually the next file in a list of about 8 files in the same 
directory.

Dave
0
david5637 (22)
11/15/2004 9:56:57 AM
> Hi guys,
> 
> I'm a newbie trying to learn AIX administration so I apologize if this 
> is a dumb question. I got a used RS6000 and it has AIX 5.1. I have the 
> original AIX 5.1 CDs. I also got an original unopened package of XLF 
> 6.1.
> 
> I used to use XLF 6.1 at work and I thought we were running it on AIX 
> 5.1, but when I installed it on the RS6000 at home, I ran into trouble.
> 
> The install was successful (although I did have to install bos.adt.libm 
> from the AIX CD1, but I got that figured out). But when I try to 
> compile/link something, it gives an error.
> 
> The error says it could not load libxlf90.a. The book says to export the 
> right LIBPATH blah blah blah, but I don't think that'll do it. In fact, 
> I don't think it should be necessary.
> 
> If I look at /usr/lib/libxlf90.a I find it is a link to
> /usr/lpp/xlf/lib/libxlf90.a
> 
> That, in turn, is a link to /usr/lpp/xlf/lib/aix51/libxlf90.a
> 
> BUT, the aix51 directory does not exist. No surprise. XLF 6.1 came out 
> before AIX 5.1 I think. There is an aix41, aix42, and aix43 directory.
> 
> So, in short, is there an update to the library for aix51, or maybe XLF 
> 6.1 really can't be supported on AIX 5.1 and I need to purchase a more 
> recent version of XLF?
> 
> Any input would be helpful.
> 
> Thanks,
> Dave

how about faking/adding some links ?
0
M.Kraemer (2048)
11/15/2004 10:05:45 AM
David Buchan wrote:
> The install was successful (although I did have to install bos.adt.libm 
> from the AIX CD1, but I got that figured out). But when I try to 
> compile/link something, it gives an error.
> 
> The error says it could not load libxlf90.a. The book says to export the 
> right LIBPATH blah blah blah, but I don't think that'll do it. In fact, 
> I don't think it should be necessary.
> 
> If I look at /usr/lib/libxlf90.a I find it is a link to
> /usr/lpp/xlf/lib/libxlf90.a
> 
> That, in turn, is a link to /usr/lpp/xlf/lib/aix51/libxlf90.a
> 
> BUT, the aix51 directory does not exist. No surprise. XLF 6.1 came out 
> before AIX 5.1 I think. There is an aix41, aix42, and aix43 directory.

No, there's no update.  You'll have to install a later level of the
XLF runtime.  You _might_ be able to install the 7.x RTE, but still
use the 6.x compiler.  Maybe.  And unsupported.
0
noway9558 (15)
11/18/2004 4:43:58 PM
In article <ij4nd.19775$fC4.17424@newssvr11.news.prodigy.com>, 
noway@nosmappers.net says...

> No, there's no update.  You'll have to install a later level of the
> XLF runtime.  You _might_ be able to install the 7.x RTE, but still
> use the 6.x compiler.  Maybe.  And unsupported.
> 
Thanks Gary. Yes, I came to the same conclusion. I'll upgrade my version 
of XLF. I should do that anyway since 6.1 doesn't do IEEE arithmetic 
exception handling (at least, I don't believe it does).

I don't want to get into mixed versions of compiler/RTE. That's just 
asking for trouble.

Thanks again,

Dave
0
david5637 (22)
11/19/2004 12:44:55 PM
Reply:

Similar Artilces:

RE: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #6
Wasn't really the solution I came up with; but it worked. You might be correct since now the OpenSSL binaries will not build against the Kerberos libraries currently. libssl and libcrypto build fine along with everything else; but the actual openssl binary fails. Phil, Have you successfully linked OpenSSL with the new Kerberos libraries ? Thanks, Lamar -----Original Message----- From: Sam Hartman [mailto:hartmans@mit.edu] Sent: Friday, February 09, 2007 10:18 AM To: Saxon, Lamar Cc: pgp@psu.edu; kerberos@MIT.EDU Subject: Re: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 Do you really want rtl as a linker flag? Isn't that going to be an issue for people linking against the kerberos libraries. Why is that the right solution? Privileged and Confidential. This e-mail, and any attachments there to, is intended only for use by the addressee(s) named herein and may contain privileged or confidential information. If you have received this e-mail in error, please notify me immediately by a return e-mail and delete this e-mail. You are hereby notified that any dissemination, distribution or copying of this e-mail and/or any attachments thereto, is strictly prohibited. ________________________________________________ Kerberos mailing list Kerberos@mit.edu https://mailman.mit.edu/mailman/listinfo/kerberos ...

RE: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #5
Phil, Tested on AIX 5.3 TL05 SP4 with XLC++/XLC 8.0 and worked great ! I will be testing on AIX 5.2 TL09 SP3 and AIX 4.3 ML11 here shortly... Thanks for getting this figured out ! Also, appreciate the help from Sam and Martin who were working on it too... Lamar -----Original Message----- From: Phil Pishioneri [mailto:pgp@psu.edu] Sent: Wednesday, February 07, 2007 6:35 PM To: Saxon, Lamar Cc: kerberos@mit.edu Subject: Re: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 I've gotten 1.5.x and 1.6 to build and run on AIX 5.2 (domain referral in 1.6 works nicely). So far I have only tested the client commands: klist, kvno, kinit, kdestroy. No 3rd party software tested yet, either. This was done with the IBM VisualAge C++ Professional / C for AIX Compiler, Version 6. The one major change: add LDFLAGS="-brtl" to configure. My configure line was (prefix edited): ./configure --without-krb4 --prefix=... CC=cc LDFLAGS=-brtl There was one problem during the 1.{5,6} builds (1.5 has a bug that's been documented already), it failed in making all in plugins/kdb/db2/libdb2/test... with ld: 0706-006 Cannot find or open library file: -l db ld:open(): A file or directory in the path name does not exist. my quick&dirty fix for that was (starting in .../krb5-1.6/src/): cd lib ln -s ../plugins/kdb/db2/libdb2/libdb.so.1.1 libdb.so.1.1 ln -s libdb.so.1.1 libdb.so -Phil Privileged and Confidential. This e-mail, and any attac...

AIX 5.1 / VAC 6.0 vs AIX 5.2 / patched VAC 6.0
Hi everybody, I am trying to build some C++ application on the following environment: AIX 5.2 / patched Visual Age C++ 6.0. This application is based on libraries built for the AIX 5.1 / Visual Age C++ 6.0 (base, ie no patch) platform. Compilation works fine. However link results in unresolved symbols (defined in the above libraries). According to IBM support: - AIX 5.1 / Visual Age C++ 6.0 is a supported platform - AIX 5.2 / Visual Age C++ 6.0 with lattest patch is a supported platform - AIX 5.2 / Visual Age C++ 6.00 base version (ie without any patch) isn't a supported platform (!...

Need to take mksysb backup of AIX 5.2 & 5.1 on AIX 5.1 Server.
Hi All Need docmented notes of step by step installing NIM Server on AIX 5.1 Server. Send me also documented notes on installing the NIM client for Aix 5.2 & 5.1. You can send the docs to prsanwal@gmail.com mail account. Awaiting your quick response. Warm Regards Prateek S How about go search IBM's web site and use the man pages... then if you get stuck, come back here and ask for help... We're not here to do your job for you. seriously! jeez prateek... have a little tact man! you want us to find you a bunch of documentation and mail it to you? and quickly? come on dude... show a little initiative... at least TRY to figure it out by yourself first, and evidence that by posting what you have tried and what happened. i know man pages suck ass (it honestly seems sometimes like they're TRYing to be vague and indirect sometimes). and i know ibm's website is ridiculously, monumentaly unorganized. but shit man, have you have heard of google? or askjeeves? i just searched for "installing NIM server on AIX" on google and found like 12,000 results! i know you come from a different culture where people may act a bit more... direct... in the workplace, but when you post a post like that, where you obviously havent even tried to find out yourself, you want people to find you documentation and EMAIL it to you, and you tell them to be QUICK? shit dude... not really how it works around here. btw- no one can see your email address in case you didnt know...

KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #2
I have seen several emails from different people over the last few months on trying to get KRB5 1.5 or later to compile on AIX 5.x. And no responses that fix the problem. I have had the same problem and can only presume that Kerberos is no longer supported on AIX. Is this the case? No Kerberos on AIX? It just won't compile anymore with the changes to shared libraries. ________________________________________________ Kerberos mailing list Kerberos@mit.edu https://mailman.mit.edu/mailman/listinfo/kerberos >>>>> "Grant," == Grant, Martin <Martin.Grant@fmr.com> writes: Grant,> I have seen several emails from different people over the Grant,> last few months on trying to get KRB5 1.5 or later to Grant,> compile on AIX 5.x. And no responses that fix the Grant,> problem. I have had the same problem and can only presume Grant,> that Kerberos is no longer supported on AIX. Is this the Grant,> case? No Kerberos on AIX? It just won't compile anymore Grant,> with the changes to shared libraries. We no longer run AIX tests. Our donated AIX box was very old and slow, and its disk was in the process of dieing. If there's no one out there in the Kerberos development community who cares enough about AIX to get the betas, test them and send bug fixes, then yes, AIX support is going to be fairly bad. Kerberos is an open-source product; if you want it to work better on your pl...

AIX 4.1.5 for Clients vs. regular AIX 4.1.5
Hi, My IBM RS/6000 Notebook 860 portable workstation was originally packaged with IBM AIX Version 4.1.5 for Clients. Does anybody know the difference with the regular 4.1.5? Many thanks, Emeric -- Posted via Mailgate.ORG Server - http://www.Mailgate.ORG Emeric Maschino wrote: > Hi, > > My IBM RS/6000 Notebook 860 portable workstation was originally packaged > with IBM AIX Version 4.1.5 for Clients. Does anybody know the difference > with the regular 4.1.5? > > Many thanks, > > Emeric > > > -- > Posted via Mailgate.ORG Server - http://www.Mailgate.ORG can't remember for sure, I also had an Aix portable I seem to recall the difference being it lacked some server daemons, required less disk space and less memory than the "Server" versions. I think the early days of 4.2 also had a "clients" and "server" editions. Here is a link to additional info on your machine: http://www.nand.net/~rjhawkin/ppc850tp/IBM_Offering_for_860.html ...

RE: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #3
Thanks. The problem also exist using GNU ld on AIX too. See below: make[2]: Entering directory `/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src/lib/rpc' making all in lib/rpc/unit-test... make[3]: Entering directory `/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src/lib/rpc/unit-test' cc -L../../../lib -blibpath:/usr/local/kerberos/lib::/usr/lib:/lib -g -qhalt=e -O -D_THREAD_SAFE -o client client. o rpc_test_clnt.o \ -lgssrpc -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lkrb5support -lpthreads ld: 0706-006 Cannot find or open library file: -l k5crypto ld:open(): No such file or directory ld: 0706-006 Cannot find or open library file: -l com_err ld:open(): No such file or directory ld: 0706-006 Cannot find or open library file: -l krb5support ld:open(): No such file or directory make[3]: *** [client] Error 255 make[3]: Leaving directory `/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src/lib/rpc/unit-test' make[2]: *** [all-recurse] Error 1 make[2]: Leaving directory `/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src/lib/rpc' make[1]: *** [all-recurse] Error 1 make[1]: Leaving directory `/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src/lib' make: *** [all-recurse] Error 1 root@aoctoolbox:/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src:> whence ld /usr/local/bin/ld root@aoctoolbox:/usr/sys/inst.images/MIT-Kerberos/krb5-1.6/5.3/src:> ld -v GNU ld version 2.16 Lamar -----Original Message----- From: Russ Al...

RE: KRB5 1.5 or 1.6 compiled on AIX 5.2/5.3 #2
Exact same errors specifying --without-tcl. I removed the config.cache, config.log, and etc the reran configure. From my configure line - ../configure --prefix=/usr/local/kerberos --enable-dns-for-realm --without-tcl --with-vague-errors Then after make... making all in lib/rpc/unit-test... Target "all" is up to date. cc -I../../../include -I./../../../include -I. -DKRB5_DEPRECATED=1 -DKRB5_PRIVATE=1 -g -qhalt=e -O _THREAD_SAFE -c client.c cc -I../../../include -I./../../../include -I. -DKRB5_DEPRECATED=1 -DKRB5_PRIVATE=1 -g -qhalt=e -O _THREAD_SAFE -c rpc_test_clnt.c cc -L../../../lib -blibpath:/usr/local/kerberos/lib::/usr/lib:/lib -g -qhalt=e -O -D_THREAD_SAFE -o c nt client.o rpc_test_clnt.o -lgssrpc -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lkrb5support -lpthreads ld: 0706-006 Cannot find or open library file: -l k5crypto ld:open(): A file or directory in the path name does not exist. ld: 0706-006 Cannot find or open library file: -l com_err ld:open(): A file or directory in the path name does not exist. ld: 0706-006 Cannot find or open library file: -l krb5support ld:open(): A file or directory in the path name does not exist. make: 1254-004 The error code from the last command is 255. Stop. make: 1254-004 The error code from the last command is 1. Stop. make: 1254-004 The error code from the last command is 1. Stop. make: 1254-004 The error code from the last command is 1. Stop. Any ot...

hacmp 5.1 on aix 5.1
Hi, Trying to define a new service ip address to one of the nodes, something went wrong and now I'm getting : ERROR: Hardware address 0.de.ad.be.ef.82 is not unique between adapter porthos on node porthos and adapter en2* on node aramis Being aramis and porthos the 2 nodes on the cluster, and the service ip_address I wanted to change was on Porthos. I changed the hosts files, and set HACMP to reload configurations from the operating system, and from there on things went bad. Any pointers on how to straighten things out? PS : I didn't make a snapshot before screwing things around, and the lastest one I have has old LV sizes, does this matter? Or can I get around this doing an exportvg & importvg etc. ? Alex, You have to set the alternate etheradress on 1 of the 2 with another deadbeef number (i.e. 83) The mac-addr will be the same now. Marcel Alex Goncalves wrote: > Hi, > > Trying to define a new service ip address to one of the nodes, > something went wrong and now I'm getting : > > ERROR: Hardware address 0.de.ad.be.ef.82 is not unique between adapter > porthos on node porthos and adapter en2* on node aramis > > Being aramis and porthos the 2 nodes on the cluster, and the service > ip_address I wanted to change was on Porthos. > > I changed the hosts files, and set HACMP to reload configurations from > the operating system, and from there on things went bad. > > Any pointers on how to straighten things ou...

pthreads/dlopen issue when building krb-1.6.3 on AIX 6.1?
I'm attempting to build MIT Kerberos version 1.6.1 on AIX 6.1. I'm mostly in need of the client libraries and utilities. I'm using the following special additions to the build environment: $ export PTHREAD_LIBS="-lpthread" $ export RPATH_FLAG="-Wl,-brtl,-blibpath:" I'm using the following ./configure command: $ ./configure --prefix=/usr/local/krb5-1.6.3 --enable-log-preauth-logins --enable-login-print-issue --with-multihomed-fixes --enable-app-proxy --with-passive-mode-off --without-anonymous-ftp And I get the following results when I run it: [snip] configure: enabling thread support checking for pthread_join in LIBS=-lpthread with CFLAGS=... yes checking for joinable pthread attribute... unknown configure: WARNING: we do not know how to create joinable pthreads checking if more special flags are required for pthreads... -D_THREAD_SAFE checking for cc_r... cc_r configure: PTHREAD_CC = cc_r configure: PTHREAD_CFLAGS = -D_THREAD_SAFE configure: PTHREAD_LIBS = -lpthread checking for pthread_once... yes checking for pthread_rwlock_init... yes configure: rechecking with PTHREAD_... options checking for pthread_rwlock_init in -lc... yes checking for library containing dlopen... none required checking keyutils.h usability... no checking keyutils.h presence... no checking for keyutils.h... no configure: disabling static libraries confi...

Java 1.5 on AIX 5.1?
Is there such a thing as a Java 1.5 JRE that will run on AIX 5.1? The most recent Java SDK that would run on AIX 5.1 that I could find on the IBM web site was 1.4. Am I looking in the wrong place? Unfortunately, we need to stick with AIX 5.1 on this particular machine, as we are using it for building and testing software that is intended to run on 5.1. Scott Norwood wrote: > Is there such a thing as a Java 1.5 JRE that will run on AIX 5.1? > The most recent Java SDK that would run on AIX 5.1 that I could > find on the IBM web site was 1.4. Am I looking in the wrong place? Nope. If that's what it says, that's the restriction. > Unfortunately, we need to stick with AIX 5.1 on this particular > machine, as we are using it for building and testing software that > is intended to run on 5.1. Good point. But if Java 1.5 isn't supported on AIX 5.1, there's no point in trying to support that config in your testing/product. ...

fuser functionality seems to have changed in AIX 6.1 TL8 and AIX 7.1
Hi AIX Gurus, Our company has some scripts that are used to check if users are logged int= o a specific directory or file system, and the script uses the fuser comman= d. What we do is look at the PIDs listed in "fuser ${pathname}" to determine w= hich users are accessing what files. This is done so we can do maintenance = at times. We make sure all users are out of the directory, have a method to= keep them out, then do our backups or maintenance or whatever. The problem we are encountering is with AIX 6.1 TL8 and above. It seems tha= t IBM may have made a change so that a non-root user can only see their own= PIDs when running fuser, and not all of the PIDs associated with that path= .. Example from AIX 5.1, 5.3, and early 6.1 systems: # whoami office1 # oslevel -s=20 6100-06-01-1043 # fuser -u /qc/sample /qc/sample: 2490476c(postgres) 5767176c(postgres) 6094882c(postgres) 67504= 34c(postgres) 6815922c(postgres) 7143588c(postgres) 7471358c(postgres) 7799= 036c(postgres) 8913140c(postgres) 11600120c(postgres) 11731066c(1008) 12976= 256c(postgres) 13303960c(postgres) 13500622c(postgres) 13566180c(postgres) = 13893696c(postgres) 15138826c(postgres) 15466614c(postgres) 16842792c(postg= res) 18153666c(1009) 18612404c(postgres) 18743530c(postgres) 19071062c(1010= ) 19202252c(postgres) 19267626c(postgres) 19595344c(postgres) 20709580c(pos= tgres) 20840526c(postgres) 23658578c(postgres) 23986214c(postgres) 25100526= c(postgres) 2...

RE: Kerberos 5 v1.5.1 on AIX 5.2 or AIX 5.3
Believe it or not; both solutions seem to work and compilation succeeds ! #define GET_HOST_BY_NAME(NAME, HP, ERR, TMP) \ { \ (HP) = (gethostbyname_r((NAME), &TMP.ent, &TMP.data) \ ? 0 \ : &TMP.data); \ (ERR) = h_errno; \ } Worked and so did... #define GET_HOST_BY_NAME(NAME, HP, ERR, TMP) \ { \ struct hostent my_h_ent; \ (HP) = (gethostbyname_r((NAME), &TMP.ent, &TMP.data) \ ? 0 \ : &my_h_ent); \ (ERR) = h_errno; \ } Thanks for the help ! I will continue testing with my current install base on AIX. I really appreciate the rapid responses and solutions ! Lamar -----Original Message----- From: Ken Raeburn [mailto:raeburn@MIT.EDU] Sent: Monday, September 18, 2006 5:13 PM To: Marcus Watts Cc: Saxon, Lamar; kerberos@mit.edu Subject: Re: Kerberos 5 v1.5.1 on AIX 5.2 or AIX 5.3 On Sep 18, 2006, at 17:56, Marcus Watts wrote: > Lamar.Saxon@americredit.com writes: > ... >> making all in util... >> making all in util/support... >> cc -I../../include -...

SSH-1.99-OpenSSH_4.1 vs. SSH-1.99-OpenSSH_3.8.1.p1 on AIX 5.3
Are there any known issues with SSH-1.99-OpenSSH_4.1, as with version SSH-1.99-OpenSSH_3.8.1.p1 I don't have to set keep alive parameter? I am not sure if this is related, I have a ksh script that calls a db2 pl stored procedure several times when it comes to certain iteration, it ends up hanging in the middle. I experienced this with an environment that has SSH-1.99-OpenSSH_4.1 but not with a different environment that has OpenSSH_3.8.1.p1. Thanks in advance ...

Dual booting AIX 5.1 and AIX 5.3
I am having trouble switching to the AIX 5.3 system from AIX 5.1 - I have no problems going the other way. The system hangs on reboot after putting up the starting software message with the LED set on E140. I am using bootlist to switch between 2 SCSI boot disks. The problems only to seem to have arisen when I upgraded the first disk from AIX 5.2 to 5.3. I can recover by booting off the 5.3 CDROM and then aborting the boot and when I now restart the system it successfully comes up in AIX 5.3. Just to complicate matters the AIX 5.1 system runs in 32-bit mode and the AIX 5.3 in 64-bit mode. John Problem solved : upgrading the system firmware to the latest level seems to have done the trick. ...

KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2 (fwd)
I have done some research on this problem. The host resolve code does not complete successfully. I have traced the error to the routine at /kerberos/mit/krb5-1.4/src/lib/krb5/os/dnsglue.c. In the routine a call is made to res_ninit to provide dns information for the kdc. res_ninit updates the structure at statbuf but overlays memory 72 bytes past the structure boundary. I have opened a problem with IBM on res_ninit. The problem is not yet resolved but IBM suggested using a malloc for the structure instead of static storage. I am trying to get IBM to correct the error in res_ninit. No resoultion yet. >Delivery-Date: Thu, 21 Apr 2005 12:15:05 -0600 >Return-Path: <owner-kerberos@lanl.gov> >X-Original-To: hgm@localhost.localdomain >Delivered-To: hgm@localhost.localdomain >Received: from localhost (localhost.localdomain [127.0.0.1]) > by moki.lanl.gov (Postfix) with ESMTP id 15AAB68739 > for <hgm@localhost.localdomain>; Thu, 21 Apr 2005 12:15:05 -0600 > (MDT) >Received: from ccn-mail.lanl.gov [128.165.4.105] > by localhost with POP3 (fetchmail-6.2.5) > for hgm@localhost.localdomain (single-drop); Thu, 21 Apr 2005 > 12:15:05 -0600 >(MDT) >Received: from ccn-mail.lanl.gov ([unix socket]) > by ccn-mail.lanl.gov (Cyrus v2.2.3-Red Hat 2.2.3-6.lanl) with > LMTP; Thu, 21 >Apr 2005 12:11:13 -0600 >X-Sieve: CMU Sieve 2.2 >Received: from mailrelay3.lanl.gov (mail...

Folks wanting to migrate AIX 5.3 ( with TCB Enabled) to AIX 6.1 and create WPAR
Greetings!!! Running AIX5.3 with TCB enabled and wanted to migrate to AIX6.1 to exploit AIX6.1 by creating WPAR was not possible. Here is a way to acheive that (if you are still on AIX5.3): 0. Modify PdAt for TCB_STATE (Make a copy of PdAt): i.e. odmget -q attribute=TCB_STATE PdAt | sed 's/tcb_enabled/ tcb_disabled/' | odmchange -o PdAt -q attribute=TCB_STATE 1. Migrate AIX5.3 to AIX6.1 Migration (Install) would pick up TCB_STATE and populate /usr/lpp/bos/ inst_root. 2. Create WPAR. Have not noticed any consequences, though testing was limited. -Khatir These are my personal opinions. ...

RE: KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2 #2
Downloaded KRB5 1.4.1 and the installation worked great with GCC and AIX make. None of the problems that were encountered with 1.4.0 and the unbalanced "(". The problem with: /usr/local/kerberos/bin/kinit -V kinit(v5): Cannot resolve network address for KDC in requested realm while getting initial credentials still exist. If I force it to version 4 KRB it seems to work with the krb5.conf: /usr/local/kerberos/bin/kinit -4 xxxxxxx Password for xxxxxx@xxx.xxxxxxxxxx.xxx: kinit(v4): Can't send request (send_to_kdc) The krb5.conf file is the same file that worked with the 1.3.6 version of KRB5. It does not seem to work with KRB 1.4 or 1.4.1. Any one having similar problems or solutions ? Thanks, Lamar -----Original Message----- From: Saxon, Lamar Sent: Monday, April 25, 2005 11:08 AM To: 'Tom Yu' Cc: kerberos@mit.edu Subject: RE: KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2 The compile with CC works with no issues. The other issue still remains. "Cannot resolve network address for KDC in requested realm while getting initial credentials" I tried kinit with the -k and verbose; but not with a password. I will post the results once I get it accomplished. Thanks, Lamar -----Original Message----- From: Tom Yu [mailto:tlyu@MIT.EDU] Sent: Thursday, April 21, 2005 2:18 PM To: Saxon, Lamar Cc: kerberos@mit.edu Subject: Re: KRB5 1.4 vs. KRB5 1.3.6 on AIX 5.2 >>>>> "Lamar" == <Lamar.Saxon@americredit.com> writes: La...

Reverse binary compatibility between AIX 5.2 and AIX 5.1
Hi , I wrote a simple "hello world" program on AIX5.2 using gcc compiler . The resultant binary exe(name - getpqstatus) when i ran on AIX5.1 it is giving the below error : exec(): 0509-036 Cannot load program ./getpqstatus because of the following errors: 0509-130 Symbol resolution failed for getpqstatus because: 0509-136 Symbol __strtollmax (number 15) is not exported from dependent module /usr/lib/libc.a(shr.o). 0509-192 Examine .loader section symbols with the 'dump -Tv' command. Does anyone has any idea why this is happening ..? Does even simple programs compiled in AIX5.2 do not run on AIX5.1 ...? Any help will be really helpful and appreciated ... Thanks and Regards Sona . H'llo Sona, What you're trying to do is not possible. AIX is being maintained in such a way that older programs will still run on the newer versions of AIX. The other way round, however, is not guaranteed. Apparently, the strtollmax() function was only invented in AIX 5.2, and AIX 5.1 doesn't have it. The golden rule is: whenever you want to support multiple versions of AIX, compile it on the oldest version you want to support. It will *usually* work on the newer versions as well. Cheers, Menno Menno Willemse <flexor@wanadoo.nl> wrote: > The golden rule is: whenever you want to support multiple versions of > AIX, compile it on the oldest version you want to support. It will >...

[ace-users] Tests failed : ACE 5.5.2 - AIX 5.3
Hi, My first mail before my message in the group failed (my subscription was not activated). The PRF below describes my problems. I can compile and link but several ACE's tests fail. I only use ACE library and only compile it by cd'ing in the ace directory before running make. I already made some fixes described below to compile and to link the library. I'm not abble to interpret the faild tests to identify the problem source or area. I didn't find the scoreboard before my mail. I see that several tests fails for all compilations on AIX. I try to reassure myself by looking these results, it's not only for my configuration. But it's a daily build with last development version. For the 5.5.2 stable version they should probably not fail ? Regards, PO Houot. ACE VERSION: 5.5.2 HOST MACHINE and OPERATING SYSTEM: bash-3.00$ uname -a AIX localhost 3 5 0040983B4C00 unknown unknown AIX bash-3.00$ oslevel -r 5300-05 TARGET MACHINE and OPERATING SYSTEM, if different from HOST: Same as host COMPILER NAME AND VERSION (AND PATCHLEVEL): bash-3.00$ g++ -v Using built-in specs. Target: powerpc-ibm-aix5.3.0.0 Configured with: ../gcc-4.1.1/configure --disable-nls Thread model: aix gcc version 4.1.1 This compiler is installed from packages provided by UCLA AIX Software library THE $ACE_ROOT/ace/config.h FILE : bash-3.00$ more $ACE_ROOT/ace/config.h #include "ace/config-aix-5.x.h" T...

Installing TOMCAT 4.1 (or higher) on AIX 5.1/5.2
Hi, I am searching for information on installing TOMCAT 4.1 (or higher) on AIX 5.1/5.2 platform. Is it possible? Regards Yes, it works. Follow the installation instruction on tomcat web site. You might have issues with running stanalone Tomcat/SSL server on AIX due to the conflicts in JDK implementations used on AIX and the one to develop Tomcat ( Sun and IBM aren't play nice in there )... Other than that -- works just fine. Thx a lot for your reply. Can Tomcat use AIX's Java platform ? Is it mandatory to install SUN's JDK on AIX ? In this last case, would you please tell me where I can download sun's jdk for AIX. Thx again, Best Regards Yes, tomcat will use AIX JDK with no problem... till you decided to use Tomcat/SSL as stanalone server ( so, no other HTTP servers out there )... See how-to SSL on tomcat web site for more details. Begining with Java 1.4.1 Sun finaly get JSSE included in the release, but IBM did it few years ago in their JDK on AIX, so you will not find Sun JSSE on AIX platform in Java 1.4.x, but Tomcat/SSL needs it... I don't know it would be resolved any time soon. So, if you can use Tomcat without SSL or have Apache/SSL/Tomcat you should be just fine . Thank you very much for these details. Regards Ok, I've installed jakarta-tomcat-4.1.31.tar.gz on a AIX 5.2 system. I've created a 'tomcat' user and added the following information to his ..profile : export JAVA_HOME=/usr/java14 export CLASSPATH=/usr/j...

Installing TOMCAT 4.1 (or higher) on AIX 5.1/5.2 #2
Hi, I am searching for information on installing TOMCAT 4.1 (or higher) on AIX 5.1/5.2 platform. Is it possible? Regards ...

1.1.1.1 ?
hi my firewall logs dropped packets from an internal IP address trying to contact 1.1.1.1 through port 9999. Any ideas whether 1.1.1.1 is valid IP? and what is port 9999?? thanks mike wrote: > hi > > my firewall logs dropped packets from an internal IP address trying to > contact 1.1.1.1 through port 9999. Any ideas whether 1.1.1.1 is valid > IP? and what is port 9999?? > thanks These trojans *BlitzNet*, *Backdoor.Oracle*, *Backdoor.Spadeace* uses port 9999 -- S.S. "StarScripter" <Star@privacy.net> wrote in message news:<bv8ejj$p54t3$1@ID-185702.news.uni-berlin.de>... > mike wrote: > > hi > > > > my firewall logs dropped packets from an internal IP address trying to > > contact 1.1.1.1 through port 9999. Any ideas whether 1.1.1.1 is valid > > IP? and what is port 9999?? > > thanks > > These trojans *BlitzNet*, *Backdoor.Oracle*, *Backdoor.Spadeace* uses port > 9999 thanks very much..will check it out ...

moving xlc 5.0.1 on aix 4.3 to aix 5.2?
We are upgrading our B50 with AIX 4.3.3 to AIX 5.2 We currently use C for AIX xlc 5.0.1 on AIX 4.3.3. I remember reading xlc 5.0.2 is required to be used for AIX 5.2. Does this mean we have to purchase a new compiler, or is there an upgrade available. thank you sol sol gongola wrote: > We are upgrading our B50 with AIX 4.3.3 to AIX 5.2 > We currently use C for AIX xlc 5.0.1 on AIX 4.3.3. > > I remember reading xlc 5.0.2 is required to be used for > AIX 5.2. Does this mean we have to purchase a new > compiler, or is there an upgrade available. Just install updates....

Web resources about - XLF 6.1 on AIX 5.1. Can it be done? Libary issues. - comp.unix.aix

Boston Public Libary searches for missing art worth hundreds of thousands of dollars
Boston Public Libary searches for missing art worth hundreds of thousands of dollars

Texas Man Arrested For Overdue Libary Book
Jory Enck, a library patron in Copperas Cove, Texas, was arrested last week after he failed to return a library book . The arrest was part of ...

Adriana Lima Opens New Libary at Children's Hospital in Brazil
Adriana Lima flashes a thumbs up while attending the Le Petit Prince Library opening at a children’s hospital on Tuesday (April 14) in Curitiba, ...

Today in APIs: OneRoof Energy Launches API Libary, and 12 New APIs
ProgrammableWeb.com keeps you up to date with web mashups and APIs: what's new, interesting, useful and important. Hundreds of mashups and APIs. ...

Side Order: The Reagan Presidential Libary and Museum gets a $15 million overhaul
The mission-style building that houses the recently renovated Ronald Reagan Presidential Foundation and Library in Simi Valley, Calif., perches ...


GNU General Public License – Wikipedia
Die GNU General Public License (oft GNU GPL oder auch GPL abgekürzt) ist eine von der Free Software Foundation (FSF) veröffentlichte Freie-Software ...

Anti-Islamic protest
Protesters demonstrate with placards at the Melbourne State Libary to take a stance on ugly clashes.

BHP Billiton in a dark place
BHP Billiton in a dark place

Learn Chinese - CRIENGLISH
• Ways to Listen • About Us • Jobs • Contact Us Choose A Language Albanian Arabic Bengali Bulgarian Burmese Cambodian Chinese Simplified Chinese ...

Resources last updated: 3/26/2016 10:35:35 PM