f



Can't run Azureus on FreeBSD 6.0/JDK15/Gnome

All,

I'm trying to get Azureus 2.4 to run under FreeBSD.  I've successfully 
built JDK15 (after reinstalling my OS) and run into this message when I 
try to execute azureus.


"/usr/local/azureus/libswt-pi-gtk-3139.so: Shared object 
"libgtk-x11-2.0.so.0" not found, required by "libswt-pi-gtk-3139.so""

Is there a package or port that contains "libgtk-x11-2.0.so.0"?  Any 
help appreciated.

Regards,

Monty

===================

Exception in thread "main" java.lang.UnsatisfiedLinkError: 
/usr/local/azureus/libswt-pi-gtk-3139.so: Shared object 
"libgtk-x11-2.0.so.0" not found, required by "libswt-pi-gtk-3139.so"
         at java.lang.ClassLoader$NativeLibrary.load(Native Method)
         at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
         at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
         at java.lang.Runtime.loadLibrary0(Runtime.java:822)
         at java.lang.System.loadLibrary(System.java:992)
         at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
         at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
         at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
         at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
         at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
         at 
org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:75)
         at 
org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:58)
         at 
org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:109)
         at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:143)
         at org.gudy.azureus2.ui.swt.Main.main(Main.java:158)
Azureus TERMINATED.
0
Monty
2/24/2006 9:39:30 PM
comp.unix.bsd.freebsd.misc 13187 articles. 1 followers. Post Follow

1 Replies
481 Views

Similar Articles

[PageSpeed] 44

Monty Hall wrote:

> All,
> 
> I'm trying to get Azureus 2.4 to run under FreeBSD.  I've successfully
> built JDK15 (after reinstalling my OS) and run into this message when I
> try to execute azureus.
> 
> 
> "/usr/local/azureus/libswt-pi-gtk-3139.so: Shared object
> "libgtk-x11-2.0.so.0" not found, required by "libswt-pi-gtk-3139.so""
> 
> Is there a package or port that contains "libgtk-x11-2.0.so.0"?  Any
> help appreciated.
> 
> Regards,
> 
> Monty
[snip]

Look here: /usr/ports/x11-toolkits/gtk20/

Be aware that it is going to have many dependencies of its own. I took a
real quick peek through the Azureus Makefile because I was curious as to
why it didn't handle the dependencies for you. It looks like it is only
cognizant of the Java stuff.

-Jason

0
Jason
2/25/2006 8:00:57 PM
Reply:

Similar Artilces:

Can't compile Samba ports under FreeBSD 6.0
Hi I made the mistake after upgrading from FreeBSD 5.4 to 6.0 to follow the instructions too closely: Eg. I did make delete-old-libs Anyway, most programs didn't work anymore due to missing libraries so I recompiled most of them. Samba is giving me problems, it doesn't compile and fails during configure with: checking for test routines... configure: error: cant find test code. Aborting config Google didn't return anything interesting always linked to rather old version of Samba (circ 2002). Any help would be appreciated. Thank you JY Jean-Yves Avenard wrote: > Samba is giving me problems, it doesn't compile and fails during > configure with: > checking for test routines... configure: error: cant find test code. > Aborting config Looks like libcups was still calling the old libssl which was removed earlier. Will know in an hour when it finishes recompiling cups, it's a 400Mhz P3, it takes forever :( JY ...

Can't run Guarddog v2.6.0 in Gnome v2.30?
Hi. A few days ago, I installed a new clean Debian stable since my old one from 2004 was badly shaped. I am still trying to configure it up like my old one from scratch. How do I run Guarddog v2.6.0 with root/sudo access in Gnome v2.3 since I don't like KDE v4.4.3 (currently installed too)? I can run Guarddog without problems if I use KDE and it even asks my root/sudo password. I noticed running Guarddog as root/sudo in Terminal in Gnome shows: # guarddog No protocol specified guarddog: cannot connect to X server :0.0 I have no problems running other KDE programs like kmail, kruler...

Can't get FreeBSD 6.0 to recognize my AC-97 audio device
Hi, I installed FreeBSD 6.0 to my Dell OptiPlex GX150 and everything worked like charm until I tried to get the audio device to work. To my great supprise the integrated AC-97 audio device was not recognized by my newly compiled kernel. I also tried to put all kinds of hints into loader.conf file without success. Is there anything I could still do about this? Jyri Jyri wrote: > Hi, > I installed FreeBSD 6.0 to my Dell OptiPlex GX150 and everything Is that 6.0-RELEASE or 6.0-STABLE? There are lots of fixes to the sound system from -release to -stable. > worked like charm until I tried to get the audio device to work. To > my great supprise the integrated AC-97 audio device was not recognized > by my newly compiled kernel. I also tried to put all kinds of hints into > loader.conf file without success. Is there anything I could still do > about this? If you are running 6.0-stable, you should describe the details of your hardware, system and problems on the freebsd-multimedia mailing list, That's where the audio experts hang out. HTH -- Torfinn Ingolfsen, Norway Jyri wrote: > Hi, > I installed FreeBSD 6.0 to my Dell OptiPlex GX150 and everything > worked like charm until I tried to get the audio device to work. To > my great supprise the integrated AC-97 audio device was not recognized > by my newly compiled kernel. I also tried to put all kinds of hints into > loader.conf file wi...

if instead of 0.0.0.0 netmask is 255.0.0.0, I can't go on internet. That doesn't make sense...
Hello 1) I'm running W2k on PC called A ( it's not really named A, but for the sake of argument ...) and if my routing table has ( destionation )0.0.0.0 ( netmask )255.0.0.0 ( gateway )192.168.2.1 instead of ( destionation )0.0.0.0 (netmask)0.0.0.0 (gateway)192.168.2.1 then I can't get on internet. I know address 0.0.0.0 basically means "send the packet on internet", but why needs netmask be 0.0.0.0? Afterall, all that netmask 255.0.0.0 should tell A is that destination address is not on the same network as A is, and thus should send it to d...

can't run a built application because it can't find Run-Time engine
Let's start at the begining.... everything was working fine, and then I started getting an&nbsp;error 2 (memory is full) while compiling any application.&nbsp; I couldn't resolve the issue but the same applications would compile on another machine, so I uninstalled every National Instrument software from Control Panel (add remove programs), and deleted the c:\Program Files\National Instruments directory.&nbsp; I then reinstall the Labview 8.0 Prof Dev system,&nbsp; and performed the labview 8.0.1 upgrade.&nbsp; I can now open and compile applications,&nbsp; but ...

FreeBSD 6.2 install can't find my keyboard
G'day there One & All, I've just tried to install 6.2 and found a problem that I have no idea how to get around. I've used Linux before, and currently have Ubuntu dual booting with WinXP Home version on my Dell machine. I want to put FreeBSD on an older machine I have sitting here to act as a server/gateway for my home nework (1 x server; 2 x desktops in total). I thought I'd first install on my main desktop to see how it all went. Well, the boot cd works fine. I get the initial menu and all gets under way. From there, no matter which option I select I see that all runs until USB hub initialisation starts and that's the end of it. I get error messages telling me that I have no USB and that the system is going to shut down. I don't recall the exact message, but I can run it again to quote accurately if need be. My question is; how can it not initialise the USB hub when it was obviously working or I'd not have been able to type the menu option with my USB keyboard to start the process to begin with??!! As a FreeBSD newbie, and not that much better with any other *nix, I don't know where to start looking. There are no log files, as nothing is mounted at this stage in the process and hence there is nowhere to save anything for later examination. All in all, it's a bit of a conundrum. Can somebody please point me in the direction of a solution? My friend Google gave me some clues, but...

can't get desired xorg resolution with FreeBSD 7.0
I have a laptop with a Radeon Mobility card on which I've been running FreeBSD 6.2 with Xorg 7.2 using a 1024x768 resolution. On a different slice of the same laptop, I installed FreeBSD 7.0/Xorg 7.3. With the same xorg.conf, X is coming up with a 1400x1050 resolution, which is too fine for my eyes. A google search led me to think that setting the desired resolution could be done using xrandr, but the command: xrandr --fb 1024x768 gives an error message: xrandr: specified screen 1024x768 not large enough for output LVDS \ (1400x1050+0+0) The contents of /etc/X11/xorg.conf: ----------------------------------- Section "ServerLayout" Identifier "X.org Configured" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard0" "CoreKeyboard" EndSection Section "Files" RgbPath "/usr/local/lib/X11/rgb" ModulePath "/usr/local/lib/xorg/modules" FontPath "/usr/local/lib/X11/fonts/misc/" FontPath "/usr/local/lib/X11/fonts/TTF/" FontPath "/usr/local/lib/X11/fonts/Type1/" FontPath "/usr/local/lib/X11/fonts/CID/" FontPath "/usr/local/lib/X11/fonts/75dpi/" FontPath "/usr/local/lib/X11/fonts/100dpi/" EndSection Section "Module" Load "dbe" Load "dri" Load "extmo...

Can't get AVG 6.0 ANTIVIRUS to run on PEGASUS
Installed AVG 6,0 free (avg6642fu_free) Installed avgemc483us. E-mail scanner set to verify incoming and outgoing. E-mail is not being scanned. Is there anything else I need to do, or will it not run on Pegasus?? Because there's more to the internet than hits alone, Pete wrote: >Installed AVG 6,0 free (avg6642fu_free) >Installed avgemc483us. >E-mail scanner set to verify incoming and outgoing. >E-mail is not being scanned. Is there anything else I need to do, or >will it not run on Pegasus?? My UK edition of AVG 6.0 says, in the e-mail scanner tab: "E-...

can't install firefox-1.0.1 on FreeBSD 5.3
Hi ! I downloaded the package firefox-1.0.1.p_2.tgz and when I try to install it on FreeBSD 5.3 I have this problem : pkg_add firefox-1.0.1.p_2.tgz pkg_add: could not find package imake-4.4.0 ! pkg_add: could not find package XFree86-libraries-4.4.0_1 ! pkg_add: could not find package XFree86-fontEncodings-4.4.0 ! pkg_add: could not find package XFree86-fontScalable-4.4.0_1 ! I have already imake 6.7 installed so why this error ? If somebody know how to install firefox-1.0.1.p_2.tgz, thank you very much for giving the solution :-) Fred fred <fred@no-spam.fr> writes: ...

Maple9 Can't run, can't re-install
-I installed the maple-9 on laptop without any problem. But when I run it, nothing happens. -I tried to uninstall it with start->settings->control panel->add/remove program->maple9, the "add/remove program" freeze (for long--------). All other programs still work at that time (computer is not froozen). -I tried to shut down the computer, it needs to 'end' the 'un-installation' -I tried to re-install the maple9 from the original CD, nothing happens. -With 'autorun', it runs a few seconds and nothing happens. -Tried to installed it ...

[6.2 + Via VT3043 Rhine] Can't resolve ftp.freebsd.org?
Hello This is my first attempt at installing FreeBSD. I burned a minimal ISO to install FB over the Net. The embedded "Via VT3043/VT86C100A Rhine PC Ethernet card" got its IP configuration successfully from my DHCP server, but when I tell the installer to download files in "FTP Passive through Firewall" mode from ftp.freebsd.org, it says it can't resolve the name. I tried FTP servers in France, same error. I changed the DNS server from my ISP's to OpenDNS in the network settings in the installer, same result. I have a second PC in my private LAN, which has no problem accessing the Net at this very moment (I'm typing this message on this PC.) Does FreeBSD have problems working with this embedded Ethernet interface? Do I need to do something special to get to the next step? Thank you. On Tue, 1 Jan 2008 01:10:57 UTC, Gilles Ganault <nospam@nospam.com> wrote: > The embedded "Via VT3043/VT86C100A Rhine PC Ethernet card" got its IP > configuration successfully from my DHCP server, but when I tell the > installer to download files in "FTP Passive through Firewall" mode > from ftp.freebsd.org, it says it can't resolve the name. > Does FreeBSD have problems working with this embedded Ethernet > interface? Do I need to do something special to get to the next step? I'm using two machine on 6.2 with the Rhine hardware. No problem here, no special action. -- ...

Using Apache 2.0.40 in FreeBSD, I can't see the Sub-Directories !!!!
Hi all... As read above I am Using FreeBSD and Apache 2.0.40, but the matter with that is that I have some directories like this ..../htdocs ..../htdocs/templates ..../htdocs/templates_c ..../htdocs/templates_c/%%17 ..../htdocs/templates_c/%%17/%%%98788 ..../htdocs/templates_c/%%17/%%%32132 The first that are without % work perfect, but the others I can't see it int the browser... I have already set the correct attributes (White, Read and Execute)... And the code of PHP can find it ... in the include(../templates_c/%%17/index.tpl.php) What Do I Have to change ??...

ntp-dev-4.2.1p250-RC won't build on FreeBSD 6.0
ntp-dev-4.2.1p250-RC It seems ntpd_intres.c in this RC needs EAI_NODATA to be defined. It should be IFDEF'd like it is in ntpdc.c and ntpq.c. Bug #611 is filed. - John John Kline wrote: > ntp-dev-4.2.1p250-RC > > It seems ntpd_intres.c in this RC needs EAI_NODATA to be defined. It > should be IFDEF'd like it is in ntpdc.c and ntpq.c. > > Bug #611 is filed. > There was a bug report #438 on exactly the same issue but this is a situation where it just got reintroduced. #ifdef is probably the best solution here. I was just reading RFC 3493 which is informat...

Another 'can't get mysql server to run' post (6.0RC1)
Here is what is in place so far: 6.0RC1 mysql-4.15 I have installed mysql41-server from the ports Placed 'enable_mysql="YES"' and mysql_dbdir="/var/db/mysql" in rc.conf Run /usr/local/bin/mysql_install-db, creating a brand new mysql directory. I changed ownership of /var/db/mysql to root:wheel (and also root:mysql) I changed everything inside that to mysql:mysql. Nothing works. Not mysqld_safe --user=mysql --datadir=/var/db/mysql Not /usr/localetc/rc.d/mysql-server.sh start Not /usr/local/share/mysql/mysql.server start Nothing. /var/log/messages g...

Can't upgrade from 6.0 to 7.0
I've been trying to upgrade to or fresh install version 7.0 of the Acrobat Reader but can't get it to run. Version 6 is fine but if I try and do anything with version 7 it seems to do nothing (or perhaps it shuts down so quick nothing appears on screen?). I get no error messages or any events in the event logs. I've removed 7.0 and reinstalled 6.0 and all is well again. I'm at a complete loss as to how to proceed. Any ideas? Any chance that you just installed SP2 on Win XP? That may be the problem "CWatters" <colin.watters@pandoraBOX.be> wrote in message news...

[News] Breaking Evil Myths: Linux Users Can't Play; Can't Run Windows Applications
Because penguins need to play too. ,----[ Quote ] | The Windows camp have a lot of great games to play and a popular | misconception is that Linux is lacking in games. That is not true. | There are literally thousands of games for Linux. In fact a lot of | them have been ported to Windows too. | | [...] | | There are both free and commercial games available. Some of the best | ones I really like are America's Army, Tremulous and Enemy Territory. `---- http://blogs.ittoolbox.com/linux/locutus/archives/because-penguins-need-to-play-too-14767 Run Windows Apps on Linux using 2X Applicat...

Can't connect to X11 window server using ':0.0'
Hi All, I'm trying to run a standalone application on solaris machine ,encountered the following problem. How to go about it. Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable. at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method) at sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:1 34) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:141) at java.awt.GraphicsEnvironment.getLoca...

Can't connect to X11 window server using 'localhost:0.0'
Hi. I'm using sendmail 8.12.9 for a project on RedHat Fedora Core 2 on my personal computer with a perfectly finctioning X window server. Part of this project requires me to modify sendmail to open a gui application. When I attempted this originally, I got the following error: "No X11 DISPLAY variable was set, but this program performed an operation which requires it." Figuring that sendmail for whatever reason unset it, I added called setenv() to set it and got the following error: "Exception in thread "main" java.lang.InternalError: Can't connect to X11 wind...

I can't install FreeBSD
I am attempting to install FreeBSD 4.11 . I had previously had 4.8 on the same machine, but I upgraded one of my hard disks and did not transfer the unix partition. I replaced my 4.8 files with 4.11 and made new floppies. After the kernel configuration, it froze on ata0 .. (can't remember right now, but someone probably knows). I then made new floppies, making sure they formatted right in DOS; the same thing happened. I had 4.8 running previously, so I wouldn't think it was an incompatibility (which shouldn't happen anyhow). What is it? Andrew Usher Andrew Usher...

autopsy can't/won't run
All, I'm trying to get the sleuthkit/autopsy suite working on a 4.11 box. sleuthkit dumps data from a partition image fine but when I run autopsy (built either from ports or the sleuthkit site's source tarball I get stuff like this: exists operator argument is not a HASH element at /home/rloef/downloads/autopsy-2.05/lib//Caseman.pm line 2815. BEGIN failed--compilation aborted at /home/rloef/downloads/autopsy-2.05/lib//Main.pm line 49. BEGIN failed--compilation aborted at ./autopsy line 58. I've copied all the perl modules into the perl directory, and they're ex...

Can't ssh to freebsd
....so I am returning to FreeBSD after an absence; seems I've forgotten how to do sys admin. When I attemp to ssh to my new box, it accepts my uid/pw and then says "Access denied" Your help in resolving this is greatly appreciated. Thanx, -Mike michael.goodrich@gmail.com wrote: > ...so I am returning to FreeBSD after an absence; seems I've forgotten > how to do sys admin. > When I attemp to ssh to my new box, it accepts my uid/pw and then says > "Access denied" > > Your help in resolving this is greatly appreciated. > > Thanx, > > -Mike if you ssh into your freebsd with root, make sure change the line "PermitRootLogin No" to "PermitRootLogin Yes" in the /etc/ssh/sshd_config file, then issue a commandline "/etc/rc.d/sshd restart". S sam <sam@boychip.net> wrote: > michael.goodrich@gmail.com wrote: >> ...so I am returning to FreeBSD after an absence; seems I've forgotten >> how to do sys admin. >> When I attemp to ssh to my new box, it accepts my uid/pw and then says >> "Access denied" >> >> Your help in resolving this is greatly appreciated. > > if you ssh into your freebsd with root, make sure change the line > "PermitRootLogin No" to "PermitRootLogin Yes" in the > /etc/ssh/sshd_config file, then issue a commandline "/etc/rc.d/sshd &...

Can't compile 2.6.0 on mac OSX 10.4/GCC 4.0
Hello, I am trying to compile wxMac 2.6.0 on a recently upgraded OSX 10.4, with Xcode 2.0 and GCC 4.0 installed. It fails with: ../bk-deps g++ -c -o coredll_webkit.o -I.pch/wxprec_coredll -D__WXMAC__ -I../src/tiff -I../src/jpeg -I../src/png -I../src/expat/lib -DWXUSINGDLL -DWXMAKINGDLL_CORE -DwxUSE_BASE=0 -dynamic -fPIC -DPIC -DWX_PRECOMP -DNO_GCC_PRAGMA -Ilib/wx/include/mac-ansi-release-2.6 -I../include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -fpascal-strings -I../src/mac/carbon/morefilex -I/Developer/Headers/FlatCarbon -O2 -Wall -Wno-ctor-dtor-privacy -fno-common ../src/htm...

3*x''+(10^-3)*x'+123*x=2*cos(3*t); x=x(t);initial conditions x(0)=0 and x'(0)=0
Hi everybody, I need to solve the Cauchy problem written in the title box ( I paste it here again ): 3*x''+(10^-3)*x'+123*x=2*cos(3*t); x=x(t);initial conditions x(0)=0 and x'(0)=0. I tried with Runge-Kutta method and it seems to work as the solution x(t) is the same that I can get solving the equation by myself. I need to know if it would be better another method (eventually multistep one) and why it would be better (please don't just tell me 'cause it's faster or so...I need to know the why too). As last thing I need to estimate the error committed with Runge...

Does Labview run-time engine 6.0 application created by Windows NT/2000 can install & run on UNIX
LabVIEW exe created in Windows and running in UNIX LabVIEW source code from one OS can be ported to another OS (except for OS specific things like ActiveX) but executables cannot. You would need the unix version of LabVIEW and it's app builder to create an new exe. ...

Web resources about - Can't run Azureus on FreeBSD 6.0/JDK15/Gnome - comp.unix.bsd.freebsd.misc

Resources last updated: 2/25/2016 9:23:33 PM