f



why does pkg want to install perl5.20?

"pkg audit" warns that curl needs to be upgraded.  OK.

# pkg upgrade curl
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
The following 3 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        libnghttp2: 1.17.0
        perl5.20: 5.20.3_15             [ <=== Why? ]

Installed packages to be UPGRADED:
        curl: 7.51.0 -> 7.51.0_5

Number of packages to be installed: 2

Checking dependencies of curl:
# pkg query %dn curl
ca_root_nss

# pkg rquery %dn curl
libnghttp2
ca_root_nss

so that explains installing libnghttp2.

# pkg rquery %dn libnghttp2
(nothing)

# pkg rquery %dn ca_root_nss
(nothing, as expected)

In fact,
# pkg rquery %rn perl5.20
(nothing) !

So why does pkg want to install the ancient/outdated perl5.20?
It's not the first time I've seen pkg do this sort of thing.

I wish there were a "pkg upgrade --explainyourself" switch.  :-/
 -WBE
0
Winston
12/24/2016 1:01:01 AM
comp.unix.bsd.freebsd.misc 13187 articles. 1 followers. Post Follow

1 Replies
1079 Views

Similar Articles

[PageSpeed] 50

Winston <wbe@UBEBLOCK.psr.com.invalid> writes:
> In fact,
> # pkg rquery %rn perl5.20
> (nothing) !

Didn't think to check this before posting, but

# pkg query %rn perl5.20
(nothing)

as well.
 -WBE
0
Winston
12/24/2016 4:46:46 PM
Reply: