I can not find Tcl/expect after install Solaris 9

  • Permalink
  • submit to reddit
  • Email
  • Follow


Why can i not find tcl/expect utility after install
Solaris 9?
The Perl is there.

TIA,

ST
0
Reply aaabbb16 2/25/2005 7:47:35 AM

See related articles to this posting


In article <dc998cfd.0502242347.41afa831@posting.google.com>,
 aaabbb16@hotmail.com (wld) wrote:

> Why can i not find tcl/expect utility after install
> Solaris 9?
> The Perl is there.
> 
> TIA,
> 
> ST

AFAIK, tcl/expect aren't part of the vanilla install.  There's a bunch 
of extra stuff in /opt/sfw, I think.  I know older versions of Solaris 
better where the full install didn't offer these extra packages unless 
you installed them afterwards.

-- 
DeeDee, don't press that button!  DeeDee!  NO!  Dee...



0
Reply Michael 2/25/2005 8:39:42 AM

According to wld <aaabbb16@hotmail.com>:
:Why can i not find tcl/expect utility after install
:Solaris 9?
:The Perl is there.

Well, Sun doesn't ship with either tclsh or expect installed in /bin .
If you loaded the optional software cd - the one with gcc, etc. on it,
then look in /opt/sfw/bin for tclsh8.3 and expect.  It appeas that
the optional software distribution has only this small amount of the
hundreds of Tcl extensions available. 

Anyone know to whom one would talk to so that more extensions might be
included - such as, say, Tk?
-- 
<URL: http://wiki.tcl.tk/> MP3 ID tag repair < http://www.fixtunes.com/?C=17038 >
Even if explicitly stated to the contrary, nothing in this posting
should be construed as representing my employer's opinions.
<URL: mailto:lvirden@gmail.com > <URL: http://www.purl.org/NET/lvirden/ >
0
Reply lvirden 2/25/2005 2:21:55 PM

In article <cvnca3$mlh$1@srv38.cas.org>,  <lvirden@gmail.com> wrote:
>
>According to wld <aaabbb16@hotmail.com>:
>:Why can i not find tcl/expect utility after install
>:Solaris 9?
>:The Perl is there.
>
>Well, Sun doesn't ship with either tclsh or expect installed in /bin .
>If you loaded the optional software cd - the one with gcc, etc. on it,
>then look in /opt/sfw/bin for tclsh8.3 and expect.  It appeas that
>the optional software distribution has only this small amount of the
>hundreds of Tcl extensions available. 
>
>Anyone know to whom one would talk to so that more extensions might be
>included - such as, say, Tk?
			.
			.
			.
On a bad day, I have the impression that it would be less
trouble to buy all of Sun, than to try to go through chan-
nels to achieve what ought to be a simple result like 
including Tk in /opt/sfw/bin.

On a technical basis, I find a lot to like in Solaris.  SMC
sure doesn't line up its products for *my* convenience,
though.
0
Reply claird 2/25/2005 4:08:04 PM

On Fri, 25 Feb 2005 14:21:55 +0000, lvirde wrote:

> 
> According to wld <aaabbb16@hotmail.com>:
> :Why can i not find tcl/expect utility after install
> :Solaris 9?
> :The Perl is there.
> 
> Well, Sun doesn't ship with either tclsh or expect installed in /bin .

Quite so.  tclsh is /usr/sfw/bin/tclsh8.4 in s10_72.  expect is not
included.

.....

> Anyone know to whom one would talk to so that more extensions might be
> included - such as, say, Tk?

Tk is included with Solaris and has been for quite some time in package
SUNWTk.

0
Reply Dave 2/25/2005 4:34:38 PM

Ah - I don't have any control over what solaris packages are loaded -
and that isn't one loaded here.  Plus I've only got Solaris 8 ...
perhaps it is a Sol 10 thing.

Thanks for the update though!

0
Reply Larry 2/25/2005 5:36:20 PM

On Fri, 25 Feb 2005 09:36:20 -0800, Larry W. Virden wrote:

> Ah - I don't have any control over what solaris packages are loaded -
> and that isn't one loaded here.  Plus I've only got Solaris 8 ...
> perhaps it is a Sol 10 thing.

You can use pkginfo to see if SUNWTcl and SUNWTk are installed.  I know
they were part of Solaris 9; don't remember about Solaris 8, but probably
not.  IIRC the whole /usr/sfw thing came about with Solaris 9 and that is
the version number in the Subject.

0
Reply Dave 2/25/2005 5:44:58 PM

Cameron Laird wrote:
> On a bad day, I have the impression that it would be less
> trouble to buy all of Sun, than to try to go through chan-
> nels to achieve what ought to be a simple result like 
> including Tk in /opt/sfw/bin.

It's there in Solaris 10, I believe.

  - Logan
0
Reply Logan 2/26/2005 3:04:02 AM

In article <pan.2005.02.25.17.44.58.108477@yahoo.com>, Dave Uhring wrote:
> On Fri, 25 Feb 2005 09:36:20 -0800, Larry W. Virden wrote:
>> Ah - I don't have any control over what solaris packages are loaded -
>> and that isn't one loaded here.  Plus I've only got Solaris 8 ...
>> perhaps it is a Sol 10 thing.
> You can use pkginfo to see if SUNWTcl and SUNWTk are installed.  I know
> they were part of Solaris 9; don't remember about Solaris 8, but probably
> not.  IIRC the whole /usr/sfw thing came about with Solaris 9 and that is
> the version number in the Subject.

Distinctly remember /opt/sfw on 8/SPARC.

lg, Bernd
-- 
There was only one road back to L.A.
0
Reply Bernd 3/1/2005 12:34:29 PM

On Tue, 01 Mar 2005 13:34:29 +0100, Bernd Haug wrote:

> In article <pan.2005.02.25.17.44.58.108477@yahoo.com>, Dave Uhring wrote:

>> You can use pkginfo to see if SUNWTcl and SUNWTk are installed.  I know
>> they were part of Solaris 9; don't remember about Solaris 8, but probably
>> not.  IIRC the whole /usr/sfw thing came about with Solaris 9 and that is
>> the version number in the Subject.
> 
> Distinctly remember /opt/sfw on 8/SPARC.

Yes, from the Software Companion CD.  But those packages had the SFW tag,
not SUNW.  Solaris 9 SCCD also installed its packages into /opt/sfw.

0
Reply Dave 3/1/2005 1:34:31 PM
comp.unix.solaris 25797 articles. 88 followers. Post

9 Replies
1171 Views

Similar Articles

[PageSpeed] 46


  • Permalink
  • submit to reddit
  • Email
  • Follow


Reply:

Similar Artilces:

Solaris 9 x86 install can't find DHCP server
I'm having trouble installing Solaris 9 on my PC. I'm using a Kingston NIC (the Solaris 9 install successfully recognizes the card as DEC 21140 Fast Ethernet, dnet0. The card worked with a previous Solaris 8 install with no hassle.) I have Windows XP on the same box and the card works ok. After selecting DHCP and waiting for several minutes for detection I get this response: "Could not contact a dhcp server on the network interface dnet0" I have a broadband connection with a cable router which I've bypassed for troubleshooting and I still get the same error. ...

Can you install Solaris 9 into a Solaris 9 container?
I found a lot of documentation about installing a Solaris 9 flar into a Solaris 9 container. Can you install Solaris 9 from media into a container? B. On 04/18/11 11:44 AM, Bartholomew wrote: > I found a lot of documentation about installing a Solaris 9 flar into a > Solaris 9 container. Can you install Solaris 9 from media into a container? I don't think so. AFAIR it works only with a flar or ufsdump. On 2011-04-18 17:04:28 +0100, Oscar del Rio said: > On 04/18/11 11:44 AM, Bartholomew wrote: >> I found a lot of documentation about installing a Solaris 9 flar into a ...

How to install/find the 3 of 9 barcode on Solaris 9 ?
anyone know where I can download this font to install on my Solaris box? Need detailed instructions. thanks. BartonekDragRacing@Yahoo.com writes in comp.unix.solaris: |anyone know where I can download this font to install on my Solaris |box? Need detailed instructions. thanks. Solaris supports most of the standard font formats, including TrueType, PostScript Type 1, PostScript Type 3, and BDF, so you don't need to find a Solaris font for it - just a TrueType or PostScript font for it. -- Alan Coopersmith * alanc@alum.calberkeley.org * Alan.Coopersmith@Sun.COM http://blogs.sun.co...

Can't find a usable init.tcl ... Tcl wasn't installed correctly
I built a toy tcl/tk program with an embedded interpreter. It works as expected under Linux. When I run the program from the Windows XP command prompt, initialization of the embedded interpreter fails, returning a message like: ----------------------------------------------------------- Can't find a usable init.tcl in the following directories: This probably means that Tcl wasn't installed correctly. ----------------------------------------------------------- I tried again after executing SET TCL_LIBRARY=C:\Tcl\Lib\tcl8.4 from the command prompt, and the Tcl_Init call succe...

Help: After installing tcl8.5.2, the expect "Can't find Expect library"
After installing ASPN TCL 8.5.2, I ran Expect demo code by c:\tcl\bin\tclsh85.exe beer.tcl #!/bin/sh # \ exec tclsh "$0" ${1+"$@"} # This is required to declare that we will use Expect package require Expect I got the error of "Can't find package Expect" while executing beet.tcl This happened after I installing TCL8.5.2 over TCL 8.4. The Tcl8.4 didn't have this issue. Any help will be highly appreciated. Thanks, Young Did you pull down (via teacup) the Expect extension. yongyan.wang@gmail.com wrote: > After installing ASPN TCL 8.5.2, I ra...

Install tcl 8.4 error, Can't find a usable init.tcl in the following directories
I build tcl 8.4.10 on Solaris 8, compile ok, but get error when running "make test" I run: configure --prefix=/users/xucai --exec-prefix=/users/xucai --enable-shared --enable-gcc //ok make //ok make test // this step failed. and get following error: LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}; export LD_LIBRARY_PATH; \ TCL_LIBRARY="/users/xucai/src/tcl8.4.10/library"; export TCL_LIBRARY; \ ../tcltest ./../tests/all.tcl application-specific initialization failed: Can't find a usable init.tcl in the following directories: /users/xucai/src/tcl8.4.10/...

After Solaris 9 full install: How can I turn off port 1720
I have installed "all" the Solaris 9 software on the 9/05 distribution CDs, including companion CDs. I see via NMAP that TCP port 1720 is listening. A netstat -a does not show the port listening. If I use the old "telnet to port 1720" it does connect...I just wanted to validate NMAP...I should never have doubted NMAP... ;-) First part of my question is why is it that port 1720 does not show up as listening via netstat -a ? Is there a global listener like RPC or something? Second part is does anyone know where to disable the H.323/port 1720 processes or listener? Plea...

Where can I find a better Solaris 10 Network installation guide?
I need to Install Solaris 10 on a SUN T1000 worksation (SPRAC no CD/DVD ROM) and it can't be booted by itself. so I can tell it only have mac addr, but no IP addr. I followed a guide and used setup_install_server, and share as NFS. copied jumpstart rules (any machine) added client with mac addr. them "boot net -i install" on the client T1000 it seems the T1000 have connected to the Install server. the LAN LED on both two machine are blinking simultaneously. but the T1000 will get a panic CPU(20) error. when it try to give it self a hostname "whoami" It seems som...

Can't ping network on fresh install Solaris 9
I am trying to install Solaris 9/X86 on a KT400 chipset which uses a RealTek 8100 series NIC. I downloaded the realtek driver and ran the install script. If I do a ifconfig -a I see the interface with a MAC address: rtls0: flags: 1000843<UP BROADCAST>, RUNNING, MULTICAST, IPv4,> mtu 1500 index 2 inet 192.168.0.37 netmask ffffff00 broadcast 192.168.0.255 ether 0:20:ed:90:b6:1a prtconf: pci10ec, 8139, instance #0 netstat -rn dest gateway flags ref use interface 192.168.0.0 192.168.0.37 U 1 53 rtls0 127.0.0.1 120.0.0.1 UH 22 10098 lo0 /etc/hosts: 127.0.0.1 localhost 192.168.0...

core install of Solaris 9 (sparc) package list can be trimmed ?
All: I just installed Solaris 9 4/03 onto a Netra T1 AC 105 and I chose the core install cluster. This is a server that will have very specific reasons for running and thus I don't need much on it except the OS bare bones. The big question is, what is bare bones? The package list for a core install is very large still and there are some obvious things that can be pkgrm'd but what are the not so obvious packages? The list, untouched, is as follows : system SMEvplr SME platform links system SMEvplu SME usr/platform links system SUNWadmr ...

Where I can find 3Com 3C905B-TX NIC driver for Solaris 9 SPARC version
Does anyone know where I can find 3Com 3C905B-TX NIC driver for Solaris 9 SPARC version? I want to install one on my Blade 150 machine. In article <mABgd.15327$6q2.14248@newssvr14.news.prodigy.com>, "Hsien-Cheng Li" <Hsien-Cheng_Li@sbcglobal.net> wrote: > Does anyone know where I can find 3Com 3C905B-TX NIC driver for Solaris 9 > SPARC version? I want to install one on my Blade 150 machine. 3Com doesn't seem to make such beasties. Any reason why you're not using a supported NIC so you don't have to go through this hassle with discontinued hard...

Installing Solaris 10 or Solaris 9
Hi there, I have an old Sun Box, is an Ultra SPARC-IIi 300MHz, right now I am using Solaris 9. I have a two parts question, first one is, can I install Solaris 10 on this machine?, maybe is just to outdated for it. Second question is, can I download all the Solaris 9 software from "www.sun.com" as DVD, into a Windows XP box, them burn them as a DVD, will it work on my Sun Box?, or once I download them in to the Windows box, do I have to expand each zip file, them burn them into a DVD, and again the same question will it work on the Sun Box? Thanks. Alfonso G. Urroz "Alfonso...

Oracle 9.2.0.1 installation on Solaris 9
Hello all, I have installed 'enterprise editon' of 64-bit Oracle 9i(9.2.0.1) on a solaris 9 machine. I use the library(libclntst9.a) from this installation to link my OCI code. But I am facing symbol referencing errors as follows: ------- kolacbktab /mainline/libraries/oracle/solaris/lib64/libclntst9.a(kola.o) kpupftv7 /mainline/libraries/oracle/solaris/lib64/libclntst9.a(ttcdrv.o) kgupntb /mainline/libraries/oracle/solaris/lib64/libclntst9.a(kgupi.o) slxlobc /mainline/libraries/oracle/solaris/lib64/libclntst9.a(lxinitc.o) slxlobj /mainline/libraries/oracle/solaris/lib64/libclntst9.a(...

packages needed for gcc installation on Solaris 9 core install
I am trying to build a barebones solaris 9 webserver (Apache, Mysql, Php, Perl). I do a default core installation and am having trouble getting the gcc-3.3.2 binary from sunfreeware.com to run (error is No AS). I believe I do not have all the necessary SUNW packages installed. The comments on sunfreeware say "To use the gcc package from sunfreeware.com you MUST install all of the SUNW deveoper packages that come on Sun's Solaris CDs.". Does anyone know of a list of packages which must be installed on top of a core install to get gcc to work? I saw on post which refered to t...

Help installing Bind 9.2.3 on Solaris 9 Sparc
I have downloaded Bind 9.2.3 to install on a Solaris 9 box running on Sparc. I previously installed OpenSSL. THe entire build goes fine. However, after doing a make install, nothing is installed. There are no new binaries anywhere and when in.named runs it is my old version 8.n running. Am I overlooking something ? When I build bind on Linux or such it sets up /var/named and the files, /etc/named.conf, and everything else. FYI, I installed from /tmp. Many thanks Mark (remove the .not4spam in my email to reply directly) Mark Voss <voss001@yahoo.com.not4spam> wrote...

Can't upgrade Solaris 7 to Solaris 9 4/03
Dear experts, we are trying to upgrade our Ultra 10 with Solaris 7 to Solaris 9. The installation process shows us: ......... ......... ... To perform an upgrade of the Solaris Operating Environment select Upgrade. The Solaris Operating Environment will be updated and other contents on the hard disk will be left unchanged. Backing up the existing Solaris Operating Environment is recommended. 1. Initial Install 2. Upgrade Install Select Upgrade or Initial install [1] 2 Gathering upgrade information, please wait... \ At this moment a new window appeared with: Could not reinitialize syste...

Expect with TCL on Solaris
Hi , This might not be the most appropriate user group to post this but since I am struggling with this, any thoughts can be real helpful. I am facing some problem trying to install an expect interpreter coz' it says it cant find the ./configure of the tcl. According to the installation document I did a ln -s "ln -s /usr/sfw/bin/tclsh8.3 .." But it still gives me this error. bash-3.00# ./configure configuring Expect 5.43.0 checking for autoconf... no checking configure up to date... yes checking host system type... sparc-sun-solaris2.10 checking target system type... sparc-sun-s...

solaris 9 install
I have a sun ultra 10 with no OS and i got my hands on the solaris 9 disks. I tried to install by just having the cd in the drive and it gives me timeout waiting for ARP/RARP packet. It is hooked up to the network but i want it to start the install from cd. How do i do this. Thanks In article <1103569851.961791.323490@c13g2000cwb.googlegroups.com>, <dot_txt@hotmail.com> wrote: >I have a sun ultra 10 with no OS and i got my hands on the solaris 9 >disks. I tried to install by just having the cd in the drive and it >gives me timeout waiting for ARP/RARP packet. It is hook...

Solaris 9 Install
Just installed Solaris 9. Have some observations and some questions. 1. The disk slice sizes recommended by webstart install are ridiculously small 2. I set the disk slice sizes pretty well BUT ... o I didn't realize Solaris only allows 8 slices o So I now have 2GB unusable space *before* the root partition thinking I'd add a slice later + No practical way to make that usable I guess? 3. Languages aren't installed automatically. o My Sun Blade came with a buncha languages installed. o The Sol 9 box set only came with a few languag...

Solaris 9 installation
Hello everyone ! Is it possible to install Sun Solaris 9 intel version on a classical PC running Windows 2000 ? Thank you for your help ! "J�r�me" <nospam@aa.org> writes: >Is it possible to install Sun Solaris 9 intel version on a classical PC >running Windows 2000 ? Check the hardware compatibility list for your system and associated hardware -- "classical PC" is too vague. "J�r�me" <nospam@aa.org> wrote in message news:<3fc5d9a6$0$28616$636a55ce@news.free.fr>... > Hello everyone ! > Is it possible to install Sun Solaris 9 in...

Installing Solaris 9
Hello: This is the first go around with Solaris for me and have a couple of questions. We have an Ultrasparc 60 that we have no idea what the root password is. It's running ver 5.7 so our idea was to install a fresh copy of 9.0. Problem is, this things boots to graphical mode and I have no idea how to change it so I can boot to cd. Any help appreciated. Thanks Ok JS Get the Solaris 9 media ready. Use disk 1 and 2 NOT the "install" disk. Put disk 1 in the cdrom drive.Shut down the machine- you might have to use the hard power switch. Boot up the machine and press and hold t...

dvipdfm can but dvipdfmx can't find font which installed for MikTeX for windows
the font map added manually first generate the pdf file using dvipdfm then i added some chinese, the dvipdfmx wouldn't work he said he couldn't find the font ...

PHP install core dump "make install" PEAR on solaris 9
php has been configured with the following two configure lines and core's during "make install" on the PEAR section. Is there something simple i'm missing? Any help would be appreciated. Environment: Solaris 9 php 5.2.1 GNU Make 3.81 gcc 4.1.1 ../configure --prefix=/opt/foo/php5 --enable-force-cgi-redirect -- enable-discard-path --enable-fastcgi --with-curl=/opt/foo --enable- sockets --with-zlib=/opt/foo --with-libxml-dir=/opt/foo --with- openssl=/opt/foo --with-nsapi=/opt/foo/sunone/current --enable-ftp -- with-ldap=/opt/foo/openldap --with-snmp=/opt/foo/net-snmp --e...

OSX: Can't install RMagick. Can't find the ImageMagick lib
Hi all I'm trying to install RMagick because one of my used plugins for RoR needs it. But I have no idea how to do this. So I just tried sudo gem install rmagick But I'm getting the following error: Building native extensions. This could take a while... ERROR: Error installing rmagick: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb install rmagick checking for Ruby version >= 1.8.2... yes checking for gcc... yes checking for Magick-config... yes checking for ImageMagick version >= 6.3.0... yes c...