f



Trouble compiling qt-x11-free-3.3.3 Solaris 8 SPARC g++ 3.4.3 gmake 3.79.1

QTDIR=/usr/local/src/qt
PATH=$QTDIR/bin:$PATH
MANPATH=$QTDIR/doc/man:$MANPATH

export QTDIR PATH MANPATH

cd $QTDIR

../configure -platform solaris-g++ && gmake

This results in:

[...]
g++ -c -Wall -W -O2 -fPIC -DQT_SHARED -DQT_NO_DEBUG -DQT_NO_CUPS
-D_LARGEFILE_SOURCE -D_LARGE_FILES -D_FILE_OFFSET_BITS=64
-DQT_NO_XINERAMA -DQT_NO_XCURSOR -DQT_NO_XRANDR -DQT_NO_XRENDER
-DQT_NO_XFTFREETYPE -DQT_NO_IMAGEIO_MNG -DQT_NO_IMAGEIO_JPEG
-DQT_NO_STYLE_MAC -DQT_NO_STYLE_AQUA -DQT_NO_STYLE_INTERLACE
-DQT_NO_STYLE_WINDOWSXP -DQT_NO_STYLE_COMPACT -DQT_NO_STYLE_POCKETPC
-I/usr/local/src/qt-x11-free-3.3.3/mkspecs/solaris-g++ -I.
-I3rdparty/libpng -I3rdparty/zlib -I../include
-I/usr/openwin/share/include -I/usr/openwin/share/include
-I.moc/release-shared/ -o .obj/release-shared/qpainter_x11.o
kernel/qpainter_x11.cpp
In file included from kernel/qt_x11_p.h:66,
from kernel/qpainter_x11.cpp:48:
/usr/openwin/share/include/X11/Xlib.h:32: warning: ignoring #pragma
ident
In file included from kernel/qt_x11_p.h:71,
from kernel/qpainter_x11.cpp:48:
/usr/openwin/share/include/X11/Xutil.h:56: warning: ignoring #pragma
ident
In file included from kernel/qt_x11_p.h:72,
from kernel/qpainter_x11.cpp:48:
/usr/openwin/share/include/X11/Xos.h:33: warning: ignoring #pragma
ident
g++: Internal error: Bus Error (program as)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
gmake[2]: *** [.obj/release-shared/qpainter_x11.o] Error 1
gmake[2]: Leaving directory `/usr/local/src/qt-x11-free-3.3.3/src'
gmake[1]: *** [sub-src] Error 2
gmake[1]: Leaving directory `/usr/local/src/qt-x11-free-3.3.3'
gmake: *** [init] Error 2
Can anyone offer any suggestions? I'd appreciate it.

Griff

0
1/4/2005 9:30:06 PM
comp.unix.solaris 26025 articles. 2 followers. Post Follow

2 Replies
1262 Views

Similar Articles

[PageSpeed] 41

Please excuse my idiocy. The filesystem was out of space.

Of course, it would have helped if gmake had not swallowed the error
message from as.
I happened to run just regular make, in desperation, and that showed me
the error from
as about the disk space being gone.

Griff

0
griff
1/4/2005 9:49:14 PM
griff.miller@positron.com wrote:

> g++: Internal error: Bus Error (program as)
> Can anyone offer any suggestions? I'd appreciate it.

My guess - you might be running out of memory/RAM. What are the specs of 
this machine? Version of gcc, OS etc.

Compiling QT is really not the faint of heart! :)

-Bruno
0
Bruno
1/4/2005 10:06:22 PM
Reply:

Similar Artilces:

Is there any difference of g++ 3.4.3 and g++ 3.3.4 ?
HI, my source code was compiled ok in g++ 3.3.4 . But when I try to use 3.4.3 to compile, I get the following error: Utility.h: In constructor `Buffer<size>::Buffer(const char*)': Utility.h:174: error: `buffer' undeclared (first use this function) Utility.h:174: error: (Each undeclared identifier is reported only once for each function it appears in.) Utility.h:176: error: no matching function for call to `strchr(<type error>, char)' /usr/include/iso/string_iso.h:130: note: candidates are: char* strchr (const char*, int) /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/.....

Compiling FFTW 3.0.1 with gcc 3.3 on Solaris
I'm attempting to build the FFTW package as a shared library on Solaris 8 using gcc 3 - without much success. I've seen other folks on this group using FFTW so maybe somebody else can help me, or point me in the direction of another group. The configure seems to work fine: ../configure --enable-shared and FFTW compiles fine but fails on the final link step. The failing link line is: /usr/ccs/bin/ld -G -h libfftw3.so.3 -o .libs/libfftw3.so.3.0.1 -z allextract kernel/.libs/libkernel.al simd/.libs/libsimd.al dft/.libs/libdft.al dft/codelets/.libs/libdft_codelets.al dft/codelets/stand...

Error while ACE 5.3.1 or 5.4.1 compiling and installing by MinGW 3.3.3
Hi, I have installed MinGW packages: binutils-2.13.90-20030111-1.tar.gz gcc-core-3.3.3-20040217-1.tar.gz gcc-g++-3.3.3-20040217-1.tar.gz mingw-runtime-3.3.tar.gz w32api-2.5.tar.gz Also I've configured environment due to ACE-INSTALL.html according MinGW compiler. OS: WinXP SP2. $ACE_ROOT=F:\ACE531 I get next compiling error: F:\ACE531\ace>gmake gmake.EXE[1]: Entering directory `F:/ACE531/ace' d:\Utils\Unix\diff.EXE: -: Invalid argument gmake.EXE[1]: Leaving directory `F:/ACE531/ace' gmake.EXE[1]: Entering directory `F:/ACE531/ace' d:/Utils/Unix/gmake.E...

how can i write this statement labels=[1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;3;]; in compress fo
How to write it in compact form to avoid repetition "shah " <shahkhn3@gmail.com> wrote in message <lodugh$8hr$1@newscl01ah.mathworks.com>... > How to write it in compact form to avoid repetition You'll find in this thread different solutions for similar question http://www.mathworks.fr/matlabcentral/newsreader/view_thread/335814 Bruno ...

Is there a g++ 3.4.3 (or better) binary available for AIX 4.3.3 ?
Have tried compiling gcc/g++ 3.4.3 from the UCLA Web site but after resolving several problems got stuck in building libstdc++.a: Assembler: /tmp//ccYxSLZd.s: line 4674: .set operand undefined or forward reference /tmp//ccYxSLZd.s: line 4675: .set operand undefined or forward reference /tmp//ccYxSLZd.s: line 4705: .set operand undefined or forward reference Any suggestions? TIA Jeffrey j3 wrote: > Have tried compiling gcc/g++ 3.4.3 from the UCLA Web site but after > resolving several problems got stuck in building libstdc++.a: > Assembler: > /tmp//ccYxSLZd...

gcc 3.3.10 on Power (AIX 3.3.3)
Is there any issue using this compiler on a Power RS/6000 ? Can it compile 64 bit? ...

Compilation problem when upgrading from g++ 3.3 to g++ 3.4
Hi, The code below has no problem with GNU g++ 3.3, but it has a problem with GNU g++ 3.4. What is reason for that? --------- [C++] foo.cpp : BEGIN --------- template <typename T> struct Boo { bool value_; }; template <typename T> struct Doo : public Boo<T> { Doo () {value_ = false;} // Line#10 }; int main() { Doo<int> inst; return 0; } --------- [C++] foo.cpp : END ---`-------- ------ Compilation with GNU gcc 3.3 (Cygwin) : BEGIN ------ $ g++ --version g++ (GCC) 3.3.3 (cygwin special) [---omitted---] $ g++ -W -Wall foo.cpp // No errors/warnings ------...

tkzinc 3.3.4 & 3.3.6+ ?
Hi ! Do anybody know what different between version 3.3.4 and 3.3.6+ ? And, where can I find documentation on tkzinc 3.3.6+ ? Thanks. ...

upgrade from 3.3 to 3.4
I keep on getting these error messages on my firewall box vrele: bad ref count: type VDIR, usecount 0, writecount 0, holdcount 1, tag VT_UFS, ino 3473483, on dev 0, 4 flags 0x1, effnlink 2, nlink 2 mode 040700, owner 2000, group 0, size 512 panic: vrele: ref cnt Seems to be always a bad ino within the mail queue, might even be related the my virus definition updating script haven't had a crash in 6 days with it disabled. Use to crash every 2nd day lately but before kind of random. My guess would be heavy I/O disk usage. I already have, squid+ntlm, apache, ...

compile 1.3.27 with php4.3.3 on aix 5.3
Has anyone any experience in compiling PHP 4.4.3 into apache 1.3.27 under AIX 5.3 ? Apache 1.3.27 was made successfully. But when trying to make the PHP 4.3.3, error occurs during doing the make The following are the details: ../configure --with-apxs=/opt/local/apache/bin/apxs make Lots of lots of cc lines (btw we used xlc of AIX C 5.0) until this line /bin/sh /opt/sw/php-4.3.3/libtool --silent --preserve-dup-deps --mode=co mpile cc -DAIX=1 -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -I/opt/local/apache/include -Isapi/apache/ -I/opt/sw/php-4.3.3/sapi/apache/ -DPHP_ATOM_INC -I/opt/sw/php-4. 3.3/in...

libc-2.3.3 and gcc-3.4.3 cross compiler
We are running embedded linux-2.4.21 on an ARM9 processor (Cirrus Logic with MaverickCrunch math coprocessor) and I have successfully cross-compiled a gnu toolchain on Windows (cygwin), Linux, and Solaris 2.8 (sparc). I am able to cross-build binaries on all platforms and run them on the ARM9 so it looks as if everything is running fine. My question is that the (glibc) libc-2.3.3.so that was built on Windows and Solaris is a different size from the one built on Linux and the one that is actually residing on the ARM9 board. I listed the maps (arm-linux-nm and sort) and notice...

Template construction in old gcc 3.3.3 does not compile in gcc 3.4.4
Hello! Below is a snippet that compiles in 3.3.3, but not in 3.4.4. Obviously, this is a result of the (laudable) efforts to make gcc more standards-compliant. Any way to get around this? gcc 3.4.4 complains that x is undeclared in the template definition. Thanks, Andrew Steiner ----------------------------------------------------------------------- #include <iostream> using namespace std; class parent { public: parent() { x=3.0; }; double x; }; template<class parent_t> class child : public parent_t { public: void test() { cout << x << endl; } ...

[ace-users] Re: Error while ACE 5.3.1 or 5.4.1 compiling and installing by MinGW 3.3.3
Hi Vitaly, Please upgrade to ACE 5.4.4, which you can download from http://deuce.doc.wustl.edu/Download.html since I think that is more likely to work with MinGW 3.3.3. Johnny, can you confirm/deny this please? Thanks, Doug >> Hi, >> I have installed MinGW packages: >> >> binutils-2.13.90-20030111-1.tar.gz >> gcc-core-3.3.3-20040217-1.tar.gz >> gcc-g++-3.3.3-20040217-1.tar.gz >> mingw-runtime-3.3.tar.gz >> w32api-2.5.tar.gz >> >> Also I've configured environment due to ACE-INSTALL.htm...

ABI information for 3.3 and 3.3.2
HI All, I'm looking to find out if there are any ABI differences between the VxWorks 3.3 and 3.3.2 tool chains regarding C++isms. My scenario is this: I am using the 3.3.2 tool chain to compile and link using VxWorks 5.5 headers and libraries against a mixture of C and C++. The second half of this equation factors in the fact tha I am also linking in 3rd party objects build and linked using against VxWorks 5.5 using the 5.5 libraries but built with the 3.3 tool chain. What I have here is really a difference in ABI's between the 3.3 (5.5) and 3.3.2 (.6.2) tools chains. Can anyone tel...

Web resources about - Trouble compiling qt-x11-free-3.3.3 Solaris 8 SPARC g++ 3.4.3 gmake 3.79.1 - comp.unix.solaris

Resources last updated: 1/24/2016 4:02:37 PM