f



How to upgrade a DB from 9.2.0.1 to 9.2.0.7 ???

Dear all,

I've just upgraded my Oracle software to version 9.2.0.7 because it corrects a
bug found in 9.2.0.1.

OK, now the bug disappeared... but ....

Now I cannot use anymore IMP and EXP. I face the following error :

------------8<------------------8<------------------

C:\Temp>exp ME/password@database file=exp_file owner=ME

Export: Release 9.2.0.7.0 - Production on Tue Oct 4 15:22:06 2005

Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.


Connected to: Oracle9i Enterprise Edition Release 9.2.0.7.0 - Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release 9.2.0.7.0 - Production
Export done in WE8MSWIN1252 character set and AL16UTF16 NCHAR character set

About to export specified users ...
.. exporting pre-schema procedural objects and actions
.. exporting foreign function library names for user ME
.. exporting PUBLIC type synonyms
.. exporting private type synonyms
.. exporting object type definitions for user ME
EXP-00008: ORACLE error 942 encountered
ORA-00942: table or view does not exist
EXP-00024: Export views not installed, please notify your DBA
EXP-00000: Export terminated unsuccessfully

------------8<------------------8<------------------


I looked for upgrade scripts/tools/info and the like... localy and on the net
(metalink, asktom, usenet, etc) without luck so far.

I found CATEXP.SQL and CATPATCH.SQL in %ORA_HOME%\rdbms\admin, but can't tell
wether this is for 9.2.0.1 or 9.2.0.7...

I also tried, just to mentioned, the "Database Upgrade Assistant", but it tells
me that my database is already in 9.2 format... Yes I know :-(

I can export & import data from a workstation that still has a 9.2.0.1 client
installed, so I suspect the problem is quite small, but I'd like to know.
Perhaps there is other issues that I did not find yet...

Can anyone give me any hints ?

My environment is :
- Windows 2000 server or Windows XP (databases on both platforms showing the
same behavior)
- Oracle 9.2.0.7 patch applied on a 9.2.0.1 server & client software.


Thanks in advance,

Charly
0
10/4/2005 2:39:40 PM
comp.databases.oracle.server 22978 articles. 1 followers. Post Follow

3 Replies
1328 Views

Similar Articles

[PageSpeed] 1

Did you run the post installation scripts against the database, as 
listed in the readme for the patch?

--Peter

Charly wrote:
> Dear all,
> 
> I've just upgraded my Oracle software to version 9.2.0.7 because it corrects a
> bug found in 9.2.0.1.
> 
> OK, now the bug disappeared... but ....
> 
> Now I cannot use anymore IMP and EXP. I face the following error :
> 
> ------------8<------------------8<------------------
> 
> C:\Temp>exp ME/password@database file=exp_file owner=ME
> 
> Export: Release 9.2.0.7.0 - Production on Tue Oct 4 15:22:06 2005
> 
> Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.
> 
> 
> Connected to: Oracle9i Enterprise Edition Release 9.2.0.7.0 - Production
> With the Partitioning, OLAP and Oracle Data Mining options
> JServer Release 9.2.0.7.0 - Production
> Export done in WE8MSWIN1252 character set and AL16UTF16 NCHAR character set
> 
> About to export specified users ...
> . exporting pre-schema procedural objects and actions
> . exporting foreign function library names for user ME
> . exporting PUBLIC type synonyms
> . exporting private type synonyms
> . exporting object type definitions for user ME
> EXP-00008: ORACLE error 942 encountered
> ORA-00942: table or view does not exist
> EXP-00024: Export views not installed, please notify your DBA
> EXP-00000: Export terminated unsuccessfully
> 
> ------------8<------------------8<------------------
> 
> 
> I looked for upgrade scripts/tools/info and the like... localy and on the net
> (metalink, asktom, usenet, etc) without luck so far.
> 
> I found CATEXP.SQL and CATPATCH.SQL in %ORA_HOME%\rdbms\admin, but can't tell
> wether this is for 9.2.0.1 or 9.2.0.7...
> 
> I also tried, just to mentioned, the "Database Upgrade Assistant", but it tells
> me that my database is already in 9.2 format... Yes I know :-(
> 
> I can export & import data from a workstation that still has a 9.2.0.1 client
> installed, so I suspect the problem is quite small, but I'd like to know.
> Perhaps there is other issues that I did not find yet...
> 
> Can anyone give me any hints ?
> 
> My environment is :
> - Windows 2000 server or Windows XP (databases on both platforms showing the
> same behavior)
> - Oracle 9.2.0.7 patch applied on a 9.2.0.1 server & client software.
> 
> 
> Thanks in advance,
> 
> Charly
0
10/4/2005 2:40:06 PM
Charly wrote:
> Dear all,
>
> I've just upgraded my Oracle software to version 9.2.0.7 because it corrects a
> bug found in 9.2.0.1.
>
> OK, now the bug disappeared... but ....
>
> Now I cannot use anymore IMP and EXP. I face the following error :
>
> ------------8<------------------8<------------------
>
> C:\Temp>exp ME/password@database file=exp_file owner=ME
>
> Export: Release 9.2.0.7.0 - Production on Tue Oct 4 15:22:06 2005
>
> Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.
>
>
> Connected to: Oracle9i Enterprise Edition Release 9.2.0.7.0 - Production
> With the Partitioning, OLAP and Oracle Data Mining options
> JServer Release 9.2.0.7.0 - Production
> Export done in WE8MSWIN1252 character set and AL16UTF16 NCHAR character set
>
> About to export specified users ...
> . exporting pre-schema procedural objects and actions
> . exporting foreign function library names for user ME
> . exporting PUBLIC type synonyms
> . exporting private type synonyms
> . exporting object type definitions for user ME
> EXP-00008: ORACLE error 942 encountered
> ORA-00942: table or view does not exist
> EXP-00024: Export views not installed, please notify your DBA
> EXP-00000: Export terminated unsuccessfully
>
> ------------8<------------------8<------------------
>
>
> I looked for upgrade scripts/tools/info and the like... localy and on the net
> (metalink, asktom, usenet, etc) without luck so far.
>
> I found CATEXP.SQL and CATPATCH.SQL in %ORA_HOME%\rdbms\admin, but can't tell
> wether this is for 9.2.0.1 or 9.2.0.7...
>
> I also tried, just to mentioned, the "Database Upgrade Assistant", but it tells
> me that my database is already in 9.2 format... Yes I know :-(
>
> I can export & import data from a workstation that still has a 9.2.0.1 client
> installed, so I suspect the problem is quite small, but I'd like to know.
> Perhaps there is other issues that I did not find yet...
>
> Can anyone give me any hints ?
>
> My environment is :
> - Windows 2000 server or Windows XP (databases on both platforms showing the
> same behavior)
> - Oracle 9.2.0.7 patch applied on a 9.2.0.1 server & client software.
>
>
> Thanks in advance,
>
> Charly

As part of the patch install process, you need to shutdown the
database, bring it up in limited fashion (startup migrate) and complete
the instructions in the readme file on how to install the patchset.

This should fix any of the oracle dictionary stuff that for example
export and import rely on.

0
johnbhurley (2707)
10/4/2005 3:08:08 PM
Hello again,

Thanks... I was just to affraid to run the patch script (wich I noticed as
mentioned in my previous message, but I wasn't sure about there version).

Finaly, once the backup done, I tried it, and it worked...

Thanks for replying...

Charly
0
10/4/2005 5:05:29 PM
Reply: