f



Eclipse problem (An Error has Occurred. See the log file)

hello there.

i just downloaded the lastest version of eclipse and tried to run it
but was impossible.
i just got an dialog box saying: 'An error has occurred. See the log
file. xxxxx.log'
i'm running tomcat 4.1 on the local. is that the problem?
i really have no idea. could somebody help me?




** following is the log file's content




!SESSION 2=EC=9B=94 17, 2005 18:21:52.210
----------------------------------------------
eclipse.buildId=3DM200409161125
java.version=3D1.3.1_01
java.vendor=3DSun Microsystems Inc.
BootLoader constants: OS=3Dwin32, ARCH=3Dx86, WS=3Dwin32, NL=3Dko_KR

!ENTRY org.eclipse.osgi 2=EC=9B=94 17, 2005 18:21:52.210
!MESSAGE Error registering XML parser services.
!STACK 0
java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClassInternal(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at
org.eclipse.core.runtime.adaptor.EclipseAdaptor.registerEndorsedXMLParser(E=
clipseAdaptor.java:272)
	at
org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStart(EclipseAdapt=
or.java:253)
	at
org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(System=
BundleActivator.java:61)
	at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleCont=
extImpl.java:958)
	at java.security.AccessController.doPrivileged(Native Method)
	at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(B=
undleContextImpl.java:954)
	at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleCont=
extImpl.java:937)
	at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(St=
artLevelManager.java:553)
	at
org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLev=
elManager.java:477)
	at
org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(=
StartLevelManager.java:273)
	at
org.eclipse.osgi.framework.internal.core.StartLevelManager.launch(StartLeve=
lManager.java:243)
	at
org.eclipse.osgi.framework.internal.core.SystemBundle.resume(SystemBundle.j=
ava:166)
	at
org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:42=
5)
	at org.eclipse.osgi.framework.internal.core.OSGi.launch(OSGi.java:51)
	at
org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java=
:216)
	at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:127)
	at java.lang.reflect.Method.invoke(Native Method)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
	at org.eclipse.core.launcher.Main.run(Main.java:704)
	at org.eclipse.core.launcher.Main.main(Main.java:688)

!ENTRY org.eclipse.osgi 2=EC=9B=94 17, 2005 18:21:52.300
!MESSAGE Startup error
!STACK 1
java.lang.NoClassDefFoundError: org/xml/sax/helpers/DefaultHandler
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.access$100(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClassInternal(Unknown Source)
	at
org.eclipse.core.runtime.adaptor.PluginConverterImpl.parsePluginInfo(Plugin=
ConverterImpl.java:557)
	at
org.eclipse.core.runtime.adaptor.PluginConverterImpl.fillPluginInfo(PluginC=
onverterImpl.java:111)
	at
org.eclipse.core.runtime.adaptor.PluginConverterImpl.convertManifest(Plugin=
ConverterImpl.java:660)
	at
org.eclipse.core.runtime.adaptor.EclipseBundleData.generateManifest(Eclipse=
BundleData.java:233)
	at
org.eclipse.core.runtime.adaptor.EclipseBundleData.loadManifest(EclipseBund=
leData.java:191)
	at
org.eclipse.core.runtime.adaptor.EclipseBundleData.getManifest(EclipseBundl=
eData.java:159)
	at
org.eclipse.core.runtime.adaptor.EclipseBundleData.loadFromManifest(Eclipse=
BundleData.java:280)
	at
org.eclipse.osgi.framework.internal.defaultadaptor.DefaultBundleData.initia=
lizeNewBundle(DefaultBundleData.java:77)
	at
org.eclipse.osgi.framework.internal.defaultadaptor.DefaultAdaptor$1.begin(D=
efaultAdaptor.java:451)
	at
org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(=
Framework.java:746)
	at
org.eclipse.osgi.framework.internal.core.Framework$2.run(Framework.java:664)
	at java.security.AccessController.doPrivileged(Native Method)
	at
org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.=
java:715)
	at
org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.=
java:659)
	at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(Bu=
ndleContextImpl.java:219)
	at
org.eclipse.core.runtime.adaptor.EclipseStarter.installBundles(EclipseStart=
er.java:800)
	at
org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseSta=
rter.java:429)
	at
org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java=
:222)
	at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:127)
	at java.lang.reflect.Method.invoke(Native Method)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
	at org.eclipse.core.launcher.Main.run(Main.java:704)
	at org.eclipse.core.launcher.Main.main(Main.java:688)

!ENTRY org.eclipse.osgi 2=EC=9B=94 17, 2005 18:21:52.320
!MESSAGE Bundle
initial@reference:file:c:/Eclipse/eclipse/plugins/org.eclipse.core.runtime_=
3=2E0.1/
[1] was not resolved.

0
2/17/2005 9:32:11 AM
comp.lang.java.softwaretools 2938 articles. 1 followers. Post Follow

4 Replies
3822 Views

Similar Articles

[PageSpeed] 16

On 17-2-2005 10:32, oceanicshot@yahoo.com wrote:

> hello there.
> 
> i just downloaded the lastest version of eclipse and tried to run it
> but was impossible.
> i just got an dialog box saying: 'An error has occurred. See the log
> file. xxxxx.log'
> i'm running tomcat 4.1 on the local. is that the problem?
> i really have no idea. could somebody help me?
> 
> 
> 
> 
> ** following is the log file's content
> 
> 
> 
> 
> !SESSION 2월 17, 2005 18:21:52.210
> ----------------------------------------------
> eclipse.buildId=M200409161125
> java.version=1.3.1_01
                ********
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ko_KR
> 
> !ENTRY org.eclipse.osgi 2월 17, 2005 18:21:52.210
> !MESSAGE Error registering XML parser services.
> !STACK 0
> java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
> 	at java.net.URLClassLoader$1.run(Unknown Source)
[snips]

Eclipse 3.0.1 requires Java 1.4.1 or later. You appear to be running it 
with 1.3.1.
-- 
Regards,

Roland de Ruiter
   ___      ___
  /__/ w_/ /__/
/  \ /_/ /  \
0
roland31 (393)
2/17/2005 12:25:59 PM
dear roland.

but i am using java 1.4.2_07
i think there's another problem.

0
2/18/2005 12:58:27 AM
following is the specification of my system.



JVM Version and Vendor  1.4.2_07 Sun Microsystems Inc.
Application server  Apache Tomcat/4.1.31
Database Name and Version  Oracle Oracle9i Enterprise Edition Release
9.2.0.1.0 - Production With the Partitioning, OLAP and Oracle Data
Mining options JServer Release 9.2.0.1.0 - Production
JDBC Driver and Version  Oracle JDBC driver 9.2.0.1.0

0
2/18/2005 1:07:12 AM
On 17 Feb 2005 17:07:12 -0800, oceanicshot@yahoo.com wrote:

>following is the specification of my system.
>
>
>
>JVM Version and Vendor  1.4.2_07 Sun Microsystems Inc.
>Application server  Apache Tomcat/4.1.31
>Database Name and Version  Oracle Oracle9i Enterprise Edition Release
>9.2.0.1.0 - Production With the Partitioning, OLAP and Oracle Data
>Mining options JServer Release 9.2.0.1.0 - Production
>JDBC Driver and Version  Oracle JDBC driver 9.2.0.1.0

	Your log show Java 1.3.1 which is probably because Oracle's
JDK is set at the front of your path.  Try launching eclipse by
changing the properties on the shortcut (if you launch it that way)
with "C:\eclipse\eclipse.exe -vm C:\j2sdk1.4.2_07\jre\bin\javaw" -
this is an example from my system.
	It might be good to peruse readme_eclipse.html in the readme
folder under eclipse.
-------
Remove underscores from e-mail address.
0
Joe
2/18/2005 2:13:00 AM
Reply: