f



Labview 8.5 error on save: "Cannot load help information of [filename]."

Hi all,
 
 I was working on a VI in Labview 8.5 when the program (Labview) crashed. When I relaunched Labview it asked me if I wanted to recover the VI I was working on, I said yes and the recovered VI runs fine, but I cannot save it. When I try to Save or Save As I receive the following error message: "Cannot load help information of [Filename]" and my only option is "Cancel Save". If I click "Cancel Save" Labview returns a "File not Found error". Until the recovery, I could and did save the file with no problems. It now seems that I am locked out of the file. 
 
  I have a backup, but it is does not contain the 2-3 hours of work I put in before the crash. Does anyone have a work-around, or know the source of this error? This is the second time I have seen it on a recovered file (the first time I had a fresh backup, so it wasn't a big issue). 
 
Here is a dump of the "Referencing files in the project or its dependencies" from the Save As dialog:
 
[Project Name].lvprojreplay2-offsets.vi:Instance:6replay2-offsets.vi:Instance:5replay2-offsets.vi:Instance:3replay2-offsets.vi:Instance:2replay2-offsets.vi:Instance:4replay2-offsets.vi:Instance:1replay2-offsets.vi:Instance:0
 
Thank you,
Tim
0
x9561 (148439)
6/27/2008 4:40:05 PM
comp.lang.labview 35210 articles. 1 followers. vasusachin24 (1) is leader. Post Follow

5 Replies
1743 Views

Similar Articles

[PageSpeed] 50

I'm having the same problem. I came here to see if there was any information about this problem, and found the previous message. Lucky for me, I'm not going too lose more than about 15 minutes of work.
0
x9561 (148439)
6/27/2008 7:40:06 PM
Brent,
 
&nbsp;After I posted this,&nbsp;I found this thread: <a href="http://forums.ni.com/ni/board/message?board.id=170&amp;thread.id=334074" target="_blank">http://forums.ni.com/ni/board/message?board.id=170&amp;thread.id=334074</a>&nbsp;about a corrupted project file, the info in there did not help me, but maybe it will help you.  
&nbsp;
Take care,
Tim
0
x9561 (148439)
6/27/2008 7:40:07 PM
Does anyone know if there is a way to clone a vi from memory to disk? That would be a good work around for me, or anything else you might suggest. It's not a big deal, as long as the computer doesn't crash before I finish this specialized project, I would just like to save my new work. I have no idea what the "help file" refers to, i've tried linking a help file to the vi and then saving but it still doesn't work... What a strange problem.
-Tim
0
x9561 (148439)
6/27/2008 11:40:04 PM
Hi Tim, One relatively simple but effective method to recover data from a corrupted VI is to "cut and paste" your block diagram to a fresh new VI. I have used this method many times in the past, and it has worked well. Just select your whole block diagram, choose copy from the edit menu, and then choose paste from the edit menu in your new VI.
0
x9561 (148439)
6/30/2008 4:40:05 PM
Kirby-
&nbsp;
&nbsp;Thanks for the tip, this is what&nbsp;I ultimately did, but the "Select All" doesn't quite select all, so it was a bit tedious.
&nbsp;
-Tim
0
x9561 (148439)
7/1/2008 7:40:05 PM
Reply: