f



Unable to install Math::BigInt::GMP on Solaris 10

Hello Guru's:

Make fails on both version 1.18 and 1.19.  I am trying to install this
to speed up Net::SSH::Perl, since that is unbearably slow with the
pure perl libraries, or even Math::BigInt::Pari, or
Math::BigInt::FastCalc.  here is what I get when I run make:
--------------------------------------------------------------------------------------------------------------------
bash-3.00# perl Makefile.PL
Note (probably harmless): No library found for -lgmp
YAML not installed, make dist will not override metafile at
Makefile.PL line 8.
Writing Makefile for Math::BigInt::GMP
bash-3.00# make
cp lib/Math/BigInt/GMP.pm blib/lib/Math/BigInt/GMP.pm
/usr/bin/perl /usr/perl5/5.8.4/lib/ExtUtils/xsubpp  -typemap /usr/
perl5/5.8.4/lib/ExtUtils/typemap -typemap typemap  GMP.xs > GMP.xsc &&
mv GMP.xsc GMP.c
cc -c    -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -xarch=v8 -
D_TS_ERRNO -xO3 -xspace -xildoff    -DVERSION=\"1.19\"  -DXS_VERSION=
\"1.19\" -KPIC "-I/usr/perl5/5.8.4/lib/sun4-solaris-64int/CORE"
GMP.c
"GMP.xs", line 4: cannot find include file: "gmp.h"
"GMP.c", line 40: undefined symbol: mpz_t
"GMP.c", line 40: undefined symbol: RETVAL
"GMP.xs", line 34: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 35: warning: implicit function declaration:
mpz_init_set_str
"GMP.xs", line 35: cannot dereference non-pointer type
"GMP.c", line 59: undefined symbol: mpz_t
"GMP.c", line 59: undefined symbol: RETVAL
"GMP.xs", line 47: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 48: cannot dereference non-pointer type
"GMP.c", line 78: undefined symbol: mpz_t
"GMP.c", line 78: undefined symbol: RETVAL
"GMP.xs", line 60: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 61: cannot dereference non-pointer type
"GMP.c", line 97: undefined symbol: mpz_t
"GMP.c", line 97: undefined symbol: RETVAL
"GMP.xs", line 73: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 74: cannot dereference non-pointer type
"GMP.c", line 115: undefined symbol: mpz_t
"GMP.c", line 115: undefined symbol: RETVAL
"GMP.xs", line 85: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 86: warning: implicit function declaration:
mpz_init_set_ui
"GMP.xs", line 86: cannot dereference non-pointer type
"GMP.c", line 133: undefined symbol: mpz_t
"GMP.c", line 133: undefined symbol: RETVAL
"GMP.xs", line 97: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 98: cannot dereference non-pointer type
"GMP.c", line 151: undefined symbol: mpz_t
"GMP.c", line 151: undefined symbol: RETVAL
"GMP.xs", line 109: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 110: cannot dereference non-pointer type
"GMP.c", line 169: undefined symbol: mpz_t
"GMP.c", line 169: undefined symbol: RETVAL
"GMP.xs", line 121: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 122: cannot dereference non-pointer type
"GMP.c", line 188: undefined symbol: mpz_t
"GMP.c", line 188: undefined symbol: n
"GMP.c", line 192: syntax error before or at: )
"GMP.xs", line 135: warning: implicit function declaration: mpz_clear
"GMP.xs", line 135: cannot dereference non-pointer type
"GMP.xs", line 136: warning: improper pointer/integer combination: arg
#1
"GMP.c", line 212: undefined symbol: mpz_t
"GMP.c", line 212: undefined symbol: n
"GMP.c", line 223: syntax error before or at: )
"GMP.xs", line 151: warning: implicit function declaration:
mpz_sizeinbase
"GMP.xs", line 151: cannot dereference non-pointer type
"GMP.xs", line 156: warning: implicit function declaration:
mpz_get_str
"GMP.xs", line 156: cannot dereference non-pointer type
"GMP.c", line 254: undefined symbol: mpz_t
"GMP.c", line 254: undefined symbol: n
"GMP.c", line 267: syntax error before or at: )
"GMP.xs", line 184: warning: implicit function declaration: mpz_tstbit
"GMP.xs", line 184: cannot dereference non-pointer type
"GMP.xs", line 189: cannot dereference non-pointer type
"GMP.xs", line 194: cannot dereference non-pointer type
"GMP.c", line 316: undefined symbol: mpz_t
"GMP.c", line 316: undefined symbol: n
"GMP.c", line 326: syntax error before or at: )
"GMP.xs", line 230: cannot dereference non-pointer type
"GMP.xs", line 235: cannot dereference non-pointer type
"GMP.c", line 353: undefined symbol: mpz_t
"GMP.c", line 353: undefined symbol: n
"GMP.c", line 363: syntax error before or at: )
"GMP.xs", line 253: cannot dereference non-pointer type
"GMP.xs", line 258: cannot dereference non-pointer type
"GMP.c", line 390: undefined symbol: mpz_t
"GMP.c", line 390: undefined symbol: n
"GMP.c", line 400: syntax error before or at: )
"GMP.xs", line 276: cannot dereference non-pointer type
"GMP.xs", line 281: cannot dereference non-pointer type
"GMP.c", line 427: undefined symbol: mpz_t
"GMP.c", line 427: undefined symbol: n
"GMP.c", line 428: operands must have arithmetic type: op "*"
"GMP.c", line 429: undefined symbol: mod
"GMP.c", line 430: undefined symbol: RETVAL
"GMP.c", line 434: syntax error before or at: )
"GMP.c", line 441: syntax error before or at: )
"GMP.c", line 448: syntax error before or at: )
"GMP.xs", line 296: warning: improper pointer/integer combination: op
"="
"GMP.xs", line 296: warning: implicit function declaration: mpz_init
"GMP.xs", line 296: cannot dereference non-pointer type
"GMP.xs", line 297: warning: implicit function declaration: mpz_powm
"GMP.xs", line 297: cannot dereference non-pointer type
"GMP.xs", line 297: cannot dereference non-pointer type
"GMP.xs", line 297: cannot dereference non-pointer type
"GMP.c", line 460: cannot recover from previous errors
cc: acomp failed for GMP.c
*** Error code 2
make: Fatal error: Command failed for target `GMP.o'
bash-3.00#
--------------------------------------------------------------------------------------------------------------------

Version 1.18 gives similar errors.  Any suggestions/advice would be
much appreciated!

Sumit

0
sumitbee (6)
2/21/2007 11:03:55 PM
comp.lang.perl.misc 33233 articles. 2 followers. brian (1246) is leader. Post Follow

11 Replies
644 Views

Similar Articles

[PageSpeed] 2

On Wed, 21 Feb 2007 15:03:55 -0800, sumitbee wrote:

> Hello Guru's:
> 
> Make fails on both version 1.18 and 1.19.  I am trying to install this
> to speed up Net::SSH::Perl, since that is unbearably slow with the
> pure perl libraries, or even Math::BigInt::Pari, or
> Math::BigInt::FastCalc.  here is what I get when I run make:
> --------------------------------------------------------------------------------------------------------------------
> bash-3.00# perl Makefile.PL
> Note (probably harmless): No library found for -lgmp
> YAML not installed, make dist will not override metafile at
> Makefile.PL line 8.
> Writing Makefile for Math::BigInt::GMP
> bash-3.00# make
> cp lib/Math/BigInt/GMP.pm blib/lib/Math/BigInt/GMP.pm
> /usr/bin/perl /usr/perl5/5.8.4/lib/ExtUtils/xsubpp  -typemap /usr/
> perl5/5.8.4/lib/ExtUtils/typemap -typemap typemap  GMP.xs > GMP.xsc &&
> mv GMP.xsc GMP.c
> cc -c    -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -xarch=v8 -
> D_TS_ERRNO -xO3 -xspace -xildoff    -DVERSION=\"1.19\"  -DXS_VERSION=
> \"1.19\" -KPIC "-I/usr/perl5/5.8.4/lib/sun4-solaris-64int/CORE"
> GMP.c
> "GMP.xs", line 4: cannot find include file: "gmp.h"

you need the header files for GMP. On fedora this is package
gmp-devel

#perl -MCPAN -e "test Math::BigInt"

on a fast machine this should return about 7-8 CPU seconds or less
once the GMP support is installed.

good luck,
Mark
0
Mark
2/21/2007 11:14:08 PM
On Feb 21, 4:03 pm, sumit...@gmail.com wrote:
> Make fails on both version 1.18 and 1.19.
> <snip>
> bash-3.00# perl Makefile.PL
> Note (probably harmless): No library found for -lgmp
> YAML not installed, make dist will not override metafile at
> Makefile.PL line 8.
> Writing Makefile for Math::BigInt::GMP

Why does the creation of the makefile for Math::BigInt::GMP say that
not finding the gmp library is "probably harmless"?  Seems like it
should be critical to me...

-jp

0
DJ
2/22/2007 3:27:19 AM
On Wed, 21 Feb 2007 19:27:19 -0800, DJ Stunks wrote:

> On Feb 21, 4:03 pm, sumit...@gmail.com wrote:
>> Make fails on both version 1.18 and 1.19.
>> <snip>
>> bash-3.00# perl Makefile.PL
>> Note (probably harmless): No library found for -lgmp
>> YAML not installed, make dist will not override metafile at
>> Makefile.PL line 8.
>> Writing Makefile for Math::BigInt::GMP
> 
> Why does the creation of the makefile for Math::BigInt::GMP say that
> not finding the gmp library is "probably harmless"?  Seems like it
> should be critical to me...

If you are on Win32, try here
http://www.kalinabears.com.au/w32perl/math_gmp.html

-- 
Mark

0
Mark
2/22/2007 5:12:53 AM
On Feb 21, 10:12 pm, Mark Pryor <tlvie...@yahoo.com> wrote:
> On Wed, 21 Feb 2007 19:27:19 -0800, DJ Stunks wrote:
> > On Feb 21, 4:03 pm, sumit...@gmail.com wrote:
> >> Make fails on both version 1.18 and 1.19.
> >> <snip>
> >> bash-3.00# perl Makefile.PL
> >> Note (probably harmless): No library found for -lgmp
> >> YAML not installed, make dist will not override metafile at
> >> Makefile.PL line 8.
> >> Writing Makefile for Math::BigInt::GMP
>
> > Why does the creation of the makefile for Math::BigInt::GMP say that
> > not finding the gmp library is "probably harmless"?  Seems like it
> > should be critical to me...
>
> If you are on Win32, try herehttp://www.kalinabears.com.au/w32perl/math_gmp.html
>
> --
> Mark

Mark, DJ, Thank you for your comments.  mark, Math::BigInt is
installed and tests succeed.  I am on Solaris, and cannot seem to find
the GMP header files.  From the Tel test results, it seems that v.
1.18 was the only one that passed tests on Solaris, but that is
failing for me as well.  Has anyone been able to install this on
Solaris?  Any other ideas as to how to speed up Net::SSH::Perl?

Thanks again,
Sumit

0
sumitbee
2/22/2007 4:10:32 PM
On Feb 22, 9:10 am, sumit...@gmail.com wrote:
> On Feb 21, 10:12 pm, Mark Pryor <tlvie...@yahoo.com> wrote:
> > On Wed, 21 Feb 2007 19:27:19 -0800, DJ Stunks wrote:
> > > On Feb 21, 4:03 pm, sumit...@gmail.com wrote:
> > >> Make fails on both version 1.18 and 1.19.
> > >> <snip>
> > >> bash-3.00# perl Makefile.PL
> > >> Note (probably harmless): No library found for -lgmp
> > >> YAML not installed, make dist will not override metafile at
> > >> Makefile.PL line 8.
> > >> Writing Makefile for Math::BigInt::GMP
>
> > > Why does the creation of the makefile for Math::BigInt::GMP say that
> > > not finding the gmp library is "probably harmless"?  Seems like it
> > > should be critical to me...
>
> > If you are on Win32, try herehttp://www.kalinabears.com.au/w32perl/math_gmp.html
>
> > --
> > Mark
>
> Mark, DJ, Thank you for your comments.  mark, Math::BigInt is
> installed and tests succeed.  I am on Solaris, and cannot seem to find
> the GMP header files.

http://www.sunfreeware.com/programlistsparc10.html#gmp

-jp

0
fmurch
2/22/2007 7:51:15 PM
On Feb 22, 12:51 pm, fmu...@gmail.com wrote:
> On Feb 22, 9:10 am, sumit...@gmail.com wrote:
>
>
>
>
>
> > On Feb 21, 10:12 pm, Mark Pryor <tlvie...@yahoo.com> wrote:
> > > On Wed, 21 Feb 2007 19:27:19 -0800, DJ Stunks wrote:
> > > > On Feb 21, 4:03 pm, sumit...@gmail.com wrote:
> > > >> Make fails on both version 1.18 and 1.19.
> > > >> <snip>
> > > >> bash-3.00# perl Makefile.PL
> > > >> Note (probably harmless): No library found for -lgmp
> > > >> YAML not installed, make dist will not override metafile at
> > > >> Makefile.PL line 8.
> > > >> Writing Makefile for Math::BigInt::GMP
>
> > > > Why does the creation of the makefile for Math::BigInt::GMP say that
> > > > not finding the gmp library is "probably harmless"?  Seems like it
> > > > should be critical to me...
>
> > > If you are on Win32, try herehttp://www.kalinabears.com.au/w32perl/math_gmp.html
>
> > > --
> > > Mark
>
> > Mark, DJ, Thank you for your comments.  mark, Math::BigInt is
> > installed and tests succeed.  I am on Solaris, and cannot seem to find
> > the GMP header files.
>
> http://www.sunfreeware.com/programlistsparc10.html#gmp
>
> -jp- Hide quoted text -
>
> - Show quoted text -

JP, thanks for the update.  I installed gmp-4.1.2, changed the
LD_LIBRARY_PATH_64 and made sure the libgmp files were in /usr/local/
lib/sparcv9, but same problem.....

0
sumitbee
2/22/2007 9:01:57 PM
<sumitbee@gmail.com> wrote in message 
news:1172178117.033755.326430@s48g2000cws.googlegroups.com...
..
..
>
> JP, thanks for the update.  I installed gmp-4.1.2, changed the
> LD_LIBRARY_PATH_64 and made sure the libgmp files were in /usr/local/
> lib/sparcv9, but same problem.....
>

Try hacking at the XS file. Where it says:

#include "gmp.h"

Change that to:

#include "/usr/local/include/sparcv9/gmp.h" // if that's where gmp.h is 
located

That should at least allow gmp.h to get found. Then it's just a matter of 
making libgmp.a (or the gmp .so) findable.

Probably the simplest way to build it is to do it manually. Download the 
M:::BI::GMP-1.19 source from CPAN, extract to some location, cd to that 
location and run:

perl Makefile.PL INC="-I/usr/local/include/sparcv9" 
LIBS="-L/usr/local/lib/sparcv9 -lgmp"
make test
make install

If you don't have a  'libgmp.a' then you should be able to link directly to 
the libgmp-3.so (or whatever it's called) but you would need to change the 
above command to properly reflect the name of the gmp .so file. Something 
like:

perl Makefile.PL INC="-I/usr/local/include/sparcv9" 
LIBS="-L/usr/local/lib/sparcv9 -lgmp-3"

All of this is, of course, untested.

Is there something there that works for you ? (You should at least be able 
to eradicate the error about gmp.h being not found - assuming it really is 
in /usr/local/include/sparcv9.)

Cheers,
Rob 


0
Sisyphus
2/23/2007 5:19:36 AM
On Feb 22, 10:19 pm, "Sisyphus" <sisyph...@nomail.afraid.com> wrote:
> <sumit...@gmail.com> wrote in message
>
> news:1172178117.033755.326430@s48g2000cws.googlegroups.com...
> .
> .
>
>
>
> > JP, thanks for the update.  I installed gmp-4.1.2, changed the
> > LD_LIBRARY_PATH_64 and made sure the libgmp files were in /usr/local/
> > lib/sparcv9, but same problem.....
>
> Try hacking at the XS file. Where it says:
>
> #include "gmp.h"
>
> Change that to:
>
> #include "/usr/local/include/sparcv9/gmp.h" // if that's where gmp.h is
> located
>
> That should at least allow gmp.h to get found. Then it's just a matter of
> making libgmp.a (or the gmp .so) findable.
>
> Probably the simplest way to build it is to do it manually. Download the
> M:::BI::GMP-1.19 source from CPAN, extract to some location, cd to that
> location and run:
>
> perl Makefile.PL INC="-I/usr/local/include/sparcv9"
> LIBS="-L/usr/local/lib/sparcv9 -lgmp"
> make test
> make install
>
> If you don't have a  'libgmp.a' then you should be able to link directly to
> the libgmp-3.so (or whatever it's called) but you would need to change the
> above command to properly reflect the name of the gmp .so file. Something
> like:
>
> perl Makefile.PL INC="-I/usr/local/include/sparcv9"
> LIBS="-L/usr/local/lib/sparcv9 -lgmp-3"
>
> All of this is, of course, untested.
>
> Is there something there that works for you ? (You should at least be able
> to eradicate the error about gmp.h being not found - assuming it really is
> in /usr/local/include/sparcv9.)
>
> Cheers,
> Rob

Rob, thanks.  I'll try it out on Monday and let you know.

Cheers,
Sumit

0
sumitbee
2/24/2007 5:04:06 PM
On Feb 24, 10:04 am, sumit...@gmail.com wrote:
> On Feb 22, 10:19 pm, "Sisyphus" <sisyph...@nomail.afraid.com> wrote:
>
>
>
>
>
> > <sumit...@gmail.com> wrote in message
>
> >news:1172178117.033755.326430@s48g2000cws.googlegroups.com...
> > .
> > .
>
> > > JP, thanks for the update.  I installed gmp-4.1.2, changed the
> > > LD_LIBRARY_PATH_64 and made sure the libgmp files were in /usr/local/
> > > lib/sparcv9, but same problem.....
>
> > Try hacking at the XS file. Where it says:
>
> > #include "gmp.h"
>
> > Change that to:
>
> > #include "/usr/local/include/sparcv9/gmp.h" // if that's where gmp.h is
> > located
>
> > That should at least allow gmp.h to get found. Then it's just a matter of
> > making libgmp.a (or the gmp .so) findable.
>
> > Probably the simplest way to build it is to do it manually. Download the
> > M:::BI::GMP-1.19 source from CPAN, extract to some location, cd to that
> > location and run:
>
> > perl Makefile.PL INC="-I/usr/local/include/sparcv9"
> > LIBS="-L/usr/local/lib/sparcv9 -lgmp"
> > make test
> > make install
>
> > If you don't have a  'libgmp.a' then you should be able to link directly to
> > the libgmp-3.so (or whatever it's called) but you would need to change the
> > above command to properly reflect the name of the gmp .so file. Something
> > like:
>
> > perl Makefile.PL INC="-I/usr/local/include/sparcv9"
> > LIBS="-L/usr/local/lib/sparcv9 -lgmp-3"
>
> > All of this is, of course, untested.
>
> > Is there something there that works for you ? (You should at least be able
> > to eradicate the error about gmp.h being not found - assuming it really is
> > in /usr/local/include/sparcv9.)
>
> > Cheers,
> > Rob
>
> Rob, thanks.  I'll try it out on Monday and let you know.
>
> Cheers,
> Sumit- Hide quoted text -
>
> - Show quoted text -

Rob,

Changing the include to the full path to gmp.h in the xs file and
creating the makefile with the INC and LIB options as you suggested
worked. I am still getting errors on "make test" but thats a different
issue.  Thanks a lot for your help!

Thanks to all others that replied as well.

Sumit

0
sumitbee
2/27/2007 6:01:44 PM
The solution, for anyone interested, was to install GNU make 3.81,
compile gmp-4.2 with this version of make, and then install
Math::BigInt::GMP pointing the lib and INC to the location of the
newly installed gmp-4.2.

0
sumitbee
3/6/2007 8:48:43 PM
On Mar 6, 12:48 pm, sumit...@gmail.com wrote:
> The solution, for anyone interested, was to install GNU make 3.81,
> compile gmp-4.2 with this version of make, and then install
> Math::BigInt::GMP pointing the lib and INC to the location of the
> newly installed gmp-4.2.

It's good to know you got it to work, but I would suggest that this
post is going to be nearly useless to some future googler unless they
come across your OP first AND the thread remains intact.  In the
future perhaps you could consider full-quoting your OP and posting the
solution below.

We've all Googled issues like this but, as I'm sure you know, all one
normally finds is other people with the same problem.

$0.02
-jp

0
DJ
3/6/2007 11:22:08 PM
Reply:

Similar Artilces:

How to install Math::BigInt::GMP?
I would like to use Math::BigInt::GMP with my ActivePerl v 5.10 but it doesn't appear in the ppm list. Can someone tell me how to get it? Quoth Sal <here@softcom.net>: > I would like to use Math::BigInt::GMP with my ActivePerl v 5.10 but it > doesn't appear in the ppm list. Can someone tell me how to get it? Add http://cpan.uwinnipeg.ca/PPMPackages/10xx/ as a PPM repository. Ben In article <0d8c120e-1fdb-4312-a979-859ffa604ad0@n4g2000yqf.googlegroups.com>, Sal <here@softcom.net> wrote: > I would like to use Math::BigInt::GMP with my Acti...

problem when installing Math::BigInt::GMP ...
Dear, Yesterday, I tried to install Net::OpenID::JanRain::Consumer. It showed it needs Crypt::DH: ========== ---- Unsatisfied dependencies detected during [A/AR/ARNESOND/Net- OpenID-JanRain-1.1.1.tar.gz] ----- Crypt::DH Shall I follow them and prepend them to the queue of modules we are processing right now? [yes] ========== While installing Crypt::DH and doing "make test", it took so long time to proceed and finally it appeared to hang at 18th test. I tried to "install Crypt::DH" first, but same result. ========== cpan[38]> install Crypt::DH Running install for...

Solaris 10 U1: Unable to install on S2895
Hi, I tried to upgrade/reinstall the latest Solaris Upgrade onto my system (Tyan S2895 mainboard with 2xOpteron 252, etc.) Earlier Solaris 10 releases installed OK (Solaris 10 GA/HW1) but when I'm trying to boot the latest Solaris 10 (01/06) the system panics immediately. With KJP 118844-20 (and lower) the system boots ok though. I tried several different BIOS settings with no luck so far. Any hints what else I could do? What I have done so far (I added the "-vkd" flags to the boot and redirected console output to the serial port so I could grab the panic messages): (1) boot...

How to install Ubuntu on a Solaris 10 installation?
Hello I've got a x86 PC with one HDD and Solaris 10 on it. I would like to install Ubuntu side-by-side to S10, but don't know how. S10 starts with GRUB. Is there a way to convert or shrink the S10 partition to have some space for Linux? Thanks Vittorio On 2006-06-19 17:00, vittoriob@gmail.com wrote: > Hello > > I've got a x86 PC with one HDD and Solaris 10 on it. > > I would like to install Ubuntu side-by-side to S10, but don't know how. > > S10 starts with GRUB. > > Is there a way to convert or shrink the S10 partition to have some > sp...

Installing Solaris 10 or Solaris 9
Hi there, I have an old Sun Box, is an Ultra SPARC-IIi 300MHz, right now I am using Solaris 9. I have a two parts question, first one is, can I install Solaris 10 on this machine?, maybe is just to outdated for it. Second question is, can I download all the Solaris 9 software from "www.sun.com" as DVD, into a Windows XP box, them burn them as a DVD, will it work on my Sun Box?, or once I download them in to the Windows box, do I have to expand each zip file, them burn them into a DVD, and again the same question will it work on the Sun Box? Thanks. Alfonso G. Urroz "Alfonso...

Installing solaris 10 10/08
I used CD's to install Solaris 10 10/08 on two E450's, and on an E 250. I found that while the E450's had almost exactly same h/w configuration, the install program behaved differently.......I did not, for instance, on one E450, get any options before getting the "do you want to enable remote services" on the other E450, I did. This seem even wierder on the E 250, here, using the same CD's, I got an option for ZFS (I got a choice between ZFS and UFS), on the E 450's I did not. All systems seem to have UltrasparcII processors of 400MHz or better, the 250 is sing...

Unicode-related problem installing perl modules on Solaris 10
I'm trying to install (from CPAN) these two perl modules: HTML::TreeBuilder HTML::FormatText on a Solaris 10 system. The install fails and I get the following messages, among others (some lines wrapped by me for readability): ============================================================ Running make test PERL_DL_NONLAZY=1 /opt/csw/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00system.......... t/00system..........ok 1/2 t/00system..........ok t/assubs............ t/assubs.....

unable to build Math-GMP perl module on AIX 5.3
Anyone had success with building Math-GMP-2.04 on an AIX box. I am running AIX 5.3. Any ideas root @ host: /var/cache/cpan/build/Math-GMP-2.04 => make cc -c -D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=16384 -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT -q32 -D_LARGE_FILES -qlonglong -qnoipa -O -DVERSION=\"2.04\" -DXS_VERSION=\"2.04\" "-I/usr/opt/perl5/lib/5.8.2/aix-thread-multi/CORE" GMP.c "/usr/opt/perl5/lib/5.8.2/aix-thread-multi/CORE/reentr.h", line 619.16: 1506-007 (S) "struct drand48_data" is undefi...

Math::GMP and Pari Installed, But BigInt Can't Find Them
> perl -MMath::Pari -e'$a=PARI 2;print $a**10000' #Big number... > perl -MMath::GMP -e'print Math::GMP->new(2) ** 1000' #Same Big Number... > perl -e'use Math::BigInt lib => "GMP,Pari";' Math::BigInt: couldn't load specified math lib(s), fallback to Math::BigInt::Calc at -e line 1 What gives? As an aside, is it possible to import GMP or Pari from the command line? -M doesn't play nice with a string of import args: > perl -MMath::BigInt='lib,Pari' -e'1' #OK, can't load module error But: > perl -MMath::BigIn...

Installing Solaris 10 on Ultra 10 472054
Hi all, I'm having trouble booting an Ultra 10 off of a burned copy of Solaris 10. I'm not sure what I could be doing wrong. I burn the CD image, I put the CD in the CD ROM drive and a restart the Ultra 10 box. I get no errors; the box just boots off of the disk and into Solaris 9, which is already installed. Is there a trick to this that I'm missing? Thanks in advance for any help, -- Desmond Rivet Blessed are they who Go Around in Circles, for they Shall be Known as Wheels Desmond Rivet wrote: > Hi all, > > I'm having trouble booting an Ultra 10 off of a bur...

ZFS missing from installation of Solaris 10
Hello! To my big surprise, I just discovered that one of "my" Solaris 10 Servers is missing ZFS :( Where can I download the ZFS packages, so that I can install it on this server? Thanks, Alexander Skwar Alexander Skwar <alexander@skwar.name> writes: >Hello! >To my big surprise, I just discovered that one of "my" Solaris >10 Servers is missing ZFS :( >Where can I download the ZFS packages, so that I can install >it on this server? You need to upgrade to release 06/06 or later. (Though I think there's an appropriate patch bundle also) Caspe...

Installing Solaris 8 Apps on Solaris 10
Does anyone know how to fool apps into thinking they are installing on a Solaris 8 system when actually running on Solaris 10? I'm trying to install OpenView 6.4.1 and getting tired of trying to hack the install script. Thanks, C. McCane On Sat, 2 Apr 2005, Charles McCane wrote: > Does anyone know how to fool apps into thinking they are installing on a > Solaris 8 system when actually running on Solaris 10? I'm trying to > install OpenView 6.4.1 and getting tired of trying to hack the install > script. Thats really the only way*. Apps shouldn't care what version...

solaris 10 installation on sparc ultra 10
Hi there I'm trying to install solaris 10 on sparc ultra 10 After boot cdrom the systems try to come up, and I receive a warning: setting ufs_ninode to max value <value>... And the installation stucks, nthing happen more. Could u kind help on this? I tried 2 different DVDs burned at different speed (2X - 8X). Have u ever seen this behaviour? In article <cfbe3fd9-79f4-459b-89ca-30e96de83245@u7g2000yqm.googlegroups.com> mammut75 <erforcella@gmail.com> writes: >Hi there >I'm trying to install solaris 10 on sparc ultra 10 >After boot cdrom the sys...

Installing Solaris 10 on Ultra 10 31377
I am trying to install Solaris 10 on an Ultra 10. I cannot get CDE to launch. Are there post install steps that I am to perform? I read on a Sun forum to run "/usr/dt/bin/dtconfig -d" I have no /usr/dt/bin/dtconfig file? Is my installation corrupt? Higglity wrote: > I am trying to install Solaris 10 on an Ultra 10. I cannot get CDE to > launch. Are there post install steps that I am to perform? I read on a > Sun forum to run "/usr/dt/bin/dtconfig -d" I have no > /usr/dt/bin/dtconfig file? Is my installation corrupt? > SUNWdtdte /usr/dt/bin/dtconfig is in...

Web resources about - Unable to install Math::BigInt::GMP on Solaris 10 - comp.lang.perl.misc

Resources last updated: 2/9/2016 8:40:33 AM