f



RE: [ace-users] Re: ACE 5.4 compilation error on HP-UX 11.11/GNU g++ 3.4.3

The needed fix is, indeed, in ACE 5.5. If, for some reason, you need
to stay on 5.4, the 5.4e Fix Kit from Riverace has this problem fixed
as well. The fix is needed for g++ 3.4 on any platform.

-Steve

























































































--
Steve Huston, Riverace Corporation
Helping you succeed with ACE
See http://www.riverace.com/support.htm


> -----Original Message-----
> From: owner-ace-users@cse.wustl.edu 
> [mailto:owner-ace-users@cse.wustl.edu] On Behalf Of Douglas C.
Schmidt
> Sent: Saturday, March 11, 2006 7:01 PM
> To: ecoboja@yahoo.com; ace-users@cs.wustl.edu
> Subject: [ace-users] Re: ACE 5.4 compilation error on HP-UX 
> 11.11/GNU g++ 3.4.3
> 
> 
> Hi,
> 
>         Thanks for using the PRF.
> 
> >> ACE VERSION: 5.4
> 
> Please upgrade to ACE 5.5, which you can download from
> 
> http://deuce.doc.wustl.edu/Download.html
> 
> The DOC groups at Washington University, UC Irvine, and Vanderbilt
> University only provide "best effort" support for non-sponsors for
the
> latest release, as described in
> 
> http://www.cs.wustl.edu/~schmidt/ACE_wrappers/docs/ACE-bug-pro
> cess.html
> 
> Thus, if you need more "predictable" help for ACE 5.4, I recommend
> that you check out
> 
> http://www.cs.wustl.edu/~schmidt/commercial-support.html
> 
> for a list of companies that will provide you with ACE+TAO
commercial
> support.
> 
> Thanks,
> 
>         Doug
> 
> 
> >> HOST MACHINE and OPERATING SYSTEM:
> >>    HP Superdome 9000/800 HP-UX B.11.11
> >> TARGET MACHINE and OPERATING SYSTEM, if different from 
> HOST: COMPILER
> >> NAME AND VERSION (AND PATCHLEVEL):
> >>    GNU g++ 3.4.3
> >> THE $ACE_ROOT/ace/config.h FILE:
> >>    ace/config-hpux-11.00.h
> >> THE $ACE_ROOT/include/makeinclude/platform_macros.GNU FILE
> >>    ($ACE_ROOT)/include/makeinclude/platform_hpux_gcc.GNU
> >> CONTENTS OF 
> $ACE_ROOT/bin/MakeProjectCreator/config/default.features
> >>    None
> >> AREA/CLASS/EXAMPLE AFFECTED:
> >>    ace/Unbounded_Queue.cpp fails to compile
> >> DOES THE PROBLEM AFFECT:
> >>    COMPILATION? Yes
> >>    LINKING? No
> >>    On Unix systems, did you run make realclean first? Yes
> >>    EXECUTION? No
> >>    OTHER (please specify)? ACE only
> >> SYNOPSIS:
> >>    ace/Unbounded_Queue.cpp fails to compile. Line 133: 
> error: expected
> >> class-name before '(' token
> >>  DESCRIPTION:
> >>     In file included
> >>        from /home/ACE/ACE_wrappers/ace/Unbounded_Queue.h:286,
> >>        from /home/ACE/ACE_wrappers/ace/ARVG.h:24
> >>        from ARGV.app:6:
> >>        ace/Unbounded_Queue.cpp: In member function 'void
> >> ACE_Unbounded_queue<T>::delete_nodes()':
> >>        ace/Unbounded_Queue.cpp:133: error: expected class-name
> >> before'(' token
> >>        ace/Unbounded_Queue.cpp: In destructor 'void
> >> ACE_Unbounded_queue<T>::~ACE_Unbounded_Queue()':
> >>        ace/Unbounded_Queue.cpp:1153: error: expected class-name
> >> before'(' token
> >>        ace/Unbounded_Queue.cpp: In member function 'void
> >> ACE_Unbounded_queue<T>::dequeue_head(T&)()':
> >>        ace/Unbounded_Queue.cpp:223: error: expected class-name
> >> before'(' token
> >>        gmake[1]: ***[.shobj/ARGV.o] Error 1
> >>  REPEAT BY:
> >>     cd ($ACE_ROOT)/ace
> >>     gmake
> >>  SAMPLE FIX/WORKAROUND:
> >>     None available.
> >>  
> >> Thanks.
> >>     Elaine
> >> 
> 
> 
> -- 
> Dr. Douglas C. Schmidt                       Professor and 
> Associate Chair
> Electrical Engineering and Computer Science  TEL: (615) 343-8197
> Institute for Software Integrated Systems    WEB: 
> www.dre.vanderbilt.edu/~schmidt
> Vanderbilt University, Nashville TN, 37203   NET: 
> d.schmidt@vanderbilt.edu
> 


0
Steve
3/13/2006 12:21:45 PM
comp.soft-sys.ace 20326 articles. 1 followers. marlow.andrew (167) is leader. Post Follow

0 Replies
1193 Views

Similar Articles

[PageSpeed] 14

Reply: