f



X11TransTRANS error on aix 6.1

Each time an X application is starting from the terminal, there is an
error line
_X11TransTRANS(ibmSHMConnect) () can't connect: errno = 68
We start applications in vnc window.
os version: 6.1
What can be the reason? Wrong network setup? There are lines
describing localhost and servername in /etc/hosts.
Norayr
0
chnorik (6)
8/12/2010 7:02:20 AM
comp.unix.aix 10963 articles. 1 followers. drkirkby (98) is leader. Post Follow

1 Replies
12339 Views

Similar Articles

[PageSpeed] 42

I ran into the same problem. I'm still trying to figure out why this
behavior changed between our (working) 5.3 systems and our (now broke)
6.1 systems.

It looks like the cause of this problem is due to the DISPLAY variable
not being properly set. I noticed that explicitly setting the display
variable to the proper setting will temporarily fix the issue.

In my case, on the broke system the DISPLAY variable was set to this --
>  :3
I got it working by prepending this value with the hostname--->
export DISPLAY=3D<hostname of my server>:3

One potential fix would be to manually export the display in
my .kshrc, but personally I'd rather figure out what changed during
our upgrade.

Jeff



On Aug 12, 3:02=A0am, Norayr Chilingarian <chno...@gmail.com> wrote:
> Each time an X application is starting from the terminal, there is an
> error line
> _X11TransTRANS(ibmSHMConnect) () can't connect: errno =3D 68
> We start applications in vnc window.
> os version: 6.1
> What can be the reason? Wrong network setup? There are lines
> describing localhost and servername in /etc/hosts.
> Norayr

0
jeffschw (3)
9/8/2010 3:42:31 PM
Reply: